AR3260V200R005C20SPC200子接口与S2700直连不通

发布时间:  2015-12-20 浏览次数:  102 下载次数:  0
问题描述

AR3260V200R005C20SPC200子接口与S2700-26TP-EI直连VLANIF60不通其他的VLANIF接口正常

 

AR3260关键配置

interface GigabitEthernet0/0/0.1
dot1q termination vid 20
ip address 192.168.20.1 255.255.255.0
#
interface GigabitEthernet0/0/0.2
dot1q termination vid 60
ip address 192.168.60.1 255.255.255.0

S2700交换机配置

interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 20 60

#
interface Vlanif20
ip address 192.168.20.2 255.255.255.0
#
interface Vlanif60
ip address 192.168.60.2 255.255.255.0
#
ip route-static 0.0.0.0 0.0.0.0 192.168.20.1

 

<S2700>ping 192.168.60.1
  PING 192.168.60.1: 56  data bytes, press CTRL_C to break
    Request time out
--- 192.168.60.1 ping statistics ---
    5 packet(s) transmitted
    0 packet(s) received
    100.00% packet loss

<S2700>ping 192.168.20.1
  PING 192.168.20.1: 56  data bytes, press CTRL_C to break
    Reply from 192.168.20.1: bytes=56 Sequence=5 ttl=255 time=50 ms
 --- 192.168.20.1 ping statistics ---
    5 packet(s) transmitted
    5 packet(s) received
    0.00% packet loss
    round-trip min/avg/max = 40/116/390 ms

VLANIF20直连可以PING通VLANIF60直连不通

处理过程

查看ARP表

<S2700>display arp  interface  Vlanif 60
IP ADDRESS      MAC ADDRESS     EXPIRE(M) TYPE INTERFACE      VPN-INSTANCE     
VLAN
------------------------------------------------------------------------------
192.168.60.2    4c1f-ccd4-6e94            I -  Vlanif60
192.168.60.1    00e0-fc3d-5c15  18        D-0  Eth0/0/1
60
------------------------------------------------------------------------------
Total:2         Dynamic:1       Static:0     Interface:1 

<AR3260>display  arp interface  GigabitEthernet 0/0/0.2
IP ADDRESS      MAC ADDRESS     EXPIRE(M) TYPE        INTERFACE   VPN-INSTANCE
VLAN/CEVLAN PVC                     
------------------------------------------------------------------------------
192.168.60.1    00e0-fc3d-5c15            I -         GE0/0/0.2
192.168.60.2    4c1f-ccd4-6e94  18        D-0         GE0/0/0.2
  60/-
------------------------------------------------------------------------------
Total:2         Dynamic:1       Static:0     Interface:1   

ARP表相互学习正常接口无限制策略 继续查看路由表

<AR3260>display  ip routing-table
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
         Destinations : 14       Routes : 14      

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface
   192.168.20.0/24  Direct  0    0           D   192.168.20.1    GigabitEthernet
0/0/0.1
   192.168.20.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
0/0/0.1
   192.168.60.0/24  Direct  0    0           D   192.168.60.1    GigabitEthernet
0/0/0.2
   192.168.60.1/32  Direct  0    0           D   127.0.0.1       GigabitEthernet
0/0/0.2
   192.168.60.2/32  OSPF    10   1           D   192.168.1.2     GigabitEthernet
0/0/1

发现AR3260从其它设备学习到192.168.60.2的32位主机路由

 

 

 

根因

AR3260通过OSPF学习到一条192.168.60.2的32位主机路由 S2700发起对192.168.60.2的PING测试 AR3260查到有32主机路由按最长匹配原则回包到192.168.1.2

解决方案

重新规划ip地址或者对OSPF路由过滤

END