NE路由器带宽测试丢包

发布时间:  2015-12-23 浏览次数:  238 下载次数:  3
问题描述

 

   如图所示,NE20E-S4通过市局及省局传输设备OSN1500OSN3500连接到省局NE40E-X8NE20E-SNE40E-X8均配置为二层接口。客户用测试仪均匀打1000M流量测试,发现丢包64字节打流丢包3.4%128字节以上未出现丢包现象。


 

告警信息
处理过程

一、找出丢包点

1.  改打流方式为单向打流,测试依然丢包;

2.  NE20E-S单机测试:NE20E-S单接口GE2/0/7接入,收发直接连接测试仪,配置接口为access接口,测试不丢包;

3.  NE20E-S单机测试:将接口GE1/0/7配置 为access口,放通相同vlan,配置loopback local,测试不丢包;

4.  取消loopback local,将接口G1/0/7自环,测试不丢包;

5.  NE20E-S4 GE1/0/7连上传输设备,在各级传输设备上外环,均测试不丢包;

6.  NE40E接入测试网络,10GE4/0/0接口收发与传输互联,测试不丢包;

7.  NE40E接口GE4/0/1接入设备,配置loopback remote丢包3.4%,与直接在外环结果一样,确认丢包位置出现在NE40E子卡上。

二、确定丢包原因

1.  核实配置,基本配置均正常,无冗余配置。

interface GigabitEthernet4/0/0               //收发接口与传输互联

portswitch

undo shutdown

port link-type trunk

port trunk allow-pass vlan 1 to 4094

dcn

#

interface GigabitEthernet4/0/1                                   //接口裸纤外环

portswitch

undo shutdown

port link-type access

port default vlan 20

dcn

#

2.  检查转发流程,确定丢包原因。

当从对端NE20E设备发送过来带vlan64字节的报文时,G4/0/0口为trunk口,带vlan tag经过交换网板到下行,从G4/0/1口出,对于G4/0/1口,现网当时配置为access口,报文的vlan id与缺省vlan id相同,access口收到与default vlan相同的报文时去掉tag,此时报文变为60字节。协议规定以太报文的最低长度为64字节,因此报文发出去之前会在子卡上填充4字节,如果不填充,则出去的报文长度只有60字节不符合协议规定的最小字节长度。由于G4/0/1口通过光纤将收发相连,发送的报文直接硬环到接收,因此从G4/0/1出去后直接又从G4/0/1口入,此时对于G4/0/1口接收而言,收到了64字节不带tag的报文。同样由于G4/0/1口为access口,收到不带tag的报文时会打上缺省vlantag,在NP会重新添加上对应的VLAN tag,此时报文变为68字节带vlan tag的报文。然后此报文经过交换网板到下行的NPG4/0/0口发送出去,G4/0/0口为trunk口,报文vlan id在允许通过的范围内,保持原有的vlan tag直接将报文从G4/0/0口发送出去,因此从G4/0/0口出去的报文变为68字节。转发流程如下:



根因

从G4/0/0口发回去的报文由原来的64字节变成了68字节。此时同样的报文个数,但是由于报文长度增加,报文所占带宽变大,在测试打满带宽打流测试时会超过中间传输设备的带宽,导致丢包

解决方案

interface GigabitEthernet4/0/0

portswitch

undo shutdown

port link-type trunk

port trunk allow-pass vlan 1 to 4094

dcn

interface GigabitEthernet4/0/1

portswitch

undo shutdown

port link-type trunk

port trunk allow-pass vlan 1 to 4094

dcn

建议与总结

END