如何使用二层远程端口镜像实现1:N的端口镜像功能

发布时间:  2015-12-30 浏览次数:  261 下载次数:  0
问题描述

版本信息:V1R5C10

组网拓扑:


组网描述:两台CE5800通过堆叠形成一台逻辑设备,服务器双网卡主备模式,有多台终端需要检测服务器流量,要通过1:N端口镜像方式实现多终端监控流量需求。


 

解决方案

1.CE5800 V1R5版本目前最多只支持一个源端口下同时配置两个监测端口,如果监测终端超过两台,则无法实现用户需求;

2.端口镜像流量在堆叠环境下,无法夸框镜像。

解决方案:


1.增加两台接入交换机,且分别于两台CE交换机互联,在S1的双上联端口配置链路聚合,S2双上联配置链路聚合,CE侧不做链路聚合;

2.CE1和CE2的堆叠组上将下联S1和S2的4个端口配置为二层远程监测端口,同时配置在堆叠组上的源端口流量镜像到本框的两个监测端口

3.S1和S2上配置远程镜像vlan(与堆叠组的镜像vlan号一致),同时将所有端口加入该vlan并关闭mac地址学习功能,使用未知单播报文泛洪特性来实现多终端监控。

CE1和CE2配置如下:

vlan 999
description mirror-vlan
#
observe-port 1 interface GE1/0/47 vlan 999 
observe-port 2 interface GE1/0/48 vlan 999 
observe-port 3 interface GE2/0/47 vlan 999 
observe-port 4 interface GE2/0/48 vlan 999 
#
interface GE1/0/31
port default vlan 20
port-mirroring observe-port 1 inbound
port-mirroring observe-port 1 outbound
port-mirroring observe-port 2 inbound
port-mirroring observe-port 2 outbound
#
interface GE2/0/31
port default vlan 20
port-mirroring observe-port 3 inbound
port-mirroring observe-port 3 outbound
port-mirroring observe-port 4 inbound
port-mirroring observe-port 4 outbound
#

S1配置:

vlan 999
description mirror-vlan
mac-address learning disable
#

interface Eth-Trunk0
port link-type access
port default vlan 999
#
interface GigabitEthernet0/0/47
eth-trunk 0
#
interface GigabitEthernet0/0/48
eth-trunk 0
#
interface GigabitEthernet0/0/1
port link-type access
port default vlan 999
#
interface GigabitEthernet0/0/2
port link-type access
port default vlan 999
#
interface GigabitEthernet0/0/3
port link-type access
port default vlan 999
#
interface GigabitEthernet0/0/4
port link-type access
port default vlan 999
#
interface GigabitEthernet0/0/5
port link-type access
port default vlan 999
#                                        
interface GigabitEthernet0/0/6
port link-type access
port default vlan 999
#

S2配置与S1类似,此处略!

 

END