S5700 无故断网,重启后就恢复正常

发布时间:  2016-01-31 浏览次数:  406 下载次数:  0
问题描述

S5700-SI作为核心设备,业务网关均在本设备上,上联出口路由器

S5700-SI V200R001C00SPC300 SPH006

内网业务不定时无故断网,大部分时候重启S5700后恢复正常

大致配置如下:

#
interface Vlanif2
ip address 26.27.166.30 255.255.255.0
#
interface Vlanif3
ip address 192.168.0.1 255.255.255.0
#
interface Vlanif10
ip address 26.27.67.153 255.255.255.0
#
interface GigabitEthernet0/0/1
description hulian
port link-type access
port default vlan 2
#
interface GigabitEthernet0/0/2
port link-type access
port default vlan 10
#
interface GigabitEthernet0/0/3
port link-type access
port default vlan 2
#
interface GigabitEthernet0/0/4
port link-type access
port default vlan 10
#
interface GigabitEthernet0/0/24
port link-type access
port default vlan 2
#
ip route-static 0.0.0.0 0.0.0.0 26.27.67.154

告警信息
Oct  1 2008 00:37:58-05:13 94883 %%01ARP/4/ARP_DUPLICATE_IPADDR(l)[0]:Received an ARP packet with a duplicate IP address from the interface. (IpAddress=26.27.166.30, InterfaceName=Vlanif2, MacAddress=4846-fbd7-7783)
处理过程

1、根据故障时采集的告警发现有vlanif2对应的ip地址冲突告警,根据当前的路由配置,该ip地址是用于与出口路由器互联;也就是路由器上回程路由下一跳ip地址,如对端学习到错误的arp表项会导致路由器的回包目的地址不是合法的S57上的ip+mac,进一步导致业务异常;

2、找到冲突ip地址对应终端,更改ip地址后,问题解决

根因
ip地址冲突
解决方案

找到内网冲突的PC,更改为另一个可用ip地址

建议与总结

交换机只用作数据转发,没有过多的复杂功能,只需确保arp表项、mac表项、路由正常即可;

如交换机业务有异常,请先确认连线是否支持,其次查看告警dis trapb,及各种表项是否正常

END