S7703 hybrid口与锐捷互联直连无法ping通

发布时间:  2016-03-24 浏览次数:  339 下载次数:  0
问题描述

S7703上创建vlanif 3000与锐捷vlanif 3000互联

S7703配置hybridtagged vlan 3000

锐捷trunk口透传vlan 3000

IP地址同网段,直连不通

处理过程

1、确认两端配置

华为接口侧配置

interface Vlanif3000
ip address 192.168.1.66 255.255.255.0

interface GigabitEthernet3/0/8
port link-type hybrid
port hybrid tagged vlan 3000
port hybrid untagged vlan 300
port vlan-stacking vlan 3 to 109 stack-vlan 300
port vlan-stacking vlan 111 to 299 stack-vlan 300
port vlan-stacking vlan 301 to 499 stack-vlan 300
port-mirroring to observe-port 2 inbound

锐捷侧配置

interface GigabitEthernet 0/1
switchport mode trunk

 
interface VLAN 3000
no ip proxy-arp
ip address 192.168.1.65 255.255.255.0

可以看到两端配置并没问题,而华为接口下的灵活QINQ不涉及到vlan 3000理应不影响

2、抓包查看锐捷侧过来报文

http://support.huawei.com/enterprise/product/images/d0331d70d8b14f9c89ba0b2acfac1118

可以看到锐捷到华为交换机报文时带了vlan 3000的标签,根据华为设备接口配置vlan 3000报文可以正常接收

但是锐捷并未收到回包,而且华为接口出方向也没有抓包回包

3、删除接口所有配置,重新配置为如下配置

interface GigabitEthernet3/0/8
port link-type hybrid
port hybrid tagged vlan 3000
测试后互ping成功ping通,到此可以确认是由于灵活QinQ导致了互ping不通

4、查看版本V200R007C00SPC500灵活QinQ解释,发现如下注意事项

S7700ES0D0G24SA00ES0D0G24CA00单板上,当接口配置了VLAN Stacking功能后,对于该接口上未配置Stacking的原始VLAN,默认会叠加接口的PVID,导致转发错误。这种情况可通过VLAN Mapping功能将这些原始VLAN映射到自身来解决。比如,用户同时有VLAN10VLAN20(即原始VLANVLAN10VLAN20)的报文需要发送到网络侧,且需要给VLAN10叠加外层VLAN100VLAN20不变。此时需要配置port vlan-stacking vlan 10 stack-vlan 100,同时,为了避免VLAN20转发出现问题,还需要配置port vlan-mapping vlan 20 map-vlan 20

display device确认使用单板型号

[Quidway]dis device
S7703's Device status:
Slot  Sub Type         Online    Power      Register       Status     Role 
-------------------------------------------------------------------------------
2     -   ES0DG48TFA00 Present   PowerOn    Registered     Normal     NA   
3     -   ES0D0G24SA00 Present   PowerOn    Registered     Normal     NA  

与注意事项中提到的单板型号吻合,然后在接口下添加 port vlan-mapping vlan 3000 map-vlan 3000,问题解决

根因

S7700使用ES0D0G24SA00ES0D0G24CA00单板,从V2R3支持该单板开始,该单板接口下配置VLAN Stacking(灵活QinQ)时,对于接口上未配置Stacking的原始vlan,会默认叠加接口的PVID。而应用于此问题,锐捷侧vlan 3000报文到达华为设备,vlan 3000不属于Stacking原始vlan,所以经过该接口会默认叠加接口PVIDvlan 1,而华为设备上并未配置vlanif 1,没有vlan响应所以导致互ping不通。通过vlan-mappingvlan 3000替换成vlan 3000,由于vlan-mappingvlan-Stacking优先级高,这样vlan 3000到达接口后vlan标签不改变,实现互通

解决方案

在接口下配置vlan-mapping,将vlan 3000的通过vlan-mapping替换成vlan 3000,命令为 port vlan-mapping vlan 3000 map-vlan 3000

建议与总结

S7700与其他设备对接时,如果接口下配置了port vlan-stacking (灵活QINQ)时,务必关注是否使用的是ES0D0G24SA00ES0D0G24CA00这两个型号的单板

该型号单板接口配置灵活QinQ,不是Stacking原始vlan会默认叠加接口PVID导致即使两端相同vlan也无法ping通,可以通过vlan-mapping解决,其他单板不存在该问题。

END