S5700-LI 无法学习到终端mac地址

发布时间:  2016-05-28 浏览次数:  190 下载次数:  0
问题描述

设备型号:S5700-28P-PWR-LI-AC

 

设备软件版本:V200R008C00SPC500

 

设备补丁:V200R008SPH002

 

关键配置:

#
vlan batch 17 to 20 199

interface GigabitEthernet0/0/24
port link-type trunk
port trunk pvid vlan 25
port trunk allow-pass vlan 2 to 4094 
#

 

故障现象:S5700-LI直连PC,交换机无法学习到终端mac地址

 

 

处理过程

1、查看设备mac地址表,发现无任何信息

CNSHPNR24POE02>dis mac-address 
-------------------------------------------------------------------------------
MAC Address    VLAN/VSI                          Learned-From        Type     
-------------------------------------------------------------------------------

-------------------------------------------------------------------------------
Total items displayed = 0

2、查看配置,发现接口下配置pvid vlan 25,但全局未创建vlan 25

#
vlan batch 17 to 20 199
#
interface GigabitEthernet0/0/24
port link-type trunk
port trunk pvid vlan 25
port trunk allow-pass vlan 2 to 4094
#

 

根因
端口配置pvid  vlan 25也加入了vlan 25,但是全局未创建vlan 25,导致无法学习到PC的mac地址
解决方案
端口配置pvid  vlan 25也加入了vlan 25,但是全局未创建vlan 25,全局创建vlan 25后,可以学习到PC mac地址
建议与总结
配置端口属于某vlan时,请注意全局要创建该vlan

END