ospf双进程实现不同业务链路隔离

发布时间:  2016-06-14 浏览次数:  173 下载次数:  0
问题描述

如图所示,s12700-1为数据中心1核心交换机,s12700-2为数据中心2核心交换机,数据中心的服务器网关在数据中心核心交换机上,两个数据中心交换机核心启用vrrp技术,对服务器提供网关冗余,主网关放在s12700-1上,备网关在s12700-2上。数据中心交换机一方面是服务器的网关,另一方面与区内的各大医院的网关进行三层对接,医院网关与数据中心核心交换机使用ospf路由技术,实现医院与数据中心的路由互通。拓扑图如上图所示:

由于数据中心内MCS1服务器为pacs服务器(提供影像图片的上传下载),而医院有特定的网段PC1与其进行互访,因次客户提供特定的链路(如图1,3,5链路)专门走该部分数据,其他业务不能占用1,3,5专线;而医院与数据中心的普通业务则走2,4,6链路。



客户要求:PC1和MCS1业务互访主走1链路,备走3,5链路,不能走2,4,6连链路(该部分业务流量较大,因次走1,3,5专线);


      PC2和MCS2业务互访主走2链路,备走4,6链路,不能走1,3,5连链路(该部分业务为普通业务,走2,4,6专线);


解决方案

使用ospf双进程,由于不同进程的ospf数据库相互不影响,因次只需要将不同的业务网段与不同的PC网段宣告进不同的ospf进程中,达到控制不同网段的路由从不同的链路学到,使得数据访问也使用不同链路

如医院10.10.10.0/24要与数据中心100.100.100.0/24互访使用上图中的1、3、5链路,而不使用2、4、6链路;而其他业务数据不使用该部分链路;

而医院20.20.20.0/24与数据中心200.200.200.0/24互访这部分属于普通业务,使用2、4、6链路,而不能使用1,3,5链路;

我们可以分别在12700-1、12700-2、医院网关s7706都启用ospf 1和ospf 100,

将1、3、5互联网段以及10.10.10.0/24和100.100.100.0/24宣告进ospf 1,并将链路3的ospf cost值调大;使得10和100网段互访主走1链路,备走3、5链路;

将2、4、6互联网段以及20.20.20.0/24和200.200.200.0/24宣告进ospf 100,并将链路5的ospf cost值调大,使得20和200网段数据互访主走2链路,备走4、6链路;



配置如下:

s7706:

interface GigabitEthernet1/0/20

undo portswitch

ip address 172.19.255.98 255.255.255.252

ospf network-type p2p

#

interface GigabitEthernet1/0/21

undo portswitch

ip address 172.19.255.198 255.255.255.252

ospf network-type p2p

#

interface GigabitEthernet1/0/22

undo portswitch

ip address 172.19.255.94 255.255.255.252

ospf network-type p2p

ospf cost 100


interface GigabitEthernet1/0/23

undo portswitch

ip address 172.19.255.194 255.255.255.252

ospf network-type p2p

ospf cost 100


ospf 1

area 0

network 172.19.255.98 0.0.0.0

network 172.19.255.94 0.0.0.0

network 10.10.10.0 0.0.0.255



ospf 100

area 0

network 172.19.255.198 0.0.0.0

network 172.19.255.194 0.0.0.0

network 20.20.20.0 0.0.0.255


int vlanif 100

ip address 10.10.10.254

#

int vlanif 200

ip address 20.20.20.254

#





s127-1:

interface GigabitEthernet1/0/20

undo portswitch

ip address 172.19.255.97 255.255.255.252

ospf network-type p2p


interface GigabitEthernet1/0/21

undo portswitch

ip address 172.19.255.197 255.255.255.252

ospf network-type p2p


interface GigabitEthernet1/0/22

undo portswitch

ip address 172.19.255.89 255.255.255.252

ospf network-type p2p


interface GigabitEthernet1/0/23

undo portswitch

ip address 172.19.255.198 255.255.255.252

ospf network-type p2p



interface Vlanif100

 ip address 100.100.100.253 255.255.255.0

 vrrp vrid 11 virtual-ip 200.200.200.254

 vrrp vrid 11 priority 200


interface Vlanif200

 ip address 200.200.200.253 255.255.255.0

 vrrp vrid 11 virtual-ip 20.20.20.254

 vrrp vrid 11 priority 200


ospf 1

area 0 

network 172.19.255.97 0.0.0.0

network 172.19.255.89 0.0.0.0

network 100.100.100.0 0.0.0.255


ospf 100

area 0

network 172.19.255.197 0.0.0.0

network 172.19.255.189 0.0.0.0

network 200.200.200.0 0.0.0.255





s127-1:

interface GigabitEthernet1/0/20

undo portswitch

ip address 172.19.255.93 255.255.255.252

ospf network-type p2p

ospf cost 100


interface GigabitEthernet1/0/21

undo portswitch

ip address 172.19.255.193 255.255.255.252

ospf network-type p2p

ospf cost 100


interface GigabitEthernet1/0/22

undo portswitch

ip address 172.19.255.90 255.255.255.252

ospf network-type p2p


interface GigabitEthernet1/0/23

undo portswitch

ip address 172.19.255.190 255.255.255.252

ospf network-type p2p



interface Vlanif100

 ip address 100.100.100.252 255.255.255.0

 vrrp vrid 11 virtual-ip 200.200.200.254

 vrrp vrid 11 priority 200


interface Vlanif200

 ip address 200.200.200.252 255.255.255.0

 vrrp vrid 11 virtual-ip 20.20.20.254

 vrrp vrid 11 priority 200


ospf 1

area 0 

network 172.19.255.90 0.0.0.0

network 172.19.255.93 0.0.0.0

network 100.100.100.0 0.0.0.255


ospf 100

area 0

network 172.19.255.190 0.0.0.0

network 172.19.255.193 0.0.0.0

network 200.200.200.0 0.0.0.255


END