ne20e-s 和ar2200对接GRE无法建立成功

发布时间:  2016-06-20 浏览次数:  228 下载次数:  0
问题描述
ne20e-s 和ar2200对接GRE无法建立成功,GRE tunnel接口无法up。
处理过程
最开始ne20e-s这端没有配置binding tunnel gre,就让在出接口配置后,发现GRE tunnel还是不能up。最后按照文档配置案例,把binding tunnel gre配置在loopback接口上,结果还是不行。
interface GigabitEthernet0/2/0
description TO zhengwuwang-SW
undo shutdown
ip address 10.0.9.250 255.255.255.0
undo dcn
binding tunnel gre

interface Tunnel0/0/1
description To Cloud-AR2240
ip address 172.16.62.37 255.255.255.252
tunnel-protocol gre
source 10.0.9.250
destination 10.1.28.17

之后查看binding tunnel gre命令介绍,发现tunnel接口分3维和1维的区别,之后改为1维的接口编号问题解决。
根因

路由器支持两种GRE:
分布式GRE:GRE隧道报文直接在入接口板上进行封装和解封装处理,分布式GRE使用的是1维Tunnel接口。
集中式GRE:GRE隧道报文集中在一块业务处理板上进行封装和解封装处理,集中式GRE使用的是3维Tunnel接口。

正好ne20e-s就是分布式的场景,接口板本身就支持GRE,所以要用1维的接口编号。

解决方案

原配置:

interface Tunnel0/0/1
description To Cloud-AR2240
ip address 172.16.62.37 255.255.255.252
tunnel-protocol gre
source 10.0.9.250
destination 10.1.28.17


修改后的配置:


interface Tunnel1
description To Cloud-AR2240
ip address 172.16.62.37 255.255.255.252
tunnel-protocol gre
source 10.0.9.250
destination 10.1.28.17

END