S6700 (V200R005) 两台对接其中一台设备vlanif接口不能up

发布时间:  2016-06-25 浏览次数:  152 下载次数:  0
问题描述

两台S6700 对下起vrrp ,通过eth-trunk 2互联,其中S6700 B vlanif 不up     (配置见附件)

 
  S6700 A

vlan batch 101 to 103


Eth-Trunk2                  up    up           0%     0%          0          0
  XGigabitEthernet0/0/13    up    up           0%     0%          0          0
  XGigabitEthernet0/0/14    up    up           0%     0%          0          0
  XGigabitEthernet0/0/15    up    up           0%     0%          0          0
  XGigabitEthernet0/0/16    up    up           0%     0%          0          0

Vlanif101                   up    up           --     --          0          0
Vlanif102                   up    up           --     --          0          0
Vlanif103                   up    up           --     --          0          0

interface Vlanif101
ip address 192.168.101.251 255.255.255.0
vrrp vrid 1 virtual-ip 192.168.101.253
vrrp vrid 1 priority 120
#
interface Vlanif102
ip address 192.168.102.251 255.255.255.0
vrrp vrid 2 virtual-ip 192.168.102.253
vrrp vrid 2 priority 120
#
interface Vlanif103
ip address 172.18.3.251 255.255.252.0
vrrp vrid 3 virtual-ip 172.18.3.254
vrrp vrid 3 priority 120

interface Eth-Trunk2
port link-type trunk
port trunk allow-pass vlan 101 to 103
mode lacp

Eth-Trunk2 current state : UP
Line protocol current state : UP
Description:
Switch Port, Link-type : trunk(configured),
PVID :    1, Hash arithmetic : According to SIP-XOR-DIP,Maximal BW: 40G, Current BW: 40G, The Maximum Frame Length is 9216
IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is 0c45-ba20-b0e0
Current system time: 2016-04-06 09:28:00+08:00
Last 300 seconds input rate 784 bits/sec, 0 packets/sec
Last 300 seconds output rate 2320 bits/sec, 3 packets/sec
Input:  43344 packets, 6075306 bytes
  Unicast:                          0,  Multicast:                       43344
  Broadcast:                        0,  Jumbo:                               0
  Discard:                          0,  Pause:                               0
  Frames:                           0

  Total Error:                      0
  CRC:                              0,  Giants:                              0
  Jabbers:                          0,  Fragments:                           0
  Runts:                            0,  DropEvents:                          0
  Alignments:                       0,  Symbols:                             0
  Ignoreds:                         0

Output:  680369 packets, 60331750 bytes
  Unicast:                          0,  Multicast:                      193550
  Broadcast:                   486819,  Jumbo:                               0
  Discard:                          0,  Pause:                               0

  Total Error:                      0
  Collisions:                       0,  ExcessiveCollisions:                 0
  Late Collisions:                  0,  Deferreds:                           0
  Buffers Purged:                   0 
 
    Input bandwidth utilization  :    0%
    Output bandwidth utilization :    0%
-----------------------------------------------------
PortName                      Status      Weight
-----------------------------------------------------
XGigabitEthernet0/0/13        UP          1     
XGigabitEthernet0/0/14        UP          1     
XGigabitEthernet0/0/15        UP          1     
XGigabitEthernet0/0/16        UP          1  


  S6700  B


InUti/OutUti: input utility/output utility
Interface                   PHY   Protocol  InUti OutUti   inErrors  outErrors
Eth-Trunk2                  up    up           0%     0%          0          0
  XGigabitEthernet0/0/13    up    up           0%     0%          0          0
  XGigabitEthernet0/0/14    up    up           0%     0%          0          0
  XGigabitEthernet0/0/15    up    up           0%     0%          0          0
  XGigabitEthernet0/0/16    up    up           0%     0%          0          0

Vlanif101                   down  down         --     --          0          0     全是down的状态
Vlanif102                   down  down         --     --          0          0
Vlanif103                   down  down         --     --          0          0

interface Vlanif101
ip address 192.168.101.252 255.255.255.0
vrrp vrid 1 virtual-ip 192.168.101.253
#
interface Vlanif102
ip address 192.168.102.252 255.255.255.0
vrrp vrid 2 virtual-ip 192.168.102.253
#
interface Vlanif103
ip address 172.18.3.252 255.255.255.0
vrrp vrid 3 virtual-ip 172.18.3.254

interface Eth-Trunk2
port link-type trunk
port trunk allow-pass vlan 101 to 103
mode lacp

Eth-Trunk2 current state : UP
Line protocol current state : UP
Description:
Switch Port, Link-type : trunk(configured),
PVID :    1, Hash arithmetic : According to SIP-XOR-DIP,Maximal BW: 40G, Current BW: 40G, The Maximum Frame Length is 9216
IP Sending Frames' Format is PKTFMT_ETHNT_2, Hardware address is 0c45-ba18-c3d0
Current system time: 2016-04-06 09:44:45+08:00
Last 300 seconds input rate 8624 bits/sec, 12 packets/sec
Last 300 seconds output rate 800 bits/sec, 0 packets/sec
Input:  6293 packets, 561637 bytes
  Unicast:                          0,  Multicast:                        1707
  Broadcast:                     4586,  Jumbo:                               0
  Discard:                          0,  Pause:                               0
  Frames:                           0

  Total Error:                      0
  CRC:                              0,  Giants:                              0
  Jabbers:                          0,  Fragments:                           0
  Runts:                            0,  DropEvents:                          0
  Alignments:                       0,  Symbols:                             0
  Ignoreds:                         0

Output:  430 packets, 61017 bytes
  Unicast:                          0,  Multicast:                         430
  Broadcast:                        0,  Jumbo:                               0
  Discard:                          0,  Pause:                               0

  Total Error:                      0
  Collisions:                       0,  ExcessiveCollisions:                 0
  Late Collisions:                  0,  Deferreds:                           0
  Buffers Purged:                   0 
 
    Input bandwidth utilization  :    0%
    Output bandwidth utilization :    0%
-----------------------------------------------------
PortName                      Status      Weight
-----------------------------------------------------
XGigabitEthernet0/0/13        UP          1     
XGigabitEthernet0/0/14        UP          1     
XGigabitEthernet0/0/15        UP          1     
XGigabitEthernet0/0/16        UP          1     
-----------------------------------------------------
The Number of Ports in Trunk : 4
The Number of UP Ports in Trunk : 4

处理过程

Eth-Trunk2                  up    up           0%     0%          0          0
  XGigabitEthernet0/0/13    up    up           0%     0%          0          0
  XGigabitEthernet0/0/14    up    up           0%     0%          0          0
  XGigabitEthernet0/0/15    up    up           0%     0%          0          0
  XGigabitEthernet0/0/16    up    up           0%     0%          0          0
1、排查是否透传vlan

S6700  B
interface Eth-Trunk2
port link-type trunk
port trunk allow-pass vlan 101 to 103
mode lacp 
以上配置证明接口是透传了vlan

2、物理接口是否up

S6700  B
Eth-Trunk2                  up    up           0%     0%          0          0
  XGigabitEthernet0/0/13    up    up           0%     0%          0          0
  XGigabitEthernet0/0/14    up    up           0%     0%          0          0
  XGigabitEthernet0/0/15    up    up           0%     0%          0          0
  XGigabitEthernet0/0/16    up    up           0%     0%          0          0

以上配置证明物理接口也是up的

3、是否创建了vlan

查看S6700 A

vlan batch 101 to 103

创建了vlan 101 to 103,而从S6700 B的配置中,发现并没有创建vlan 101 to 103

 

根因
S6700 B上没有创建相应vlan
解决方案


在S6700 B上配置 vlan batch 101 to 103后查看vlanif 接口物理协议均up状态


Vlanif101                   up    up           --     --          0          0
Vlanif102                   up    up           --     --          0          0
Vlanif103                   up    up           --     --          0          0

建议与总结

vlanif up的必备条件:

1,首先创建相应vlan

2,接口透传此vlan

3,vlanif 配置了ip

4,对应物理接口up状态

此问题虽然简单,但是第一点也最容易忽略,希望大家注意。

END