S7706交换机因Eth-trunk聚合口环路导致全网广播风暴现象

发布时间:  2016-07-05 浏览次数:  853 下载次数:  0
问题描述

网络拓扑如上图所示,某单位网络为安防监控网,接入摄像头大概在1000多个,核心为S7706交换机堆叠,接入交换机为S5700级联组网并下挂各点位摄像头。服务器为vlan10直接挂在核心S7706下,摄像头属于vlan1.摄像头与监控服务器网关全部在核心S7706上。

故障现象为:

网络交付后完成后客户反馈海康威视监控视频反复频卡顿和离线,监控室ping摄像头地址丢包严重。

告警信息

在核心交换机上查看告警信息如下,eth-trunk接口出现mac地址漂移,经检查实际mac地址为一台摄像头mac,挂在接入侧,但mac地址却漂移到互联核心的上行eth-trunk接口。

Jun 14 2016 20:46:36-08:00 Huawei L2IFPPI/4/MFLPVLANALARM:OID 1.3.6.1.4.1.2011.5

.25.160.3.7 MAC move detected, VlanId = 1, MacAddress = 4c1f-ccd6-24b4, Original

-Port = Eth-Trunk1, Flapping port = GE0/0/3 and GE0/0/1. Please check the networ

k accessed to flapping port.

处理过程

1、通过抓包分析原因:经过抓包检查发现网络存在大量广播包,为视频服务器及摄像头发出arp请求广播包,抓包如下:



抓包统计显示,每秒抓到一两万个arp广播包。

2、分析核心交换机7706日志发现如下告警:

Jun 14 2016 20:46:36-08:00 Huawei L2IFPPI/4/MFLPVLANALARM:OID 1.3.6.1.4.1.2011.5

.25.160.3.7 MAC move detected, VlanId = 1, MacAddress = 4c1f-ccd6-24b4, Original

-Port = Eth-Trunk1, Flapping port = GE0/0/3 and GE0/0/1. Please check the networ

k accessed to flapping port.

3、如上分析可以看出产生大量广播风暴的原因是交换机产生环路导致,依据漂移提示的端口进一步向下排查为eth-trunk1下联交换机可能存在环路。Eth-trunk1下联一台S5700交换机,漂移的mac地址为摄像机mac,登陆到S5700交换机查看flaping信息。如下:

[Huawei]display mac-address flapping record

S  : start time                                                               

E  : end time                                                                 

(Q) : quit vlan                                                                

(D) : error down                                                               

-------------------------------------------------------------------------------

Move-Time             VLAN MAC-Address   Original-Port   Move-Ports      MoveNum

-------------------------------------------------------------------------------



S:2016-06-14 18:45:56 1    4c1f-cc8b-1594 GE0/0/1         GE0/0/2         3061  

E:2016-06-14 20:56:02                                     

继续检查lldp信息发现漂移的端口未上连核心S7706交换机的接口。

[Huawei]display lldp ne brief

Local Intf   Neighbor Dev             Neighbor Intf             Exptime

GE0/0/1      HXS7706                  GE0/0/1                   117   

GE0/0/2      HXS7706                  GE0/0/2                   117

4、如上显示漂移发生在S5700和S7706之间,分别检查S7706与S5700互联接口配置如下:

S7706:


interface Eth-Trunk1

port link-type trunk

port trunk allow-pass vlan 2 to 4094

#

interface GigabitEthernet0/0/1

eth-trunk 1

#

interface GigabitEthernet0/0/2

eth-trunk 1

#




S5700:


interface GigabitEthernet0/0/1

port link-type trunk

port trunk allow-pass vlan 2 to 4094

#

interface GigabitEthernet0/0/2

port link-type trunk

port trunk allow-pass vlan 2 to 4094

#

检查配置发现该点位接入交换机上行接口配置错误,核心侧配置eth-trunk链路聚合但S5700上行接口并未配置链路聚合,因而导致环路。

 

S5700上行端口配置成链路聚合:

interface Eth-Trunk1

 port link-type trunk

 port trunk allow-pass vlan 2 to 4094

#

interface GigabitEthernet0/0/1

 eth-trunk 1

#

interface GigabitEthernet0/0/2

 eth-trunk 1

#

配置完成后问题解决。

根因

核心侧S7706配置了eth-trunk手工链路聚合,但是S5700上行接口并未配置链路聚合,因而导致环路。

解决方案

由于视频监控网接入交换机非常多,在大批量的交换机开局时可能存在配置错误。

处理方法为:将S5700上行端口配置成链路聚合, 配置完成后问题解决

建议与总结

在交换机数量较大时,建议将链路聚合方式改为lacp方式,避免使用手工聚合,因为lacp模式及时出现接入交换机配置错误也会避免因eth-trunk聚合错误而产生的环路。

END