s5700配置vlanif后不能ping通不能up

发布时间:  2016-12-22 浏览次数:  857 下载次数:  0
问题描述
s5700配置vlanif后不能ping通,将接口加入了该VLAN后端口up,vlanif也不能正常up
处理过程

一、查看接口状态信息

[S5700]display interface brief                                            
PHY: Physical                                                                  
*down: administratively down                                                   
(l): loopback                                                                  
(s): spoofing                                                                  
(b): BFD down                                                                  
(e): ETHOAM down                                                               
(dl): DLDP down                                                                
(d): Dampening Suppressed                                                      
InUti/OutUti: input utility/output utility                                     
Interface                   PHY   Protocol InUti OutUti   inErrors  outErrors  

MEth0/0/1                   down  down         0%     0%          0          0 
NULL0                       up    up(s)        0%     0%          0          0 
Vlanif1                     up    up           --     --          0          0 
Vlanif2                     up    up           --     --          0          0 
Vlanif500                   up    up           --     --          0          0 
Vlanif1000                  down  down         --     --          0          0

二、查看接口配置是否正常

[S5700-GigabitEthernet0/0/24]display this                                  
#                                                                              
interface GigabitEthernet0/0/24                                                
port link-type trunk                                                          
port trunk allow-pass vlan 2 to 4094        

三、检查配置是否在vlanif下面配置了shutdown 

 [S5328C-EI]display current-configuration                                       
#                                                                              
!Software Version V200R007C00SPC500                                             
                                                                                                                          
#                                                                              
vlan batch 2 500                                                                                                                                 
#                                                                              
interface Vlanif1                                                              
ip address 1.1.1.1 255.255.255.0   
#
interface Vlanif500   
ip address 10.10.5.1 255.255.255.0                                       
#                                                                              
interface Vlanif1000
ip address 10.10.1.1 255.255.255.0                                   
#                                        

根因
在s5700上未创建VLAN直接创建了vlanif接口,导致vlanif不能up。
解决方案

在设备系统试图下创建对应VLAN后正常

[S5700]vlan 1000                                                           
[S5700-vlan1000]  

建议与总结

S5700在V200R005及以后版本不创建VLAN直接创建vlanif地址设备不会报错,可以直接配置。

在V200R005之前的版本在创建vlanif时必须有对应的VLAN不然会报错。

[S5700]interface Vlanif 200                                                      
Error: The VLAN does not exist.

END