华为S9712与华三8600路由器OSPF无法建立邻接关系

发布时间:  2016-08-02 浏览次数:  144 下载次数:  0
问题描述

华为S9712与华三8600路由器OSPF无法建立邻接关系

1、XXX网络拓扑如下:



2、网络配置说明:
     1、整个网络的核心为华为两台S9712组成,与各盟市地区互联为华三的8600路由器(主备),组成口字型网络实现主备数据转发。各盟市的主路由与核心的主交换机建立OSPF邻接关系,备路由与核心的备交换机建立OSPF邻接关系。整个核心网络的互联使用的IGP协议为OSPF。
     2、两台核心华为交换机S9712互联VLAN为VLAN900
     3、华为S9712与华三的8600路由器互联VLAN910,路由器启动子接口
     4、备交换机上的接口地址及相关配置:


interface Vlanif900            核心交换机互联VLAN
description pinglianSW2-1
ip address 1.23.0.6 255.255.255.252
#
interface Vlanif910            与华三路由器互联的VLAN
description shanglianRT4-2
ip address 1.23.2.2 255.255.255.240
#
5、华三备路由器的接口地址及相关配置
interface GE1/0/0.910         与华为交换机互联的VLAN
description shanglianSW2-2
ip address 1.23.2.1 255.255.255.240
#

2、 故障现象说明:
    1、华为交换机与华三路由器中间的防火墙重新启动后,华为S9712与华三的8600无法建立OSPF关系,并且华三路由器收到OSPF密钥不匹配错误,我方交换机收到以下日志提示信息:


Jul 20 2016 17:49:40+08:00 NMGS-HH-SJL-H-S2.MCE %%01OSPF/6/BAD_OSPF_PACKET(l)[5]:Received the first bad OSPF packet within an interval of 15 minutes. (ErrorType=Cryto Authentication error, ErrorInformation=Authentication data mismatch, ProcessId=100, InterfaceName=Vlanif910, SourceAddress=1.23.1.1, DestinationAddress=224.0.0.5, NeighborRouterId=1.22.0.1, PacketType=1, Count=12, PacketLength=48, PacketContent= 02 01 00 30 15 16 00 01 00 00 00 00 00 00 00 02 00 00 0a 10 00 00 11 5f ff ff ff f0 00 0a 02 01 00 00 Jul 20 2016 15:36:06+08:00 NMGS-HH-SJL-H-S2.MCE %%01OSPF/4/NBR_CHANGE_E(l)[24]:Neighbor changes event: neighbor status changed. (ProcessId=100, NeighborAddress=1.23.40.130, NeighborEvent=LoadingDone, NeighborPreviousState=Loading, NeighborCurrentState=Full)



Jul 20 2016 20:45:09+08:00 NMGS-HH-SJL-H-S2.MCE %%01OSPF/6/BAD_OSPF_PACKET(l)[46]:Received the first bad OSPF packet within an interval of 15 minutes. (ErrorType=Cryto Authentication error, ErrorInformation=Authentication data mismatch, ProcessId=100, InterfaceName=Vlanif910, SourceAddress=1.23.1.2, DestinationAddress=224.0.0.5, NeighborRouterId=1.22.0.3, PacketType=1, Count=11, PacketLength=48, PacketContent= 02 01 00 30 15 16 00 03 00 00 00 00 00 00 00 02 00 00 0a 10 06 1c e6 a6 ff ff ff f0 00 0a 02 01 00 00 00 28 00 00 00 00 00 00 00 00 15 16 00 01)




2、通过命令查看OSPF状态结果是:


华为设备OSPF状态为FULL状态而华三的路由器OSPF为InIt状态
         OSPF Process 100 with Router ID 1.22.0.4
                  Peer Statistic Information
----------------------------------------------------------------------------
Area Id          Interface              Neighbor id      State   
0.0.0.0          Vlanif900                  1.22.0.3        Full       
0.0.0.0          Vlanif910                   1.21.0.2       Full


告警信息:
设备无告警信息
<NMGS-HH-SJL-H-S2.MCE>dis alarm all
----------------------------------------------------------------------------
NO alarm
---------------------------------------------------------------------------- 


原因分析:
    1、 根据日志提示信息与客户进行确认,以下源地址是分别为华为主交换机与华三主路由器互联的接口地址。
    InterfaceName=Vlanif910, SourceAddress=1.23.1.1
    InterfaceName=Vlanif910, SourceAddress=1.23.1.2,


    2、与华三工程师沟通确认收到的OSPF密钥不匹配的提示信息也是以上两台设备发过来的组播报文。
    InterfaceName=Vlanif910, SourceAddress=1.23.1.1
    InterfaceName=Vlanif910, SourceAddress=1.23.1.2,


处理过程
处理过程:


步骤一、根据客户要求对设备做自查,确认设备没有故障。

步骤二、根据以上日志信息,与客户沟通对整个组网结构进行排查,整个核心区的设备全部采用三层互联启动OSPF协议进行互联。

步骤三、发现核心交换机之间通过VLAN三层互联后同时透传相关VLAN,导致主设备的OSPF组播报文透传至备设备上导致备设备OSPF MD5认证失败。


interface Eth-Trunk10
description To:SW2-1
port link-type trunk
port trunk allow-pass vlan 301 to 993


步骤四、处理过程

interface Eth-Trunk10
description To:SW2-1
port link-type trunk
port trunk allow-pass vlan 301 to 993
    undo port trunk allow-pass vlan 910     把该VLAN从列表中删除

    步骤五、对业务进行测试,双方设备的OSPF建立正常。

根因

原因还是组网的时候没有考虑到广播的问题,导致OSPF无法建立。

END