FAQ-如何让ospf宣告sub地址的路由

发布时间:  2016-08-09 浏览次数:  580 下载次数:  0
问题描述

设备型号:s12700交换机 

软件版本:V200R005C00SPC500

组网拓扑:


LSW2配置:

interface Vlanif1
ip address 1.1.1.2 255.255.255.0

ospf 1
area 0.0.0.0
  network 1.1.1.0 0.0.0.255

LSW1配置:

interface Vlanif1
ip address 1.1.1.1 255.255.255.0
#
interface Vlanif2
ip address 2.2.2.2 255.255.255.0
ip address 3.3.3.3 255.255.255.0 sub

interface GigabitEthernet0/0/2
port link-type access
port default vlan 2

ospf 1
area 0.0.0.0
  network 1.1.1.0 0.0.0.255
  network 3.3.3.0 0.0.0.255

故障现象:

LSW1在ospf里面宣告了sub地址3.3.3.3以后,在LSW2里面查看路由表没有路由信息:

[Huawei-ospf-1]dis ip routing-table
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
         Destinations : 4        Routes : 4       

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

        1.1.1.0/24  Direct  0    0           D   1.1.1.2         Vlanif1
        1.1.1.2/32  Direct  0    0           D   127.0.0.1       Vlanif1
      127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
      127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0

解决方案

需要在ospf区域里面宣告sub地址对应接口的主地址

interface Vlanif2
ip address 2.2.2.2 255.255.255.0
ip address 3.3.3.3 255.255.255.0 sub

area 0.0.0.0
  network 1.1.1.0 0.0.0.255
  network 3.3.3.0 0.0.0.255   
  network 2.2.2.0 0.0.0.255  ---先宣告主地址

宣告以后即可看到sub网段的路由信息:

 

[Huawei-ospf-1]dis ip routing-table
Route Flags: R - relay, D - download to fib
------------------------------------------------------------------------------
Routing Tables: Public
         Destinations : 6        Routes : 6       

Destination/Mask    Proto   Pre  Cost      Flags NextHop         Interface

        1.1.1.0/24  Direct  0    0           D   1.1.1.2         Vlanif1
        1.1.1.2/32  Direct  0    0           D   127.0.0.1       Vlanif1
        2.2.2.0/24  OSPF    10   2           D   1.1.1.1         Vlanif1
        3.3.3.0/24  OSPF    10   2           D   1.1.1.1         Vlanif1   ----包含了sub地址的路由信息
      127.0.0.0/8   Direct  0    0           D   127.0.0.1       InLoopBack0
      127.0.0.1/32  Direct  0    0           D   127.0.0.1       InLoopBack0

END