CE12800部署M-lag双活网关,互联服务器网络时断时续

发布时间:  2016-12-15 浏览次数:  120 下载次数:  0
问题描述

1.  组网描述:

网关:2CE12808部署M-lag双活网关 通过Eth-trunk9互联服务器的接入TOR,通过Eth-trunk10互联VRM服务器

TOR:2CE6850部署istack堆叠通过Eth-trunk0互联网关CE12808,通过Eth-trunk接口互联计算服务器;

服务器:计算服务器、VRM服务器部署Bond网卡互联交换机设备;

2.  问题描述:

计算服务器和VRM服务器都部署在同一个VLAN 300中,计算服务器之间通过CE5855互访正常,但是访问VRM服务器网络时断时续。

3.  网关配置如下:

=============

CE12808-1

=============

#

interface Vlanif300

 description TO_guanli

 ip address 10.112.200.253 255.255.255.0

 vrrp vrid 1 virtual-ip 10.112.200.254

##

interface Eth-Trunk9

 description TO_J4F-C31211-GYY-CE5855-01_1.1.112.7_ETH-TRUNK0

 port link-type trunk

 undo port trunk allow-pass vlan 1

 port trunk allow-pass vlan 300 302 350 996

 mode lacp-static

dfs-group 1 m-lag 9

#

interface Eth-Trunk10

 description TO_C320_Openstack_SV4_bond0

 port link-type trunk

 undo port trunk allow-pass vlan 1

 port trunk allow-pass vlan 300

 dfs-group 1 m-lag 10

#

=============

CE12808-2

=============

#

interface Vlanif300

 description TO_guanli

 ip address 10.112.200.252 255.255.255.0

 vrrp vrid 1 virtual-ip 10.112.200.254

#

interface Eth-Trunk9

 description TO_J4F-C31211-GYY-CE5855-01_1.1.112.7_ETH-TRUNK0

 port link-type trunk

 undo port trunk allow-pass vlan 1

 port trunk allow-pass vlan 300 302 350 996

 mode lacp-static

dfs-group 1 m-lag 9

#

interface Eth-Trunk10

 description TO_C320_Openstack_SV4_bond0

 port link-type trunk

 undo port trunk allow-pass vlan 1

 port trunk allow-pass vlan 300

 dfs-group 1 m-lag 10

#

 

告警信息

处理过程
1.根据故障现象,将CE12808-1、CE12808-2上互联VRM服务器的接口从Eth-trunk10中删除,并配置为普通的二层trunk接口;
#
interface 10GE7/0/43
undo eth-trunk 10   //将接口从Eth-trunk10中删除
port link-type trunk   //配置接口类型为trunk
undo port trunk allow-pass vlan 1 
port trunk allow-pass vlan 300
#

根因

经过故障定位和排查,发现VRM服务器配置的bond接口模式为主备模式,备网卡是不会发送和处理数据流量,而交换机的Eth-trunk接口是负载均衡的,如果流量流向VRM服务器的备份网卡,业务会中断,如果流量流向VRM的主网卡,则业务正常,所以才有时通时断的现象;

解决方案

按照服务器产品文档建议,删除CE12808互联VRMEth-trunk接口,并将互联的物理接口配置为二层trunk接口,配置如下;

=======

CE12808-1

=======

#

interface 10GE7/0/43

 description TO_C320_Openstack_SV4_bond0

 port link-type trunk

 undo port trunk allow-pass vlan 1

 port trunk allow-pass vlan 300

#

========

=CE12808-2

=======

#

interface 10GE7/0/43

 description TO_C320_Openstack_SV4_bond0

 port link-type trunk

 undo port trunk allow-pass vlan 1

 port trunk allow-pass vlan 300

#

建议与总结
服务器bond网卡与交换机对接建议如下:
1.服务器bond网卡(主备模式)-------> 交换机工作在堆叠或M-LAG模式下,互联的接口不需要加入到Eth-trunk接口中;
2.服务器bond网卡(负载均衡模式)---> 交换机工作在堆叠或M-LAG模式下,互联的接口需要配置到相同Eth-trunk接口中并启用LACP;

END