Java已安装,启动BMC远程控制时仍提示需要安装插件

发布时间:  2017-02-23 浏览次数:  938 下载次数:  0
问题描述

客户端PC上已正确安装Java 7,并且已调整安全级别至“中”,但通过BMC启动远程控制时仍提示“需要安装插件”。

FireFox提示信息如下图,

尝试使用IE浏览器,也卡在如下界面无法进入远程控制,

处理过程

1.在cmd下用java -version检查Java版本,发现版本为1.7,没有问题。

2.检查java配置,“启用浏览器中的Java内容”已勾选,安全级别已调为“中”,都没问题。

3.最后检查发现,浏览器IE和FireFox均为32bit版本,而Java为64bit版本,考虑可能是这一点没匹配导致的问题。

4.卸载Java 7 64bit,重新安装Java 7 32bit,问题解决。

根因
由于客户端PC Windows操作系统为64位,安装Java时默认安装了64bit版本,而系统中浏览器为32bit版本,Java和浏览器版本不匹配导致Java在浏览器中不生效。所以必须安装32bit Java环境以适应32bit浏览器,而不能根据Windows为64位而安装64bit Java。

END