刀片服务器通过HMM界面kvm远程连接无响应故障处理

发布时间:  2017-02-26 浏览次数:  380 下载次数:  0
问题描述

前提注意:os 版本 java 版本 浏览器 版本

MM版本

JRE版本

IE浏览器

Firefox浏览器

Chrome

2.20及之前版本

JRE1.6

JRE1.7

Internet Explorer 8.0及以上版本

只支持32位浏览器

Mozilla Firefox 9.0以上

只支持32位浏览器

Chrome 13.0 ~Chrome 41.0

只支持32位浏览器

2.52~5.50

JRE1.6

JRE1.7

JRE1.8

Internet Explorer 8.0及以上版本

Mozilla Firefox 9.0以上

Chrome 13.0 ~Chrome 41.0

5.51~5.58

JRE1.7

JRE1.8

Internet Explorer 8.0及以上版本

Mozilla Firefox 20.0以上

Chrome 25.0 ~Chrome 41.0

5.59之后

JRE1.6(需要手工打开TLS1.0)

JRE1.7

JRE1.8

Internet Explorer 8.0及以上版本

Mozilla Firefox 9.0~ Mozilla Firefox 20.0:需要手工打开TLS1.0,

Mozilla Firefox 20.0以上:自动支持

Chrome 13.0 ~Chrome 25.0:需要手工打开

Chrome 25.0~Chrome 41.0:自动支持

问题描述:无法打开KVM,有错误提示,如下:


告警信息

打开kvm后,出现ClassNotFoundException错误




处理过程

【步骤1】查询MM板的版本号


【步骤2】查看JRE版本版本

在“控制面板 > 程序”下打开java控制台,在“常规”标签下点击“关于”,查看java版本:


如果MM板的版本是2.20及之前版本,并且JRE1.8版本,需要把MM板升级到最新版本或者把JRE安装成1.7版本。

【步骤3】查看浏览器是否位64


如果操作系统是64位,但是浏览器的进程没有 *32 的标志,表示使用64位的浏览器;如果有 *32 的标志,表示使用32位浏览器。

MM板的2.20及之前版本,必须使用32位浏览器。

【步骤4】 查看JRE1.71.8版本的安全级别是否为高以上,如果是,需要增加例外站点:


JRE1.7版本可以选择中的安全级别,选择为中安全级别后,可以不添加例外站点。

JRE1.8版本只能选择高以上的级别,需要增加例外站点。

【步骤5】 查看是否选择了TLS1.1TLS1.2

MM板在5.51以上版本,JRE需要选择TLS1.1TLS1.2


【步骤6】如果是火狐浏览器,查看JRE是否被禁用,如果JRE被禁用,需要打开。


--结束

根因

问题原因

Ø  MM2.20及之前的版本使用JRE1.8版本

Ø  2.20及之前版本使用64位浏览器

Ø  JRE1.7JRE1.8版本的安全级别为高及以上,但是没有增加例外站点。

Ø   MM5.51以上版本,没有选中TLS1.1TLS1.2

Ø   火狐浏览器的JRE被禁用

解决方案

【步骤1】查询MM板的版本号

【步骤2】查看JRE版本版本,在“控制面板 > 程序”下打开java控制台,在“常规”标签下点击“关于”,查看java版本:

如果MM板的版本是2.20及之前版本,并且JRE1.8版本,需要把MM板升级到最新版本或者把JRE安装成1.7版本。

【步骤3】查看浏览器是否位64

如果操作系统是64位,但是浏览器的进程没有 *32 的标志,表示使用64位的浏览器;如果有 *32 的标志,表示使用32位浏览器。

MM板的2.20及之前版本,必须使用32位浏览器。

【步骤4】 查看JRE1.71.8版本的安全级别是否为高以上,如果是,需要增加例外站点:

JRE1.7版本可以选择中的安全级别,选择为中安全级别后,可以不添加例外站点。

JRE1.8版本只能选择高以上的级别,需要增加例外站点。

【步骤5】 查看是否选择了TLS1.1TLS1.2

MM板在5.51以上版本,JRE需要选择TLS1.1TLS1.2

【步骤6】如果是火狐浏览器,查看JRE是否被禁用,如果JRE被禁用,需要打开。

--结束






建议与总结

E9000刀片系列HMM,kvm远程连接无响应

os_版本 java_版本 浏览器_版本,匹配及设置问题,会导致无法打开页面,对设备管理造成影响,上述方法可参考,排查及解决KVM远程无响应问题


END