S7703(DHCP server)----S5700--PC PC获取不到地址

发布时间:  2017-03-18 浏览次数:  243 下载次数:  0
问题描述

S7703(DHCP server)----S5700--PC   PC获取不到地址

S7703和S5700都是Version V200R008C00SPC500

告警信息

处理过程

1.梳理设备配置,核对故障现象

S7703的配置
vlan batch 101 to 125 350
interface Vlanif102
 ip address 10.122.2.254 255.255.255.0
 dhcp select interface
 dhcp server excluded-ip-address 10.122.2.2 10.122.2.24
 dhcp server lease day 999 hour 0 minute 0
interface Vlanif111
 ip address 10.122.11.254 255.255.255.0
 dhcp select interface
 dhcp server lease day 999 hour 0 minute 0
interface GigabitEthernet2/0/2           //互联S5700交换机G0/0/48
 port link-type trunk
 undo port trunk allow-pass vlan 1
 port trunk allow-pass vlan 102 to 114

 
S5700的配置

vlan batch 102
interface GigabitEthernet0/0/48     //互联S7703交换机G2/0/2
 port link-type trunk
 undo port trunk allow-pass vlan 1
 port trunk allow-pass vlan 102 to 114
 
interface GigabitEthernet0/0/1      //接PC获取不到地址
 port link-type access
 port default vlan 111
#
interface GigabitEthernet0/0/2      //接PC可获取地址
 port link-type access                   
 port default vlan 102

2.display vlan查看信息,GigabitEthernet0/0/1没有VLAN 111. 

梳理配置和核对故障现象后可以发现:VLAN 102内PC可以获取地址,VLAN 1111内PC不能获取地址。

对比所有相关配置,发现二者唯一区别在S5700上,vlan 102 被创建了,VLAN 111 没有被创建。

在S5700上创建VLAN 111 后测试,问题解决。

 

根因

 

port default vlan配置未创建的VLAN为PVID,则收到的untagged报文加入的PVID为VLAN 1,当PVID VLAN全局创建后,接口的PVID值刷新为当前配置值。

解决方案

在S5700上配置:

vlan 111

建议与总结

这里有个常被忽略的问题一定要谨记,不然小问题会成为大麻烦。port default vlan在使用时

若配置未创建的VLAN为PVID,则收到的untagged报文加入的PVID为VLAN 1,当PVID VLAN全局创建后,接口的PVID值刷新为当前配置值。

END