FusionCompute centos 7.0 安装Pv driver报错,提示提示“error: please boot kernel 3.10.0-514.6.2.el7.x86_86 and upgrade again”

发布时间:  2017-05-12 浏览次数:  40 下载次数:  0
问题描述

centos 7.0 安装Pv driver报错,提示提示“error: please boot kernel 3.10.0-514.6.2.el7.x86_86 and upgrade again”

版本:FusionCompute R5C10

告警信息

处理过程

1、通过vnc登录虚拟机内部,执行./install进行pvdriver安装, 报错误提示为“error: please boot kernel 3.10.0-327.el7.x86_86 and upgrade again”;

2、通过执行命令uname -a 查看当前内核版本;


3、通过查看/etc/.uvp-monitor/version.ini, 发现所记录的内核版本和出错版本一致。


4、由于安装pvdriver时会查询虚拟机的内核版本,在配置文件/etc/.uvp-monitor/version.ini中读取内核版本,将配置文件中的内核版本信息删除掉后,这样检查的时候会跳过此步骤。

5、删除/etc/.uvp-monitor/version.ini中的kernalVersion=”3.10.0-327.el7.x86_64", 保存后重新执行./install,安装成功,tools正常运行。

6、在产品文档中也有操作系统的兼容性列表,可以进行查看。


7、如果升级响应的内核版本,请参考产品文档。



华为兼容性列表链接:http://support.huawei.com/onlinetool/datums/fusioncloud/comptool/index.jsp


根因

删除/etc/.uvp-monitor/version.ini中的kernalVersion=”3.10.0-327.el7.x86_64", 保存后重新执行./install,安装成功,Tools正常运行。

解决方案

删除/etc/.uvp-monitor/version.ini中的kernalVersion=”3.10.0-327.el7.x86_64", 保存后重新执行./install,安装成功,Tools正常运行。

END