Pixelation in VOD Programs Due to Multicast Traffic Bursts

Publication Date:  2015-03-24 Views:  755 Downloads:  0
Issue Description
Applicable Products and Versions:

S2700&S3700&S5700 V100R005/V100R006/V200R001/V200R002/V200R003
S6700 V100R006/V200R001/V200R002/V200R003
S7700&S9700 V100R003/V100R006/V200R001/V200R002/V200R003

Networking:

User terminals connected to a switch can use the video on demand (VOD) service.

Pixelation in VOD Programs Due to Multicast Traffic Bursts.
Alarm Information
Pixelation occurs in video programs during peak hours.

Handling Process
1.  Run the display interface interface-type interface-number command in any view or the display this interface command in the interface view to check the number of outgoing packets on the interface connecting to user terminals. The command output shows that a large number of packets are discarded, and the number keeps growing.

2.  Mirror incoming packets on the interface connecting to the multicast server. Use Wireshark to parse the traffic, and determine whether packet loss occurs on the switch.
  • If there is only a small amount of burst traffic, increase the link bandwidth between network devices.
  • The burst traffic rate may reach 1 Gbit/s. As shown in Figure 4-7, the multicast server hibernates for more than a second, sends video at an approximate rate of 1 Gbit/s, and enters the hibernation state several milliseconds later. Although the average outgoing traffic rate is about 10 Mbit/s, the traffic rate approximates to 1 Gbit/s if measured in milliseconds.
Figure 4-7 Video traffic burst on the multicast server



In this case, change the mode in which the multicast server sends packets, so that packets can be sent at more stable rates, with little traffic burst, as shown in Figure 4-8.

For V200R001 and later versions, you can also run the qos burst-mode enhanced command on the related interface to increase the interface buffer size, so that more burst traffic can be buffered. Then ensure that packets are sent in a stable manner, with little traffic burst, as shown in Figure 4-8.

Figure 4-8 Traffic information after traffic burst is resolved



Root Cause
Video traffic bursts frequently occur on the multicast server. When the switch receives multicast traffic, it forwards multiple copies of the traffic. As a result, the bandwidth required to forward the traffic may exceed the limit. When the switch's buffer is full, packet loss will occur due to congestion, resulting in pixelation on user terminals.

Suggestions
When pixelation occurs in the VOD service, check the number of packets received and sent by the interface connected to user terminals. Determine whether packets are discarded and check the mode in which the multicast server sends packets.

If packets are discarded by the interface, traffic congestions occur. In this case, perform the following operations:

1.  Install the latest patch for the version in use, and check whether the problem is resolved.

2.  Adjust the mode in which the multicast server sends packets to mitigate traffic congestion.

3.  If multiple traffic conflicts occur, increase the link bandwidth between devices.

END