Called Numbers Are Incomplete In CDRs for AT0 Trunk Calls

Publication Date:  2015-07-25 Views:  189 Downloads:  0
Issue Description
The U1910 is connected to the upper-level office through the AT0 trunk. Called numbers displayed in CDRs are incomplete. For example, only 123 is displayed for called number 12345678.
Handling Process
The commands for configuring the AT0 trunk on the U1910 are as follows:
config modify prefix dn <string> minlen <0~32>
config modify timerinterval pid at0 timergroup 0 timerindex 16 interval <100~1000>
The minlen and timerinterval parameters can be adjusted.
  • minlen: minimum number length. This parameter determines the maximum number of digits that can be received at a time and stored locally by the AT0 trunk.
  • timerinterval: interval for sending digits to the peer end.
However, the larger the two parameters are set, the slower the connection speed is. Therefore, optimize the two parameters based on the following rules:

Step 1 Set minlen to 9 and timerinterval to 300, and check the effect.

Step 2 If the connection speed is too slow, gradually decrease the timerinterval value, and check the effect.

Step 3 If the connection speed is still slow, gradually decrease the minlen value, and check the effect.

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Root Cause
The AT0 trunk is an analog trunk. The connection principle is as follows:

The AT0 trunk starts a timer whenever a user dials a digit. Assume that the called number is 123456789 and the minimum number length is 5.

1. The calling party picks up the phone and dials the called number. The AT0 trunk collects the first five digits (1, 2, 3, 4, and 5) and stores them locally.
2. When the first timer times out, the AT0 trunk sends the first five digits stored locally. The AT0 trunk sends only one digit at a time, and waits for the next timer to time out before sending the next digit.
3. When sending the first five digits, the AT0 trunk continues to collect the digits dialed by the calling party. After the first five digits are sent, the AT0 trunk continues to send the following digits one by one when each timer times out.
4. If all digits stored locally are sent but no digit is collected when the next timer times out, the AT0 trunk sends the connect message to the peer office.
5. If more digits are collected after the connect message is sent, the AT0 trunk packs these digits into audio for transmission. (Digits transmitted in audio will not be recorded into U1910 CDRs.)

The following figure shows the process.



According to the fault symptom, the possible cause is that the parameter settings for the AT0 trunk are not optimized.
Suggestions
 Adjusting minlen is coarse-tuning, and adjusting timerinterval is fine-tuning. During deployment, frontline engineers must adjust the two parameters repeatedly until the optimized configuration is obtained in the condition that service requirements are met. That is, complete numbers can be displayed in CDRs without affecting the call connection speed.

 From V100R001C20, the U1910 supports polarity reversal detection, which allows the U1910 to detect on-hook and off-hook of the peer party based on the polarity reversal signals sent by the peer office. This increases the accuracy of digit collection but has requirements on the peer office's capability of sending polarity reversal signals.

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