SIP Trunk unable to work between AR router and Dlink router

Publication Date:  2016-06-17 Views:  761 Downloads:  0
Issue Description

Product: AR1200

Software version: V200R007C00SPC200

Peer device: Dlink

Problem: After trying to configure a SIP Trunk from Dlink router to Huawei AR 1200 t's not working, the configuration was successful with Espace U1911 but unable to configure it with AR Router. As per Dlink team AR router is not accepting the packets from Dlink.

Alarm Information

Apr 26 2016 14:20:02.900.1+04:00 Al_MAS_AR VOICE/7/VSP:DEBUG: [LOGID=0xffffffff][tpa_func.c 1691]msg from mgc([10.10.102.2]:5060) to mg([10.10.120.1]:5060):

INVITE sip:318@10.10.120.1 SIP/2.0

Via: SIP/2.0/UDP 10.10.102.2:5060;branch=z9hG4bK6b4d6cf3;rport

Max-Forwards: 70

From: <sip:224@10.10.102.2>;tag=as33ffcc84

To: <sip:***@10.10.120.1>

Contact: <sip:***@10.10.102.2:5060>

Call-ID: 774745bf0eb01206263503342d3acda9@10.10.102.2:5060

CSeq: 102 INVITE

User-Agent: FPBX-2.8.1(11.5.0)

Date: Tue, 26 Apr 2016 09:34:24 GMT

Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH

Supported: replaces, timer

Content-Type: application/sdp

Content-Length: 280

Handling Process

1. Check the diag information for the router to check the logs

2. Check the network topology

3. Check the connection between the two devices

4. Check the role of Dlink device and what is the role of AR1200 in the network

5. Get the debugging information to check:

<Huawei>sys

[Huawei]display current

[Huawei]display voice trunk-group {trunk-name}       // {trunk-name} is the trunk name which you configured and used

[Huawei]diagnose

[Huawei-diagnose]debugging voice innertrace

[Huawei-diagnose]debugging voice sipmsg

[Huawei-diagnose]debugging voice ccm all

[Huawei-diagnose]quit

[Huawei]quit

<Huawei>terminal debugging  

<Huawei> terminal monitor

6. After do a call test (the failed one, from 2xx to 3xx), and then waiting for 3 Mins, and then turn off the debug by following command:

<Huawei> undo terminal debugging

<Huawei>sys

[Huawei] diagnose

[Huawei-diagnose]undo debugging voice all

 

Root Cause

After analyzed the debug information, we found that the root cause is the port is different between the configuration on AR1200 device and the packets which Dlink router sent. The port of packets which Dlink device sent is 5060, but the configuration on AR 1200 divice is 5062. As following:

trunk-group GSQ_office sip no-register

  enterprise SAMRA

  callroute GSQ

  signalling-address ip 10.10.120.1 port 5062         //the port configuration on AR device is 5062

  media-ip 10.10.120.1

  peer-address static 10.10.102.2 5060

  home-domain SAMRA

  maxcr 10

#

 

From the debug information, the port of packets is 5060, as following:

Apr 26 2016 14:20:02.900.1+04:00 Al_MAS_AR VOICE/7/VSP:DEBUG: [LOGID=0xffffffff][tpa_func.c 1691]msg from mgc([10.10.102.2]:5060) to mg([10.10.120.1]:5060):

INVITE sip:318@10.10.120.1 SIP/2.0

Via: SIP/2.0/UDP 10.10.102.2:5060;branch=z9hG4bK6b4d6cf3;rport

Max-Forwards: 70

From: <sip:224@10.10.102.2>;tag=as33ffcc84

To: <sip:***@10.10.120.1>

Contact: <sip:***@10.10.102.2:5060>

Call-ID: 774745bf0eb01206263503342d3acda9@10.10.102.2:5060

CSeq: 102 INVITE

User-Agent: FPBX-2.8.1(11.5.0)

Date: Tue, 26 Apr 2016 09:34:24 GMT

Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH

Supported: replaces, timer

Content-Type: application/sdp

Content-Length: 280

Solution

As port 5060 is used by other task(SIP server process) on AR device, so on AR device, can’t change the port 5062 to 5060, the only way is to change the port 5060 to 5062 on Dlink device. 

END