DCC Dial Failed Due To Unnecessary PPP Configuration

Publication Date:  2012-07-27 Views:  159 Downloads:  0
Issue Description
A synchronous/asynchronous serial port on the R1602 router is set as asynchronous, and connects the C&C08 switch through a Modem and then the uplink A8010 Expert to perform DCC dialing. The R1602 serial port is encapsulated in PPP and PAP authentication is performed with the A8010. After router configuration, dialing is triggered through the ping operation and dialing tone is then produced by the Modem for negotiation. The dialing tone disappears and after a while the Modem begins to dial again. This process repeats but the dialing connection is never established successfully.
Handling Process
Access the Dialer and PPP debugging information of the router, then initiate dialing through the ping operation again, and you will see the debugging output as shown in the following debug.txt file. It includes the following important information (descriptions are behind the debugging information): % Interface Serial0 changed state to UP The port is already UP %MODEM: Serial0 changed state to UP. DCC: Receive CALL_CONN_CFM A connection confirmation message is received from the EXPERT. DCC: link layer ask the PPP_interface of the interface Serial0 Serial0 PPP negotiation begins. PPP O LCP(c021) Pkt, Len 39 State starting, code ConfReq(01), id 3, len 35 MRU(1), len 4, val 05dc ACCMAP(2), len 6, val ffffffff AuthProto(3), len 4, PAP c023 MagicNumber(5), len 6, val 000aa5af MRRU(11), len 4, val 05dc Discri(13), len 7, val 0434ab54d0 ............... Serial0 PPP I LCP(c021) Pkt, Len 39 State acksent, code ConfAck(02), id 3, len 35 MRU(1), len 4, val 05dc ACCMAP(2), len 6, val ffffffff AuthProto(3), len 4, PAP c023 MagicNumber(5), len 6, val 000aa5af MRRU(11), len 4, val 05dc Discri(13), len 7, val 0434ab54d0 LCP negotiation ends. Serial0 PAP negotiation begins. PPP O PAP(c023) Pkt, Len 20 PAP AuthRequest, id 3, length 16 User(5): kevin Send user name and password. Passwd(5): kevin Serial0 PPP I PAP(c023) Pkt, Len 10 PAP AuthRequest, id 1, length 6 A PPP authentication request message is received including no user name or password. User(0): Passwd(0): Serial0 authentication request username ' Serial0 A messaga is returned to the A8010EXPERT, requesting its user name and password. PPP O PAP(c023) Pkt, Len 22 PAP AuthNak, id 1, length 18 Message(13): No user name. Serial0 PPP I PAP(c023) Pkt, Len 100 The A8010EXPERT passes the authentication of the router and sends back a confirmation message. PAP AuthAck, id 3, length 96 Message(79): Welcome to Quidway A8010 Expert Multiservice Access Switch, Huawei Technologies Serial0 PPP I PAP(c023) Pkt, Len 10 The information sent by the A8010EXPERT includes no user name and passoword again. PAP AuthRequest, id 2, length 6 User(0): Passwd(0): Serial0 authentication request username '' Serial0 The A8010EXPERT is requested to provide its user name and password again. PPP O PAP(c023) Pkt, Len 22 PAP AuthNak, id 2, length 18 Message(13): No user name. ............ DCC: Receive CALL_DISC_IND, shutdown link, start enable-timeout Multiple times of authentication fail and the connection is broken. The above information shows that the cause for the failed establishment of dialing connection is that the router keeps requesting the user name and password of the A8010 Expert but never obtains them from the A8010 Expert thus leading to authentication failure and disconnection. When checking the R1602 configuration, you will find the ppp authentication pap command in the serial port configuration. That is just the key to the problem. In presence of the command, the router will request the A8010 Expert to provide its user name and password for authentication, but the A8010 has no such configuration. To solve the problem, delete the ppp authentication pap command and then dial again.
Root Cause
The successful dialing initiation through the ping operation shows the DCC and routers are correctly configured. The producing of dialing negotiation tone shows the local router and the A8010 Expert can negotiate through the Modem and the Modem of the A8010 Expert is correctly configured. A problem arises after the dialing negotiation tone disappears, namely, in the PPP negotiation and authentication course. It proves the PPP negotiation and authentication probably account for the fault.

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