NE40E with high cpu utilization due to DHCP process

Publication Date:  2012-07-27 Views:  171 Downloads:  0
Issue Description
A NE40E shows high cpu utilization without a specific reason. The DHCP task is the most demanding task according with the symptoms taken. The problem ocurred several times during a week without services affectation. 
Alarm Information
<bog-sbb-ne40e>display cpu
CPU Usage Stat. Cycle: 60 (Second)
CPU Usage            : 97% Max: 100%
CPU Usage Stat. Time : 2010-03-23  16:28:31
CPU Usage Stat. Tick : 0x59cd3(CPU Tick High) 0xb678627d(CPU Tick Low)
Actual Stat. Cycle   : 0x0(CPU Tick High) 0x780927ae(CPU Tick Low)
 
TaskName        CPU        Runtime(CPU Tick High/CPU Tick Low)
BUFM             0%               0/   1ae66
VIDL             3%               0/ 3d7f3e7
TICK             0%               0/  1700bf
 HOT             0%               0/   336f1
IPCR             0%               0/  142cb3
 VPR             0%               0/  194f9e
 VPS             0%               0/   49ef7
 Ecm             0%               0/  430c86
IPCQ             0%               0/   e725b
  VP             0%               0/     629
RPCQ             0%               0/   2a0f5
VMON             0%               0/     559
STND             0%               0/   3685d
 CFA             0%               0/   24bef
INFO             0%               0/    ecad
 RPR             0%               0/   617ad
L2IF             0%               0/   2a589
 BFD             0%               0/   21f93
ROUT             3%               0/ 4927abb
LSPM             0%               0/ 114c062
 OAM             0%               0/   32850
LSPA             0%               0/    43d0
 LDP             0%               0/  6a5ae6
RSVP             0%               0/   299ab
TNLM             0%               0/   2eddc
 L2V             0%               0/  3cf1e5
 SRM             0%               0/  73d006
LOAD             0%               0/   15b01
DIAG             0%               0/   6056b
 CAN             0%               0/   43a6e
RFIB             0%               0/   219e5
SOCK             0%               0/  26b2a1
VTYD             0%               0/   4c76a
IFNT             0%               0/     107
IPSP             0%               0/    29b9
L2TP             0%               0/   24a59
AGNT             0%               0/  530005
TRAP             0%               0/   73f7d
MDMT             0%               0/   50fb8
NTPT             0%               0/   e0dc5
 AAA             0%               0/    4b80
 TAC             0%               0/   4d1a7
 UCM             0%               0/    5aab
HS2M             0%               0/   724be
MSTP             0%               0/   fe1f3
RRPP             0%               0/   2336c
COPS             0%               0/   2890d
NE50             0%               0/   39e28
TSTA             0%               0/   35f43
 ARQ             0%               0/   d9894
VRRP             0%               0/    370a
DHCP            89%               0/6bbf693f
RMON             0%               0/   17baf
 vt0             0%               0/   f8885
 co0             0%               0/   2c741
  OS             5%               0/       0
Handling Process
1. Send the case and corresponding information to GTAC.
2. Send display diagnostic and others symptoms to GTAC.
3. When the issue occured it was necessary to confirm the following in hiden mode:
[161-hidecmd]dis task 
name Tid VOS_Tid priority Status CPU Total(Millsecs) 
==============================================================================
DHCP 0x6c89930 141 100 eventblock 23386
[161-hidecmd]dis inspect system callstack 141 ===> execute this command according with VOS Tid in the previous command
*******************************************
Task Name = DHCP
Task VosID = 86
Current SP = 0x5aa6960
Current PC = 0x507354
Current callstack info:
<-- 0x00507354 (taskDelay)
<-- 0x0055c6d4 (OSAL_TaskDelay)
<-- 0x0054a9c4 (VOS_TaskRunDelay)
<-- 0x005abb50 (VOS_T_RunDelay)
<-- 0x001234c8 (0x1234c8)
<-- 0x00122ffc (0x122ffc)
<-- 0x0109a308 (DHCP_FSM_GetIpFromTimeout) ? Verify if this line exists.
<-- 0x0109c224 (DHCP_FSM_DHCP_DiscoverTimeoutLease) ?Verify if this line exists.
<-- 0x0109cb6c (DHCP_FSM_DHCP_Discover)
<-- 0x0109e700 (DHCP_FSM_DHCP_Receive)
<-- 0x01096e88 (DHCP_COMM_DealDhcp)
<-- 0x010603a0 (DHCP_COMM_DealServerAndRelay)
<-- 0x01060e7c (DHCP_TaskMain)
<-- 0x005477e0 (tskAllTaskEntry)
<-- 0x0050cf94 (vxTaskEntry)
4. Inform to the customer about the GTAC answer to the case (Software version should be updated to the recommended one)
Root Cause
DHCP packets are received from an interface whose IP address is not on the same network segment of the IP address pool. Such packets cannot be processed normally. Thus, the DHCP task is frequently scheduled and the CPU usage becomes too high.
It is necessary to update the software version to NE40E&80E V300R002SPH036 in order to solve the problem. V6R1 also has the fix.
Suggestions
Mantain the software version update.

END