After a New License Replaces an Old One on the USG5300 V100R002, the New License Fails to be Activated

Publication Date:  2012-07-17 Views:  107 Downloads:  0
Issue Description
When the customer activates a new license file on an in-service device, the device displays a message, stating "A file has been activated." However, when the user views the license status, the information of the old license is displayed. The license replacement fails.
Alarm Information
None.
Handling Process

1.          Upload the new license file to the flash of the device.  

2.          In the system view, run the undo license file command to deactivate the old license file.

3.          In the system view, run the license file filename command to activate the new license file.

4.          In any view, run the display license command to view the currently effective license. The new license file is running.

Root Cause
The message "A file has been activated" indicates that the device has an activated license file. Because the old license is running and effective, the new license file cannot be activated. On the USG5300 V100R002C01SPC009 or later, the message is changed to "A file has been activated, please deactivate it first."
Suggestions
There is a short service shutdown between the time when the old license is deactivated and the time when the new license is activated. Therefore, communicate with the customer before the license replacement, as well as back up and roll back the old license file.

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