NX110 Switch Board Terminal Continuously Returns UP/DOWN Information

Publication Date:  2012-07-17 Views:  732 Downloads:  0
Issue Description
At a commercial deployment, the management terminal continuously reports port DOWN/UP information (as shown below) after the E6000 is installed due to a customer-made NX110 switch board configuration, disrupting the normal configuration process.
%Dec 31 01:25:36 2003 Fabric L2INF/5/PORT LINK STATUS CHANGE:
GigabitEthernet0/4: turns into DOWN state
%Dec 31 01:25:36 2003 Fabric L2INF/5/PORT LINK STATUS CHANGE:
GigabitEthernet0/4: turns into UP state
%Dec 31 01:25:38 AM 2003 Fabric L2INF/5/PORT LINK STATUS CHANGE:
GigabitEthernet0/6: turns into DOWN state
%Dec 31 01:25:38 AM 2003 Fabric L2INF/5/PORT LINK STATUS CHANGE:
GigabitEthernet0/6: turns into UP state
Alarm Information
none
Handling Process
This phenomenon disappears after an operating system is installed on the boards.
When no operating system is installed, users can configure the NX110 switch board by running the undo terminal logging command in the monitor view to suppress reported information for proceeding with other configuration procedures.
undo terminal logging
%Current terminal logging is off
Root Cause
Questionable ports range from GigabitEthernet0/1 to GigabitEthernet0/10 by checking the output. Besides, the status of the same port switches from DOWN to UP shortly or even simultaneously. The ports ranging from G0/1 to G0/10 correspond to ten BH620 blade servers of the E6000, and users can query port information by running the display port-connection-relationships command. When no operating system is installed, the blade server restarts during boot device discovery, causing continuous DOWN/UP switchover.
By running the display port-connection-relationships command, the following mappings of NX1100 ports are returned:
E6000
Port Number   Connection Relationships
      G0/1      Slot 1
      G0/2      Slot 2
      G0/3      Slot 3
      G0/4      Slot 4
      G0/5      Slot 5
      G0/6      Slot 6
      G0/7      Slot 7
      G0/8      Slot 8
      G0/9      Slot 9
      G0/10     Slot 10
      G0/15     Fabric interconnection
      G0/16     RTM LAN 1
      G0/17     RTM LAN 2
      G0/18     RTM LAN 3
      G0/19     RTM LAN 4
      G0/20     RTM LAN 5
      G0/21     RTM LAN 6
      G0/22     RTM LAN 7
      G0/23     RTM LAN 8
Suggestions
This problem reflects a feature of blade servers; that is, when the E6000 detects a blade that cannot be loaded into the operating system, the watchdog reaches the timeout and then restarts.
This problem is common for switch boards of both the E6000 and T8000 blade servers.
Their difference is, given the E6000 and T8000 have different port mappings, different ports would be employed for displaying DOWN/UP information.

END