Router on the stick+ two-node cluster hot backup-- the best solution to solve switch and two-node cluster port shortage.

Publication Date:  2012-09-10 Views:  254 Downloads:  0
Issue Description
When access layer switch has multiple VLAN,the access layer switch is just a layer 2 device. It should have two-node cluster hot backup to make sure that multiple VLAN uplink redundancy. Commonly, every VLAN need two lines to connect to the two devices. It will use a device port and multiple VLAN will use multiple ports. No matter how many VLAN, it only use a port in this scheme .More VLAN can more able to reflect the advantage of saving port.
No matter how much VLAN ,open how much VRRP, it just need two lines.


Alarm Information
None
Handling Process
R1:
interface Ethernet0/0.30   --------------------use subinterface form to shart VRRP
ip address 10.32.96.2 255.255.255.128
vrrp vrid 30 virtual-ip 10.32.96.1
vlan-type dot1q vid 30
#
interface Ethernet0/0.70
ip address 10.160.96.2 255.255.255.0
vrrp vrid 70 virtual-ip 10.160.96.1
vlan-type dot1q vid 70
R2:
interface Ethernet0/0.30
ip address 10.32.96.3 255.255.255.128
vrrp vrid 30 virtual-ip 10.32.96.1
vlan-type dot1q vid 30
#
interface Ethernet0/0.70
ip address 10.160.96.3 255.255.255.0
vrrp vrid 70 virtual-ip 10.160.96.1
vlan-type dot1q vid 70
SW1:
interface Ethernet0/0/1
port link-type trunk
port trunk allow-pass vlan 30 70   
#
interface Ethernet0/0/48
port link-type trunk
port trunk allow-pass vlan 30 70
Let us take this  two VLAN as an example:
Root Cause
Use trunk-link to make sure all VLAN link redundancy ,and no confine port and VLAN.
Suggestions
Recommend when have  multiple VLAN or one switch has multiple VLAN need to link redundancy with core,you can use the scheme.

END