S5300 Multicast problem

Publication Date:  2013-03-12 Views:  736 Downloads:  9
Issue Description

Topology:-
S5328EI is connected with 8 multicast sources with multicast IPs 239.0.3.15 to 239.0.3.22.
(These multicast sources are for video on demand)

One port is connected with multicast receiver.

And one port of switch is configured as a trunk port for connecting the switch to network for telnet access.
(right now this port is not being used)

Multicast sources are connected with first 8 ports & receiver is connected with 9th port of the switch and all these ports are in VLAN1
VLAN 10, VLAN 11, VLAn12 are not being used.

ISSUE:-
Multicast traffic of every multicast source is forwarded out to every port of the switch and we want to control this behavior.
Due to this issue the utilization of output bandwidth of any port goes to above 98%.

Requirement:-
Multicast traffic is required only for the port which is connected to receiver.

Alarm Information
N/A
Handling Process
I did the following steps and get required results

igmp-snooping enable
vlan 1
undo ip pim sm
igmp-snooping enable

(as pim sm was enabled in vlan1)

And

interface GigabitEthernet0/0/11
l2-multicast static-group group-address 239.0.3.15 to 239.0.3.22 vlan 1
as mentioned  interface is connected to multicast receiver.

Now solution is working well
Root Cause
IGMP was not enable

Kindly configure the IGMP snooping on the switch and please feedback.
<Quidway> system-view
[Quidway] igmp-snooping enable
[Quidway] vlan 1
[Quidway-vlan2] igmp-snooping enable
Suggestions
Since All the users was in the same Vlan and the L3 multicast so He had to configure IGMP.

END