Failure in Bundling Links Between a Huawei S5700 Switch and a Cisco Switch

Publication Date:  2013-12-31 Views:  1502 Downloads:  0
Issue Description
A customer fails to bundle links between a Huawei S5700 and a Cisco Catalyst 3560.
Interfaces G0/0/1 to G0/0/4 of the Huawei S5700 are respectively connected to interfaces F0/1 to F0/4 of the Cisco Catalyst 3560 as follows.
G0/0/1--F0/1
G0/0/2--F0/2
G0/0/3--F0/3
G0/0/4--F0/4

The link aggregation configurations on the Huawei S5700 are as follows:
#
interface Eth-Trunk22
port link-type trunk
port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/1
eth-trunk 22
#
interface GigabitEthernet0/0/2
eth-trunk 22
#
interface GigabitEthernet0/0/3
eth-trunk 22
#
interface GigabitEthernet0/0/4
eth-trunk 22
#

The link aggregation configurations on the Cisco Catalyst 3560 are as follows:
!
interface FastEthernet0/1
channel-protocol pagp   //The link aggregation protocol is set to PAgP.
channel-group 22 mode desirable
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/2
channel-protocol pagp
channel-group 22 mode desirable
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/3
channel-protocol pagp
channel-group 22 mode desirable
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/4
channel-protocol pagp
channel-group 22 mode desirable
switchport trunk encapsulation dot1q
switchport mode trunk
!
Alarm Information
None
Handling Process
Based on configurations on Huawei and Cisco switches, configurations on the Huawei S5700 are correct.
Notify the customer that the fault is not caused by Huawei switches and the customer can contact Cisco for a solution. After the link aggregation protocol is changed from PAgP to LACP on the Cisco switch, the fault is rectified.
The new link aggregation configurations on the Cisco Catalyst 3560 are as follows:
!
interface FastEthernet0/1
channel-protocol lacp //The link aggregation protocol is set to LACP.
channel-group 22 mode active //The link aggregation mode is set to active.
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/2
channel-protocol lacp
channel-group 22 mode active
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/3
channel-protocol lacp
channel-group 22 mode active
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface FastEthernet0/4
channel-protocol lacp
channel-group 22 mode active
switchport trunk encapsulation dot1q
switchport mode trunk
!
Root Cause
After knowing the customer requirements and configurations, we conclude the fault cause as follows:
The Huawei S5700 uses LACP defined by the IEEE, and the link aggregation configurations on the S5700 are correct.
In addition to LACP, the Cisco Catalyst 3560 also supports Cisco proprietary PAgP. In this case, PAgP is enabled on the Cisco Catalyst 3560. Huawei and Cisco switches use different link aggregation protocols. Therefore, links fail to be aggregated between them.
Suggestions
When devices of different vendors are connected, pay attention to protocols used on the devices.

END