OSPF failed to establish peer relationship between Huawei AR2200 router and S7706 switch

Publication Date:  2014-06-10 Views:  946 Downloads:  0
Issue Description
We enabled OSPF process between Huawei 2200 series router and s7706 switch. But it failed to establish peer relationship
I can ping between both device.
There is no physical cabling issue. 



AR2200 Configuration
**************************
#
interface GigabitEthernet0/0/0
ip address 10.116.4.1 255.255.255.252
combo-port fiber
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/1.99
dot1q termination vid 99
ip address 10.115.1.2 255.255.255.0
#
interface GigabitEthernet0/0/1.223
dot1q termination vid 223
ip binding vpn-instance VPN223
ip address 10.115.223.2 255.255.255.0
#
interface GigabitEthernet0/0/2
#
interface Cellular0/0/0
link-protocol ppp
#
interface Cellular0/0/1
link-protocol ppp
#
interface NULL0
#
interface LoopBack0
ip address 10.116.4.254 255.255.255.255
#
ospf 1
default-route-advertise always
import-route static
area 0.0.0.0
  network 10.115.1.0 0.0.0.255
  network 10.116.4.254 0.0.0.0
#

S7706 Configuration
************************
#
interface Vlanif99
ip address 10.115.1.1 255.255.255.128
#
ospf 1
import-route static
area 0.0.0.0
  network 10.115.1.0 0.0.0.255
#
Alarm Information
Jun  5 2014 14:29:35+00:00 RT-EG-Huawei-PoC OSPF/2/IFCFGERR:OID 1.3.6.1.2.1.14.16.2.4: A packet is received on the non-virtual interface from a router whose configuration conflicts with the local configuration. (IfIpAddress=10.115.1.2, AddressLessIf=0, ProcessId=1, RouterId=10.116.4.1, PacketSrc=10.115.1.1, ConfigErrorType=7, PacketType=1, InstanceName=) 
Handling Process
On AR :
*********

interface GigabitEthernet0/0/1.99
dot1q termination vid 99
ip address 10.115.1.2 255.255.255.0
arp broadcast enable ---- [ add the command ]

On S7706
***********

interface Vlanif99
ip address 10.115.1.1 255.255.255.0 ---- [ Change your ip address mask ] like this . ( the original configuration is : ip address 10.115.1.1 255.255.255.128 , it didn’t match the distributed ospf subnet and the opposite subnet .)


Root Cause
Check the configuration Error Type in the Alarm 
*****************************************************
It is Type 7



It means that NetMask Mismatch between both sides 


Suggestions
No

END