Fault occurred when trying to listen to CMS call recordings made by UAP3300

Publication Date:  2014-06-23 Views:  317 Downloads:  0
Issue Description
   Customer discovered that although the call recordings are made successfully, when trying to listen to them using the CMS, the recording playback time is less then it shows on the webpage. By listening to it, it’s clear that the recording process stopped at some point. This leads to incomplete call recording and thus, the inspector cannot evaluate Agent performance.
Alarm Information
None.
Handling Process
1. On the MRS log we found:
[      27934][2014-06-17 15:15:37.02] [mrpd_io_fun.c  ][12395][4][ -1] [IO]MrpdIo_OpenWriteLog():write filey:/MRSLOG/1_4/MRSLOG-20140617150835.log failed !errcode:3080197!
[      27935][2014-06-17 15:15:39.35] [mrpd_io_fun.c  ][ 2874][4][268] [IO]MrpdIo_WriteFile():write is err !errno is 3080197
[      27936][2014-06-17 15:15:39.35] [mrpd_io_fun.c  ][ 5340][4][268] [IO]MrpdIo_WriteMBDataToFile: Write File Fail!
[      27937][2014-06-17 15:15:39.35] [mrpd_io_fun.c  ][ 5630][4][268] [IO]MrpdIo_WriteDataToFileFromMB:MrpdIo_WriteMBDataToFile Fail!
[      27938][2014-06-17 15:15:39.35] [mrpd_io_msg.c  ][10785][4][268] [IO]MrpdIo_ProcWriteFileFrmMRFD() : write file z1:/1/0/20140617/106/1521334.V3 fail!

2. On the UAP log, current.log:
[0149][0x00001096][2014-06-17 15:40:27.40][cpm.c 8418][Conf_No =   126] app_StopConfRecHandle : record_task[CP_CONF_TASK_IDLE] of Conf_No [126] is error!

3. The 2 error indicate that there was a network disconnection between the MRS and the File server, thus recording has stopped.

4. Analyzing the network topology, we have found some packet loss due to many bad switched connected between the devices.

5.SOLUTION:  Connect the UAP3300, File Server, CTI server and other key components of the eSpace CC solution to a good centralized Switch.
Root Cause
1. Check other call recordings and see if the issue appears

2. Check the length of each recording and see if there is a pattern

3. Download the recordings from CMS and check file size and playback length

4. Check UAP3300 MRS board status – show board

5. Check File Server Status and connection to the UAP3300 MRS board. Make a continuous ping from one to each other. Look for network interruption.
/etc/init.d/nfsserver status  - check the NFS service
more /etc/exports  - view the access permission of the shard directory
hastatus –sum  - check the status of the VCS two-node cluster resources

6. Make test calls and collect UAP debug log and MRS log.
debug set mrslog type log level debug - in debug mode on UAP3300
Media resource logs are stored in \fileserver\MRSLOG\module number_slot number
Suggestions
As you know, the VoIP networks depend a lot on network quality parameters like: congestion, delay, jitter, packet loss and others. If you have long delay switches in your network, and many connected in serial, thus separating the key point servers, this will lead to bad network environment. Network delays will cause VoIP components to disconnect, to playback bad voice quality and so on. So, this is an important matter. Design your network taking into consideration this fact. 

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