The CentOS login failed by VNC on the FusionCompute Portal

Publication Date:  2014-10-28 Views:  312 Downloads:  0
Issue Description
After installing the CentOS system, when you login the OS with VNC on the FusionCompute Portal, you can see the window as below:
Alarm Information
None
Handling Process
1. Checking if the status of the OS is normal, we can restart the CentOS
2. Checking if the VNC window is hung up, we can input "ALT", "CTRL" to confirm it
3. Checking the OS version and confirm with customer if they install any GUI driver for the OS.
Root Cause
There is a bug in the GUI driver for the CentOS system
Solution
1. enter the "grub" of the OS


2. Click “E” to edit the grub of CentOS.


3. Use "↓"  to select "kernel"  item as below, then click "edit"


4. At the end of "kernel" item, add the number "3" as below, then "enter" to save it, then click "B" to restart the OS.


5. After login the system with CLI, please configure the IP for the VM to make your local computer connect to the VM with winSCP tool.
6. Then, download a driver in the link below: xorg-x11-drv-cirrus-1.5.2-1.el6_4.x86_64.rpm
http://pkgs.org/centos-6/centos-updates-x86_64/xorg-x11-drv-cirrus-1.5.2-1.el6_4.x86_64.rpm/download/
7. Transfer the RPM package to the VM with winSCP tool.
8. Run the command to install the RPM package as below, at last reboot the VM to check if it is normal to login the Centos with GUI.
rpm -U xorg-x11-drv-cirrus-1.5.2-1.el6_4.x86_64.rpm
Suggestions
It is better to install the OS with latest patch and driver.

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