Troubleshooting Of AP Fault For AR2200

Publication Date:  2014-11-24 Views:  631 Downloads:  0
Issue Description
After adding the APs offline based on the AP type ID. The customer found the state of AP is fault.
Alarm Information
After powering on the APs, run the display ap all command on the Router AR2200 to check the AP running status:
<AR>dis ap all
  All AP information(Normal-0,UnNormal-1):
  ------------------------------------------------------------------------------
  AP    AP                    AP              Profile   AP              AP
                                              /Region
  ID    Type                  MAC             ID        State           Sysname
  ------------------------------------------------------------------------------
  0     AP6610DN-AGN          e097-9654-c180    0/10    fault           ap-0
  ------------------------------------------------------------------------------
  Total number: 1
It is show that AP running status is fault.
Handling Process
1. The topology is just as below:



2. Collect the running information about all modules by the command display diagnostic-information.
3. Check the status of the board by the command display device. Check the alarm information by the command display alarm active. It is found the board is registered and normal. There isn’t any hardware communication error.
4. Collect the information of the AP by the command display ap-run-info id 0 . It is found that there isn’t any IP address for the AP. Check the AP type ID by the command display ap-type all.
[AR-wlan-view] display ap-type all
All AP types information:    
------------------------------------------------------------------------------
ID     Type                  
------------------------------------------------------------------------------
17     AP6010SN-GN           
19     AP6010DN-AGN          
21     AP6310SN-GN           
23     AP6510DN-AGN          
25     AP6610DN-AGN          
27     AP7110SN-GN           
28     AP7110DN-AGN          
29     AP5010SN-GN           
30     AP5010DN-AGN          
31     AP3010DN-AGN          
33     AP6510DN-AGN-US       
34     AP6610DN-AGN-US       
35     AP5030DN              
36     AP5130DN              
37     AP7030DE
38     AP2010DN
39     AP8130DN
40     AP8030DN     ------------------------------------------------------------------------------
Total number: 18 
And the AP type is AP6610DN-AGN(25). But the configuration is just as below:
#
wlan ac
wlan ac source interface loopback0
ap-region id 10
ap id 0 type-id 23 mac e097-9654-c180
#
Change the AP type to 25: ap id 0 type-id 25 mac e097-9654-c180
5. Run the display ap all command on the AR-2200 to check the AP running status. The State of AP is still fault. Check the information of the AP by the command display ap-run-info id 0 . It is found that there still isn’t any IP address for the AP.
6. Check the configuration for the DHCP.
#
interface GigabitEthernet0/0/0
ip address 192.168.10.2 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 192.168.11.2 255.255.255.0
#
7. The customer forgot the command dhcp select global on the interface GE0/0/0 & GE0/0/1. After completing this command, Check the information of the AP by the command display ap-run-info id 0 . It is found that there still isn’t any IP address for the AP.
8. For the AR-2200 if you want enable the function for AC, you should load and active license. Check the information of the license by the command display license. The License state is not normal.
9. Check the steps of loading license. The customer forgot to active license.
<AR>license active XXXXX.dat
10. Run the display ap all command on the AR-2200 to check the AP running status. The State of AP become normal.
   <AR>display ap all
  All AP information(Normal-0,UnNormal-1):
  ------------------------------------------------------------------------------
  AP    AP                    AP              Profile   AP              AP
                                              /Region
  ID    Type                  MAC             ID        State           Sysname
  ------------------------------------------------------------------------------
  0     AP6610DN-AGN          e097-9654-c180    0/10    normal           ap-0
  ------------------------------------------------------------------------------
  Total number: 1
Root Cause
Firstly, The customer chose wrong type-id for the AP; Secondly the customer forgot the configuration for DHCP; Thirdly the customer made some mistake during loading license.
Suggestions
During the Troubleshooting, using different way to reduce the arrange of  possible root cause. That will be helpful for the work.

END