Broadcast storm occured in S5300 when STP was ruuning

Publication Date:  2015-01-22 Views:  355 Downloads:  4
Issue Description
There were 2, S5300 switches and 1 Eudemon 200E firewall, connected in a ring in layer 2 mode. Vlans were passing between switches and firewall.

Networking Scanario:

On swtich S5300_01:
port towards S5300_02:                                             Ethernet trunk 1 (gig 0/0/19,gig0/0/20) passing vlans 10,20,30,40.
port towards Firewall Eudemon_200E:                       gig0/0/18 in trunk mode passing vlans 10,20,30,40

On swtich S5300_02:
port towards S5300_01:                                             Ethernet trunk 1 (gig 0/0/19,gig0/0/20) passing vlans 10,20,30,40.
port towards Firewall Eudemon_200E:                       gig0/0/18 in trunk mode passing vlans 10,20,30,40


On Eudemon_200E:
port towards S5300_01:                                            gig 0/0/0 in trunk mode passing vlans 10,20,30,40
port towards S5300_2:                                              gig 0/0/1 in trunk mode passing vlans 10,20,30,40

Issue:
 STP was not working and there was a broadcast storm on the devices due to which firewall cup-utilization got very high and it could not process packets any more.and same was the case with the switches.




Solution


On trouble shooting it came out that Ether-trunk on S5300 was not  passing STP bpdu's.

By default ether-trunk on S5300 does not passes the STP BPDU's. we have to maunally define STP bpdu enabe under the ether-trunk mode on S5300.So when Ether-trunk passed the STP bpdu's, stp was working fine as expected.

END