We need Huawei S12700 switches work as VTP Transparent

Publication Date:  2015-03-30 Views:  2784 Downloads:  0
Issue Description

We have Huawei S12712 switches and C edge switches. Facing some issues with VTP Transparent configuration

Huawei S12712 switches acting as a Core and all the C edge switches are connected into it .. So C switches are talking to another C switches through Huawei S12712 switches 


Handling Process

C-H-C model, a C switch directly connects to a Huawei switch that has a downstream C switch connected, as shown in this photo 



·   Network Configuration


Configuration Requirements

Huawei switches need to interwork with Cisco VTP-capable switches on a network.

 

Configuration Methods

On Cisco switches: Enable VTP, configure ports between switches as trunk ports, add the trunk ports to all VLANs, and configure user-side ports as access ports.

On Huawei switches: Configure L2PT and local VLANs, configure ports between switches as trunk ports, add the trunk ports to all VLANs, and configure user-side ports as access ports.

 

Configuration Files

  • C switch in VTP server mode

 

Switch(config)#vtp domain Cisco [Set the VTP domain name to C .]

Switch(config)#vtp mode server [Set the VTP mode to server.]

Switch(config)#vtp password Cisco [Set the VTP password to C .]

Switch(config)#vlan 20

!

interface GigabitEthernet5/48

switchport access vlan 20

switchport mode access

end

!

interface GigabitEthernet5/1

switchport mode trunk

end

!

interface GigabitEthernet5/3

switchport mode trunk

end

  • C switch in VTP client mode

 

Switch(config)#vtp domain C

Switch(config)#vtp mode client

Switch(config)#vtp password C

!

interface GigabitEthernet0/48

switchport access vlan 20

switchport mode access

end

!

interface GigabitEthernet0/3

switchport mode trunk

end


  • Huawei switch

 

vlan 20 [Create a local VLAN.]

#

l2protocol-tunnel vtp group-mac 0100-5e00-0011 [Map the VTP destination MAC address to a specified multicast address.]

interface GigabitEthernet0/0/1

port link-type trunk

port trunk allow-pass vlan 2 to 4094

l2protocol-tunnel vtp vlan 1 [Set up a Layer 2 protocol tunnel to transmit VTP frames in VLAN 1.]

#

interface GigabitEthernet0/0/26

port link-type trunk

port trunk allow-pass vlan 2 to 4094

l2protocol-tunnel vtp vlan 1 [Set up a Layer 2 protocol tunnel to transmit VTP frames in VLAN 1.]

#

interface GigabitEthernet0/0/48

port link-type access

port default vlan 20



Suggestions

When setting up a Layer 2 protocol tunnel on the Huawei switch, map the VTP destination MAC address to a multicast address not in use to prevent address conflicts. The Layer 2 protocol tunnel must be set up on ports in VLAN 1 where VTP frames are transmitted. 

END