Failure to Display the Calling Number When PSTN Users Call SoftCo Users Through the AT0 Trunk

Publication Date:  2015-07-14 Views:  197 Downloads:  0
Issue Description
The SoftCo is connected to the Public Switched Telephone Network (PSTN) through the AT0 trunk. When a PSTN user calls a SoftCo user, the call number cannot be displayed.
Handling Process
Step 1 Check whether the CLIP service has been enabled for the SoftCo user. If the CLIP service has not been enabled, ask the user to subscribe to the CLIP service.

Step 2 Connect the phone to the AT0 trunk interface provided by the carrier and make a call to check whether the calling number can be displayed. If the calling number is not displayed, go to step 1. If the calling number is displayed, go to step 3.

Step 3 Check whether FSK signals are used:

If the calling number is displayed when the phone starts to ring, DTMF signals are used.
If the calling number is displayed between the first ring and the second ring, FSK signals may be used. Then go to step 4.

Note:
The calling number can also be configured to display between the first ring and the second ring when the DTMF signals are used.

Step 4 Adjust the AT0 incoming gain to rectify the fault.
 For SoftCo9500, run the following command to set incoming gain of eight AT0 trunk circuits to 10:
config modify at0tkc slot x portinboard 0-7 fskgain 5 adgain 10
In the preceding command, x specifies the number of the slot in which the ATU board is located.



 For SoftCo5816, perform the following operations to adjust the AT0 incoming gain:
− Adjust the incoming gain of the eight AT0 trunk circuits on the shelf.
config modify at0tkc mpu portinboard 0-7 fskgain 5 adgain 10
− Adjust the incoming gain of the AT0 trunk circuits on the ATU board.
config modify at0tkc card slot 2 portinboard 0-7 fskgain 5 adgain 10
The keywords in the preceding commands are similar to those of the SoftCo9500.

Note:
After the FSK gain is adjusted, the changed gain value takes effect only when an incoming or outgoing call is made for the second time. To verify that the calling number is displayed, make the call for the second time.

Step 5 If the fault persists, contact Huawei technical support engineers.

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Root Cause
1.  The calling line identification presentation (CLIP) service has not been enabled for the SoftCo user.

2.  Signals are degraded because the AT0 line is long. As a result, the SoftCo fails to detect signals.

3.  The peer device sends calling numbers by using dual tone multi-frequency (DTMF) signals, but the SoftCo supports only frequency shift keying (FSK) signals.

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