Failure for the R2 Trunk to Route Outgoing Calls When Different Timeslots Are Used for Placing Outgoing Calls and Receiving Incoming Calls

Publication Date:  2015-07-15 Views:  173 Downloads:  0
Issue Description
When a user makes an outgoing call, he or she hears "The subscriber you dialed cannot be connected for the moment. Please redial later."
Handling Process
Step 1 Check the DTU board. The loss of signal (LOS) and request for announcement (RFA) indicators are off on the DTU board. Run the show tkc command to check the R2 trunk. All the timeslots on the R2 trunk are IDLE.

Step 2 Verify that the outgoing prefix configuration is correct.

Step 3 Run the following commands to verify that the R2 scripts are running normally.

show line send id <0-254>
show line report id <0-254>
show register send id <0-254>
show register report id <0-254>

Step 4 After confirmation with the customer, the R2 trunk uses different timeslots to make outgoing calls and receive incoming calls. Run the show protocol cassignal command. The following information is displayed:
Cas
Office Direction SelectLineMode DefaultCLDNum1 DefaultCLDNum2 Slot DeviceType
------ ----------- -------------- -------------- -------------- -------- -----------
2 BIDIRECTION POLL None None Card[1] OtherDevice
2 OUTGOING POLL None None Card[1] OtherDevice
2 INCOMING POLL None None Card[1] OtherDevice
3 BIDIRECTION POLL None None Card[1] OtherDevice
3 OUTGOING POLL None None Card[1] OtherDevice
3 INCOMING POLL None None Card[1] OtherDevice
4 BIDIRECTION POLL None None Card[2] OtherDevice
4 OUTGOING POLL None None Card[2] OtherDevice
4 INCOMING POLL None None Card[2] OtherDevice
OTMN CASNAME SupportCliPredeal
------- ----------- -----------------
refused xiaguanjidi Yes
refused Yes
refused Yes
refused zhongdiao Yes
refused Yes
refused Yes
refused xidian Yes
refused Yes
refused Yes

Step 5 According to the output of the show tkc command, all the timeslot directions for making outgoing calls are set to outgoing. However, in the output of the show protocol cassignal command, all the timeslot directions for making outgoing calls are set to None. As a result, the R2 adaptation for routing a call to the office route fails.

Step 6 Run the following commands:
config protocol cassignal officeno 2 direction outgoing casname xiaguanjidi selectlinemode poll
config protocol cassignal officeno 2 direction incoming casname xiaguanjidi selectlinemode poll
config protocol cassignal officeno 3 direction outgoing casname zhongdiao selectlinemode poll
config protocol cassignal officeno 3 direction incoming casname zhongdiao selectlinemode poll
config protocol cassignal officeno 4 direction outgoing casname xidian selectlinemode poll
config protocol cassignal officeno 4 direction incoming casname xidian selectlinemode poll

----End
Root Cause
The possible causes are as follows:
  • The E1 cable or data transform unit (DTU) board is faulty.
  • The clock source is not configured.
  • The outgoing prefix is not configured.
  • The R2 adaptation script is not executed.
  • The timeslots configured for making outgoing calls and receiving incoming calls through R2 trunks are different from those used in actual situations.

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