Failed to Access the Web Page of an IPC

Publication Date:  2015-06-27 Views:  229 Downloads:  0
Issue Description
Applicable Models:
All IPC models.

Symptom:

When you press Enter after entering the IP address of an IPC in the address box of Internet Explorer, the message "Internet Explorer cannot display the webpage" is displayed.
Handling Process
Fault Locating Process

Table 1 lists the fault locating process.

Table 1 Fault locating process





Solution:

Step 1 View the User Guide or related documents of the IPC to check whether the IPC supports the web browser that you use and its version. Ensure that your web browser and its version are supported by the IPC.

Step 2 Clear the web browser cache.

1. Open Internet Explorer and choose Tools > Internet Options.
The Internet Options dialog box is displayed.

2. On the General tab page, click Delete in the Browsing history area, and delete cached data as prompted.

Step 3 Enter the IP address of the IPC in the address box, press Enter, and check whether the correct web page can be displayed.
  • If the page redirects to an HTTPS connection, the certificate has problems. Go to Step 8.
  • If the page does not redirect to an HTTPS connection, go to Step 4.
Step 4 Ping the IP address of the IPC on your PC.

If the IPC can be pinged, go to Step 5. If the IPC cannot be pinged, go to the next step.

1. Check whether the IP address segment to which the IPC's IP address belongs is added to your PC.

For details about how to add IPC IP address segments to the PC, see Figure 1 and Figure 2.

Figure 1 Adding an IPC IP address segment



Figure 2 Adding an IPC IP address segment



2. Check whether the fault is rectified.
   a. If yes, no further operation is required.
   b. If no, go to the next step.

3. Check whether the network connection is normal.
Ensure that the network port, network cable, and routing or switching device between the PC and the IPC are normal.

4. Check whether the fault is rectified.
   a. If yes, no further operation is required.
   b. If no, go to Step 5.

Step 5 Check whether the proxy server is enabled in Internet Options.

1. Open Internet Explorer and choose Tools > Internet Options.
The Internet Options dialog box is displayed.

2. Click the Connections tab.

3. Click LAN settings.
The Local Area Network (LAN) Settings dialog box is displayed.

4. Disable the proxy server.
    a. Deselect the option under Proxy server, as shown in Figure 3.

Figure 3 Disabling the proxy server



    b. If the proxy server is not enabled, go to Step 6.

5. Check whether the fault is rectified.

6. If yes, no further operation is required.

7. If no, go to Step 6.

Step 6 Check whether the PC enables the firewall.

1. Open Control Panel on your PC to check whether the firewall is enabled.

2. Disable the firewall on your PC.
    a. If the firewall is enabled, disable the firewall.
    b. If the firewall is not enabled, go to Step 7.

3. Check whether the fault is rectified.
    a. If yes, no further operation is required.
    b. If no, go to Step 7.

Step 7 Check security settings in Internet Options.

1. Set the local intranet security level to low and access the web page of the IPC again.
Open Internet Explorer and choose Tools > Internet Options. In the Internet Options dialog box, choose Security > Local Intranet, click Custom level, and select a required security level in the security setting dialog box, as shown in Figure 4.

Figure 4 Security settings



2. Add the IP address of the IPC to the trusted sites of your PC and access the web page of the IPC again.
Open Internet Explorer and choose Tools > Internet Options. In the Internet Options dialog box, choose Security > Trusted sites, click Sites, and perform required settings in the Trusted sites dialog box that is displayed, as shown in Figure 5. Assume that the IP address of the IPC is 192.168.0.120.

Figure 5 Security settings



3. Reset Internet Explorer settings and access the web page of the IPC again.
Open Internet Explorer and choose Tools > Internet Options. In the Internet Options dialog box, click the Advanced tab, and reset Internet Explorer settings.

4. In the Internet Options dialog box, click the Advanced tab, deselect Use TLS 1.0, Use TLS 1.1, and Use TLS 1.2, and access the web page of the IPC again.

5. Check whether the fault is rectified.
    a. If yes, no further operation is required.
    b. If no, go to Step 11.

Step 8 Uninstall the Windows KB2661254 patch.

The following takes the Windows 7 operating system as an example. To uninstall the KB2661254 patch, perform the following steps:

1. Open Control Panel on the PC.

2. Select Programs.

3. In the Programs and Features area, select View installed updates.

4. Uninstall the KB2661254 patch and restart the PC.

5. Check whether the fault is rectified.
    a. If yes, no further operation is required.
    b. If no, go to Step 9.

Step 9 Modify the PC registry.

NOTE:
Before modifying the PC registry, back it up.

Step 10 The following takes the Windows 7 operating system as an example. To modify the PC registry, perform the following steps:

1. Choose Start > Run.

2. Enter regedit and click OK.
The regedit editor window is displayed.

3. In the pane on the left, choose HKEY_LOCAL_MACHINE > Software > Microsoft > Cryptography > OID > EncodingType 0 > CertDLLCreateCertificateChainEngine > Config.

4. Right-click the blank area on the right, choose New > DWORD (32-bit) Value, and create the MinRsaPubKeyBitLength DWORD value file.

5. Right-click the file and choose Modify.
The dialog box for changing the DWORD value is displayed.

6. Set Value data to 512.

7. Click OK.

Figure 6 shows the DWORD value file after being modified.

Figure 6 Modifying the registry



8. Check whether the fault is rectified.
    a. If yes, no further operation is required.
    b. If no, go to Step 11.



Step 11 Upgrade the IPC.

For details about how to upgrade the IPC, see the upgrade guide for the IPC. For details about how to obtain the upgrade guide, see Obtaining IPC Upgrade Guides(As Follow).

Step 12 Install Windows patches and access the web page of the IPC again.
  • If the correct web page is displayed, no further operation is required.
  • If the fault persists, go to Step 13.
Step 13 Use a PC running the Windows of another version to access the web page of the IPC.

Step 14 Check whether the fault is rectified.
  • If yes, no further operation is required.
  • If no, contact your service provider for assistance.
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As Follow:
Obtaining IPC Upgrade Guides
To obtain the upgrade guide for an IPC, perform the following steps:
Step 1 Visit http://enterprise.huawei.com.
Step 2 Choose SUPPORT > Product Support.
Step 3 Choose Unified Communications and Collaboration > Video Surveillance > Cameras.
Step 4 Select the required IPC version and download the required upgrade guide under Installation & Upgrade.
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Root Cause
The possible causes are as follows:
  • The cache of Internet Explorer is full.
  • The IP address segment to which the IPC's IP address belongs is not added to your PC.
  • There is a network fault.
  • The settings of Internet Explorer are incorrect.
  • The root certificate of the IPC conflicts with a Windows patch.
  • There is a security certificate conflict.
  • The Windows operating system has problems.
  • The IPC does not support the browser and version.

END