Failure to Access the CMS System

Publication Date:  2015-06-29 Views:  158 Downloads:  0
Issue Description
The CMS service is started, but users fail to access the CMS system using a web browser.
Handling Process
1. Add the IP address of the CMS server on the web configuration console.
a. Log in to the web configuration console as a system administrator.
b. Choose Web Configuration Console > System Configuration > WAS and click Add.
c. Add the IP address of the CMS server.
2. Check the ICDComm status.
a. Log in to the web configuration console as a system administrator.
b. View the Tomcat startup logs.
If the content in bold in the following information is displayed, the ICDComm fails to start:
2013-09-30 03:32:17 [Common] WAS Initializing......
2013-09-30 03:32:17 [Common] Initializing config file......
2013-09-30 03:32:18 [Common] Initializing config file......OK!
2013-09-30 03:32:18 [Common] Initializing data source(ptdb)......
2013-09-30 03:32:18 [Common] Initializing data source(ptdb)......Skipped!
2013-09-30 03:32:18 [Common] Initializing data source(wfmdb)......
2013-09-30 03:32:18 [Common] Initializing data source(wfmdb)......Skipped!
2013-09-30 03:32:18 [Common] Initializing data source(sysmondb)......
2013-09-30 03:32:18 [Common] Initializing data source(sysmondb)......Skipped!
2013-09-30 03:32:18 [Common] Initializing data source(configdb)......
2013-09-30 03:32:18 [Common] Initializing data source(configdb)......Skipped!
2013-09-30 03:32:18 [Common] Initializing data source(gmdb)......
2013-09-30 03:32:18 [Common] Initializing data source(gmdb)......Skipped!
2013-09-30 03:32:18 [Common] Connecting NIRC......
2013-09-30 03:32:18 [Common] Connecting NIRC......Skipped!
2013-09-30 03:32:18 [Common] Connecting Call Center(ID=30, Name=callcenter1)......
2013-09-30 03:32:18 [Common] Create CCS Connection......
com.huawei.icd.common.comm.cti.intf.PException: Expected UisAnyConnectAckMessage is null.
Change to back server and reconnect......
com.huawei.icd.common.comm.cti.intf.PException: Expected UisAnyConnectAckMessage is null.
Change to back server and reconnect......
2013-09-30 03:32:46 [Common] Create CCS Connection......Fail!
2013-09-30 03:32:46 [Common] Create Alert Connection......
2013-09-30 03:32:46 [Common] Create Alert Connection......Skipped!
2013-09-30 03:32:46 [Common] Create WFM(ID=1, Name=wfm1) Connection......
2013-09-30 03:32:46 [Common] Create WFM(ID=1, Name=wfm1) Connection......Skipped!
c. Go to /home/cms/icdcomm/bin.
cd /home/cms/icdcomm/bin
d. Restart the ICDComm.
./stopcomm
./icdcomm
3. Modify the CMS_Release/conf/was.xml file.
a. Log in to the CMS server as the cms user.
b. Go to /home/cms/CMS_Release/conf.
cd /home/cms/CMS_Release/conf
c. In the was.xml file, change the IP addresses of the active and standby CCSs as follows:
                       .
                        .
                        .
<callcenters>
      <callcenter id="1" name="callcenter1">    //Enter the contact center ID and name.
        <ccs>
          <main>
            <host>10.10.10.17</host>        //Enter the IP address of the active CCS.
            <port>20</port>
            <receive>20</receive>
            <byte-sequence>BigEndian</byte-sequence>
          </main>
          <back>
            <host>10.10.10.18</host>      //Enter the IP address of the standby CCS. If no standby CCS is deployed, leave this parameter empty.
            <port>20</port>
            <receive>20</receive>
            <byte-sequence>BigEndian</byte-sequence>
          </back>
          <argument-ref>core-server-arg</argument-ref>
        </ccs>
                        .
                        .
                        .
4. If the fault still persists, obtain help through the channels described in Help Channels.
Root Cause
 The IP address of the CMS server is not configured on the web configuration console so that the CCS cannot connect to the CMS server.
 The ICDComm used by the CMS service is not started.
 The IP addresses of the active and standby CCSs are incorrectly set in the was.xml file on the CMS server.

END