Failure to Make an Outgoing Call After Dialing the VU Switchboard as a Mobile Phone User

Publication Date:  2015-07-16 Views:  214 Downloads:  0
Issue Description
Network: IMS–SIP–SoftCo9500 (office A)–SIP trunk–SoftCo9500 (office B)–POTS phone

Versions:
  • SoftCo9500 in office A: V100R003C01SPC600
  • SoftCo9500 in office B: V100R002C04SPCc00
When a mobile phone user whose number is 136017****2 dials VU switchboard 31195390 of office A, and presses 0 (transferring a call to extension number 600 in office B) as prompted, an announcement is played indicating that the call cannot be connected.
Handling Process
Step 1 Check whether phones in offices A and B can make calls to each other through the SIP trunk. Calls can be made properly. Therefore, the SIP trunk between the two SoftCos in offices A and B is correctly configured.

Run the show subs dn 600 type all command. The command output shows that called number 600 has the incoming and outgoing call rights, as shown in the following figure.



Step 2 Check the log for the failed call.

[0118][0x000000c5][2014-02-27 16:05:28.08][ccm.c 15813][dwCCMNo=  205] CCM_ProcDBMsg:::<-  MsgType = EN_DBCCM_TRUNK_SELECT//Line selection starts.
……
[0088][0x000000c5][2014-02-27 16:05:28.08][ccm.c 57919][dwCCMNo=  205] This Call No history. 
[0093][0x000000c5][2014-02-27 16:05:28.08][ccm.c 16670][CCMNo =  205] No calling right,call fail!!//Right does not exist.
…… 
[0129][0x000000c5][2014-02-27 16:05:28.08][ccm.c 24239][Release Line= 16671][dwCCMNo=  205] CCM_ReleaseCallByCaller( ucCause = [22] )//The calling party releases the call.
According to onsite feedback, calls to phones under the SoftCo in office A can be connected properly after users dial the VU switchboard. Based on the log information, the following preliminary conclusion is obtained:

The VU switchboard does not have the outgoing call right. The call is released by the calling party.

Run the show pref dn 31195390 command. The following figure shows the command output. The preliminary conclusion is confirmed.



Step 3 Run the conf mod pref dn 31195390 vuoutgoingright inter&local command to grant the outgoing call right to the VU switchboard.



Step 4 Run the config softargu type 378 value 1 command to set software parameter 378 to 1.

The system uses software parameter 378 to control the call transfer right of the VU switchboard. By default, the call transfer right is disabled.
ID           : 378 
Type         : service 
Current Value: 0x0 
Desc         : Set Outgoing call right for VU [1:YES 0:NO(default:NO Right)]
The fault is rectified.

----End
Root Cause
  • The SIP trunk between the two SoftCos in offices A and B is not properly configured.
  • The VU switchboard does not have the outgoing call right.
Suggestions
When encountering call barring faults, make the fault symptom clear. Clear fault information provides the direction for finding fault causes.

To rectify faults, check the configurations first. If the configurations are correct, capture and analyze call logs to find fault causes.

END