VCM service:video search function cannot work well

Publication Date:  2015-12-26 Views:  538 Downloads:  0
Issue Description

VCM version:V100R001C10

As you can see, when we are performing video search(include scene search and track search), it raises the error;



Handling Process

1. confirm the Error code 1009 as picture:we cannot access a property or method of a null object reference,it means we access a wrong nul object, which is code fault of software, mostly because of compatibility issues.And then check the version compatibility with R&D,knows that

 system cannot support the newest version, only can support version from flash player 6 to flash player 17,except 18.19.20:

as a result, we should uninstall the current version, and reinstall the compatible version within 6 ro 17.

2. uninstal the current version;

3. install new version(download version .exe from web, and click it to install), but we cannot, it displays as follow:

we can know that the older version cannot be installed.

4. confirm the reason with R&D, it turns out we need a specialized tool to uninstall flash player, which can be downloal from Adobe web, tool can be download from attachment;

5.with the help of tool(get the tool exe, and click it on PC to uninstall current version), we can install the older version successfully.

6. check the operation, and the issue is solved.


Root Cause
our VCM system (vsersion:V100R001C10) cannot support the newest version for flash player, it can only support the version from 6 to 17. 
Solution

1. check the Adobe flash player version before login SEM system;

2. if the flsh player verison is nor within 6 to 17, we have to prepare the specialized tool to uninstall the version.

Suggestions

when we use the IE browser on new PC, we are supposed to check the Adobe flash player version to make sure it can be compatible with SEM system.

and most of time, we have always already installed the newest version of flash player, which we have to uninstall, we have to use the specialized tool to

uninstall the current version, or older version cannot be installed successfully.

END