Use MUX VLAN to manage a device with only one vlanif from 2 different VLAN's

Publication Date:  2017-02-23 Views:  545 Downloads:  0
Issue Description

This KB help you to manage a device that can support only one VLANif interface from 2 different vlan's.

This scenario can ocure when for example there are 2 companies and one company (ISP) buy a part of the network infrastructure of another company and during transition period both company need to manage same devices.

If company A use management VLAN 4093 and company B use management VLAN 400 and company B buy a part of network infrastructure of company A and among the devices some of them don't support multiple VLANif interfaces - for example:
S2750EI/S5700LI/S5700S-LI: earlier versions of V200R005 (support only 1 VLANif interface) - then we can use MUX VLAN to configure VLAN 4093 as the "Principal VLAN" and VLAN 400 as "Subordinate VLAN".



Handling Process

vlan 4093                                                                      
mux-vlan                                                                      
subordinate group 400



interface GigabitEthernet0/0/8                                                 

port ink-type access                                                         

port default vlan 400                                                         

port mux-vlan enable vlan 400


Remember you have to enable mux-vlan function on each transit interface, for example if you
have one more switch to reach managed device and you have a trunck interface between, then you have to enable on it also.



Solution

Create both VLAN

#

vlan batch 4093 400


Assign first and second ip to VLANif interface:


interface Vlanif4093 

ip address 10.10.2.205 255.255.252.0

ip address 10.2.10.15 255.255.252.0 sub


Configure Principal and subordinate VLAN:

#                                                                              

vlan 4093                                                                      

mux-vlan                                                                      

subordinate group 400


Enable mux-vlan function on subordinate VLAN interface and on transit interfaces if there are any.

#                                                                              
interface GigabitEthernet0/0/8                                                 

port link-type access                                                         

port default vlan 400                                                         

port mux-vlan enable vlan 400


Now you should be able to access the device from both VLAN's.



END