No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Typical Configuration Examples

CloudEngine 12800, 12800E, 8800, 7800, 6800, and 5800 Series Switches

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring M-LAG Active-Active Devices to Connect to a VXLAN Network Using BGP EVPN in Centralized Gateway Mode

Example for Configuring M-LAG Active-Active Devices to Connect to a VXLAN Network Using BGP EVPN in Centralized Gateway Mode

Applicable Products and Versions

This example applies to the CE12800, CE12800E, CE8800, CE7800, CE5880EI, and CE6800 (excluding CE6850EI, CE6810EI, and CE6810LI) V200R001C00 or later.

Networking Requirements

In Figure 1-18 has the following requirements when servers access the VXLAN network:
  • To ensure high reliability, the server is dual-homed to two leaf devices. When one access link fails, traffic can be rapidly switched to the other link.
  • To improve bandwidth utilization, two links are in active state simultaneously to load balance traffic.

This example uses the CE12804 switch.

Figure 1-18 M-LAG Active-Active Devices to Connect to a VXLAN Network

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure a routing protocol on Leaf1, Leaf2, and Spine to ensure Layer 3 network connectivity.
  2. Configure M-LAG.
    • Associate a DFS group with VXLAN on Leaf1 and Leaf2.
    • Configure a link between Leaf1 and Leaf2 as the peer link.
    • Bind the user-side Eth-Trunk to the DFS group on Leaf1 and Leaf2.
  3. Configure a service access point on Leaf1 and Leaf2 to differentiate service traffic.
  4. Configure EVPN as the VXLAN control plane.
  5. Configure a BGP EVPN peer relationship.
  6. Configure EVPN instances.
  7. Configure an ingress replication list.
NOTE:

If the link through which Leaf1 is uplink connected to the VXLAN network fails, Leaf1 discards all received user traffic because no uplink outbound interface is available. You can configure a monitor-link to associate the uplink and downlink interfaces of Leaf1. When the uplink outbound interface of Leaf1 becomes Down, the downlink interface also becomes Down. Then user traffic will not be forwarded or discarded by Leaf1. For details about the monitor-link configuration, see Configuring the Uplink and Downlink Interfaces in a Monitor Link Group.

Data Plan

The following data is needed to complete the configuration:

  • VMs' VLAN IDs (10 and 20)
  • Interface IP addresses for device interconnection
  • Routing protocol: OSPF
  • BD IDs (10 and 20)
  • VNI IDs (5010 and 5020)
  • EVPN instances' RDs (11:1, 12:1, 21:1, 22:1, 31:1 and 32:1) and RTs (1:1 and 2:2)

Procedure

  1. Configure a routing protocol.

    When OSPF is used, the devices advertise the 32-bit loopback IP addresses.

    # Configure Leaf1.

    <HUAWEI> system-view
    [~HUAWEI] sysname Leaf1
    [*HUAWEI] commit
    [~Leaf1] interface loopback 1
    [*Leaf1-LoopBack1] ip address 10.1.1.1 32
    [*Leaf1-LoopBack1] quit
    [*Leaf1] interface loopback 2
    [*Leaf1-LoopBack2] ip address 10.2.1.1 32
    [*Leaf1-LoopBack2] quit
    [*Leaf1] interface 10ge 1/0/1
    [*Leaf1-10GE1/0/1] undo portswitch
    [*Leaf1-10GE1/0/1] ip address 192.168.1.1 24
    [*Leaf1-10GE1/0/1] quit
    [*Leaf1] ospf
    [*Leaf1-ospf-1] area 0
    [*Leaf1-ospf-1-area-0.0.0.0] network 10.1.1.1 0.0.0.0
    [*Leaf1-ospf-1-area-0.0.0.0] network 10.2.1.1 0.0.0.0
    [*Leaf1-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [*Leaf1-ospf-1-area-0.0.0.0] quit
    [*Leaf1-ospf-1] quit
    [*Leaf1] commit

    # Configure Leaf2.

    <HUAWEI> system-view
    [~HUAWEI] sysname Leaf2
    [*HUAWEI] commit
    [~Leaf2] interface loopback 1
    [*Leaf2-LoopBack1] ip address 10.1.1.2 32
    [*Leaf2-LoopBack1] quit
    [*Leaf2] interface loopback 2
    [*Leaf2-LoopBack2] ip address 10.2.1.1 32
    [*Leaf2-LoopBack2] quit
    [*Leaf2] interface 10ge 1/0/1
    [*Leaf2-10GE1/0/1] undo portswitch
    [*Leaf2-10GE1/0/1] ip address 192.168.2.1 24
    [*Leaf2-10GE1/0/1] quit
    [*Leaf2] ospf
    [*Leaf2-ospf-1] area 0
    [*Leaf2-ospf-1-area-0.0.0.0] network 10.1.1.2 0.0.0.0
    [*Leaf2-ospf-1-area-0.0.0.0] network 10.2.1.1 0.0.0.0
    [*Leaf2-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255
    [*Leaf2-ospf-1-area-0.0.0.0] quit
    [*Leaf2-ospf-1] quit
    [*Leaf2] commit

    # Configure Spine.

    <HUAWEI> system-view
    [~HUAWEI] sysname Spine
    [*HUAWEI] commit
    [~Spine] interface loopback 1
    [*Spine-LoopBack1] ip address 10.1.1.3 32
    [*Spine-LoopBack1] quit
    [*Spine] interface 10ge 1/0/1
    [*Spine-10GE1/0/1] undo portswitch
    [*Spine-10GE1/0/1] ip address 192.168.1.2 24
    [*Spine-10GE1/0/1] quit
    [*Spine] interface 10ge 1/0/2
    [*Spine-10GE1/0/2] undo portswitch
    [*Spine-10GE1/0/2] ip address 192.168.2.2 24
    [*Spine-10GE1/0/2] quit
    [*Spine] ospf
    [*Spine-ospf-1] area 0
    [*Spine-ospf-1-area-0.0.0.0] network 10.1.1.3 0.0.0.0
    [*Spine-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [*Spine-ospf-1-area-0.0.0.0] network 192.168.2.0 0.0.0.255
    [*Spine-ospf-1-area-0.0.0.0] quit
    [*Spine-ospf-1] quit
    [*Spine] commit

    After OSPF is configured, the devices can learn the loopback IP address of each other and successfully ping each other. The following shows the ping result from Leaf1 to Spine.

    [~Leaf1] ping 10.1.1.3
      PING 10.1.1.3: 56  data bytes, press CTRL_C to break
        Reply from 10.1.1.3: bytes=56 Sequence=1 ttl=254 time=1 ms
        Reply from 10.1.1.3: bytes=56 Sequence=2 ttl=254 time=1 ms
        Reply from 10.1.1.3: bytes=56 Sequence=3 ttl=254 time=1 ms
        Reply from 10.1.1.3: bytes=56 Sequence=4 ttl=254 time=1 ms
        Reply from 10.1.1.3: bytes=56 Sequence=5 ttl=254 time=1 ms
    
      --- 10.1.1.3 ping statistics ---
        5 packet(s) transmitted
        5 packet(s) received
        0.00% packet loss
        round-trip min/avg/max = 1/1/1 ms
                                                

  2. Configure M-LAG.

    Configure dual-active detection links, V-STP, DFS groups, peer-links, and M-LAG member interfaces on Leaf1 and Leaf2.

    1. Configure V-STP.

      # Configure Leaf1.

      [~Leaf1] stp mode rstp
      [*Leaf1] stp v-stp enable
      [*Leaf1] stp flush disable
      [*Leaf1] commit

      # Configure Leaf2.

      [~Leaf2] stp mode rstp
      [*Leaf2] stp v-stp enable
      [*Leaf2] stp flush disable
      [~Leaf2] commit

    2. Configure dual-active detection links.

      The DAD link is deployed on a service network in this case, and the IP address bound to the DFS group must be reachable at Layer 3.

    3. Configure DFS Group.

      # Configure Leaf1.

      [~Leaf1] dfs-group 1
      [*Leaf1-dfs-group-1] source ip 10.1.1.1
      [*Leaf1-dfs-group-1] priority 150
      [*Leaf1-dfs-group-1] quit
      [*Leaf1] commit

      # Configure Leaf2.

      [~Leaf2] dfs-group 1
      [*Leaf2-dfs-group-1] source ip 10.1.1.2
      [*Leaf2-dfs-group-1] priority 120
      [*Leaf2-dfs-group-1] quit
      [*Leaf2] commit

    4. Configure peer-link.

      It is recommended that Eth-Trunk member interfaces of the peer-link be deployed on different cards to prevent the peer-link fault caused by a single-point failure.

      # Configure Leaf1.

      [~Leaf1] interface eth-trunk 1
      [*Leaf1-Eth-Trunk1] trunkport 10ge 1/0/4
      [*Leaf1-Eth-Trunk1] trunkport 10ge 2/0/4 
      [*Leaf1-Eth-Trunk1] mode lacp-static
      [*Leaf1-Eth-Trunk1] peer-link 1
      [*Leaf1-Eth-Trunk1] quit
      [*Leaf1] commit

      # Configure Leaf2.

      [~Leaf2] interface eth-trunk 1
      [*Leaf2-Eth-Trunk1] trunkport 10ge 1/0/4
      [*Leaf2-Eth-Trunk1] trunkport 10ge 2/0/4 
      [*Leaf2-Eth-Trunk1] mode lacp-static
      [*Leaf2-Eth-Trunk1] peer-link 1
      [*Leaf2-Eth-Trunk1] quit
      [*Leaf2] commit

      # Configure VLANIF interfaces on peer-link interfaces of Leaf1 and Leaf2, and add the VLANIF interfaces to the OSPF area so that the peer-link functions as the backup link for the uplinks of Leaf1 and Leaf2.

      [~Leaf1] vlan batch 30
      [*Leaf1] interface vlanif 30
      [*Leaf1-Vlanif30] ip address 192.168.3.1 24
      [*Leaf1-Vlanif30] ospf cost 100
      [*Leaf1-Vlanif30] quit
      [*Leaf1] ospf
      [*Leaf1-ospf-1] area 0
      [*Leaf1-ospf-1-area-0.0.0.0] network 192.168.3.0 0.0.0.255
      [*Leaf1-ospf-1-area-0.0.0.0] quit
      [*Leaf1-ospf-1] quit
      [*Leaf1] commit
      [~Leaf2] vlan batch 30
      [*Leaf2] interface vlanif 30
      [*Leaf2-Vlanif30] ip address 192.168.3.2 24
      [*Leaf2-Vlanif30] ospf cost 100
      [*Leaf2-Vlanif30] quit
      [*Leaf2] ospf
      [*Leaf2-ospf-1] area 0
      [*Leaf2-ospf-1-area-0.0.0.0] network 192.168.3.0 0.0.0.255
      [*Leaf2-ospf-1-area-0.0.0.0] quit
      [*Leaf2-ospf-1] quit
      [*Leaf2] commit

    5. Configure M-LAG member interfaces.

      • The uplink interface of the server connected to the switch needs to be bound to an aggregated link, and the link aggregation modes on the server and switch must be consistent.

      • Configure the Eth-Trunk on Leaf connected to servers as the edge interface and enable BPDU protection on the Eth-Trunk.

      # Configure Leaf1.

      [~Leaf1] interface eth-trunk 10
      [*Leaf1-Eth-Trunk10] trunkport 10ge 1/0/2
      [*Leaf1-Eth-Trunk10] mode lacp-static
      [*Leaf1-Eth-Trunk10] dfs-group 1 m-lag 1
      [*Leaf1-Eth-Trunk10] stp edged-port enable
      [*Leaf1-Eth-Trunk10] quit
      [*Leaf1] interface eth-trunk 20
      [*Leaf1-Eth-Trunk20] trunkport 10ge 1/0/3
      [*Leaf1-Eth-Trunk20] mode lacp-static
      [*Leaf1-Eth-Trunk20] dfs-group 1 m-lag 2
      [*Leaf1-Eth-Trunk20] stp edged-port enable
      [*Leaf1-Eth-Trunk20] quit
      [*Leaf1] commit

      # Configure Leaf2.

      [~Leaf2] interface eth-trunk 10
      [*Leaf2-Eth-Trunk10] trunkport 10ge 1/0/2
      [*Leaf2-Eth-Trunk10] mode lacp-static
      [*Leaf2-Eth-Trunk10] dfs-group 1 m-lag 1
      [*Leaf2-Eth-Trunk10] stp edged-port enable
      [*Leaf2-Eth-Trunk10] quit
      [*Leaf2] interface eth-trunk 20
      [*Leaf2-Eth-Trunk20] trunkport 10ge 1/0/3
      [*Leaf2-Eth-Trunk20] mode lacp-static
      [*Leaf2-Eth-Trunk20] dfs-group 1 m-lag 2
      [*Leaf2-Eth-Trunk20] stp edged-port enable
      [*Leaf2-Eth-Trunk20] quit
      [*Leaf1] commit

  3. Configure the VXLAN tunnel mode and enable the VXLAN ACL extension function.(This step only needs to be performed on the CE12800, CE6870EI, and CE6875EI.)

    # Configure Leaf1. The configurations on Leaf2 and Spine are similar to that on Leaf1, and are not mentioned here.

    [~Leaf1] ip tunnel mode vxlan
    [*Leaf1] assign forward nvo3 acl extend enable
    [*Leaf1] commit
    NOTE:

    After modifying the VXLAN tunnel mode or enabling the VXLAN ACL extension function, save the configuration and restart the device to make the configuration take effect. Restart the device immediately or after completing all the configurations.

  4. Configure a service access point on Leaf1 and Leaf2.

    # Configure Leaf1.

    [~Leaf1] vlan batch 10 20
    [*Leaf1] bridge-domain 10
    [*Leaf1-bd10] l2 binding vlan 10
    [*Leaf1-bd10] quit
    [*Leaf1] interface eth-trunk 10
    [*Leaf1-Eth-Trunk10] port link-type trunk
    [*Leaf1-Eth-Trunk10] undo port trunk allow-pass vlan 1
    [*Leaf1-Eth-Trunk10] port trunk allow-pass vlan 10
    [*Leaf1-Eth-Trunk10] quit
    [*Leaf1] bridge-domain 20
    [*Leaf1-bd20] l2 binding vlan 20
    [*Leaf1-bd20] quit
    [*Leaf1] interface eth-trunk 20
    [*Leaf1-Eth-Trunk20] port link-type trunk
    [*Leaf1-Eth-Trunk20] undo port trunk allow-pass vlan 1
    [*Leaf1-Eth-Trunk20] port trunk allow-pass vlan 20
    [*Leaf1-Eth-Trunk20] quit
    [*Leaf1] commit

    # Configure Leaf2.

    [~Leaf2] vlan batch 10 20
    [*Leaf2] bridge-domain 10
    [*Leaf2-bd10] l2 binding vlan 10
    [*Leaf2-bd10] quit
    [*Leaf2] interface eth-trunk 10
    [*Leaf2-Eth-Trunk10] port link-type trunk
    [*Leaf2-Eth-Trunk10] undo port trunk allow-pass vlan 1
    [*Leaf2-Eth-Trunk10] port trunk allow-pass vlan 10
    [*Leaf2-Eth-Trunk10] quit
    [*Leaf2] bridge-domain 20
    [*Leaf2-bd20] l2 binding vlan 20
    [*Leaf2-bd20] quit
    [*Leaf2] interface eth-trunk 20
    [*Leaf2-Eth-Trunk20] port link-type trunk
    [*Leaf2-Eth-Trunk20] undo port trunk allow-pass vlan 1
    [*Leaf2-Eth-Trunk20] port trunk allow-pass vlan 20
    [*Leaf2-Eth-Trunk20] quit
    [*Leaf2] commit

  5. Configure EVPN as the VXLAN control plane on Leaf1, Leaf2 and Spine.

    # Configure Leaf1. Repeat this step for Leaf2 and Spine.

    [~Leaf1] evpn-overlay enable
    [*Leaf1] commit

  6. Configure a BGP EVPN peer relationship.

    # Configure Leaf1.

    [~Leaf1] bgp 100
    [*Leaf1-bgp] peer 10.1.1.2 as-number 100
    [*Leaf1-bgp] peer 10.1.1.2 connect-interface LoopBack1
    [*Leaf1-bgp] peer 10.1.1.3 as-number 100
    [*Leaf1-bgp] peer 10.1.1.3 connect-interface LoopBack1
    [*Leaf1-bgp] l2vpn-family evpn
    [*Leaf1-bgp-af-evpn] peer 10.1.1.2 enable
    Warning: This operation will reset the peer session. Continue? [Y/N]: y
    [*Leaf1-bgp-af-evpn] peer 10.1.1.3 enable
    Warning: This operation will reset the peer session. Continue? [Y/N]: y
    [*Leaf1-bgp-af-evpn] quit
    [*Leaf1-bgp] quit
    [*Leaf1] commit

    # Configure Leaf2.

    [~Leaf2] bgp 100
    [*Leaf2-bgp] peer 10.1.1.1 as-number 100
    [*Leaf2-bgp] peer 10.1.1.1 connect-interface LoopBack1
    [*Leaf2-bgp] peer 10.1.1.3 as-number 100
    [*Leaf2-bgp] peer 10.1.1.3 connect-interface LoopBack1
    [*Leaf2-bgp] l2vpn-family evpn
    [*Leaf2-bgp-af-evpn] peer 10.1.1.1 enable
    Warning: This operation will reset the peer session. Continue? [Y/N]: y
    [*Leaf2-bgp-af-evpn] peer 10.1.1.3 enable
    Warning: This operation will reset the peer session. Continue? [Y/N]: y
    [*Leaf2-bgp-af-evpn] quit
    [*Leaf2-bgp] quit
    [*Leaf2] commit

    # Configure Spine.

    [~Spine] bgp 100
    [*Spine-bgp] peer 10.1.1.1 as-number 100
    [*Spine-bgp] peer 10.1.1.1 connect-interface LoopBack1
    [*Spine-bgp] peer 10.1.1.2 as-number 100
    [*Spine-bgp] peer 10.1.1.2 connect-interface LoopBack1
    [*Spine-bgp] l2vpn-family evpn
    [*Spine-bgp-af-evpn] peer 10.1.1.1 enable
    Warning: This operation will reset the peer session. Continue? [Y/N]: y
    [*Spine-bgp-af-evpn] peer 10.1.1.2 enable
    Warning: This operation will reset the peer session. Continue? [Y/N]: y
    [*Spine-bgp-af-evpn] quit
    [*Spine-bgp] quit
    [*Spine] commit

  7. Configure an EVPN instance.

    # Configure Leaf1.

    [~Leaf1] bridge-domain 10
    [*Leaf1-bd10] vxlan vni 5010
    [*Leaf1-bd10] evpn
    [*Leaf1-bd10-evpn] route-distinguisher 11:1
    [*Leaf1-bd10-evpn] vpn-target 1:1
    [*Leaf1-bd10-evpn] quit
    [*Leaf1-bd10] quit
    [*Leaf1] bridge-domain 20
    [*Leaf1-bd20] vxlan vni 5020
    [*Leaf1-bd20] evpn
    [*Leaf1-bd20-evpn] route-distinguisher 12:1
    [*Leaf1-bd20-evpn] vpn-target 2:2
    [*Leaf1-bd20-evpn] quit
    [*Leaf1-bd20] quit
    [*Leaf1] commit

    # Configure Leaf2.

    [~Leaf2] bridge-domain 10
    [*Leaf2-bd10] vxlan vni 5010
    [*Leaf2-bd10] evpn
    [*Leaf2-bd10-evpn] route-distinguisher 21:1
    [*Leaf2-bd10-evpn] vpn-target 1:1
    [*Leaf2-bd10-evpn] quit
    [*Leaf2-bd10] quit
    [*Leaf2] bridge-domain 20
    [*Leaf2-bd20] vxlan vni 5020
    [*Leaf2-bd20] evpn
    [*Leaf2-bd20-evpn] route-distinguisher 22:1
    [*Leaf2-bd20-evpn] vpn-target 2:2
    [*Leaf2-bd20-evpn] quit
    [*Leaf2-bd20] quit
    [*Leaf2] commit

    # Configure Spine.

    [~Spine] bridge-domain 10
    [*Spine-bd10] vxlan vni 5010
    [*Spine-bd10] evpn
    [*Spine-bd10-evpn] route-distinguisher 31:1
    [*Spine-bd10-evpn] vpn-target 1:1
    [*Spine-bd10-evpn] quit
    [*Spine-bd10] quit
    [*Spine] bridge-domain 20
    [*Spine-bd20] vxlan vni 5020
    [*Spine-bd20] evpn
    [*Spine-bd20-evpn] route-distinguisher 32:1
    [*Spine-bd20-evpn] vpn-target 2:2
    [*Spine-bd20-evpn] quit
    [*Spine-bd20] quit
    [*Spine] commit

  8. Configure an ingress replication list.

    Because Leaf1 and Leaf2 work as active-active access, you need to ensure that the IP addresses of NVE interfaces on the two devices are the same.

    # Configure Leaf1.

    [~Leaf1] interface nve1
    [*Leaf1-Nve1] source 10.2.1.1
    [*Leaf1-Nve1] mac-address 0000-5e00-0101
    [*Leaf1-Nve1] vni 5010 head-end peer-list protocol bgp
    [*Leaf1-Nve1] vni 5020 head-end peer-list protocol bgp
    [*Leaf1-Nve1] quit
    [*Leaf1] commit

    # Configure Leaf2.

    [~Leaf2] interface nve1
    [*Leaf2-Nve1] source 10.2.1.1
    [*Leaf2-Nve1] mac-address 0000-5e00-0101
    [*Leaf2-Nve1] vni 5010 head-end peer-list protocol bgp
    [*Leaf2-Nve1] vni 5020 head-end peer-list protocol bgp
    [*Leaf2-Nve1] quit
    [*Leaf2] commit

    # Configure Spine.

    [~Spine] interface nve1
    [*Spine-Nve1] source 10.1.1.3
    [*Spine-Nve1] vni 5010 head-end peer-list protocol bgp
    [*Spine-Nve1] vni 5020 head-end peer-list protocol bgp
    [*Spine-Nve1] quit
    [*Spine] commit

  9. Configure Spine as a Layer 3 VXLAN gateway.

    [~Spine] interface vbdif 10
    [*Spine-Vbdif10] ip address 192.168.10.10 24
    [*Spine-Vbdif10] quit
    [*Spine] interface vbdif 20
    [*Spine-Vbdif20] ip address 192.168.20.10 24
    [*Spine-Vbdif20] quit
    [*Spine] commit

  10. Verify the configuration.

    After the configuration is complete, run the display vxlan vni command on Spine. The command output shows that the VNI status is up. Run the display vxlan tunnel command, and you can see VXLAN tunnel information.

    [~Spine] display vxlan vni
    Number of vxlan vni : 2
    VNI            BD-ID            State
    ---------------------------------------
    5010           10               up
    5020           20               up
    [~Spine] display vxlan tunnel
    Number of vxlan tunnel : 1
    Tunnel ID   Source                Destination           State  Type     Uptime
    -----------------------------------------------------------------------------------
    4026531841  10.1.1.3              10.2.1.1              up     dynamic  00:00:51           

    Run the display dfs-group 1 m-lag command to check M-LAG information on Leaf1 and Leaf2. The following example shows the command output on Leaf1.

    [~Leaf1] display dfs-group 1 m-lag
    *                : Local node
    Heart beat state : OK
    Node 1 *
      Dfs-Group ID   : 1
      Priority       : 150
      Address        : ip address 10.1.1.1
      State          : Master
      Causation      : -
      System ID      : 0052-7512-2401
      SysName        : Leaf1
      Version        : V200R003C00SPC200
      Device Type    : CE12800
    Node 2
      Dfs-Group ID   : 1
      Priority       : 120
      Address        : ip address 10.1.1.2
      State          : Backup
      Causation      : -
      System ID      : 0034-2354-9901
      SysName        : Leaf2
      Version        : V200R003C00SPC200
      Device Type    : CE12800                     

    Check M-LAG information on Leaf1.

    [~Leaf1] display dfs-group 1 node 1 m-lag brief
    * - Local node
    
    M-Lag ID     Interface      Port State    Status                Consistency-check
           1     Eth-Trunk 10   Up            active(*)-active      -
           2     Eth-Trunk 20   Up            active(*)-active      -
    
    Failed reason:
        1 -- Relationship between vlan and port is inconsistent
        2 -- STP configuration under the port is inconsistent
        3 -- STP port priority configuration is inconsistent
        4 -- LACP mode of M-LAG is inconsistent
        5 -- M-LAG configuration is inconsistent           

    Run the display bridge-domain 10 verbose command on Leaf1 and Leaf2 to view BD information. The display on Leaf1 is taken as an example.

    [~Leaf1] display bridge-domain 10 verbose
      Bridge-domain ID        : 10
      Description             :
      State                   : Up
      MAC Learning            : Enable
      Statistics              : Disable
      Broadcast               : Forward
      Unknown-unicast         : Forward
      Unknown-multicast       : Forward
      Split-horizon           : Disable
      Vxlan Vni               : 5010
    
      ----------------
    Interface                                State
      Eth-Trunk1.5010                        up         

Configuration Files

  • Leaf1 configuration file

    #
    sysname Leaf1
    #
    assign forward nvo3 acl extend enable
    #
    dfs-group 1
     priority 150
     source ip 10.1.1.1
    #
    vlan batch 10 20 30
    #
    stp mode rstp
    stp v-stp enable
    stp flush disable
    #
    evpn-overlay enable
    #
    bridge-domain 10
     l2 binding vlan 10
     vxlan vni 5010
     evpn
      route-distinguisher 11:1
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
    #
    bridge-domain 20
     l2 binding vlan 20
     vxlan vni 5020
     evpn
      route-distinguisher 12:1
      vpn-target 2:2 export-extcommunity
      vpn-target 2:2 import-extcommunity
    #
    interface Vlanif30
     ip address 192.168.3.1 255.255.255.0
     ospf cost 100
    #
    interface Eth-Trunk1
     mode lacp-static
     peer-link 1
    #
    interface Eth-Trunk10
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10
     stp edged-port enable
     mode lacp-static
     dfs-group 1 m-lag 1
    #
    interface Eth-Trunk20
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20
     stp edged-port enable
     mode lacp-static
     dfs-group 1 m-lag 2
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.1.1 255.255.255.0
    #
    interface 10GE1/0/2
     eth-trunk 10
     lacp force-up
    #
    interface 10GE1/0/3
     eth-trunk 20
     lacp force-up
    #
    interface 10GE1/0/4
     eth-trunk 1
    #
    interface 10GE2/0/4
     eth-trunk 1
    #
    interface LoopBack1
     ip address 10.1.1.1 255.255.255.255
    #
    interface LoopBack2
     ip address 10.2.1.1 255.255.255.255
    #
    interface Nve1
     source 10.2.1.1
     vni 5010 head-end peer-list protocol bgp
     vni 5020 head-end peer-list protocol bgp
     mac-address 0000-5e00-0101
    #
    bgp 100
     peer 10.1.1.2 as-number 100
     peer 10.1.1.2 connect-interface LoopBack1
     peer 10.1.1.3 as-number 100
     peer 10.1.1.3 connect-interface LoopBack1
     #
     ipv4-family unicast
      peer 10.1.1.2 enable  
      peer 10.1.1.3 enable
     #
     l2vpn-family evpn
      policy vpn-target
      peer 10.1.1.2 enable
      peer 10.1.1.3 enable
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.1 0.0.0.0
      network 10.2.1.1 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    return
  • Leaf2 configuration file

    #
    sysname Leaf2
    #
    assign forward nvo3 acl extend enable
    #
    dfs-group 1
     priority 120
     source ip 10.1.1.2
    #
    vlan batch 10 20 30
    #
    stp mode rstp
    stp v-stp enable
    stp flush disable
    #
    evpn-overlay enable
    #
    bridge-domain 10
     l2 binding vlan 10
     vxlan vni 5010
     evpn
      route-distinguisher 21:1
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
    #
    bridge-domain 20
     l2 binding vlan 20
     vxlan vni 5020
     evpn
      route-distinguisher 22:1
      vpn-target 2:2 export-extcommunity
      vpn-target 2:2 import-extcommunity
    #
    interface Vlanif30
     ip address 192.168.3.2 255.255.255.0
     ospf cost 100
    #
    interface Eth-Trunk1
     mode lacp-static
     peer-link 1
    #
    interface Eth-Trunk10
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10
     stp edged-port enable
     mode lacp-static
     dfs-group 1 m-lag 1
    #
    interface Eth-Trunk20
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20
     stp edged-port enable
     mode lacp-static
     dfs-group 1 m-lag 2
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.2.1 255.255.255.0
    #
    interface 10GE1/0/2
     eth-trunk 10
     lacp force-up
    #
    interface 10GE1/0/3
     eth-trunk 20
     lacp force-up
    #
    interface 10GE1/0/4
     eth-trunk 1
    #
    interface 10GE2/0/4
     eth-trunk 1
    #
    interface LoopBack1
     ip address 10.1.1.2 255.255.255.255
    #
    interface LoopBack2
     ip address 10.2.1.1 255.255.255.255
    #
    interface Nve1
     source 10.2.1.1
     vni 5010 head-end peer-list protocol bgp
     vni 5020 head-end peer-list protocol bgp
     mac-address 0000-5e00-0101
    #
    bgp 100
     peer 10.1.1.1 as-number 100
     peer 10.1.1.1 connect-interface LoopBack1
     peer 10.1.1.3 as-number 100
     peer 10.1.1.3 connect-interface LoopBack1
     #
     ipv4-family unicast
      peer 10.1.1.1 enable  
      peer 10.1.1.3 enable
     #
     l2vpn-family evpn
      policy vpn-target
      peer 10.1.1.1 enable
      peer 10.1.1.3 enable
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.2 0.0.0.0
      network 10.2.1.1 0.0.0.0
      network 192.168.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
    #
    return
  • Spine configuration file

    #
    sysname Spine
    #
    evpn-overlay enable
    #
    bridge-domain 10
     vxlan vni 5010
     evpn
      route-distinguisher 31:1
      vpn-target 1:1 export-extcommunity
      vpn-target 1:1 import-extcommunity
    #
    bridge-domain 20
     vxlan vni 5020
     evpn
      route-distinguisher 32:1
      vpn-target 2:2 export-extcommunity
      vpn-target 2:2 import-extcommunity
    #
    interface Vbdif10
     ip address 192.168.10.10 255.255.255.0
    #
    interface Vbdif20
     ip address 192.168.20.10 255.255.255.0
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.1.2 255.255.255.0
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 192.168.2.2 255.255.255.0
    #
    interface LoopBack1
     ip address 10.1.1.3 255.255.255.255
    #
    interface Nve1
     source 10.1.1.3
     vni 5010 head-end peer-list protocol bgp
     vni 5020 head-end peer-list protocol bgp
    #
    bgp 100
     peer 10.1.1.1 as-number 100
     peer 10.1.1.1 connect-interface LoopBack1
     peer 10.1.1.2 as-number 100
     peer 10.1.1.2 connect-interface LoopBack1
    #
     ipv4-family unicast
      peer 10.1.1.1 enable  
      peer 10.1.1.2 enable
     #
     l2vpn-family evpn
      policy vpn-target
      peer 10.1.1.1 enable
      peer 10.1.1.2 enable
    #
    ospf 1
     area 0.0.0.0
      network 10.1.1.3 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
    #
    return 
Download
Updated: 2019-04-03

Document ID: EDOC1000039339

Views: 105880

Downloads: 7472

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next