No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Typical Configuration Examples

CloudEngine 12800, 12800E, 8800, 7800, 6800, and 5800 Series Switches

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring the Enhanced Stack DAD Function

Example for Configuring the Enhanced Stack DAD Function

Applicable Products and Versions

This example applies to the CE6800 (except CE6880EI), CE7800, and CE8800 series switches running V200R005C10 or later versions.

Networking Requirements

In the inter-DC network shown in Figure 1-7, two core switches in each DC form a stack and function as the gateways in the DC. Access switches function as DAD relay agents for the stacks. Servers are connected to the stacks in active/standby mode. OSPF is used for inter-DC communication. OSPF routes work in active/standby mode. The two stack masters are interconnected, and the route for the link between them has a high priority.

The enhanced stack DAD function needs to be configured to implement fast convergence in case of a device or link fault.

Figure 1-7 Inter-DC networking
NOTE:

In the figure, 1/0/1 or 1/0/2 indicates an interface number, and the interface rate is 10GE. For example, 1/0/1 indicates 10GE1/0/1.

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure a stack of core switches.
  2. Configure the enhanced stack DAD function, and configure access switches as DAD relay agents.
  3. Configure gateways and routes on core switches.
  4. Configure access switches.

Procedure

  1. Configure a stack of core switches. The following example configures a stack of Spine1 and Spine2.

    1. Configure stack attributes for Spine1 and Spine2. Set a higher stack priority for Spine1 than Spine2 to make Spine1 become the stack master.

      # On Spine1, set the stack priority to 150 and stack domain ID to 10. By default, the stack member ID of a switch is 1. In this example, Spine1 retains the default stack member ID 1, removing the need to configure this parameter.

      <HUAWEI> system-view
      [~HUAWEI] sysname Spine1
      [*HUAWEI] commit
      [~Spine1] stack
      [~Spine1-stack] stack member 1 priority 150
      [*Spine1-stack] stack member 1 domain 10
      [*Spine1-stack] quit
      [*Spine1] commit

      # On Spine2, set the stack member ID to 2 and stack domain ID to 10, and retain the default stack priority 100.

      <HUAWEI> system-view
      [~HUAWEI] sysname Spine2
      [*HUAWEI] commit
      [~Spine2] stack
      [~Spine2-stack] stack member 1 domain 10
      [*Spine2-stack] stack member 1 renumber 2 inherit-config
      Warning: The stack configuration of member ID 1 will be inherited to member ID 2 after the device resets. Continue? [Y/N]: y
      [*Spine2-stack] quit
      [*Spine2] commit
    2. Configure logical stack ports.

      # On Spine1, add 10GE1/0/1 and 10GE1/0/2 to stack port 1/1.

      [~Spine1] interface stack-port 1/1
      [*Spine1-Stack-Port1/1] port member-group interface 10ge 1/0/1 to 1/0/2
      Warning: After the configuration is complete,
      1.The interface(s) (10GE1/0/1-1/0/2) will be converted to stack mode and be configured with the port crc-statistics trigger error-do
      wn command if the configuration does not exist.
      2.The interface(s) may go Error-Down (crc-statistics) because there is no shutdown configuration on the interfaces.Continue? [Y/N]: y
      [*Spine1-Stack-Port1/1] quit
      [*Spine1] commit

      # On Spine2, add 10GE1/0/1 and 10GE1/0/2 to stack port 1/1.

      [~Spine2] interface stack-port 1/1
      [*Spine2-Stack-Port1/1] port member-group interface 10ge 1/0/1 to 1/0/2
      Warning: After the configuration is complete,
      1.The interface(s) (10GE1/0/1-1/0/2) will be converted to stack mode and be configured with the port crc-statistics trigger error-do
      wn command if the configuration does not exist.
      2.The interface(s) may go Error-Down (crc-statistics) because there is no shutdown configuration on the interfaces.Continue? [Y/N]: y
      [*Spine2-Stack-Port1/1] quit
      [*Spine2] commit
    3. Save the configurations of Spine1 and Spine2, and power off them. Connect them with stack cables after powering off them. After the switches are connected with stack cables, power on them.

      You are advised to first power on the high-priority switch so that it starts first and becomes the stack master.

    4. Rename the stack as iStack1 after Spine1 and Spine2 set up a stack.

      <Spine1> system-view
      [~Spine1] sysname iStack1
      [*Spine1] commit
      [~Spine1] quit
      <Spine1> save
    5. Configure a stack of Spine3 and Spine4 according to the preceding configurations, and ensure that Spine4 functions as the stack master. Rename the stack as iStack2 after Spine3 and Spine4 set up a stack. The configuration details are not mentioned here.

  2. Configure the enhanced stack DAD function, and configure access switches as DAD relay agents.

    # On iStack1, configure the enhanced stack DAD function, configure uplink ports, and configure uplink ports as reserved ports. The configuration of iStack2 is similar to that of iStack1.

    [~iStack1] interface eth-trunk 1
    [*iStack1-Eth-Trunk1] trunkport 10ge 1/0/3 2/0/3
    [*iStack1-Eth-Trunk1] mode lacp-static
    [*iStack1-Eth-Trunk1] lacp timeout fast
    [*iStack1-Eth-Trunk1] dual-active detect mode relay  // Configure the DAD function.
    [*iStack1-Eth-Trunk1] quit
    [*iStack1] interface eth-trunk 2
    [*iStack1-Eth-Trunk2] trunkport 10ge 1/0/4 2/0/4
    [*iStack1-Eth-Trunk2] mode lacp-static
    [*iStack1-Eth-Trunk2] lacp timeout fast
    [*iStack1-Eth-Trunk2] dual-active detect mode relay
    [*iStack1-Eth-Trunk2] quit
    [*iStack1] stack
    [*iStack1-stack] stack dual-active detect enhanced  // Enable the enhanced DAD function.
    [*iStack1-stack] quit
    [*iStack1] interface 10ge 1/0/5
    [*iStack1-10GE1/0/5] uplink-port enable  // Configure the upstream interface.
    [*iStack1-10GE1/0/5] quit
    [*iStack1] interface 10ge 2/0/5
    [*iStack1-10GE2/0/5] uplink-port enable
    [*iStack1-10GE2/0/5] quit
    [*iStack1] dual-active exclude interface 10ge 1/0/5 // Configure the reserved interface.
    [*iStack1] dual-active exclude interface 10ge 2/0/5 // Configure the reserved interface.
    [*iStack1] interface meth 0/0/0
    [*iStack1-MEth0/0/0] ip address 192.168.100.10 24
    [*iStack1-MEth0/0/0] dual-active backup ip address 192.168.100.11 24 member all   // Configure the backup IP address of the management interface.
    [*iStack1] commit

    # Connect Leaf1 to iStack1 through an Eth-Trunk, and enable the DAD relay function on the Eth-Trunk. The configurations of Leaf2, Leaf3, and Leaf4 are similar to that of Leaf1.

    <HUAWEI> system-view
    [~HUAWEI] sysname Leaf1
    [*HUAWEI] commit
    [~Leaf1] interface eth-trunk 1
    [*Leaf1-Eth-Trunk1] trunkport 10ge 1/0/3 1/0/4
    [*Leaf1-Eth-Trunk1] mode lacp-static
    [*Leaf1-Eth-Trunk1] lacp timeout fast
    [*Leaf1-Eth-Trunk1] dual-active proxy
    [*Leaf1-Eth-Trunk1] quit
    [*Leaf1] commit

  3. Configure gateways and routes on core switches.

    # Configure Layer 3 gateways on iStack1. The configuration of iStack2 is similar to that of iStack1.

    [~iStack1] vlan batch 10
    [*iStack1] interface vlanif 10
    [*iStack1-Vlanif10] ip address 192.168.1.1 24
    [*iStack1-Vlanif10] quit
    [*iStack1] interface eth-trunk 1
    [*iStack1-Eth-Trunk1] port link-type trunk
    [*iStack1-Eth-Trunk1] undo port trunk allow-pass vlan 1
    [*iStack1-Eth-Trunk1] port trunk allow-pass vlan 10
    [*iStack1-Eth-Trunk1] quit
    [*iStack1] interface eth-trunk 2
    [*iStack1-Eth-Trunk2] port link-type trunk
    [*iStack1-Eth-Trunk2] undo port trunk allow-pass vlan 1
    [*iStack1-Eth-Trunk2] port trunk allow-pass vlan 10
    [*iStack1-Eth-Trunk2] quit
    [*iStack1] stp disable
    Warning: The global STP state will be changed. Continue? [Y/N]: y
    [*iStack1] commit

    # On iStack1, configure OSPF routes to iStack2. OSPF routes work in active/standby mode, and the route for the link between two stack masters has a high priority. The configuration of iStack2 is similar to that of iStack1.

    [~iStack1] interface 10ge 1/0/5
    [*iStack1-10GE1/0/5] undo portswitch
    [*iStack1-10GE1/0/5] ip address 10.1.1.1 24
    [*iStack1-10GE1/0/5] ospf cost 5  // Set the cost for an OSPF interface.
    [*iStack1-10GE1/0/5] ospf network-type p2p // Set the network type to P2P.
    [*iStack1-10GE1/0/5] ospf timer hello 1 // Set the interval for sending OSPF Hello packets. The default value is 10 for the P2P network.
    [*iStack1-10GE1/0/5] ospf timer dead 20 // Set the dead time of an OSPF neighbor. The default value is 40 for the P2P network.
    [*iStack1-10GE1/0/5] ospf suppress-flapping peer disable // Disable OSPF neighbor relationship flapping suppression.
    [*iStack1-10GE1/0/5] port-status fast-detect enable // Enable the function of quickly detecting the interface physical status change.
    [*iStack1-10GE1/0/5] quit
    [*iStack1] interface 10ge 2/0/5
    [*iStack1-10GE2/0/5] undo portswitch
    [*iStack1-10GE2/0/5] ip address 10.1.2.1 24
    [*iStack1-10GE2/0/5] ospf cost 20
    [*iStack1-10GE2/0/5] ospf network-type p2p
    [*iStack1-10GE2/0/5] ospf timer hello 1
    [*iStack1-10GE2/0/5] ospf timer dead 20
    [*iStack1-10GE2/0/5] ospf suppress-flapping peer disable
    [*iStack1-10GE2/0/5] port-status fast-detect enable
    [*iStack1-10GE2/0/5] quit
    [*iStack1] commit
    [~iStack1] acl number 2000
    [*iStack1-acl4-basic-2000] rule 5 deny source 10.1.1.0 24
    [*iStack1-acl4-basic-2000] rule 10 permit
    [*iStack1-acl4-basic-2000] quit
    [*iStack1] acl number 2001
    [*iStack1-acl4-basic-2001] rule 5 deny source 10.1.2.0 24
    [*iStack1-acl4-basic-2001] rule 10 permit
    [*iStack1-acl4-basic-2001] quit
    [*iStack1] route-policy policy1 permit node 10
    [*iStack1-route-policy] if-match acl 2000
    [*iStack1-route-policy] quit
    [*iStack1] route-policy policy2 permit node 20
    [*iStack1-route-policy] if-match acl 2001
    [*iStack1-route-policy] quit
    [*iStack1] ospf 10 router-id 10.1.1.1
    [*iStack1-ospf-10] import-route direct type 1 route-policy policy2 // Import the direct route.
    [*iStack1-ospf-10] spf-schedule-interval intelligent-timer 200 50 50  // Set the interval for OSPF route calculation.
    [*iStack1-ospf-10] lsa-originate-interval intelligent-timer 200 50 50 // Set the interval for updating OSPF LSAs.
    [*iStack1-ospf-10] lsa-arrival-interval intelligent-timer 200 50 50
    [*iStack1-ospf-10] lsa-arrival-interval suppress-flapping 0 // Set the suppression period when OSPF LSAs flap.
    [*iStack1-ospf-10] lsa-originate-interval suppress-flapping 0
    [*iStack1-ospf-10] suppress-flapping peer disable // Disable OSPF neighbor relationship flapping suppression.
    [*iStack1-ospf-10] area 0
    [*iStack1-ospf-10-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [*iStack1-ospf-10-area-0.0.0.0] quit
    [*iStack1-ospf-10] quit
    [*iStack1] ospf 20 router-id 10.1.2.1
    [*iStack1-ospf-20] import-route direct type 1 route-policy policy1
    [*iStack1-ospf-20] spf-schedule-interval intelligent-timer 200 50 50
    [*iStack1-ospf-20] lsa-originate-interval intelligent-timer 200 50 50
    [*iStack1-ospf-20] lsa-arrival-interval intelligent-timer 200 50 50
    [*iStack1-ospf-20] lsa-arrival-interval suppress-flapping 0
    [*iStack1-ospf-20] lsa-originate-interval suppress-flapping 0
    [*iStack1-ospf-20] suppress-flapping peer disable
    [*iStack1-ospf-20] area 0
    [*iStack1-ospf-20-area-0.0.0.0] network 10.1.2.0 0.0.0.255
    [*iStack1-ospf-20-area-0.0.0.0] quit
    [*iStack1-ospf-20] quit
    [*iStack1] commit

    # On iStack1, configure an ARP port protection group, and add two downlink Eth-Trunk interfaces to the ARP port protection group. The configuration of iStack2 is similar to that of iStack1.

    [~iStack1] arp port-group 1 member eth-trunk 1 eth-trunk 2
    [*iStack1] commit

  4. Configure access switches.

    # On Leaf1, configure VLANs to which uplink and downlink ports belong, and configure Monitor Link to monitor the uplink status. The configurations of Leaf2, Leaf3, and Leaf4 are similar to that of Leaf1.

    [~Leaf1] vlan batch 10
    [*Leaf1] interface 10ge 1/0/1
    [*Leaf1-10GE1/0/1] port default vlan 10
    [*Leaf1-10GE1/0/1] quit
    [*Leaf1] interface 10ge 1/0/2
    [*Leaf1-10GE1/0/2] port default vlan 10
    [*Leaf1-10GE1/0/2] quit
    [*Leaf1] interface eth-trunk 1
    [*Leaf1-Eth-Trunk1] port link-type trunk
    [*Leaf1-Eth-Trunk1] undo port trunk allow-pass vlan 1
    [*Leaf1-Eth-Trunk1] port trunk allow-pass vlan 10
    [*Leaf1-Eth-Trunk1] quit
    [*Leaf1] stp disable
    Warning: The global STP state will be changed. Continue? [Y/N]: y
    [*Leaf1] monitor-link group 1
    [*Leaf1-mtlk-group1] port 10ge 1/0/3 uplink
    [*Leaf1-mtlk-group1] port 10ge 1/0/4 uplink
    [*Leaf1-mtlk-group1] port 10ge 1/0/1 downlink 1
    [*Leaf1-mtlk-group1] port 10ge 1/0/2 downlink 1
    [*Leaf1-mtlk-group1] timer recover-time 0
    [*Leaf1-mtlk-group1] quit
    [*Leaf1] commit

Verifying the Configuration

On iStack1 or iStack2, check whether a stack has been set up successfully. The display on iStack1 is used as an example.

[~iStack1] display stack
<HUAWEI> display stack
--------------------------------------------------------------------------------
MemberID Role     MAC              Priority   DeviceType         Description
--------------------------------------------------------------------------------
 1       Master   006c-2003-0740   150        CE6850-48S6Q-HI
 2       Standby  006c-2003-0780   100        CE6850-48S6Q-HI
--------------------------------------------------------------------------------

On iStack1 or iStack2, check whether there are routes to the peer end. The display on iStack1 is used as an example.

[~iStack1] display ip routing-table
Proto: Protocol        Pre: Preference
Route Flags: R - relay, D - download to fib, T - to vpn-instance, B - black hole route
------------------------------------------------------------------------------
Routing Table : _public_
         Destinations : 14       Routes : 14

Destination/Mask    Proto   Pre  Cost        Flags NextHop         Interface

       10.1.1.0/24  Direct  0    0             D   10.1.1.1        10GE1/0/5
       10.1.1.1/32  Direct  0    0             D   127.0.0.1       10GE1/0/5
     10.1.1.255/32  Direct  0    0             D   127.0.0.1       10GE1/0/5
       10.1.2.0/24  Direct  0    0             D   10.1.2.1        10GE2/0/5
       10.1.2.1/32  Direct  0    0             D   127.0.0.1       10GE2/0/5
     10.1.2.255/32  Direct  0    0             D   127.0.0.1       10GE2/0/5
      127.0.0.0/8   Direct  0    0             D   127.0.0.1       InLoopBack0
      127.0.0.1/32  Direct  0    0             D   127.0.0.1       InLoopBack0
127.255.255.255/32  Direct  0    0             D   127.0.0.1       InLoopBack0
    192.168.1.0/24  Direct  0    0             D   192.168.1.1     Vlanif10
    192.168.1.1/32  Direct  0    0             D   127.0.0.1       Vlanif10
  192.168.1.255/32  Direct  0    0             D   127.0.0.1       Vlanif10
    192.168.2.0/24  O_ASE   150  6             D   10.1.1.2        10GE1/0/5
255.255.255.255/32  Direct  0    0             D   127.0.0.1       InLoopBack0

Shut down the primary link between iStack1 and iStack2, and check routes to determine whether the backup link takes effect.

[~iStack1] display ip routing-table
Proto: Protocol        Pre: Preference
Route Flags: R - relay, D - download to fib, T - to vpn-instance, B - black hole route
------------------------------------------------------------------------------
Routing Table : _public_
         Destinations : 11       Routes : 11

Destination/Mask    Proto   Pre  Cost        Flags NextHop         Interface

       10.1.2.0/24  Direct  0    0             D   10.1.2.1        10GE2/0/5
       10.1.2.1/32  Direct  0    0             D   127.0.0.1       10GE2/0/5
     10.1.2.255/32  Direct  0    0             D   127.0.0.1       10GE2/0/5
      127.0.0.0/8   Direct  0    0             D   127.0.0.1       InLoopBack0
      127.0.0.1/32  Direct  0    0             D   127.0.0.1       InLoopBack0
127.255.255.255/32  Direct  0    0             D   127.0.0.1       InLoopBack0
    192.168.1.0/24  Direct  0    0             D   192.168.1.1     Vlanif10
    192.168.1.1/32  Direct  0    0             D   127.0.0.1       Vlanif10
  192.168.1.255/32  Direct  0    0             D   127.0.0.1       Vlanif10
    192.168.2.0/24  O_ASE   150  21            D   10.1.2.2        10GE2/0/5
255.255.255.255/32  Direct  0    0             D   127.0.0.1       InLoopBack0

After the preceding configurations are complete, check whether servers in the two DCs can ping each other successfully.

Configuration Files

  • Spine1 configuration file

    #
    sysname Spine1
    #
    vlan batch 10
    #
    stp disable
    #
    dual-active exclude interface 10GE1/0/5
    dual-active exclude interface 10GE2/0/5
    # 
    acl number 2000
     rule 5 deny source 10.1.1.0 0.0.0.255
     rule 10 permit
    #
    acl number 2001
     rule 5 deny source 10.1.2.0 0.0.0.255
     rule 10 permit
    #
    stack
     #
     stack member 1 domain 10
     stack member 1 priority 150
     #
     stack member 2 domain 10
     #
     stack dual-active detect enhanced
    #
    interface Vlanif10
     ip address 192.168.1.1 255.255.255.0
    #
    interface MEth0/0/0
     ip address 192.168.100.10 255.255.255.0
     dual-active backup ip address 192.168.100.11 255.255.255.0 member 1
     dual-active backup ip address 192.168.100.11 255.255.255.0 member 2
    #
    interface Eth-Trunk1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10
     mode lacp-static
     lacp timeout fast
     dual-active detect mode relay
    #
    interface Eth-Trunk2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10
     mode lacp-static
     lacp timeout fast
     dual-active detect mode relay
    #
    interface Stack-Port1/1
    #
    interface Stack-Port2/1
    #
    interface 10GE1/0/1
     port mode stack 
     stack-port 1/1
     port crc-statistics trigger error-down
    #
    interface 10GE1/0/2
     port mode stack 
     stack-port 1/1
     port crc-statistics trigger error-down
    #
    interface 10GE1/0/3
     eth-trunk 1
    #
    interface 10GE1/0/4
     eth-trunk 2
    #
    interface 10GE1/0/5
     undo portswitch
     ip address 10.1.1.1 255.255.255.0
     ospf cost 5
     ospf network-type p2p
     ospf timer hello 1
     ospf timer dead 20
     ospf suppress-flapping peer disable
     uplink-port enable
     port-status fast-detect enable
    #
    interface 10GE2/0/1
     port mode stack 
     stack-port 2/1
     port crc-statistics trigger error-down
    #
    interface 10GE2/0/2
     port mode stack 
     stack-port 2/1
     port crc-statistics trigger error-down
    #
    interface 10GE2/0/3
     eth-trunk 1
    #
    interface 10GE2/0/4
     eth-trunk 2
    #
    interface 10GE2/0/5
     undo portswitch
     ip address 10.1.2.1 255.255.255.0
     ospf cost 20
     ospf network-type p2p
     ospf timer hello 1
     ospf timer dead 20
     ospf suppress-flapping peer disable
     uplink-port enable
     port-status fast-detect enable
    #
    arp port-group 1 member Eth-Trunk1 Eth-Trunk2
    #
    ospf 10 router-id 10.1.1.1
     import-route direct type 1 route-policy policy2
     spf-schedule-interval intelligent-timer 200 50 50
     lsa-originate-interval intelligent-timer 200 50 50
     lsa-arrival-interval intelligent-timer 200 50 50
     lsa-arrival-interval suppress-flapping 0
     lsa-originate-interval suppress-flapping 0
     suppress-flapping peer disable
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    ospf 20 router-id 10.1.2.1
     import-route direct type 1 route-policy policy1
     spf-schedule-interval intelligent-timer 200 50 50
     lsa-originate-interval intelligent-timer 200 50 50
     lsa-arrival-interval intelligent-timer 200 50 50
     lsa-arrival-interval suppress-flapping 0
     lsa-originate-interval suppress-flapping 0
     suppress-flapping peer disable
     area 0.0.0.0
      network 10.1.2.0 0.0.0.255
    #
    route-policy policy1 permit node 10
     if-match acl 2000
    #
    route-policy policy2 permit node 20
     if-match acl 2001
    #
    return
    
  • Spine2 configuration file

    #
    sysname Spine2
    #
    vlan batch 20
    #
    stp disable
    #
    dual-active exclude interface 10GE1/0/5
    dual-active exclude interface 10GE2/0/5
    # 
    acl number 2000
     rule 5 deny source 10.1.1.0 0.0.0.255
     rule 10 permit
    #
    acl number 2001
     rule 5 deny source 10.1.2.0 0.0.0.255
     rule 10 permit
    #
    stack
     #
     stack member 1 domain 10
     stack member 1 priority 150
     #
     stack member 2 domain 10
     #
     stack dual-active detect enhanced
    #
    interface Vlanif20
     ip address 192.168.2.1 255.255.255.0
    #
    interface MEth0/0/0
     ip address 192.168.200.10 255.255.255.0
     dual-active backup ip address 192.168.200.11 255.255.255.0 member 1
     dual-active backup ip address 192.168.200.11 255.255.255.0 member 2
    #
    interface Eth-Trunk1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20
     mode lacp-static
     lacp timeout fast
     dual-active detect mode relay
    #
    interface Eth-Trunk2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20
     mode lacp-static
     lacp timeout fast
     dual-active detect mode relay
    #
    interface Stack-Port1/1
    #
    interface Stack-Port2/1
    #
    interface 10GE1/0/1
     port mode stack 
     stack-port 1/1
     port crc-statistics trigger error-down
    #
    interface 10GE1/0/2
     port mode stack 
     stack-port 1/1
     port crc-statistics trigger error-down
    #
    interface 10GE1/0/3
     eth-trunk 1
    #
    interface 10GE1/0/4
     eth-trunk 2
    #
    interface 10GE1/0/5
     undo portswitch
     ip address 10.1.1.2 255.255.255.0
     ospf cost 5
     ospf network-type p2p
     ospf timer hello 1
     ospf timer dead 20
     ospf suppress-flapping peer disable
     uplink-port enable
     port-status fast-detect enable
    #
    interface 10GE2/0/1
     port mode stack 
     stack-port 2/1
     port crc-statistics trigger error-down
    #
    interface 10GE2/0/2
     port mode stack 
     stack-port 2/1
     port crc-statistics trigger error-down
    #
    interface 10GE2/0/3
     eth-trunk 1
    #
    interface 10GE2/0/4
     eth-trunk 2
    #
    interface 10GE2/0/5
     undo portswitch
     ip address 10.1.2.2 255.255.255.0
     ospf cost 20
     ospf network-type p2p
     ospf timer hello 1
     ospf timer dead 20
     ospf suppress-flapping peer disable
     uplink-port enable
     port-status fast-detect enable
    #
    arp port-group 1 member Eth-Trunk1 Eth-Trunk2
    #
    ospf 10 router-id 10.1.1.2
     import-route direct type 1 route-policy policy2
     spf-schedule-interval intelligent-timer 200 50 50
     lsa-originate-interval intelligent-timer 200 50 50
     lsa-arrival-interval intelligent-timer 200 50 50
     lsa-arrival-interval suppress-flapping 0
     lsa-originate-interval suppress-flapping 0
     suppress-flapping peer disable
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    ospf 20 router-id 10.1.2.2
     import-route direct type 1 route-policy policy1
     spf-schedule-interval intelligent-timer 200 50 50
     lsa-originate-interval intelligent-timer 200 50 50
     lsa-arrival-interval intelligent-timer 200 50 50
     lsa-arrival-interval suppress-flapping 0
     lsa-originate-interval suppress-flapping 0
     suppress-flapping peer disable
     area 0.0.0.0
      network 10.1.2.0 0.0.0.255
    #
    route-policy policy1 permit node 10
     if-match acl 2000
    #
    route-policy policy2 permit node 20
     if-match acl 2001
    #
    return
    
  • Leaf1 configuration file

    sysname Leaf1
    #
    vlan batch 10
    #
    stp disable
    #
    interface Eth-Trunk1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10
     mode lacp-static
     lacp timeout fast
     dual-active proxy
    #
    interface 10GE1/0/1
     port default vlan 10
    #
    interface 10GE1/0/2
     port default vlan 10
    #
    interface 10GE1/0/3
     eth-trunk 1
    #
    interface 10GE1/0/4
     eth-trunk 1
    #
    monitor-link group 1
     port 10GE1/0/3 uplink
     port 10GE1/0/4 uplink
     port 10GE1/0/1 downlink 1
     port 10GE1/0/2 downlink 2
     timer recover-time 0
    #
    return
  • Leaf2 configuration file

    sysname Leaf2
    #
    vlan batch 10
    #
    stp disable
    #
    interface Eth-Trunk1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 10
     mode lacp-static
     lacp timeout fast
     dual-active proxy
    #
    interface 10GE1/0/1
     port default vlan 10
    #
    interface 10GE1/0/2
     port default vlan 10
    #
    interface 10GE1/0/3
     eth-trunk 1
    #
    interface 10GE1/0/4
     eth-trunk 1
    #
    monitor-link group 1
     port 10GE1/0/3 uplink
     port 10GE1/0/4 uplink
     port 10GE1/0/1 downlink 1
     port 10GE1/0/2 downlink 2
     timer recover-time 0
    #
    return
  • Leaf3 configuration file

    sysname Leaf3
    #
    vlan batch 20
    #
    stp disable
    #
    interface Eth-Trunk1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20
     mode lacp-static
     lacp timeout fast
     dual-active proxy
    #
    interface 10GE1/0/1
     port default vlan 20
    #
    interface 10GE1/0/2
     port default vlan 20
    #
    interface 10GE1/0/3
     eth-trunk 1
    #
    interface 10GE1/0/4
     eth-trunk 1
    #
    monitor-link group 1
     port 10GE1/0/3 uplink
     port 10GE1/0/4 uplink
     port 10GE1/0/1 downlink 1
     port 10GE1/0/2 downlink 2
     timer recover-time 0
    #
    return
  • Leaf4 configuration file

    sysname Leaf4
    #
    vlan batch 20
    #
    stp disable
    #
    interface Eth-Trunk1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 20
     mode lacp-static
     lacp timeout fast
     dual-active proxy
    #
    interface 10GE1/0/1
     port default vlan 20
    #
    interface 10GE1/0/2
     port default vlan 20
    #
    interface 10GE1/0/3
     eth-trunk 1
    #
    interface 10GE1/0/4
     eth-trunk 1
    #
    monitor-link group 1
     port 10GE1/0/3 uplink
     port 10GE1/0/4 uplink
     port 10GE1/0/1 downlink 1
     port 10GE1/0/2 downlink 2
     timer recover-time 0
    #
    return
Download
Updated: 2019-04-03

Document ID: EDOC1000039339

Views: 117854

Downloads: 7532

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next