No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Typical Configuration Examples

CloudEngine 12800, 12800E, 8800, 7800, 6800, and 5800 Series Switches

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuring Inter-AS Segment VXLAN to Implement Layer 3 Interworking

Configuring Inter-AS Segment VXLAN to Implement Layer 3 Interworking

Applicable Products and Versions

This example applies to the CE12800, CE12800E, CE8800, CE7800, CE5880EI, and CE6800 (excluding CE6850EI, CE6810EI, and CE6810LI) V200R002C50 or later.

Networking Requirements

In Figure 2-49, DC-A and DC-B reside in different BGP ASs. To allow intra-DC VM communication (VMa1 and VMa2 in DC-A, and VMb1 and VMb2 in DC-B), configure BGP EVPN on the devices in the DCs to create VXLAN tunnels between distributed gateways. To allow VMs in different DCs (for example, VMa1 and VMb2) to communicate with each other, configure BGP EVPN on Leaf2 and Leaf3 to create another VXLAN tunnel. In this way, segment VXLAN tunnels are established to implement DC interconnection (DCI).

Figure 2-49 Inter-AS segment VXLAN
Table 2-11 Interface IP addresses

Device Name

Interface Name

IP Address

Device Name

Interface Name

IP Address

Device1

10GE1/0/1

192.168.50.1/24

Device2

10GE1/0/1

192.168.60.1/24

10GE1/0/2

192.168.1.1/24

10GE1/0/2

192.168.1.2/24

Loopback1

1.1.1.1/32

Loopback1

2.2.2.2/32

Spine1

10GE1/0/1

192.168.10.1/24

Spine2

10GE1/0/1

192.168.30.1/24

10GE1/0/2

192.168.20.1/24

10GE1/0/2

192.168.40.1/24

Loopback1

3.3.3.3/32

Loopback1

4.4.4.4/32

Leaf1

10GE1/0/1

192.168.10.2/24

Leaf4

10GE1/0/1

192.168.40.2/24

10GE1/0/2

-

10GE1/0/2

-

Loopback1

5.5.5.5/32

Loopback1

8.8.8.8/32

Leaf2

10GE1/0/1

192.168.20.2/24

Leaf3

10GE1/0/1

192.168.30.2/24

10GE1/0/2

-

10GE1/0/2

-

10GE1/0/3

192.168.50.2/24

10GE1/0/3

192.168.60.2/24

Loopback1

6.6.6.6/32

Loopback1

7.7.7.7/32

Configuration Roadmap

The configuration roadmap is as follows:

  1. Assign an IP address to each interface.

  2. Configure a routing protocol to ensure route reachability between nodes.

  3. Configure BGP EVPN on Leaf1 and Leaf2 in DC-A and Leaf3 and Leaf4 in DC-B to create VXLAN tunnels between distributed gateways.

  4. Configure BGP EVPN on DC edge nodes Leaf2 and Leaf3 to create a VXLAN tunnel between DCs.

Data Preparation

To complete the configuration, you need the following data:

  • VLAN IDs of the VMs

  • BD IDs

  • VXLAN network identifiers (VNIs) in BDs and VNIs in VPN instances

Procedure

  1. Assign an IP address to each interface (including each loopback interface) on each node.

    For configuration details, see Configuration Files in this section.

  2. Configure a routing protocol.

    Configure an IGP within a data center or configure BGP between data centers. OSPF is used in this example.

    For configuration details, see Configuration File in this section.

  3. Configure the VXLAN tunnel mode and enable the VXLAN ACL extension function. (This step only needs to be performed on the CE12800, CE6870EI, and CE6875EI.)

    # Configure Leaf1. The configurations on Leaf2, Leaf3 and Leaf4 are similar to that on Leaf1, and is not mentioned here.

    [~Leaf1] ip tunnel mode vxlan
    [*Leaf1] assign forward nvo3 acl extend enable
    [*Leaf1] commit
    NOTE:

    After modifying the VXLAN tunnel mode or enabling the VXLAN ACL extension function, you need to save the configuration and restart the device to make the configuration take effect. You can restart the device immediately or after completing all the configurations.

  4. Configure BGP EVPN on Leaf1 and Leaf2 in DC-A and Leaf3 and Leaf4 in DC-B to create VXLAN tunnels between distributed gateways.
    1. Configure a service access point on leaf nodes.

      # Configure Leaf1.

      [~Leaf1] bridge-domain 10
      [*Leaf1-bd10] quit
      [*Leaf1] interface 10GE1/0/2.1 mode l2
      [*Leaf1-10GE1/0/2.1] encapsulation dot1q vid 10
      [*Leaf1-10GE1/0/2.1] bridge-domain 10
      [*Leaf1-10GE1/0/2.1] quit
      [*Leaf1] commit

      The configurations of Leaf2, Leaf3, and Leaf4 are similar to the configurations of Leaf1. For configuration details, see Configuration Files in this section.

    2. Configure EVPN as the VXLAN control plane of leaf nodes.

      # Configure Leaf1.

      [~Leaf1] evpn-overlay enable
      [*Leaf1] commit

      The configurations of Leaf2, Leaf3, and Leaf4 are similar to the configurations of Leaf1. For configuration details, see Configuration Files in this section.

    3. Configure an IBGP EVPN peer relationship between Leaf1 and Leaf2 in DC-A and between Leaf3 and Leaf4 in DC-B.

      # Configure Leaf1.

      [~Leaf1] bgp 100 instance evpn1
      [*Leaf1-bgp-instance-evpn1] peer 6.6.6.6 as-number 100
      [*Leaf1-bgp-instance-evpn1] peer 6.6.6.6 connect-interface LoopBack 1
      [*Leaf1-bgp-instance-evpn1] l2vpn-family evpn
      [*Leaf1-bgp-instance-evpn1-af-evpn] peer 6.6.6.6 enable
      [*Leaf1-bgp-instance-evpn1-af-evpn] quit
      [*Leaf1-bgp-instance-evpn1] quit
      [*Leaf1] commit

      The configurations of Leaf2, Leaf3, and Leaf4 are similar to the configurations of Leaf1. For configuration details, see Configuration Files in this section.

    4. Configure VPN instances and EVPN instances on leaf nodes.

      # Configure Leaf1.

      [~Leaf1] ip vpn-instance vpn1
      [*Leaf1-vpn-instance-vpn1] vxlan vni 5010
      [*Leaf1-vpn-instance-vpn1] ipv4-family
      [*Leaf1-vpn-instance-vpn1-af-ipv4] route-distinguisher 11:11
      [*Leaf1-vpn-instance-vpn1-af-ipv4] vpn-target 1:1
      [*Leaf1-vpn-instance-vpn1-af-ipv4] vpn-target 11:1 evpn
      [*Leaf1-vpn-instance-vpn1-af-ipv4] quit
      [*Leaf1-vpn-instance-vpn1] quit
      [*Leaf1] bridge-domain 10
      [*Leaf1-bd10] vxlan vni 10
      [*Leaf1-bd10] evpn
      [*Leaf1-bd10-evpn] route-distinguisher 10:1
      [*Leaf1-bd10-evpn] vpn-target 10:1
      [*Leaf1-bd10-evpn] vpn-target 11:1 export-extcommunity
      [*Leaf1-bd10-evpn] quit
      [*Leaf1-bd10] quit
      [*Leaf1] commit

      The configurations of Leaf2, Leaf3, and Leaf4 are similar to the configurations of Leaf1. For configuration details, see Configuration Files in this section.

    5. Configure an ingress replication list on leaf nodes.

      # Configure Leaf1.

      [~Leaf1] interface nve 1
      [*Leaf1-Nve1] source 5.5.5.5
      [*Leaf1-Nve1] vni 10 head-end peer-list protocol bgp
      [*Leaf1-Nve1] quit
      [*Leaf1] commit

      The configurations of Leaf2, Leaf3, and Leaf4 are similar to the configurations of Leaf1. For configuration details, see Configuration Files in this section.

    6. Configure leaf nodes as Layer 3 VXLAN gateways.

      # Configure a service loopback interface on Leaf1. The configurations on Leaf2, Leaf3 and Leaf4 are similar to that on Leaf1, and is not mentioned here. (This step only needs to be performed on the CE6850HI, CE6850U-HI, CE6851HI, CE6860EI, CE7850EI, CE8850EI, and CE8860EI.)
      [~Leaf1] interface eth-trunk 2
      [*Leaf1-Eth-Trunk2] service type tunnel
      [*Leaf1-Eth-Trunk2] quit
      [*Leaf1] interface 10ge 1/0/5
      [*Leaf1-10GE1/0/5] eth-trunk 2
      [*Leaf1-10GE1/0/5] quit
      [*Leaf1] commit
      NOTE:
      • The member interfaces must be idle physical interfaces that do not transmit services. There is no requirement on the interface status.
      • Ensure that the Eth-Trunk bandwidth is at least twice the bandwidth required for transmitting Layer 3 VXLAN gateway traffic. For example, if traffic is sent from users to the gateway across the VXLAN network at a rate of 10 Gbit/s, add two 10GE interface to the Eth-Trunk that you want to use as the service loopback interface.

      # Configure Leaf1.

      [~Leaf1] interface vbdif10
      [*Leaf1-Vbdif10] ip binding vpn-instance vpn1
      [*Leaf1-Vbdif10] ip address 10.10.1.1 24
      [*Leaf1-Vbdif10] vxlan anycast-gateway enable
      [*Leaf1-Vbdif10] arp collect host enable
      [*Leaf1-Vbdif10] quit
      [*Leaf1] commit

      The configurations of Leaf2, Leaf3, and Leaf4 are similar to the configurations of Leaf1. For configuration details, see Configuration Files in this section.

    7. Configure IRB route advertisement on leaf nodes.

      # Configure Leaf1.

      [~Leaf1] bgp 100 instance evpn1
      [~Leaf1-bgp-instance-evpn1] l2vpn-family evpn
      [~Leaf1-bgp-instance-evpn1-af-evpn] peer 6.6.6.6 advertise irb
      [*Leaf1-bgp-instance-evpn1-af-evpn] quit
      [*Leaf1-bgp-instance-evpn1] quit
      [*Leaf1] commit

      # Configure Leaf2.

      [~Leaf2] bgp 100 instance evpn1
      [~Leaf2-bgp-instance-evpn1] l2vpn-family evpn
      [~Leaf2-bgp-instance-evpn1-af-evpn] peer 5.5.5.5 advertise irb
      [*Leaf2-bgp-instance-evpn1-af-evpn] quit
      [*Leaf2-bgp-instance-evpn1] quit
      [*Leaf2] commit

      The configurations of Leaf4 are similar to the configurations of Leaf1, and those of Leaf3 are similar to the configurations of Leaf2. For configuration details, see Configuration Files in this section.

      After the configurations are complete, run the display vxlan tunnel command on leaf nodes to check VXLAN tunnel information. The following example uses the command output on Leaf1. The command output shows that the VXLAN tunnel is Up.
      [~Leaf1] display vxlan tunnel
      Number of vxlan tunnel : 1
      Tunnel ID   Source                Destination           State  Type     Uptime                                                      
      -----------------------------------------------------------------------------------
      4026531841  5.5.5.5               6.6.6.6               up     dynamic  0035h21m

  5. Configure BGP EVPN on Leaf2 and Leaf3 to create a VXLAN tunnel.
    1. Configure an EBGP EVPN peer relationship between Leaf2 and Leaf3.

      NOTE:

      As VPN and EVPN instances have been configured on Leaf2 and Leaf3, you only need to configure an EBGP EVPN peer relationship between Leaf2 and Leaf3 to ensure IP route reachability. Ensure that VPN and EVPN instances on Leaf2 and Leaf3 have matching RTs.

      # Configure Leaf2.

      [~Leaf2] bgp 100 instance evpn1
      [~Leaf2-bgp-instance-evpn1] peer 7.7.7.7 as-number 200
      [*Leaf2-bgp-instance-evpn1] peer 7.7.7.7 connect-interface LoopBack 1
      [*Leaf2-bgp-instance-evpn1] peer 7.7.7.7 ebgp-max-hop 255
      [*Leaf2-bgp-instance-evpn1] l2vpn-family evpn
      [*Leaf2-bgp-instance-evpn1-af-evpn] peer 7.7.7.7 enable
      [*Leaf2-bgp-instance-evpn1-af-evpn] peer 7.7.7.7 advertise irb
      [*Leaf2-bgp-instance-evpn1-af-evpn] quit
      [*Leaf2-bgp-instance-evpn1] quit
      [*Leaf2] commit

      # Configure Leaf3.

      [~Leaf3] bgp 200 instance evpn1
      [~Leaf3-bgp-instance-evpn1] peer 6.6.6.6 as-number 100
      [*Leaf3-bgp-instance-evpn1] peer 6.6.6.6 connect-interface LoopBack 1
      [*Leaf3-bgp-instance-evpn1] peer 6.6.6.6 ebgp-max-hop 255
      [*Leaf3-bgp-instance-evpn1] l2vpn-family evpn
      [*Leaf3-bgp-instance-evpn1-af-evpn] peer 6.6.6.6 enable
      [*Leaf3-bgp-instance-evpn1-af-evpn] peer 6.6.6.6 advertise irb
      [*Leaf3-bgp-instance-evpn1-af-evpn] quit
      [*Leaf3-bgp-instance-evpn1] quit
      [*Leaf3] commit

    2. Configure the regeneration of IRB routes and IP prefix routes in EVPN routing tables.

      # Configure Leaf2.

      [~Leaf2] bgp 100 instance evpn1
      [~Leaf2-bgp-instance-evpn1] l2vpn-family evpn
      [~Leaf2-bgp-instance-evpn1-af-evpn] peer 5.5.5.5 import reoriginate
      [*Leaf2-bgp-instance-evpn1-af-evpn] peer 5.5.5.5 advertise route-reoriginated evpn mac-ip
      [*Leaf2-bgp-instance-evpn1-af-evpn] peer 5.5.5.5 advertise route-reoriginated evpn ip
      [*Leaf2-bgp-instance-evpn1-af-evpn] peer 7.7.7.7 import reoriginate
      [*Leaf2-bgp-instance-evpn1-af-evpn] peer 7.7.7.7 advertise route-reoriginated evpn mac-ip
      [*Leaf2-bgp-instance-evpn1-af-evpn] peer 7.7.7.7 advertise route-reoriginated evpn ip
      [*Leaf2-bgp-instance-evpn1-af-evpn] quit
      [*Leaf2-bgp-instance-evpn1] quit
      [*Leaf2] commit

      # Configure Leaf3.

      [~Leaf3] bgp 200 instance evpn1
      [~Leaf3-bgp-instance-evpn1] l2vpn-family evpn
      [~Leaf3-bgp-instance-evpn1-af-evpn] peer 8.8.8.8 import reoriginate
      [*Leaf3-bgp-instance-evpn1-af-evpn] peer 8.8.8.8 advertise route-reoriginated evpn mac-ip
      [*Leaf3-bgp-instance-evpn1-af-evpn] peer 8.8.8.8 advertise route-reoriginated evpn ip
      [*Leaf3-bgp-instance-evpn1-af-evpn] peer 6.6.6.6 import reoriginate
      [*Leaf3-bgp-instance-evpn1-af-evpn] peer 6.6.6.6 advertise route-reoriginated evpn mac-ip
      [*Leaf3-bgp-instance-evpn1-af-evpn] peer 6.6.6.6 advertise route-reoriginated evpn ip
      [*Leaf3-bgp-instance-evpn1-af-evpn] quit
      [*Leaf3-bgp-instance-evpn1] quit
      [*Leaf3] commit

Verifying the Configuration

Run the display vxlan tunnel command on leaf nodes to check VXLAN tunnel information. The following example uses the command output on Leaf2. The command output shows that the VXLAN tunnels are Up.

[~Leaf2] display vxlan tunnel
Number of vxlan tunnel : 2
Tunnel ID   Source                Destination           State  Type     Uptime
----------------------------------------------------------------------------------- 
4026531841  6.6.6.6               5.5.5.5               up     dynamic  0035h21m 
4026531842  6.6.6.6               7.7.7.7               up     dynamic  0035h25m

After the configurations are complete, VMa1 and VMb2 can communicate with each other.

Configuration File

The following example is the CE12800 configuration file.

  • Spine1 configuration file

    #
    sysname Spine1
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.10.1 255.255.255.0
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 192.168.20.1 255.255.255.0
    #
    interface LoopBack1
     ip address 3.3.3.3 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.3 0.0.0.0
      network 192.168.10.0 0.0.0.255
      network 192.168.20.0 0.0.0.255
    #
    return 
  • Leaf1 configuration file

    #
    sysname Leaf1
    #
    assign forward nvo3 acl extend enable
    #
    evpn-overlay enable
    #
    ip vpn-instance vpn1
     ipv4-family
      route-distinguisher 11:11
      vpn-target 1:1 export-extcommunity
      vpn-target 11:1 export-extcommunity evpn
      vpn-target 1:1 import-extcommunity
      vpn-target 11:1 import-extcommunity evpn
     vxlan vni 5010
    #
    bridge-domain 10
     vxlan vni 10
     evpn
      route-distinguisher 10:1
      vpn-target 10:1 export-extcommunity
      vpn-target 11:1 export-extcommunity
      vpn-target 10:1 import-extcommunity
    #
    interface Vbdif10
     ip binding vpn-instance vpn1
     ip address 10.10.1.1 255.255.255.0
     vxlan anycast-gateway enable
     arp collect host enable
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.10.2 255.255.255.0
    #
    interface 10GE1/0/2.1 mode l2
     encapsulation dot1q vid 10
     bridge-domain 10
    #
    interface LoopBack1
     ip address 5.5.5.5 255.255.255.255
    #
    interface Nve1
     source 5.5.5.5
     vni 10 head-end peer-list protocol bgp
    #
    bgp 100 instance evpn1
     peer 6.6.6.6 as-number 100
     peer 6.6.6.6 connect-interface LoopBack1
     #
     l2vpn-family evpn
      policy vpn-target
      peer 6.6.6.6 enable
      peer 6.6.6.6 advertise irb
    #
    ospf 1
     area 0.0.0.0
      network 5.5.5.5 0.0.0.0
      network 192.168.10.0 0.0.0.255
    #
    return    
  • Leaf2 configuration file

    #
    sysname Leaf2
    #
    assign forward nvo3 acl extend enable
    #
    evpn-overlay enable
    #
    ip vpn-instance vpn1
     ipv4-family
      route-distinguisher 11:12
      vpn-target 1:2 export-extcommunity
      vpn-target 11:1 export-extcommunity evpn
      vpn-target 33:3 export-extcommunity evpn
      vpn-target 1:2 import-extcommunity
      vpn-target 11:1 import-extcommunity evpn
      vpn-target 33:3 import-extcommunity evpn
     vxlan vni 5010
    #
    bridge-domain 20
     vxlan vni 20
     evpn
      route-distinguisher 10:2
      vpn-target 20:1 export-extcommunity
      vpn-target 11:1 export-extcommunity
      vpn-target 33:3 export-extcommunity
      vpn-target 20:1 import-extcommunity
    #
    interface Vbdif20
     ip binding vpn-instance vpn1
     ip address 10.20.1.1 255.255.255.0
     vxlan anycast-gateway enable
     arp collect host enable
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.20.2 255.255.255.0
    #
    interface 10GE1/0/2.1 mode l2
     encapsulation dot1q vid 20
     bridge-domain 20
    #
    interface 10GE1/0/3
     undo portswitch
     ip address 192.168.50.2 255.255.255.0
    #
    interface LoopBack1
     ip address 6.6.6.6 255.255.255.255
    #
    interface Nve1
     source 6.6.6.6
     vni 20 head-end peer-list protocol bgp
    #
    bgp 20
     peer 192.168.50.1 as-number 10
     #
     ipv4-family unicast
      network 6.6.6.6 255.255.255.255
      peer 192.168.50.1 enable
    #
    bgp 100 instance evpn1
     peer 5.5.5.5 as-number 100
     peer 5.5.5.5 connect-interface LoopBack1
     peer 7.7.7.7 as-number 200
     peer 7.7.7.7 ebgp-max-hop 255
     peer 7.7.7.7 connect-interface LoopBack1
     #
     l2vpn-family evpn
      policy vpn-target
      peer 5.5.5.5 enable
      peer 5.5.5.5 advertise irb
      peer 5.5.5.5 import reoriginate
      peer 5.5.5.5 advertise route-reoriginated evpn mac-ip
      peer 5.5.5.5 advertise route-reoriginated evpn ip
      peer 7.7.7.7 enable
      peer 7.7.7.7 advertise irb
      peer 7.7.7.7 import reoriginate
      peer 7.7.7.7 advertise route-reoriginated evpn mac-ip
      peer 7.7.7.7 advertise route-reoriginated evpn ip
    #
    ospf 1
     area 0.0.0.0
      network 6.6.6.6 0.0.0.0
      network 192.168.20.0 0.0.0.255
    #
    return
  • Spine2 configuration file

    #
    sysname Spine2
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.30.1 255.255.255.0
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 192.168.40.1 255.255.255.0
    #
    interface LoopBack1
     ip address 4.4.4.4 255.255.255.255
    #
    ospf 1
     area 0.0.0.0
      network 4.4.4.4 0.0.0.0
      network 192.168.30.0 0.0.0.255
      network 192.168.40.0 0.0.0.255
    #
    return
  • Leaf3 configuration file

    #
    sysname Leaf3
    #
    assign forward nvo3 acl extend enable
    #
    evpn-overlay enable
    #
    ip vpn-instance vpn1
     ipv4-family
      route-distinguisher 11:13
      vpn-target 1:3 export-extcommunity
      vpn-target 22:2 export-extcommunity evpn
      vpn-target 33:3 export-extcommunity evpn
      vpn-target 1:3 import-extcommunity
      vpn-target 22:2 import-extcommunity evpn
      vpn-target 33:3 import-extcommunity evpn
     vxlan vni 5010
    #
    bridge-domain 10
     vxlan vni 10
     evpn
      route-distinguisher 10:3
      vpn-target 30:1 export-extcommunity
      vpn-target 22:2 export-extcommunity
      vpn-target 33:3 export-extcommunity
      vpn-target 30:1 import-extcommunity
    #
    interface Vbdif10
     ip binding vpn-instance vpn1
     ip address 10.30.1.1 255.255.255.0
     vxlan anycast-gateway enable
     arp collect host enable
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.30.2 255.255.255.0
    #
    interface 10GE1/0/2.1 mode l2
     encapsulation dot1q vid 10
     bridge-domain 10
    #
    interface 10GE1/0/3
     undo portswitch
     ip address 192.168.60.2 255.255.255.0
    #
    interface LoopBack1
     ip address 7.7.7.7 255.255.255.255
    #
    interface Nve1
     source 7.7.7.7
     vni 10 head-end peer-list protocol bgp
    #
    bgp 30
     peer 192.168.60.1 as-number 10
     #
     ipv4-family unicast
      network 7.7.7.7 255.255.255.255
      peer 192.168.60.1 enable
    #
    bgp 200 instance evpn1
     peer 6.6.6.6 as-number 100
     peer 6.6.6.6 ebgp-max-hop 255
     peer 6.6.6.6 connect-interface LoopBack1
     peer 8.8.8.8 as-number 200
     peer 8.8.8.8 connect-interface LoopBack1
     #
     l2vpn-family evpn
      policy vpn-target
      peer 6.6.6.6 enable
      peer 6.6.6.6 advertise irb
      peer 6.6.6.6 import reoriginate
      peer 6.6.6.6 advertise route-reoriginated evpn mac-ip
      peer 6.6.6.6 advertise route-reoriginated evpn ip
      peer 8.8.8.8 enable
      peer 8.8.8.8 advertise irb
      peer 8.8.8.8 import reoriginate
      peer 8.8.8.8 advertise route-reoriginated evpn mac-ip
      peer 8.8.8.8 advertise route-reoriginated evpn ip
    #
    ospf 1
     area 0.0.0.0
      network 7.7.7.7 0.0.0.0
      network 192.168.30.0 0.0.0.255
    #
    return
  • Leaf4 configuration file

    #
    sysname Leaf4
    #
    assign forward nvo3 acl extend enable
    #
    evpn-overlay enable
    #
    ip vpn-instance vpn1
     ipv4-family
      route-distinguisher 11:14
      vpn-target 1:4 export-extcommunity
      vpn-target 22:2 export-extcommunity evpn
      vpn-target 1:4 import-extcommunity
      vpn-target 22:2 import-extcommunity evpn
     vxlan vni 5010
    #
    bridge-domain 20
     vxlan vni 20
     evpn
      route-distinguisher 10:4
      vpn-target 40:1 export-extcommunity
      vpn-target 22:2 export-extcommunity
      vpn-target 40:1 import-extcommunity
    #
    interface Vbdif20
     ip binding vpn-instance vpn1
     ip address 10.40.1.1 255.255.255.0
     vxlan anycast-gateway enable
     arp collect host enable
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.40.2 255.255.255.0
    #
    interface 10GE1/0/2.1 mode l2
     encapsulation dot1q vid 20
     bridge-domain 20
    #
    interface LoopBack1
     ip address 8.8.8.8 255.255.255.255
    #
    interface Nve1
     source 8.8.8.8
     vni 20 head-end peer-list protocol bgp
    #
    bgp 200 instance evpn1
     peer 7.7.7.7 as-number 200
     peer 7.7.7.7 connect-interface LoopBack1
     #
     l2vpn-family evpn
      policy vpn-target
      peer 7.7.7.7 enable
      peer 7.7.7.7 advertise irb
    #
    ospf 1
     area 0.0.0.0
      network 8.8.8.8 0.0.0.0
      network 192.168.40.0 0.0.0.255
    #
    return
  • Device1 configuration file

    #
    sysname Device1
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.50.1 255.255.255.0
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 192.168.1.1 255.255.255.0
    #
    interface LoopBack1
     ip address 1.1.1.1 255.255.255.255
    #
    bgp 10
     peer 192.168.1.2 as-number 10
     peer 192.168.50.2 as-number 20
     #
     ipv4-family unicast
      peer 192.168.1.2 enable
      peer 192.168.1.2 next-hop-local
      peer 192.168.50.2 enable
    #
    return 
  • Device2 configuration file

    #
    sysname Device2
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.60.1 255.255.255.0
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 192.168.1.2 255.255.255.0
    #
    interface LoopBack1
     ip address 2.2.2.2 255.255.255.255
    #
    bgp 10
     peer 192.168.1.1 as-number 10
     peer 192.168.60.2 as-number 30
     #
     ipv4-family unicast
      peer 192.168.1.1 enable
      peer 192.168.1.1 next-hop-local
      peer 192.168.60.2 enable
    #
    return 
Download
Updated: 2019-04-03

Document ID: EDOC1000039339

Views: 105332

Downloads: 7470

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next