No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Typical Configuration Examples

CloudEngine 12800, 12800E, 8800, 7800, 6800, and 5800 Series Switches

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuring Dynamic BFD for OSPF

Configuring Dynamic BFD for OSPF

Applicable Products and Versions

This example applies to the CE12800/CE6800/CE5800 V100R001C00 or later, the CE12800E V200R002C50 or later, the CE8800 V100R006C00 or later, and the CE7800 V100R003C00 or later.

Networking Requirements

OSPF runs between SwitchA and SwitchB. It is required that faults on the link between SwitchA and SwitchB be fast detected and notified to OSPF.

Figure 2-36 Networking of BFD for OSPF

Requirement Analysis

Configure BFD for OSPF on SwitchA and SwitchB to fast detect faults on the link between them.

Procedure

  1. Configure Layer 2 forwarding function on SwitchA and SwitchB.

    • Create VLAN 10 on SwitchA and SwitchB.

      # Create VLAN 10 on SwitchA.

      <HUAWEI> system-view
      [~HUAWEI] sysname SwitchA
      [*HUAWEI] commit
      [~SwitchA] vlan batch 10
      [*SwitchA] commit

      # Create VLAN 10 on SwitchB.

      <HUAWEI> system-view
      [~HUAWEI] sysname SwitchB
      [*HUAWEI] commit
      [~SwitchB] vlan batch 10
      [*SwitchB] commit
    • Add 10GE1/0/1 interfaces on SwitchA and SwitchB to VLAN 10.

      # Add 10GE1/0/1 on SwitchA to VLAN 10.

      [~SwitchA] interface 10ge 1/0/1
      [~SwitchA-10GE1/0/1] port link-type trunk
      [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 10
      [*SwitchA-10GE1/0/1] port trunk pvid vlan 10
      [*SwitchA-10GE1/0/1] commit
      [~SwitchA-10GE1/0/1] quit

      # Add 10GE1/0/1 on SwitchB to VLAN 10.

      [~SwitchB] interface 10ge 1/0/1
      [~SwitchB-10GE1/0/1] port link-type trunk
      [*SwitchB-10GE1/0/1] port trunk allow-pass vlan 10
      [*SwitchB-10GE1/0/1] port trunk pvid vlan 10
      [*SwitchB-10GE1/0/1] commit
      [~SwitchB-10GE1/0/1] quit

  2. Configure connectivity between SwitchA and SwitchB.

    # Assign an IP address to each interface. SwitchA is used as an example. The configuration of SwitchB is similar to that of SwitchA.

    [~SwitchA] interface vlanif 10
    [*SwitchA-Vlanif10] ip address 10.1.1.1 24
    [*SwitchA-Vlanif10] quit
    [*SwitchA] commit

    # Configure OSPF between SwitchA and SwitchB. SwitchA is used as an example. The configuration of SwitchB is similar to that of SwitchA.

    [~SwitchA] router id 1.1.1.1
    [*SwitchA] ospf 1
    [*SwitchA-ospf-1] area 0
    [*SwitchA-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] quit
    [*SwitchA-ospf-1] quit
    [*SwitchA] commit

  3. Configure BFD for OSPF.

    # Enable global BFD on SwitchA.

    [~SwitchA] bfd
    [*SwitchA-bfd] quit
    [*SwitchA] ospf
    [*SwitchA-ospf-1] bfd all-interfaces enable
    [*SwitchA-ospf-1] quit
    [*SwitchA] commit

    # Enable global BFD on SwitchB.

    [~SwitchB] bfd
    [*SwitchB-bfd] quit
    [*SwitchB] ospf
    [*SwitchB-ospf-1] bfd all-interfaces enable
    [*SwitchB-ospf-1] quit
    [*SwitchB] commit

  4. Configure BFD parameters on interfaces.

    # Configure BFD on VLANIF 10 of SwitchA and set both the minimum intervals for sending and receiving BFD packets to 500 ms and the local detection multiplier to 4.

    [~SwitchA] interface vlanif 10
    [~SwitchA-Vlanif10] ospf bfd enable
    [*SwitchA-Vlanif10] ospf bfd min-tx-interval 500 min-rx-interval 500 detect-multiplier 4
    [*SwitchA-Vlanif10] quit
    [*SwitchA] commit

    # Configure BFD on VLANIF 10 of SwitchB and set both the minimum intervals for sending and receiving BFD packets to 500 ms and the local detection multiplier to 4.

    [~SwitchB] interface vlanif 10
    [~SwitchB-Vlanif10] ospf bfd enable
    [*SwitchB-Vlanif10] ospf bfd min-tx-interval 500 min-rx-interval 500 detect-multiplier 4
    [*SwitchB-Vlanif10] quit
    [*SwitchB] commit

Verifying the Configuration

  1. # After the configuration is complete, run the display ospf bfd session all command on the SwitchA. You can see that the value of BFDState is up.

    [~SwitchA] display ospf bfd session all
                                                                                    
             OSPF Process 1 with Router ID 1.1.1.1                            
      Area 0.0.0.0 interface 10.1.1.1(Vlanif10)'s BFD Sessions                    
                                                                                    
     NeighborId:2.2.2.2          AreaId:0.0.0.0          Interface:Vlanif10         
     BFDState:up                 rx    :500              tx       :500              
     Multiplier:4                BFD Local Dis:8193      LocalIpAdd:10.1.1.1      
     RemoteIpAdd:10.1.1.2        Diagnostic Info:No diagnostic information 
        Total UP/DOWN/UNKNOWN BFD Session Number : 1 / 0 / 0
  2. # After the configuration is complete, run the display ospf bfd session all command on the SwitchB. You can see that the value of BFDState is up.

    [~SwitchB] display ospf bfd session all
                                                                                    
             OSPF Process 1 with Router ID 2.2.2.2                            
      Area 0.0.0.0 interface 10.1.1.2(Vlanif10)'s BFD Sessions                    
                                                                                    
     NeighborId:1.1.1.1          AreaId:0.0.0.0          Interface:Vlanif10         
     BFDState:up                 rx    :500              tx       :500              
     Multiplier:4                BFD Local Dis:8192      LocalIpAdd:10.1.1.2      
     RemoteIpAdd:10.1.1.1        Diagnostic Info:No diagnostic information 
        Total UP/DOWN/UNKNOWN BFD Session Number : 1 / 0 / 0

Configuration Files

  • Configuration file of SwitchA

    #
     sysname SwitchA
    #
     router id 1.1.1.1
    #
     vlan batch 10
    #
     bfd
    #
    interface Vlanif10
     ip address 10.1.1.1 255.255.255.0
     ospf bfd enable
     ospf bfd min-tx-interval 500 min-rx-interval 500 detect-multiplier 4
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 10
     port trunk allow-pass vlan 10
    #
    ospf 1
     bfd all-interface enable
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
  • Configuration file of SwitchB

    #
     sysname SwitchB
    #
     router id 2.2.2.2
    #
    vlan batch 10
    #
     bfd
    #
    interface Vlanif10
     ip address 10.1.1.2 255.255.255.0
     ospf bfd enable
     ospf bfd min-tx-interval 500 min-rx-interval 500 detect-multiplier 4
    #
    interface 10GE1/0/1
     port link-type trunk
     port trunk pvid vlan 10
     port trunk allow-pass vlan 10
    #
    ospf 1
     bfd all-interface enable
     area 0.0.0.0
      network 10.1.1.0 0.0.0.255
    #
    return
Download
Updated: 2019-10-14

Document ID: EDOC1000039339

Views: 147869

Downloads: 7825

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next