No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Typical Configuration Examples

CloudEngine 12800, 12800E, 8800, 7800, 6800, and 5800 Series Switches

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring NFVI Distributed Gateways

Example for Configuring NFVI Distributed Gateways

Applicable Products and Versions

This example applies to switches running V200R005C10 or later versions. The CE6865EI, CE6857EI, or CE8861EI can be deployed as a leaf switch on the network. The CE12800 can be deployed as a spine switch on the network.

Networking Requirements

Huawei's NFVI telecommunications (telco) cloud is a networking solution that consists of Data Center Interconnect (DCI) and data communication network (DCN) technologies. Mobile phone traffic enters the data center network (DCN) and is sen to its virtualized unified gateway (vUGW) and virtual multiservice engine (vMSE). After being processed by vUGW and vMSE, the phone traffic is forwarded over the Internet through the DCN to the destination devices. Similarly, response traffic sent over the Internet from the destination devices to the mobile phones also undergoes this process. To meet the preceding requirements and ensure that the phone traffic is load balanced within the DCN, you need to deploy the NFVI distributed gateway function on devices in the DCN.

In IPv4 NFVI distributed gateway networking, DCGW1 and DCGW2 are the DCN's border gateways, and they can exchange Internet routes with the external network. Leaf switches provide network access for Virtualized Network Functions (VNFs). As virtualized NEs, VNF1 and VNF2 can be deployed separately to implement the functions of the vUGW and vMSE. VNF1 and VNF2 are connected to leaf switches through respective interface process units (IPUs).

This networking combines the distributed gateway function and the VXLAN active-active gateway function:
  • The VXLAN active-active gateway function is configured on DCGW1 and DCGW2. Specifically, a bypass VXLAN tunnel is set up between DCGW1 and DCGW2. In addition, they use a virtual anycast VTEP address to establish VXLAN tunnels with leaf switches.

  • Spine switches transparently transmit packets and connect to DCGW devices and leaf switches.
  • The distributed gateway function is configured on leaf switches and a VXLAN tunnel is established between the two M-LAG systems.

Figure 1-14 NFVI distributed gateway networking
NOTE:

In the preceding figure, 1/0/1 indicates an interface number and the interface rate is 10 Gbit/s. That is, 1/0/1 indicates 10GE1/0/1. Other interfaces are specified in a similar way.

Table 1-10 Interface IP address list

Device Name

Interface

IP Address

Device Name

Interface

IP Address

DCGW1

10GE1/0/1

192.168.9.2/24

DCGW2

10GE1/0/1

192.168.11.2/24

10GE1/0/2

192.168.12.2/24

10GE1/0/2

192.168.10.2/24

Loopback0

11.11.11.11/32

Loopback0

11.11.11.11/32

Loopback1

9.9.9.9/32

Loopback1

10.10.10.10/32

Spine1

10GE1/0/1

192.168.1.1/24

Spine2

10GE1/0/1

192.168.5.1/24

10GE1/0/2

192.168.2.1/24

10GE1/0/2

192.168.6.1/24

10GE1/0/3

192.168.3.1/24

10GE1/0/3

192.168.7.1/24

10GE1/0/4

192.168.4.1/24

10GE1/0/4

192.168.8.1/24

10GE1/0/5

192.168.9.1/24

10GE1/0/5

192.168.11.1/24

10GE1/0/6

192.168.10.1/24

10GE1/0/6

192.168.12.1/24

Loopback0

7.7.7.7/32

Loopback0

8.8.8.8/32

Leaf1

10GE1/0/1

192.168.1.2/24

Leaf2

10GE1/0/1

192.168.2.2/24

10GE1/0/2

192.168.5.2/24

10GE1/0/2

192.168.6.2/24

Loopback0

5.5.5.5/32

Loopback0

5.5.5.5/32

Loopback1

1.1.1.1/32

Loopback1

2.2.2.2/32

Leaf3

10GE1/0/1

192.168.3.2/24

Leaf4

10GE1/0/1

192.168.4.2/24

10GE1/0/2

192.168.7.2/24

10GE1/0/2

192.168.8.2/24

Loopback0

6.6.6.6/32

Loopback0

6.6.6.6/32

Loopback1

3.3.3.3/32

Loopback1

4.4.4.4/32

IPU1

-

IPv4: 10.1.1.2/24

IPv6: fc00:1::2/64

IPU2

-

IPv4: 10.2.1.2/24

IPv6: fc00:2::2/64

IPU3

-

IPv4: 10.3.1.2/24

IPv6: fc00:3::2/64

IPU4

-

IPv4: 10.4.1.2/24

IPv6: fc00:4::2/64

VNF1

-

IPv4: 201.1.1.1/32

IPv6: 201::1/128

VNF2

-

IPv4: 202.1.1.1/32

IPv6: 202::1/128

Configuration Roadmap

The configuration roadmap is as follows:

  1. Configure a routing protocol to ensure Layer 3 connectivity on the network.
  2. Configure M-LAG on leaf switches.
  3. Configure BGP EVPN to establish a VXLAN tunnel.
  4. Configure static routes from leaf switches to VNFs and advertise the routes using BGP EVPN.
  5. Configure load balancing among routes.

Procedure

  1. Configure IP addresses for physical interfaces and loopback interfaces, and configure a routing protocol to ensure Layer 3 connectivity. OSPF is used in this example.

    Configure Leaf1. Repeat this step for other switches. For details, see Configuration Files.

    <HUAWEI> system-view
    [~HUAWEI] sysname Leaf1
    [*HUAWEI] commit
    [~Leaf1] interface 10ge 1/0/1
    [~Leaf1-10GE1/0/1] undo portswitch
    [*Leaf1-10GE1/0/1] ip address 192.168.1.2 24
    [*Leaf1-10GE1/0/1] ospf network-type p2p
    [*Leaf1-10GE1/0/1] ospf peer hold-max-cost timer 600000
    [*Leaf1-10GE1/0/1] quit
    [*Leaf1] interface 10ge 1/0/2
    [*Leaf1-10GE1/0/2] undo portswitch
    [*Leaf1-10GE1/0/2] ip address 192.168.5.2 24
    [*Leaf1-10GE1/0/2] ospf network-type p2p
    [*Leaf1-10GE1/0/2] ospf peer hold-max-cost timer 600000
    [*Leaf1-10GE1/0/2] quit
    [*Leaf1] interface loopback 0
    [*Leaf1-LoopBack0] ip address 5.5.5.5 32
    [*Leaf1-LoopBack0] quit
    [*Leaf1] interface loopback 1
    [*Leaf1-LoopBack1] ip address 1.1.1.1 32
    [*Leaf1-LoopBack1] quit
    [*Leaf1] ospf
    [*Leaf1-ospf-1] area 0
    [*Leaf1-ospf-1-area-0.0.0.0] network 192.168.1.0 0.0.0.255
    [*Leaf1-ospf-1-area-0.0.0.0] network 192.168.5.0 0.0.0.255
    [*Leaf1-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0
    [*Leaf1-ospf-1-area-0.0.0.0] network 5.5.5.5 0.0.0.0
    [*Leaf1-ospf-1-area-0.0.0.0] quit
    [*Leaf1-ospf-1] quit
    [*Leaf1] commit

  2. Configure the resource allocation mode on leaf switches.

    # Configure Leaf1. Repeat this step for Leaf2, Leaf3, and Leaf4.

    [~Leaf1] assign forward layer-3 resource large-overlay   //Set the Layer 3 resource allocation mode to large-overlay so that the switch supports more VXLAN overlay entries.
    [*Leaf1] assign forward ipv6 longer-mask resource share-mode   //Set the resource allocation mode of IPv6 addresses and routes with prefixes longer than 64 bits to shared mode. In this mode, IPv4 addresses and routes share chip resources with IPv6 addresses and routes.
    [*Leaf1] commit
    NOTE:

    After configuring the resource allocation mode, save the configuration and restart the switch to make the configuration take effect.

  3. Configure M-LAG on leaf switches.

    # Configure Leaf1 and Leaf2 to establish an M-LAG. Repeat this step for Leaf3 and Leaf4.

    [~Leaf1] stp mode rstp
    [*Leaf1] stp v-stp enable
    [*Leaf1] dfs-group 1
    [*Leaf1-dfs-group-1] source ip 1.1.1.1
    [*Leaf1-dfs-group-1] priority 150
    [*Leaf1-dfs-group-1] m-lag up-delay 240 auto-recovery interval 10   //Configure the delay for an M-LAG member interface to report the Up event and the automatic recovery interval.
    [*Leaf1-dfs-group-1] quit
    [*Leaf1] interface eth-trunk 1   //Configure the peer-link.
    [*Leaf1-Eth-Trunk1] trunkport 10ge 1/0/3
    [*Leaf1-Eth-Trunk1] trunkport 10ge 1/0/4
    [*Leaf1-Eth-Trunk1] mode lacp-static
    [*Leaf1-Eth-Trunk1] peer-link 1
    [*Leaf1-Eth-Trunk1] quit 
    [*Leaf1] interface eth-trunk 10   //Configure an M-LAG member interface connected to a VNF.
    [*Leaf1-Eth-Trunk10] trunkport 10ge 1/0/5 
    [*Leaf1-Eth-Trunk10] mode lacp-static 
    [*Leaf1-Eth-Trunk10] dfs-group 1 m-lag 1 
    [*Leaf1-Eth-Trunk10] stp edged-port enable 
    [*Leaf1-Eth-Trunk10] quit
    [*Leaf1] interface eth-trunk 11 
    [*Leaf1-Eth-Trunk11] trunkport 10ge 1/0/6 
    [*Leaf1-Eth-Trunk11] mode lacp-static 
    [*Leaf1-Eth-Trunk11] dfs-group 1 m-lag 2 
    [*Leaf1-Eth-Trunk11] stp edged-port enable 
    [*Leaf1-Eth-Trunk11] quit
    [*Leaf1] commit 
    [~Leaf1] monitor-link group 1 
    [*Leaf1-mtlk-group1] port 10ge 1/0/1 uplink 
    [*Leaf1-mtlk-group1] port 10ge 1/0/2 uplink 
    [*Leaf1-mtlk-group1] port eth-trunk 10 downlink 1 
    [*Leaf1-mtlk-group1] port eth-trunk 11 downlink 2 
    [*Leaf1-mtlk-group1] quit 
    [*Leaf1] commit
    [~Leaf2] stp mode rstp
    [*Leaf2] stp v-stp enable
    [*Leaf2] dfs-group 1
    [*Leaf2-dfs-group-1] source ip 2.2.2.2
    [*Leaf2-dfs-group-1] m-lag up-delay 240 auto-recovery interval 10
    [*Leaf2-dfs-group-1] quit
    [*Leaf2] interface eth-trunk 1
    [*Leaf2-Eth-Trunk1] trunkport 10ge 1/0/3
    [*Leaf2-Eth-Trunk1] trunkport 10ge 1/0/4
    [*Leaf2-Eth-Trunk1] mode lacp-static
    [*Leaf2-Eth-Trunk1] peer-link 1
    [*Leaf2-Eth-Trunk1] quit 
    [*Leaf2] interface eth-trunk 10 
    [*Leaf2-Eth-Trunk10] trunkport 10ge 1/0/5 
    [*Leaf2-Eth-Trunk10] mode lacp-static 
    [*Leaf2-Eth-Trunk10] dfs-group 1 m-lag 1 
    [*Leaf2-Eth-Trunk10] stp edged-port enable 
    [*Leaf2-Eth-Trunk10] quit
    [*Leaf2] interface eth-trunk 11 
    [*Leaf2-Eth-Trunk11] trunkport 10ge 1/0/6 
    [*Leaf2-Eth-Trunk11] mode lacp-static 
    [*Leaf2-Eth-Trunk11] dfs-group 1 m-lag 2 
    [*Leaf2-Eth-Trunk11] stp edged-port enable 
    [*Leaf2-Eth-Trunk11] quit
    [*Leaf2] commit 
    [~Leaf2] monitor-link group 1 
    [*Leaf2-mtlk-group1] port 10ge 1/0/1 uplink 
    [*Leaf2-mtlk-group1] port 10ge 1/0/2 uplink 
    [*Leaf2-mtlk-group1] port eth-trunk 10 downlink 1 
    [*Leaf2-mtlk-group1] port eth-trunk 11 downlink 2 
    [*Leaf2-mtlk-group1] quit 
    [*Leaf2] commit

  4. Configure BGP EVPN to establish a VXLAN tunnel.

    1. Configure the VXLAN tunnel mode and enable the VXLAN ACL extension function on spine switches.

      # Configure Spine1. Repeat this step for Spine2.

      [~Spine1] ip tunnel mode vxlan
      [*Spine1] assign forward nvo3 acl extend enable
      [*Spine1] commit
      NOTE:

      After configuring the VXLAN tunnel mode and enabling the VXLAN ACL extension function, save the configuration and restart the switch to make the configuration take effect.

    2. Establish BGP EVPN peer relationships. Spine1 and Spine2 function as RRs.

      # Configure Spine1. Repeat this step for Spine2.

      [~Spine1] evpn-overlay enable
      [*Spine1] bgp 100
      [*Spine1-bgp] peer 1.1.1.1 as-number 100
      [*Spine1-bgp] peer 1.1.1.1 connect-interface LoopBack0
      [*Spine1-bgp] peer 2.2.2.2 as-number 100
      [*Spine1-bgp] peer 2.2.2.2 connect-interface LoopBack0
      [*Spine1-bgp] peer 3.3.3.3 as-number 100
      [*Spine1-bgp] peer 3.3.3.3 connect-interface LoopBack0
      [*Spine1-bgp] peer 4.4.4.4 as-number 100
      [*Spine1-bgp] peer 4.4.4.4 connect-interface LoopBack0
      [*Spine1-bgp] peer 9.9.9.9 as-number 100
      [*Spine1-bgp] peer 9.9.9.9 connect-interface LoopBack0
      [*Spine1-bgp] peer 10.10.10.10 as-number 100
      [*Spine1-bgp] peer 10.10.10.10 connect-interface LoopBack0
      [*Spine1-bgp] l2vpn-family evpn
      [*Spine1-bgp-af-evpn] peer 1.1.1.1 enable
      Warning: This operation will reset the peer session. Continue? [Y/N]: y
      [*Spine1-bgp-af-evpn] peer 1.1.1.1 reflect-client
      [*Spine1-bgp-af-evpn] peer 1.1.1.1 advertise irb
      [*Spine1-bgp-af-evpn] peer 1.1.1.1 advertise irbv6
      [*Spine1-bgp-af-evpn] peer 2.2.2.2 enable
      Warning: This operation will reset the peer session. Continue? [Y/N]: y
      [*Spine1-bgp-af-evpn] peer 2.2.2.2 advertise irb
      [*Spine1-bgp-af-evpn] peer 2.2.2.2 advertise irbv6
      [*Spine1-bgp-af-evpn] peer 2.2.2.2 reflect-client
      [*Spine1-bgp-af-evpn] peer 3.3.3.3 enable
      Warning: This operation will reset the peer session. Continue? [Y/N]: y
      [*Spine1-bgp-af-evpn] peer 3.3.3.3 advertise irb
      [*Spine1-bgp-af-evpn] peer 3.3.3.3 advertise irbv6
      [*Spine1-bgp-af-evpn] peer 3.3.3.3 reflect-client
      [*Spine1-bgp-af-evpn] peer 4.4.4.4 enable
      Warning: This operation will reset the peer session. Continue? [Y/N]: y
      [*Spine1-bgp-af-evpn] peer 4.4.4.4 advertise irb
      [*Spine1-bgp-af-evpn] peer 4.4.4.4 advertise irbv6
      [*Spine1-bgp-af-evpn] peer 4.4.4.4 reflect-client
      [*Spine1-bgp-af-evpn] peer 9.9.9.9 enable
      Warning: This operation will reset the peer session. Continue? [Y/N]: y
      [*Spine1-bgp-af-evpn] peer 9.9.9.9 advertise irb
      [*Spine1-bgp-af-evpn] peer 9.9.9.9 advertise irbv6
      [*Spine1-bgp-af-evpn] peer 9.9.9.9 reflect-client
      [*Spine1-bgp-af-evpn] peer 10.10.10.10 enable
      Warning: This operation will reset the peer session. Continue? [Y/N]: y
      [*Spine1-bgp-af-evpn] peer 10.10.10.10 advertise irb
      [*Spine1-bgp-af-evpn] peer 10.10.10.10 advertise irbv6
      [*Spine1-bgp-af-evpn] peer 10.10.10.10 reflect-client
      [*Spine1-bgp-af-evpn] undo policy vpn-target
      [*Spine1-bgp-af-evpn] quit
      [*Spine1-bgp] quit
      [*Spine1] commit

      # Configure Leaf1. Repeat this step for Leaf2, Leaf3, and Leaf4.

      [~Leaf1] evpn-overlay enable
      [*Leaf1] bgp 100
      [*Leaf1-bgp] peer 7.7.7.7 as-number 100
      [*Leaf1-bgp] peer 7.7.7.7 connect-interface LoopBack1
      [*Leaf1-bgp] peer 8.8.8.8 as-number 100
      [*Leaf1-bgp] peer 8.8.8.8 connect-interface LoopBack1
      [*Leaf1-bgp] l2vpn-family evpn
      [*Leaf1-bgp-af-evpn] peer 7.7.7.7 enable
      Warning: This operation will reset the peer session. Continue? [Y/N]: y
      [*Leaf1-bgp-af-evpn] peer 7.7.7.7 advertise irb
      [*Leaf1-bgp-af-evpn] peer 7.7.7.7 advertise irbv6
      [*Leaf1-bgp-af-evpn] peer 8.8.8.8 enable
      Warning: This operation will reset the peer session. Continue? [Y/N]: y
      [*Leaf1-bgp-af-evpn] peer 8.8.8.8 advertise irb
      [*Leaf1-bgp-af-evpn] peer 8.8.8.8 advertise irbv6
      [*Leaf1-bgp-af-evpn] quit
      [*Leaf1-bgp] quit
      [*Leaf1] commit
    3. Configure VPN and EVPN instances.

      # Configure Leaf1. Repeat this step for Leaf2, Leaf3, and Leaf4.

      [~Leaf1] ip vpn-instance vpn1
      [*Leaf1-vpn-instance-vpn1] vxlan vni 200
      [*Leaf1-vpn-instance-vpn1] ipv4-family
      [*Leaf1-vpn-instance-vpn1-af-ipv4] route-distinguisher 1.1.1.1:1
      [*Leaf1-vpn-instance-vpn1-af-ipv4] vpn-target 0:1 evpn
      [*Leaf1-vpn-instance-vpn1-af-ipv4] quit
      [*Leaf1-vpn-instance-vpn1] ipv6-family
      [*Leaf1-vpn-instance-vpn1-af-ipv6] route-distinguisher 1.1.1.1:1
      [*Leaf1-vpn-instance-vpn1-af-ipv6] vpn-target 0:1 evpn
      [*Leaf1-vpn-instance-vpn1-af-ipv6] quit
      [*Leaf1-vpn-instance-vpn1] quit
      [*Leaf1] bridge-domain 10
      [*Leaf1-bd10] vxlan vni 110
      [*Leaf1-bd10] evpn
      [*Leaf1-bd10-evpn] route-distinguisher 1.1.1.1:110
      [*Leaf1-bd10-evpn] vpn-target 0:110
      [*Leaf1-bd10-evpn] vpn-target 0:1 export-extcommunity
      [*Leaf1-bd10-evpn] quit
      [*Leaf1-bd10] quit
      [*Leaf1] bridge-domain 20
      [*Leaf1-bd20] vxlan vni 120
      [*Leaf1-bd20] evpn
      [*Leaf1-bd20-evpn] route-distinguisher 1.1.1.1:120
      [*Leaf1-bd20-evpn] vpn-target 0:120
      [*Leaf1-bd20-evpn] vpn-target 0:1 export-extcommunity
      [*Leaf1-bd20-evpn] quit
      [*Leaf1-bd20] quit
      [*Leaf1] bridge-domain 30
      [*Leaf1-bd30] vxlan vni 130
      [*Leaf1-bd30] evpn
      [*Leaf1-bd30-evpn] route-distinguisher 1.1.1.1:130
      [*Leaf1-bd30-evpn] vpn-target 0:130
      [*Leaf1-bd30-evpn] vpn-target 0:1 export-extcommunity
      [*Leaf1-bd30-evpn] quit
      [*Leaf1-bd30] quit
      [*Leaf1] bridge-domain 40
      [*Leaf1-bd40] vxlan vni 140
      [*Leaf1-bd40] evpn
      [*Leaf1-bd40-evpn] route-distinguisher 1.1.1.1:140
      [*Leaf1-bd40-evpn] vpn-target 0:140
      [*Leaf1-bd40-evpn] vpn-target 0:1 export-extcommunity
      [*Leaf1-bd40-evpn] quit
      [*Leaf1-bd40] quit
      [*Leaf1] interface nve 1
      [*Leaf1-Nve1] source 5.5.5.5    //The IP addresses and MAC addresses of NVE interfaces on the two devices that establish an M-LAG must be the same.
      [*Leaf1-Nve1] mac-address 0000-5e00-0111   
      [*Leaf1-Nve1] vni 110 head-end peer-list protocol bgp
      [*Leaf1-Nve1] vni 120 head-end peer-list protocol bgp
      [*Leaf1-Nve1] vni 130 head-end peer-list protocol bgp
      [*Leaf1-Nve1] vni 140 head-end peer-list protocol bgp
      [*Leaf1-Nve1] quit
      [*Leaf1] commit
    4. Configure Layer 3 gateways.

      # Configure Leaf1. Repeat this step for Leaf2, Leaf3, and Leaf4.

      [~Leaf1] interface vbdif10   //The IP addresses and MAC addresses of the same VBDIF interface on a leaf switch and a DCGW must be the same.
      [*Leaf1-Vbdif10] ip binding vpn-instance vpn1
      [*Leaf1-Vbdif10] ip address 10.1.1.1 24
      [*Leaf1-Vbdif10] ipv6 enable
      [*Leaf1-Vbdif10] ipv6 address fc00:1::1 64 
      [*Leaf1-Vbdif10] arp generate-rd-table enable 
      [*Leaf1-Vbdif10] ipv6 nd generate-rd-table enable 
      [*Leaf1-Vbdif10] arp broadcast-detect enable 
      [*Leaf1-Vbdif10] vxlan anycast-gateway enable
      [*Leaf1-Vbdif10] arp collect host enable
      [*Leaf1-Vbdif10] ipv6 nd collect host enable
      [*Leaf1-Vbdif10] mac-address 0000-5e00-0101
      [*Leaf1-Vbdif10] quit
      [*Leaf1] interface vbdif20
      [*Leaf1-Vbdif20] ip binding vpn-instance vpn1
      [*Leaf1-Vbdif20] ip address 10.2.1.1 24
      [*Leaf1-Vbdif20] ipv6 enable
      [*Leaf1-Vbdif20] ipv6 address fc00:2::1 64 
      [*Leaf1-Vbdif20] arp generate-rd-table enable
      [*Leaf1-Vbdif20] ipv6 nd generate-rd-table enable
      [*Leaf1-Vbdif20] arp broadcast-detect enable 
      [*Leaf1-Vbdif20] vxlan anycast-gateway enable
      [*Leaf1-Vbdif20] arp collect host enable
      [*Leaf1-Vbdif20] ipv6 nd collect host enable
      [*Leaf1-Vbdif20] mac-address 0000-5e00-0102
      [*Leaf1-Vbdif20] quit
      [*Leaf1] interface vbdif30
      [*Leaf1-Vbdif30] ip binding vpn-instance vpn1
      [*Leaf1-Vbdif30] ip address 10.3.1.1 24
      [*Leaf1-Vbdif30] ipv6 enable
      [*Leaf1-Vbdif30] ipv6 address fc00:3::1 64 
      [*Leaf1-Vbdif30] arp generate-rd-table enable
      [*Leaf1-Vbdif30] ipv6 nd generate-rd-table enable
      [*Leaf1-Vbdif30] arp broadcast-detect enable 
      [*Leaf1-Vbdif30] vxlan anycast-gateway enable
      [*Leaf1-Vbdif30] arp collect host enable
      [*Leaf1-Vbdif30] ipv6 nd collect host enable
      [*Leaf1-Vbdif30] mac-address 0000-5e00-0103
      [*Leaf1-Vbdif30] quit
      [*Leaf1] interface vbdif40
      [*Leaf1-Vbdif40] ip binding vpn-instance vpn1
      [*Leaf1-Vbdif40] ip address 10.4.1.1 24
      [*Leaf1-Vbdif40] ipv6 enable
      [*Leaf1-Vbdif40] ipv6 address fc00:4::1 64 
      [*Leaf1-Vbdif40] arp generate-rd-table enable
      [*Leaf1-Vbdif40] ipv6 nd generate-rd-table enable
      [*Leaf1-Vbdif40] arp broadcast-detect enable 
      [*Leaf1-Vbdif40] vxlan anycast-gateway enable
      [*Leaf1-Vbdif40] arp collect host enable
      [*Leaf1-Vbdif40] ipv6 nd collect host enable
      [*Leaf1-Vbdif40] mac-address 0000-5e00-0104
      [*Leaf1-Vbdif40] quit
      [*Leaf1] commit
    5. Configure service access points.

      # Configure Leaf1. Repeat this step for Leaf2, Leaf3, and Leaf4.

      [~Leaf1] interface eth-trunk 10.10 mode l2
      [*Leaf1-Eth-Trunk10.10] encapsulation dot1q vid 10
      [*Leaf1-Eth-Trunk10.10] bridge-domain 10
      [*Leaf1-Eth-Trunk10.10] quit
      [*Leaf1] interface eth-trunk 11.20 mode l2
      [*Leaf1-Eth-Trunk11.20] encapsulation dot1q vid 20
      [*Leaf1-Eth-Trunk11.20] bridge-domain 20
      [*Leaf1-Eth-Trunk11.20] quit
      [*Leaf1] commit

  5. Configure BFD on leaf switches to detect links between leaf switches and VNFs.

    # Configure Leaf1. Repeat this step for Leaf2, Leaf3, and Leaf4.

    [~Leaf1] bfd
    [*Leaf1-bfd] quit
    [*Leaf1] bfd toipu1_v4 bind peer-ip 10.1.1.2 vpn-instance vpn1 interface vbdif10 one-arm-echo
    [*Leaf1-bfd-session-toipu1_v4] discriminator local 10
    [*Leaf1-bfd-session-toipu1_v4] detect-multiplier 6
    [*Leaf1-bfd-session-toipu1_v4] min-echo-rx-interval 300
    [*Leaf1-bfd-session-toipu1_v4] quit
    [*Leaf1] bfd toipu2_v4 bind peer-ip 10.2.1.2 vpn-instance vpn1 interface vbdif20 one-arm-echo
    [*Leaf1-bfd-session-toipu2_v4] discriminator local 30
    [*Leaf1-bfd-session-toipu2_v4] detect-multiplier 6
    [*Leaf1-bfd-session-toipu2_v4] min-echo-rx-interval 300
    [*Leaf1-bfd-session-toipu2_v4] quit
    [*Leaf1] bfd toipu1_v6 bind peer-ipv6 fc00:1::2 vpn-instance vpn1 interface vbdif10 one-arm-echo
    [*Leaf1-bfd-session-toipu1_v6] discriminator local 50
    [*Leaf1-bfd-session-toipu1_v6] detect-multiplier 6
    [*Leaf1-bfd-session-toipu1_v6] min-echo-rx-interval 300
    [*Leaf1-bfd-session-toipu1_v6] quit
    [*Leaf1] bfd toipu2_v6 bind peer-ipv6 fc00:2::2 vpn-instance vpn1 interface vbdif20 one-arm-echo
    [*Leaf1-bfd-session-toipu2_v6] discriminator local 70
    [*Leaf1-bfd-session-toipu2_v6] detect-multiplier 6
    [*Leaf1-bfd-session-toipu2_v6] min-echo-rx-interval 300
    [*Leaf1-bfd-session-toipu2_v6] quit
    [*Leaf1] bfd
    [*Leaf1-bfd] bfd forwarding match remote-discriminator 20   //Specify the remote discriminator of the BFD session.
    [*Leaf1-bfd] bfd forwarding match remote-discriminator 40
    [*Leaf1-bfd] bfd forwarding match remote-discriminator 60
    [*Leaf1-bfd] bfd forwarding match remote-discriminator 80
    [*Leaf1-bfd] quit
    [*Leaf1] commit

  6. Configure static VPN routes from leaf switches to VNFs, configure BGP EVPN to import static VPN routes, and configure a routing policy for the L3VPN instance to keep the original next hops of the static VPN routes.

    # Configure Leaf1. Repeat this step for Leaf2, Leaf3, and Leaf4.

    [~Leaf1] ip route-static vpn-instance vpn1 201.1.1.1 32 10.1.1.2 tag 1000 track bfd-session toipu1_v4 inter-protocol-ecmp
    [*Leaf1] ip route-static vpn-instance vpn1 201.1.1.1 32 10.2.1.2 tag 1000 track bfd-session toipu2_v4 inter-protocol-ecmp
    [*Leaf1] ipv6 route-static vpn-instance vpn1 201::1 128 fc00:1::2 tag 2000 track bfd-session toipu1_v6 inter-protocol-ecmp
    [*Leaf1] ipv6 route-static vpn-instance vpn1 201::1 128 fc00:2::2 tag 2000 track bfd-session toipu2_v6 inter-protocol-ecmp
    [*Leaf1] bgp 100
    [*Leaf1-bgp] ipv4-family vpn-instance vpn1
    [*Leaf1-bgp-vpn1] import-route static
    [*Leaf1-bgp-vpn1] advertise l2vpn evpn import-route-multipath    //Advertise all routes with the same destination address.
    [*Leaf1-bgp-vpn1] irb asymmetric    //Enable the asymmetric mode for IRB routes.
    [*Leaf1-bgp-vpn1] quit
    [*Leaf1-bgp] ipv6-family vpn-instance vpn1
    [*Leaf1-bgp-6-vpn1] import-route static
    [*Leaf1-bgp-6-vpn1] advertise l2vpn evpn import-route-multipath 
    [*Leaf1-bgp-6-vpn1] irb asymmetric 
    [*Leaf1-bgp-6-vpn1] quit
    [*Leaf1-bgp] quit
    [*Leaf1] route-policy sp_v4 permit node 10
    [*Leaf1-route-policy] if-match tag 1000
    [*Leaf1-route-policy] apply gateway-ip origin-nexthop   //Specify the next-hop address of a route as the gateway address.
    [*Leaf1-route-policy] quit
    [*Leaf1] route-policy sp_v4 deny node 20
    [*Leaf1-route-policy] quit
    [*Leaf1] route-policy sp_v6 permit node 10
    [*Leaf1-route-policy] if-match tag 2000
    [*Leaf1-route-policy] apply ipv6 gateway-ip origin-nexthop
    [*Leaf1-route-policy] quit
    [*Leaf1] route-policy sp_v6 deny node 20
    [*Leaf1-route-policy] quit
    [*Leaf1] ip vpn-instance vpn1
    [*Leaf1-vpn-instance-vpn1] ipv4-family
    [*Leaf1-vpn-instance-vpn1-af-ipv4] export route-policy sp_v4 evpn
    [*Leaf1-vpn-instance-vpn1-af-ipv4] quit
    [*Leaf1-vpn-instance-vpn1] ipv6-family
    [*Leaf1-vpn-instance-vpn1-af-ipv6] export route-policy sp_v6 evpn
    [*Leaf1-vpn-instance-vpn1-af-ipv6] quit
    [*Leaf1-vpn-instance-vpn1] quit
    [*Leaf1] commit

  7. Configure load balancing among routes.

    # Configure Leaf1. Repeat this step for Leaf2, Leaf3, and Leaf4.

    [~Leaf1] bgp 100
    [*Leaf1-bgp] ipv4-family vpn-instance vpn1
    [*Leaf1-bgp-vpn1] maximum load-balancing 128
    [*Leaf1-bgp-vpn1] preference 60 60 60   //Set the preference of BGP routes to be the same as that of static routes so that traffic is load balanced between BGP routes and static routes.
    [*Leaf1-bgp-vpn1] quit
    [*Leaf1-bgp] ipv6-family vpn-instance vpn1
    [*Leaf1-bgp-6-vpn1] maximum load-balancing 128
    [*Leaf1-bgp-6-vpn1] preference 60 60 60
    [*Leaf1-bgp-6-vpn1] quit
    [*Leaf1-bgp] l2vpn-family evpn
    [*Leaf1-bgp-af-evpn] bestroute add-path path-number 64   //Enable the BGP ADD-PATH function.
    [*Leaf1-bgp-af-evpn] peer 7.7.7.7 capability-advertise add-path both
    [*Leaf1-bgp-af-evpn] peer 7.7.7.7 advertise add-path path-number 64
    [*Leaf1-bgp-af-evpn] peer 8.8.8.8 capability-advertise add-path both
    [*Leaf1-bgp-af-evpn] peer 8.8.8.8 advertise add-path path-number 64
    [*Leaf1-bgp-af-evpn] quit
    [*Leaf1-bgp] quit
    [*Leaf1] commit

Verifying the Configuration

After completing the configurations, run the display ip routing-table vpn-instance vpn1 command on a leaf switch. The command output shows that the leaf switch has received routes from the VPN instance on a DCGW and the next hop is the anycast VTEP address. The following uses the command output on Leaf 1 as an example.

[~Leaf1] display ip routing-table vpn-instance vpn1
Proto: Protocol        Pre: Preference
Route Flags: R - relay, D - download to fib, T - to vpn-instance, B - black hole route
------------------------------------------------------------------------------
Routing Table : vpn1
         Destinations : 16       Routes : 18

Destination/Mask    Proto   Pre  Cost        Flags NextHop         Interface

        0.0.0.0/0   IBGP    60   0             RD  11.11.11.11     VXLAN
       10.1.1.0/24  Direct  0    0             D   10.1.1.1        Vbdif10
       10.1.1.1/32  Direct  0    0             D   127.0.0.1       Vbdif10
     10.1.1.255/32  Direct  0    0             D   127.0.0.1       Vbdif10
       10.2.1.0/24  Direct  0    0             D   10.2.1.1        Vbdif20
       10.2.1.1/32  Direct  0    0             D   127.0.0.1       Vbdif20
     10.2.1.255/32  Direct  0    0             D   127.0.0.1       Vbdif20
       10.3.1.0/24  Direct  0    0             D   10.3.1.1        Vbdif30
       10.3.1.1/32  Direct  0    0             D   127.0.0.1       Vbdif30
     10.3.1.255/32  Direct  0    0             D   127.0.0.1       Vbdif30
       10.4.1.0/24  Direct  0    0             D   10.4.1.1        Vbdif40
       10.4.1.1/32  Direct  0    0             D   127.0.0.1       Vbdif40
     10.4.1.255/32  Direct  0    0             D   127.0.0.1       Vbdif40
      201.1.1.1/32  Static  60   0             RD  10.1.1.2        Vbdif10
                    Static  60   0             RD  10.2.1.2        Vbdif20
      202.1.1.1/32  IBGP    60   0             RD  10.3.1.2        Vbdif30
                    IBGP    60   0             RD  10.4.1.2        Vbdif40
255.255.255.255/32  Direct  0    0             D   127.0.0.1       InLoopBack0

On a DCGW, you can view ARP information about IPUs. The information is not provided here.

Configuration Files

  • Spine1 configuration file
    #
    sysname Spine1
    #
    assign forward nvo3 acl extend enable
    #
    evpn-overlay enable
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.1.1 255.255.255.0
     ospf network-type p2p
     ospf peer hold-max-cost timer 600000
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 192.168.2.1 255.255.255.0
     ospf network-type p2p
     ospf peer hold-max-cost timer 600000
    #
    interface 10GE1/0/3
     undo portswitch
     ip address 192.168.3.1 255.255.255.0
     ospf network-type p2p
     ospf peer hold-max-cost timer 600000
    #
    interface 10GE1/0/4
     undo portswitch
     ip address 192.168.4.1 255.255.255.0
     ospf network-type p2p
     ospf peer hold-max-cost timer 600000
    #
    interface 10GE1/0/5
     undo portswitch
     ip address 192.168.9.1 255.255.255.0
     ospf network-type p2p
     ospf peer hold-max-cost timer 600000
    #
    interface 10GE1/0/6
     undo portswitch
     ip address 192.168.10.1 255.255.255.0
     ospf network-type p2p
     ospf peer hold-max-cost timer 600000
    #
    interface LoopBack0
     ip address 7.7.7.7 255.255.255.255
    #
    bgp 100
     peer 1.1.1.1 as-number 100
     peer 1.1.1.1 connect-interface LoopBack0
     peer 2.2.2.2 as-number 100
     peer 2.2.2.2 connect-interface LoopBack0
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack0
     peer 4.4.4.4 as-number 100
     peer 4.4.4.4 connect-interface LoopBack0
     peer 9.9.9.9 as-number 100
     peer 9.9.9.9 connect-interface LoopBack0
     peer 10.10.10.10 as-number 100
     peer 10.10.10.10 connect-interface LoopBack0
     #
     ipv4-family unicast
      peer 1.1.1.1 enable
      peer 2.2.2.2 enable
      peer 3.3.3.3 enable
      peer 4.4.4.4 enable
      peer 9.9.9.9 enable
      peer 10.10.10.10 enable
     #
     l2vpn-family evpn
      undo policy vpn-target
      peer 1.1.1.1 enable
      peer 1.1.1.1 advertise irb
      peer 1.1.1.1 advertise irbv6
      peer 1.1.1.1 reflect-client
      peer 2.2.2.2 enable
      peer 2.2.2.2 advertise ir
      peer 2.2.2.2 advertise irbv6
      peer 2.2.2.2 reflect-client
      peer 3.3.3.3 enable
      peer 3.3.3.3 advertise irb
      peer 3.3.3.3 advertise irbv6
      peer 3.3.3.3 reflect-client
      peer 4.4.4.4 enable
      peer 4.4.4.4 advertise irb
      peer 4.4.4.4 advertise irbv6
      peer 4.4.4.4 reflect-client
      peer 9.9.9.9 enable
      peer 9.9.9.9 advertise irb
      peer 9.9.9.9 advertise irbv6
      peer 9.9.9.9 reflect-client
      peer 10.10.10.10 enable
      peer 10.10.10.10 advertise irb
      peer 10.10.10.10 advertise irbv6
      peer 10.10.10.10 reflect-client
    #
    ospf 1
     area 0.0.0.0
      network 7.7.7.7 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.2.0 0.0.0.255
      network 192.168.3.0 0.0.0.255
      network 192.168.4.0 0.0.0.255
      network 192.168.9.0 0.0.0.255
      network 192.168.10.0 0.0.0.255  
    #
    return
  • Spine2 configuration file
    #
    sysname Spine2
    #
    assign forward nvo3 acl extend enable
    #
    evpn-overlay enable
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.5.1 255.255.255.0
     ospf network-type p2p
     ospf peer hold-max-cost timer 600000
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 192.168.6.1 255.255.255.0
     ospf network-type p2p
     ospf peer hold-max-cost timer 600000
    #
    interface 10GE1/0/3
     undo portswitch
     ip address 192.168.7.1 255.255.255.0
     ospf network-type p2p
     ospf peer hold-max-cost timer 600000
    #
    interface 10GE1/0/4
     undo portswitch
     ip address 192.168.8.1 255.255.255.0
     ospf network-type p2p
     ospf peer hold-max-cost timer 600000
    #
    interface 10GE1/0/5
     undo portswitch
     ip address 192.168.11.1 255.255.255.0
     ospf network-type p2p
     ospf peer hold-max-cost timer 600000
    #
    interface 10GE1/0/6
     undo portswitch
     ip address 192.168.12.1 255.255.255.0
     ospf network-type p2p
     ospf peer hold-max-cost timer 600000
    #
    interface LoopBack0
     ip address 8.8.8.8 255.255.255.255
    #
    bgp 100
     peer 1.1.1.1 as-number 100
     peer 1.1.1.1 connect-interface LoopBack0
     peer 2.2.2.2 as-number 100
     peer 2.2.2.2 connect-interface LoopBack0
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack0
     peer 4.4.4.4 as-number 100
     peer 4.4.4.4 connect-interface LoopBack0
     peer 9.9.9.9 as-number 100
     peer 9.9.9.9 connect-interface LoopBack0
     peer 10.10.10.10 as-number 100
     peer 10.10.10.10 connect-interface LoopBack0
     #
     ipv4-family unicast
      peer 1.1.1.1 enable
      peer 2.2.2.2 enable
      peer 3.3.3.3 enable
      peer 4.4.4.4 enable
      peer 9.9.9.9 enable
      peer 10.10.10.10 enable
     #
     l2vpn-family evpn
      undo policy vpn-target
      peer 1.1.1.1 enable
      peer 1.1.1.1 advertise irb
      peer 1.1.1.1 advertise irbv6
      peer 1.1.1.1 reflect-client
      peer 2.2.2.2 enable
      peer 2.2.2.2 advertise irb
      peer 2.2.2.2 advertise irbv6
      peer 2.2.2.2 reflect-client
      peer 3.3.3.3 enable
      peer 3.3.3.3 advertise irb
      peer 3.3.3.3 advertise irbv6
      peer 3.3.3.3 reflect-client
      peer 4.4.4.4 enable
      peer 4.4.4.4 advertise irb
      peer 4.4.4.4 advertise irbv6
      peer 4.4.4.4 reflect-client
      peer 9.9.9.9 enable
      peer 9.9.9.9 advertise irb
      peer 9.9.9.9 advertise irbv6
      peer 9.9.9.9 reflect-client
      peer 10.10.10.10 enable
      peer 10.10.10.10 advertise irb
      peer 10.10.10.10 advertise irbv6
      peer 10.10.10.10 reflect-client
    #
    ospf 1
     area 0.0.0.0
      network 8.8.8.8 0.0.0.0
      network 192.168.5.0 0.0.0.255
      network 192.168.6.0 0.0.0.255
      network 192.168.7.0 0.0.0.255
      network 192.168.8.0 0.0.0.255
      network 192.168.11.0 0.0.0.255
      network 192.168.12.0 0.0.0.255  
    #
    return
  • Leaf1 configuration file
    #
    sysname Leaf1
    #
    dfs-group 1
     priority 150
     source ip 1.1.1.1 
     m-lag up-delay 240 auto-recovery interval 10
    #
    assign forward layer-3 resource large-overlay
    #
    assign forward ipv6 longer-mask resource share-mode
    #
    stp mode rstp 
    stp v-stp enable 
    #
    evpn-overlay enable
    #
    ip vpn-instance vpn1
     ipv4-family
      route-distinguisher 1.1.1.1:1
      export route-policy sp_v4 evpn
      vpn-target 0:1 export-extcommunity evpn
      vpn-target 0:1 import-extcommunity evpn
     ipv6-family 
      route-distinguisher 1.1.1.1:1
      export route-policy sp_v6 evpn
      vpn-target 0:1 export-extcommunity evpn
      vpn-target 0:1 import-extcommunity evpn
     vxlan vni 200
    #
    bfd
     bfd forwarding match remote-discriminator 20
     bfd forwarding match remote-discriminator 40
     bfd forwarding match remote-discriminator 60
     bfd forwarding match remote-discriminator 80
    #
    bridge-domain 10
     vxlan vni 110
     evpn
      route-distinguisher 1.1.1.1:110
      vpn-target 0:110 export-extcommunity
      vpn-target 0:1 export-extcommunity
      vpn-target 0:110 import-extcommunity
    #
    bridge-domain 20
     vxlan vni 120
     evpn
      route-distinguisher 1.1.1.1:120
      vpn-target 0:120 export-extcommunity
      vpn-target 0:1 export-extcommunity
      vpn-target 0:120 import-extcommunity
    #
    bridge-domain 30
     vxlan vni 130
     evpn
      route-distinguisher 1.1.1.1:130
      vpn-target 0:130 export-extcommunity
      vpn-target 0:1 export-extcommunity
      vpn-target 0:130 import-extcommunity
    #
    bridge-domain 40
     vxlan vni 140
     evpn
      route-distinguisher 1.1.1.1:140
      vpn-target 0:140 export-extcommunity
      vpn-target 0:1 export-extcommunity
      vpn-target 0:140 import-extcommunity
    #
    interface Vbdif10
     ip binding vpn-instance vpn1
     ipv6 enable
     ip address 10.1.1.1 255.255.255.0
     ipv6 address FC00:1::1/64
     arp generate-rd-table enable
     arp broadcast-detect enable
     mac-address 0000-5e00-0101
     ipv6 nd collect host enable
     ipv6 nd generate-rd-table enable
     vxlan anycast-gateway enable
     arp collect host enable
    #
    interface Vbdif20
     ip binding vpn-instance vpn1
     ipv6 enable
     ip address 10.2.1.1 255.255.255.0
     ipv6 address FC00:2::1/64
     arp generate-rd-table enable
     arp broadcast-detect enable
     mac-address 0000-5e00-0102
     ipv6 nd collect host enable
     ipv6 nd generate-rd-table enable
     vxlan anycast-gateway enable
     arp collect host enable
    #
    interface Vbdif30
     ip binding vpn-instance vpn1
     ipv6 enable
     ip address 10.3.1.1 255.255.255.0
     ipv6 address FC00:3::1/64
     arp generate-rd-table enable
     arp broadcast-detect enable
     mac-address 0000-5e00-0103
     ipv6 nd collect host enable
     ipv6 nd generate-rd-table enable
     vxlan anycast-gateway enable
     arp collect host enable
    #
    interface Vbdif40
     ip binding vpn-instance vpn1
     ipv6 enable
     ip address 10.4.1.1 255.255.255.0
     ipv6 address FC00:4::1/64
     arp generate-rd-table enable
     arp broadcast-detect enable
     mac-address 0000-5e00-0104
     ipv6 nd collect host enable
     ipv6 nd generate-rd-table enable
     vxlan anycast-gateway enable
     arp collect host enable
    #
    interface Eth-Trunk1
     mode lacp-static
     peer-link 1
    #
    interface Eth-Trunk10
     stp edged-port enable                                                          
     mode lacp-static
     dfs-group 1 m-lag 1
    #
    interface Eth-Trunk10.10 mode l2
     encapsulation dot1q vid 10 
     bridge-domain 10 
    #
    interface Eth-Trunk11
     stp edged-port enable                                                          
     mode lacp-static
     dfs-group 1 m-lag 2
    #
    interface Eth-Trunk11.20 mode l2
     encapsulation dot1q vid 20 
     bridge-domain 20 
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.1.2 255.255.255.0
     ospf network-type p2p
     ospf peer hold-max-cost timer 600000
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 192.168.5.2 255.255.255.0
     ospf network-type p2p
     ospf peer hold-max-cost timer 600000
    #
    interface 10GE1/0/3
     eth-trunk 1
    #
    interface 10GE1/0/4
     eth-trunk 1
    #
    interface 10GE1/0/5
     eth-trunk 10
    #
    interface 10GE1/0/6
     eth-trunk 11
    #
    interface LoopBack0
     ip address 5.5.5.5 255.255.255.255
    #
    interface LoopBack1
     ip address 1.1.1.1 255.255.255.255
    #
    interface Nve1
     source 5.5.5.5
     vni 110 head-end peer-list protocol bgp
     vni 120 head-end peer-list protocol bgp
     vni 130 head-end peer-list protocol bgp
     vni 140 head-end peer-list protocol bgp
     mac-address 0000-5e00-0111
    #
    monitor-link group 1
     port 10GE1/0/1 uplink
     port 10GE1/0/2 uplink
     port Eth-Trunk10 downlink 1
     port Eth-Trunk11 downlink 2 
    # 
    bfd toipu1_v4 bind peer-ip 10.1.1.2 vpn-instance vpn1 interface Vbdif10 one-arm-echo
     discriminator local 10
     detect-multiplier 6 
     min-echo-rx-interval 300
    #
    bfd toipu1_v6 bind peer-ipv6 FC00:1::2 vpn-instance vpn1 interface Vbdif10 one-arm-echo
     discriminator local 50
     detect-multiplier 6 
     min-echo-rx-interval 300
    #
    bfd toipu2_v4 bind peer-ip 10.2.1.2 vpn-instance vpn1 interface Vbdif20 one-arm-echo
     discriminator local 30
     detect-multiplier 6 
     min-echo-rx-interval 300
    #
    bfd toipu2_v6 bind peer-ipv6 FC00:2::2 vpn-instance vpn1 interface Vbdif20 one-arm-echo
     discriminator local 70
     detect-multiplier 6 
     min-echo-rx-interval 300
    #
    bgp 100
     peer 7.7.7.7 as-number 100
     peer 7.7.7.7 connect-interface LoopBack1
     peer 8.8.8.8 as-number 100
     peer 8.8.8.8 connect-interface LoopBack1
     #
     ipv4-family unicast
      peer 7.7.7.7 enable
      peer 8.8.8.8 enable
     #
     ipv4-family vpn-instance vpn1
      preference 60 60 60
      import-route static
      maximum load-balancing 128
      irb asymmetric
      advertise l2vpn evpn import-route-multipath
     #
     ipv6-family vpn-instance vpn1
      preference 60 60 60
      import-route static
      maximum load-balancing 128
      irb asymmetric
      advertise l2vpn evpn import-route-multipath
     #
     l2vpn-family evpn
      policy vpn-target
      bestroute add-path path-number 64 
      peer 7.7.7.7 enable
      peer 7.7.7.7 advertise irb
      peer 7.7.7.7 advertise irbv6
      peer 7.7.7.7 capability-advertise add-path both
      peer 7.7.7.7 advertise add-path path-number 64
      peer 8.8.8.8 enable
      peer 8.8.8.8 advertise irb
      peer 8.8.8.8 advertise irbv6
      peer 8.8.8.8 capability-advertise add-path both
      peer 8.8.8.8 advertise add-path path-number 64
    #
    ospf 1
     area 0.0.0.0
      network 1.1.1.1 0.0.0.0
      network 5.5.5.5 0.0.0.0
      network 192.168.1.0 0.0.0.255
      network 192.168.5.0 0.0.0.255
    #
    route-policy sp_v4 permit node 10
     if-match tag 1000
     apply gateway-ip origin-nexthop
    #
    route-policy sp_v4 deny node 20
    #
    route-policy sp_v6 permit node 10
     if-match tag 2000
     apply ipv6 gateway-ip origin-nexthop
    #
    route-policy sp_v6 deny node 20
    #
    ip route-static vpn-instance vpn1 201.1.1.1 255.255.255.255 10.1.1.2 tag 1000 track bfd-session toipu1_v4 inter-protocol-ecmp
    ip route-static vpn-instance vpn1 201.1.1.1 255.255.255.255 10.2.1.2 tag 1000 track bfd-session toipu2_v4 inter-protocol-ecmp
    #
    ipv6 route-static vpn-instance vpn1 201::1 128 FC00:1::2 tag 2000 track bfd-session toipu1_v6 inter-protocol-ecmp
    ipv6 route-static vpn-instance vpn1 201::1 128 FC00:2::2 tag 2000 track bfd-session toipu2_v6 inter-protocol-ecmp
    #
    return
  • Leaf2 configuration file
    #
    sysname Leaf2
    #
    dfs-group 1
     source ip 2.2.2.2 
     m-lag up-delay 240 auto-recovery interval 10
    #
    assign forward layer-3 resource large-overlay
    #
    assign forward ipv6 longer-mask resource share-mode
    #
    stp mode rstp 
    stp v-stp enable 
    #
    evpn-overlay enable
    #
    ip vpn-instance vpn1
     ipv4-family
      route-distinguisher 2.2.2.2:1
      export route-policy sp_v4 evpn
      vpn-target 0:1 export-extcommunity evpn
      vpn-target 0:1 import-extcommunity evpn
     ipv6-family 
      route-distinguisher 2.2.2.2:1
      export route-policy sp_v6 evpn
      vpn-target 0:1 export-extcommunity evpn
      vpn-target 0:1 import-extcommunity evpn
     vxlan vni 200
    #
    bfd
     bfd forwarding match remote-discriminator 10
     bfd forwarding match remote-discriminator 30
     bfd forwarding match remote-discriminator 50
     bfd forwarding match remote-discriminator 70
    #
    bridge-domain 10
     vxlan vni 110
     evpn
      route-distinguisher 2.2.2.2:110
      vpn-target 0:110 export-extcommunity
      vpn-target 0:1 export-extcommunity
      vpn-target 0:110 import-extcommunity
    #
    bridge-domain 20
     vxlan vni 120
     evpn
      route-distinguisher 2.2.2.2:120
      vpn-target 0:120 export-extcommunity
      vpn-target 0:1 export-extcommunity
      vpn-target 0:120 import-extcommunity
    #
    bridge-domain 30
     vxlan vni 130
     evpn
      route-distinguisher 2.2.2.2:130
      vpn-target 0:130 export-extcommunity
      vpn-target 0:1 export-extcommunity
      vpn-target 0:130 import-extcommunity
    #
    bridge-domain 40
     vxlan vni 140
     evpn
      route-distinguisher 2.2.2.2:140
      vpn-target 0:140 export-extcommunity
      vpn-target 0:1 export-extcommunity
      vpn-target 0:140 import-extcommunity
    #
    interface Vbdif10
     ip binding vpn-instance vpn1
     ipv6 enable
     ip address 10.1.1.1 255.255.255.0
     ipv6 address FC00:1::1/64
     arp generate-rd-table enable
     arp broadcast-detect enable
     mac-address 0000-5e00-0101
     ipv6 nd collect host enable
     ipv6 nd generate-rd-table enable
     vxlan anycast-gateway enable
     arp collect host enable
    #
    interface Vbdif20
     ip binding vpn-instance vpn1
     ipv6 enable
     ip address 10.2.1.1 255.255.255.0
     ipv6 address FC00:2::1/64
     arp generate-rd-table enable
     arp broadcast-detect enable
     mac-address 0000-5e00-0102
     ipv6 nd collect host enable
     ipv6 nd generate-rd-table enable
     vxlan anycast-gateway enable
     arp collect host enable
    #
    interface Vbdif30
     ip binding vpn-instance vpn1
     ipv6 enable
     ip address 10.3.1.1 255.255.255.0
     ipv6 address FC00:3::1/64
     arp generate-rd-table enable
     arp broadcast-detect enable
     mac-address 0000-5e00-0103
     ipv6 nd collect host enable
     ipv6 nd generate-rd-table enable
     vxlan anycast-gateway enable
     arp collect host enable
    #
    interface Vbdif40
     ip binding vpn-instance vpn1
     ipv6 enable
     ip address 10.4.1.1 255.255.255.0
     ipv6 address FC00:4::1/64
     arp generate-rd-table enable
     arp broadcast-detect enable
     mac-address 0000-5e00-0104
     ipv6 nd collect host enable
     ipv6 nd generate-rd-table enable
     vxlan anycast-gateway enable
     arp collect host enable
    #
    interface Eth-Trunk1
     mode lacp-static
     peer-link 1
    #
    interface Eth-Trunk10
     stp edged-port enable                                                          
     mode lacp-static
     dfs-group 1 m-lag 1
    #
    interface Eth-Trunk10.10 mode l2
     encapsulation dot1q vid 10 
     bridge-domain 10 
    #
    interface Eth-Trunk11
     stp edged-port enable                                                          
     mode lacp-static
     dfs-group 1 m-lag 2
    #
    interface Eth-Trunk11.20 mode l2
     encapsulation dot1q vid 20 
     bridge-domain 20 
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.2.2 255.255.255.0
     ospf network-type p2p
     ospf peer hold-max-cost timer 600000
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 192.168.6.2 255.255.255.0
     ospf network-type p2p
     ospf peer hold-max-cost timer 600000
    #
    interface 10GE1/0/3
     eth-trunk 1
    #
    interface 10GE1/0/4
     eth-trunk 1
    #
    interface 10GE1/0/5
     eth-trunk 10
    #
    interface 10GE1/0/6
     eth-trunk 11
    #
    interface LoopBack0
     ip address 5.5.5.5 255.255.255.255
    #
    interface LoopBack1
     ip address 2.2.2.2 255.255.255.255
    #
    interface Nve1
     source 5.5.5.5
     vni 110 head-end peer-list protocol bgp
     vni 120 head-end peer-list protocol bgp
     vni 130 head-end peer-list protocol bgp
     vni 140 head-end peer-list protocol bgp
     mac-address 0000-5e00-0111
    #
    monitor-link group 1
     port 10GE1/0/1 uplink
     port 10GE1/0/2 uplink
     port Eth-Trunk10 downlink 1
     port Eth-Trunk11 downlink 2 
    # 
    bfd toipu1_v4 bind peer-ip 10.1.1.2 vpn-instance vpn1 interface Vbdif10 one-arm-echo
     discriminator local 20
     detect-multiplier 6 
     min-echo-rx-interval 300
    #
    bfd toipu1_v6 bind peer-ipv6 FC00:1::2 vpn-instance vpn1 interface Vbdif10 one-arm-echo
     discriminator local 60
     detect-multiplier 6 
     min-echo-rx-interval 300
    #
    bfd toipu2_v4 bind peer-ip 10.2.1.2 vpn-instance vpn1 interface Vbdif20 one-arm-echo
     discriminator local 40
     detect-multiplier 6 
     min-echo-rx-interval 300
    #
    bfd toipu2_v6 bind peer-ipv6 FC00:2::2 vpn-instance vpn1 interface Vbdif20 one-arm-echo
     discriminator local 80
     detect-multiplier 6 
     min-echo-rx-interval 300
    #
    bgp 100
     peer 7.7.7.7 as-number 100
     peer 7.7.7.7 connect-interface LoopBack1
     peer 8.8.8.8 as-number 100
     peer 8.8.8.8 connect-interface LoopBack1
     #
     ipv4-family unicast
      peer 7.7.7.7 enable
      peer 8.8.8.8 enable
     #
     ipv4-family vpn-instance vpn1
      preference 60 60 60
      import-route static
      maximum load-balancing 128
      irb asymmetric
      advertise l2vpn evpn import-route-multipath
     #
     ipv6-family vpn-instance vpn1
      preference 60 60 60
      import-route static
      maximum load-balancing 128
      irb asymmetric
      advertise l2vpn evpn import-route-multipath
     #
     l2vpn-family evpn
      policy vpn-target
      bestroute add-path path-number 64 
      peer 7.7.7.7 enable
      peer 7.7.7.7 advertise irb
      peer 7.7.7.7 advertise irbv6
      peer 7.7.7.7 capability-advertise add-path both
      peer 7.7.7.7 advertise add-path path-number 64
      peer 8.8.8.8 enable
      peer 8.8.8.8 advertise irb
      peer 8.8.8.8 advertise irbv6
      peer 8.8.8.8 capability-advertise add-path both
      peer 8.8.8.8 advertise add-path path-number 64
    #
    ospf 1
     area 0.0.0.0
      network 2.2.2.2 0.0.0.0
      network 5.5.5.5 0.0.0.0
      network 192.168.2.0 0.0.0.255
      network 192.168.6.0 0.0.0.255
    #
    route-policy sp_v4 permit node 10
     if-match tag 1000
     apply gateway-ip origin-nexthop
    #
    route-policy sp_v4 deny node 20
    #
    route-policy sp_v6 permit node 10
     if-match tag 2000
     apply ipv6 gateway-ip origin-nexthop
    #
    route-policy sp_v6 deny node 20
    #
    ip route-static vpn-instance vpn1 201.1.1.1 255.255.255.255 10.1.1.2 tag 1000 track bfd-session toipu1_v4 inter-protocol-ecmp
    ip route-static vpn-instance vpn1 201.1.1.1 255.255.255.255 10.2.1.2 tag 1000 track bfd-session toipu2_v4 inter-protocol-ecmp
    #
    ipv6 route-static vpn-instance vpn1 201::1 128 FC00:1::2 tag 2000 track bfd-session toipu1_v6 inter-protocol-ecmp
    ipv6 route-static vpn-instance vpn1 201::1 128 FC00:2::2 tag 2000 track bfd-session toipu2_v6 inter-protocol-ecmp
    #
    return
  • Leaf3 configuration file
    #
    sysname Leaf3
    #
    dfs-group 1
     priority 150
     source ip 3.3.3.3 
     m-lag up-delay 240 auto-recovery interval 10
    #
    assign forward layer-3 resource large-overlay
    #
    assign forward ipv6 longer-mask resource share-mode
    #
    stp mode rstp 
    stp v-stp enable 
    #
    evpn-overlay enable
    #
    ip vpn-instance vpn1
     ipv4-family
      route-distinguisher 3.3.3.3:1
      export route-policy sp_v4 evpn
      vpn-target 0:1 export-extcommunity evpn
      vpn-target 0:1 import-extcommunity evpn
     ipv6-family 
      route-distinguisher 1.1.1.1:1
      export route-policy sp_v6 evpn
      vpn-target 0:1 export-extcommunity evpn
      vpn-target 0:1 import-extcommunity evpn
     vxlan vni 200
    #
    bfd
     bfd forwarding match remote-discriminator 20
     bfd forwarding match remote-discriminator 40
     bfd forwarding match remote-discriminator 60
     bfd forwarding match remote-discriminator 80
    #
    bridge-domain 10
     vxlan vni 110
     evpn
      route-distinguisher 3.3.3.3:110
      vpn-target 0:110 export-extcommunity
      vpn-target 0:1 export-extcommunity
      vpn-target 0:110 import-extcommunity
    #
    bridge-domain 20
     vxlan vni 120
     evpn
      route-distinguisher 3.3.3.3:120
      vpn-target 0:120 export-extcommunity
      vpn-target 0:1 export-extcommunity
      vpn-target 0:120 import-extcommunity
    #
    bridge-domain 30
     vxlan vni 130
     evpn
      route-distinguisher 3.3.3.3:130
      vpn-target 0:130 export-extcommunity
      vpn-target 0:1 export-extcommunity
      vpn-target 0:130 import-extcommunity
    #
    bridge-domain 40
     vxlan vni 140
     evpn
      route-distinguisher 3.3.3.3:140
      vpn-target 0:140 export-extcommunity
      vpn-target 0:1 export-extcommunity
      vpn-target 0:140 import-extcommunity
    #
    interface Vbdif10
     ip binding vpn-instance vpn1
     ipv6 enable
     ip address 10.1.1.1 255.255.255.0
     ipv6 address FC00:1::1/64
     arp generate-rd-table enable
     arp broadcast-detect enable
     mac-address 0000-5e00-0101
     ipv6 nd collect host enable
     ipv6 nd generate-rd-table enable
     vxlan anycast-gateway enable
     arp collect host enable
    #
    interface Vbdif20
     ip binding vpn-instance vpn1
     ipv6 enable
     ip address 10.2.1.1 255.255.255.0
     ipv6 address FC00:2::1/64
     arp generate-rd-table enable
     arp broadcast-detect enable
     mac-address 0000-5e00-0102
     ipv6 nd collect host enable
     ipv6 nd generate-rd-table enable
     vxlan anycast-gateway enable
     arp collect host enable
    #
    interface Vbdif30
     ip binding vpn-instance vpn1
     ipv6 enable
     ip address 10.3.1.1 255.255.255.0
     ipv6 address FC00:3::1/64
     arp generate-rd-table enable
     arp broadcast-detect enable
     mac-address 0000-5e00-0103
     ipv6 nd collect host enable
     ipv6 nd generate-rd-table enable
     vxlan anycast-gateway enable
     arp collect host enable
    #
    interface Vbdif40
     ip binding vpn-instance vpn1
     ipv6 enable
     ip address 10.4.1.1 255.255.255.0
     ipv6 address FC00:4::1/64
     arp generate-rd-table enable
     arp broadcast-detect enable
     mac-address 0000-5e00-0104
     ipv6 nd collect host enable
     ipv6 nd generate-rd-table enable
     vxlan anycast-gateway enable
     arp collect host enable
    #
    interface Eth-Trunk1
     mode lacp-static
     peer-link 1
    #
    interface Eth-Trunk10
     stp edged-port enable                                                          
     mode lacp-static
     dfs-group 1 m-lag 1
    #
    interface Eth-Trunk10.30 mode l2
     encapsulation dot1q vid 30 
     bridge-domain 30 
    #
    interface Eth-Trunk11
     stp edged-port enable                                                          
     mode lacp-static
     dfs-group 1 m-lag 2
    #
    interface Eth-Trunk11.40 mode l2
     encapsulation dot1q vid 40 
     bridge-domain 40 
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.3.2 255.255.255.0
     ospf network-type p2p
     ospf peer hold-max-cost timer 600000
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 192.168.7.2 255.255.255.0
     ospf network-type p2p
     ospf peer hold-max-cost timer 600000
    #
    interface 10GE1/0/3
     eth-trunk 1
    #
    interface 10GE1/0/4
     eth-trunk 1
    #
    interface 10GE1/0/5
     eth-trunk 10
    #
    interface 10GE1/0/6
     eth-trunk 11
    #
    interface LoopBack0
     ip address 6.6.6.6 255.255.255.255
    #
    interface LoopBack1
     ip address 3.3.3.3 255.255.255.255
    #
    interface Nve1
     source 6.6.6.6
     vni 110 head-end peer-list protocol bgp
     vni 120 head-end peer-list protocol bgp
     vni 130 head-end peer-list protocol bgp
     vni 140 head-end peer-list protocol bgp
     mac-address 0000-5e00-0112
    #
    monitor-link group 1
     port 10GE1/0/1 uplink
     port 10GE1/0/2 uplink
     port Eth-Trunk10 downlink 1
     port Eth-Trunk11 downlink 2 
    # 
    bfd toipu3_v4 bind peer-ip 10.3.1.2 vpn-instance vpn1 interface Vbdif30 one-arm-echo
     discriminator local 10
     detect-multiplier 6 
     min-echo-rx-interval 300
    #
    bfd toipu3_v6 bind peer-ipv6 FC00:3::2 vpn-instance vpn1 interface Vbdif30 one-arm-echo
     discriminator local 50
     detect-multiplier 6 
     min-echo-rx-interval 300
    #
    bfd toipu4_v4 bind peer-ip 10.4.1.2 vpn-instance vpn1 interface Vbdif40 one-arm-echo
     discriminator local 30
     detect-multiplier 6 
     min-echo-rx-interval 300
    #
    bfd toipu4_v6 bind peer-ipv6 FC00:4::2 vpn-instance vpn1 interface Vbdif40 one-arm-echo
     discriminator local 70
     detect-multiplier 6 
     min-echo-rx-interval 300
    #
    bgp 100
     peer 7.7.7.7 as-number 100
     peer 7.7.7.7 connect-interface LoopBack1
     peer 8.8.8.8 as-number 100
     peer 8.8.8.8 connect-interface LoopBack1
     #
     ipv4-family unicast
      peer 7.7.7.7 enable
      peer 8.8.8.8 enable
     #
     ipv4-family vpn-instance vpn1
      preference 60 60 60
      import-route static
      maximum load-balancing 128
      irb asymmetric
      advertise l2vpn evpn import-route-multipath
     #
     ipv6-family vpn-instance vpn1
      preference 60 60 60
      import-route static
      maximum load-balancing 128
      irb asymmetric
      advertise l2vpn evpn import-route-multipath
     #
     l2vpn-family evpn
      policy vpn-target
      bestroute add-path path-number 64 
      peer 7.7.7.7 enable
      peer 7.7.7.7 advertise irb
      peer 7.7.7.7 advertise irbv6
      peer 7.7.7.7 capability-advertise add-path both
      peer 7.7.7.7 advertise add-path path-number 64
      peer 8.8.8.8 enable
      peer 8.8.8.8 advertise irb
      peer 8.8.8.8 advertise irbv6
      peer 8.8.8.8 capability-advertise add-path both
      peer 8.8.8.8 advertise add-path path-number 64
    #
    ospf 1
     area 0.0.0.0
      network 3.3.3.3 0.0.0.0
      network 6.6.6.6 0.0.0.0
      network 192.168.3.0 0.0.0.255
      network 192.168.7.0 0.0.0.255
    #
    route-policy sp_v4 permit node 10
     if-match tag 1000
     apply gateway-ip origin-nexthop
    #
    route-policy sp_v4 deny node 20
    #
    route-policy sp_v6 permit node 10
     if-match tag 2000
     apply ipv6 gateway-ip origin-nexthop
    #
    route-policy sp_v6 deny node 20
    #
    ip route-static vpn-instance vpn1 202.1.1.1 255.255.255.255 10.3.1.2 tag 1000 track bfd-session toipu3_v4 inter-protocol-ecmp
    ip route-static vpn-instance vpn1 202.1.1.1 255.255.255.255 10.4.1.2 tag 1000 track bfd-session toipu4_v4 inter-protocol-ecmp
    #
    ipv6 route-static vpn-instance vpn1 202::1 128 FC00:3::2 tag 2000 track bfd-session toipu3_v6 inter-protocol-ecmp
    ipv6 route-static vpn-instance vpn1 202::1 128 FC00:4::2 tag 2000 track bfd-session toipu4_v6 inter-protocol-ecmp
    #
    return
  • Leaf4 configuration file
    #
    sysname Leaf4
    #
    dfs-group 1
     source ip 4.4.4.4 
     m-lag up-delay 240 auto-recovery interval 10
    #
    assign forward layer-3 resource large-overlay
    #
    assign forward ipv6 longer-mask resource share-mode
    #
    stp mode rstp 
    stp v-stp enable 
    #
    evpn-overlay enable
    #
    ip vpn-instance vpn1
     ipv4-family
      route-distinguisher 4.4.4.4:1
      export route-policy sp_v4 evpn
      vpn-target 0:1 export-extcommunity evpn
      vpn-target 0:1 import-extcommunity evpn
     ipv6-family 
      route-distinguisher 1.1.1.1:1
      export route-policy sp_v6 evpn
      vpn-target 0:1 export-extcommunity evpn
      vpn-target 0:1 import-extcommunity evpn
     vxlan vni 200
    #
    bfd
     bfd forwarding match remote-discriminator 10
     bfd forwarding match remote-discriminator 30
     bfd forwarding match remote-discriminator 50
     bfd forwarding match remote-discriminator 70
    #
    bridge-domain 10
     vxlan vni 110
     evpn
      route-distinguisher 4.4.4.4:110
      vpn-target 0:110 export-extcommunity
      vpn-target 0:1 export-extcommunity
      vpn-target 0:110 import-extcommunity
    #
    bridge-domain 20
     vxlan vni 120
     evpn
      route-distinguisher 4.4.4.4:120
      vpn-target 0:120 export-extcommunity
      vpn-target 0:1 export-extcommunity
      vpn-target 0:120 import-extcommunity
    #
    bridge-domain 30
     vxlan vni 130
     evpn
      route-distinguisher 4.4.4.4:130
      vpn-target 0:130 export-extcommunity
      vpn-target 0:1 export-extcommunity
      vpn-target 0:130 import-extcommunity
    #
    bridge-domain 40
     vxlan vni 140
     evpn
      route-distinguisher 4.4.4.4:140
      vpn-target 0:140 export-extcommunity
      vpn-target 0:1 export-extcommunity
      vpn-target 0:140 import-extcommunity
    #
    interface Vbdif10
     ip binding vpn-instance vpn1
     ipv6 enable
     ip address 10.1.1.1 255.255.255.0
     ipv6 address FC00:1::1/64
     arp generate-rd-table enable
     arp broadcast-detect enable
     mac-address 0000-5e00-0101
     ipv6 nd collect host enable
     ipv6 nd generate-rd-table enable
     vxlan anycast-gateway enable
     arp collect host enable
    #
    interface Vbdif20
     ip binding vpn-instance vpn1
     ipv6 enable
     ip address 10.2.1.1 255.255.255.0
     ipv6 address FC00:2::1/64
     arp generate-rd-table enable
     arp broadcast-detect enable
     mac-address 0000-5e00-0102
     ipv6 nd collect host enable
     ipv6 nd generate-rd-table enable
     vxlan anycast-gateway enable
     arp collect host enable
    #
    interface Vbdif30
     ip binding vpn-instance vpn1
     ipv6 enable
     ip address 10.3.1.1 255.255.255.0
     ipv6 address FC00:3::1/64
     arp generate-rd-table enable
     arp broadcast-detect enable
     mac-address 0000-5e00-0103
     ipv6 nd collect host enable
     ipv6 nd generate-rd-table enable
     vxlan anycast-gateway enable
     arp collect host enable
    #
    interface Vbdif40
     ip binding vpn-instance vpn1
     ipv6 enable
     ip address 10.4.1.1 255.255.255.0
     ipv6 address FC00:4::1/64
     arp generate-rd-table enable
     arp broadcast-detect enable
     mac-address 0000-5e00-0104
     ipv6 nd collect host enable
     ipv6 nd generate-rd-table enable
     vxlan anycast-gateway enable
     arp collect host enable
    #
    interface Eth-Trunk1
     mode lacp-static
     peer-link 1
    #
    interface Eth-Trunk10
     stp edged-port enable                                                          
     mode lacp-static
     dfs-group 1 m-lag 1
    #
    interface Eth-Trunk10.30 mode l2
     encapsulation dot1q vid 30 
     bridge-domain 30 
    #
    interface Eth-Trunk11
     stp edged-port enable                                                          
     mode lacp-static
     dfs-group 1 m-lag 2
    #
    interface Eth-Trunk11.40 mode l2
     encapsulation dot1q vid 40 
     bridge-domain 40 
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.4.2 255.255.255.0
     ospf network-type p2p
     ospf peer hold-max-cost timer 600000
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 192.168.8.2 255.255.255.0
     ospf network-type p2p
     ospf peer hold-max-cost timer 600000
    #
    interface 10GE1/0/3
     eth-trunk 1
    #
    interface 10GE1/0/4
     eth-trunk 1
    #
    interface 10GE1/0/5
     eth-trunk 10
    #
    interface 10GE1/0/6
     eth-trunk 11
    #
    interface LoopBack0
     ip address 6.6.6.6 255.255.255.255
    #
    interface LoopBack1
     ip address 4.4.4.4 255.255.255.255
    #
    interface Nve1
     source 6.6.6.6
     vni 110 head-end peer-list protocol bgp
     vni 120 head-end peer-list protocol bgp
     vni 130 head-end peer-list protocol bgp
     vni 140 head-end peer-list protocol bgp
     mac-address 0000-5e00-0112
    #
    monitor-link group 1
     port 10GE1/0/1 uplink
     port 10GE1/0/2 uplink
     port Eth-Trunk10 downlink 1
     port Eth-Trunk11 downlink 2 
    # 
    bfd toipu3_v4 bind peer-ip 10.3.1.2 vpn-instance vpn1 interface Vbdif30 one-arm-echo
     discriminator local 20
     detect-multiplier 6 
     min-echo-rx-interval 300
    #
    bfd toipu3_v6 bind peer-ipv6 FC00:3::2 vpn-instance vpn1 interface Vbdif30 one-arm-echo
     discriminator local 60
     detect-multiplier 6 
     min-echo-rx-interval 300
    #
    bfd toipu4_v4 bind peer-ip 10.4.1.2 vpn-instance vpn1 interface Vbdif40 one-arm-echo
     discriminator local 40
     detect-multiplier 6 
     min-echo-rx-interval 300
    #
    bfd toipu4_v6 bind peer-ipv6 FC00:4::2 vpn-instance vpn1 interface Vbdif40 one-arm-echo
     discriminator local 80
     detect-multiplier 6 
     min-echo-rx-interval 300
    #
    bgp 100
     peer 7.7.7.7 as-number 100
     peer 7.7.7.7 connect-interface LoopBack1
     peer 8.8.8.8 as-number 100
     peer 8.8.8.8 connect-interface LoopBack1
     #
     ipv4-family unicast
      peer 7.7.7.7 enable
      peer 8.8.8.8 enable
     #
     ipv4-family vpn-instance vpn1
      preference 60 60 60
      import-route static
      maximum load-balancing 128
      irb asymmetric
      advertise l2vpn evpn import-route-multipath
     #
     ipv6-family vpn-instance vpn1
      preference 60 60 60
      import-route static
      maximum load-balancing 128
      irb asymmetric
      advertise l2vpn evpn import-route-multipath
     #
     l2vpn-family evpn
      policy vpn-target
      bestroute add-path path-number 64 
      peer 7.7.7.7 enable
      peer 7.7.7.7 advertise irb
      peer 7.7.7.7 advertise irbv6
      peer 7.7.7.7 capability-advertise add-path both
      peer 7.7.7.7 advertise add-path path-number 64
      peer 8.8.8.8 enable
      peer 8.8.8.8 advertise irb
      peer 8.8.8.8 advertise irbv6
      peer 8.8.8.8 capability-advertise add-path both
      peer 8.8.8.8 advertise add-path path-number 64
    #
    ospf 1
     area 0.0.0.0
      network 4.4.4.4 0.0.0.0
      network 6.6.6.6 0.0.0.0
      network 192.168.4.0 0.0.0.255
      network 192.168.8.0 0.0.0.255
    #
    route-policy sp_v4 permit node 10
     if-match tag 1000
     apply gateway-ip origin-nexthop
    #
    route-policy sp_v4 deny node 20
    #
    route-policy sp_v6 permit node 10
     if-match tag 2000
     apply ipv6 gateway-ip origin-nexthop
    #
    route-policy sp_v6 deny node 20
    #
    ip route-static vpn-instance vpn1 202.1.1.1 255.255.255.255 10.3.1.2 tag 1000 track bfd-session toipu3_v4 inter-protocol-ecmp
    ip route-static vpn-instance vpn1 202.1.1.1 255.255.255.255 10.4.1.2 tag 1000 track bfd-session toipu4_v4 inter-protocol-ecmp
    #
    ipv6 route-static vpn-instance vpn1 202::1 128 FC00:3::2 tag 2000 track bfd-session toipu3_v6 inter-protocol-ecmp
    ipv6 route-static vpn-instance vpn1 202::1 128 FC00:4::2 tag 2000 track bfd-session toipu4_v6 inter-protocol-ecmp
    #
    return
Download
Updated: 2019-04-03

Document ID: EDOC1000039339

Views: 106119

Downloads: 7475

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next