No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Typical Configuration Examples

CloudEngine 12800, 12800E, 8800, 7800, 6800, and 5800 Series Switches

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IPv4 Layer 3 Multicast Over VXLAN When the Multicast Source is Located on an External Network

Example for Configuring IPv4 Layer 3 Multicast Over VXLAN When the Multicast Source is Located on an External Network

Applicable Products and Versions

This example applies to CE12800, CE8800, CE7800, and CE6800 series switches running V200R005C10 or later versions. (A switch running V200R005C00 cannot function as a border leaf switch when configured with the IP multicast over VXLAN function.) The CE12800E, CE6880EI, CE6850EI, CE6810EI, and CE6810LI do not support IPv4 Layer 3 multicast over VXLAN.

The CE8860EI, CE8850EI, CE7855EI, CE7850EI, CE6860EI, CE6856HI, CE6855HI, CE6851HI, CE6850HI, and CE6850U-HI cannot function as border leaf switches.

Networking Requirements

On the IPv4 network shown in Networking diagram for configuring IPv4 Layer 3 multicast over VXLAN when the multicast source is located on an external network, Borderleaf1, Borderleaf2, Leaf1, and Leaf2 function as distributed VXLAN gateways. In addition, the two border leaf switches and two leaf switches set up two M-LAG systems to ensure high reliability. The multicast source is located on the external network, and the multicast receiver is located on the VXLAN overlay network. The multicast source is directly connected to the CE. The CE is connected to the VXLAN network through the active-active gateways Borderleaf1 and Borderleaf2. The multicast receiver is connected to the VXLAN network through Layer 2 sub-interfaces on the active-active gateways Leaf1 and Leaf2, and belongs to BD 10. The multicast receiver orders a program without specifying the multicast source. The multicast group address is 225.1.1.1.

To meet these requirements, configure IPv4 Layer3 multicast on the VXLAN network where distributed gateways are deployed.

Figure 1-35 Networking diagram for configuring IPv4 Layer 3 multicast over VXLAN when the multicast source is located on an external network
Table 1-18 Data plan

Device

Interface

IP Address

Device to Connect

CE

10GE1/0/1

192.168.10.2/24

Source

10GE1/0/2

192.168.20.2/24

Borderleaf1

10GE1/0/3

192.168.30.2/24

Borderleaf2

Borderleaf1

10GE1/0/1

10.1.1.1/24

Spine1

10GE1/0/2

192.168.20.1/24

CE

VLANIF 3000

10.10.21.1/24

Borderleaf2

10GE1/0/3

10.1.11.1/24

Spine2

10GE1/0/6.1

10.6.1.1/24

Borderleaf2

LoopBack1

1.1.1.1/32

NA

LoopBack2

1.1.1.110/32

NA

LoopBack3

1.1.1.10/32 (VPN RP)

NA

MEth0/0/0

10.10.11.1/24

NA

Borderleaf2

10GE1/0/1

10.1.44.1/24

Spine2

10GE1/0/2

192.168.30.1/24

CE

VLANIF 3000

10.10.21.2/24

Borderleaf1

10GE1/0/3

10.1.4.1/24

Spine1

10GE1/0/6.1

10.6.1.2/24

Borderleaf1

LoopBack1

2.2.2.2/32

NA

LoopBack2

1.1.1.110/32

NA

MEth0/0/0

10.10.11.2/24

NA

Spine1

10GE1/0/1

10.1.1.2/24

Borderleaf1

10GE1/0/2

10.1.2.2/24

Leaf1

10GE1/0/3

10.1.3.2/24

Leaf2

10GE1/0/4

10.1.4.2/24

Borderleaf2

LoopBack1

5.5.5.5/32 (public network RP)

NA

LoopBack2

5.5.5.1/32

NA

Spine2

10GE1/0/1

10.1.11.2/24

Borderleaf1

10GE1/0/2

10.1.22.2/24

Leaf1

10GE1/0/3

10.1.33.2/24

Leaf2

10GE1/0/4

10.1.44.2/24

Borderleaf2

LoopBack1

5.5.5.5/32 (public network RP)

NA

LoopBack2

5.5.5.2/32

NA

Leaf1

10GE1/0/1

10.1.2.1/24

Spine1

VBDIF 10

192.168.60.1/24

Receiver

VLANIF 4000

10.10.20.1/24

Leaf2

10GE1/0/6

10.1.22.1/24

Spine2

LoopBack1

3.3.3.3/32

NA

LoopBack2

2.2.2.210/32

NA

MEth0/0/0

10.10.10.1/24

NA

Leaf2

10GE1/0/1

10.1.33.1/24

Spine1

VBDIF 10

192.168.60.1/24

Receiver

VLANIF 4000

10.10.20.2/24

Leaf1

10GE1/0/6

10.1.3.1/24

Spine1

LoopBack1

4.4.4.4/32

NA

LoopBack2

2.2.2.210/32

NA

MEth0/0/0

10.10.10.2/24

NA

Configuration Roadmap

NOTE:

To address the preceding requirements, ensure that in addition to the peer-link, there is a direct Layer 3 link between Borderleaf1 and Borderleaf2 that function as the M-LAG master and backup devices. In addition, the PIM protocol must be enabled on the Layer 3 link, and the M-LAG master and backup devices must have the same multicast configuration.

The configuration roadmap is as follows:
  1. Configure M-LAG between Borderleaf1 and Borderleaf2, and between Leaf1 and Leaf2.

  2. Configure each leaf to set up VXLAN tunnels using BGP EVPN, configure the leaf switches to function as distributed gateways, and enable the hosts connected to these leaf nodes to communicate at Layer 3 through VPN routes.

  3. Configure BUM multicast replication for the Layer 3 VNI of the L3VPN instance on each leaf.

  4. Configure BGP MVPN peer relationships between Borderleaf1, Borderleaf2, Leaf1, and Leaf2.

  5. Configure the VXLAN I-PMSI tunnel on each leaf.

  6. On the interface of each leaf that is bound to the L3VPN instance, enable PIM-SM to create a multicast routing table for the VPN.

  7. Configure IGMP on each VBDIF interface and physical interface that connect multicast devices to user subnets.

  8. Configure VPN Layer 3 multicast on Borderleaf1, Borderleaf2, and the CE.

Data Preparation

To complete the configuration, you need to prepare the following data according to Data plan:

  • VLAN ID of the receiver on the VXLAN overlay network (VLAN 10)

  • BD ID (BD 10)

  • VNI ID of the BD (VNI 10)

  • L3VPN instance name (mcast1) and VNI ID of the L3VPN instance (VNI 5010)

  • RDs of the EVPN instances (11:1 and 11:2) and RTs of the EVPN instances (12:1, 12:2, and 13:1)

  • RD of the L3VPN instance (1:1), RT of the L3VPN instance (1:1), and RT used for interoperation between the L3VPN instance and the EVPN instance (13:1)

  • Multicast group address for BUM multicast replication based on the Layer 3 VNI of the L3VPN instance (225.0.0.1)

  • MVPN ID of each leaf (IP address of the Loopback2 interface)

  • Local VPN instance ID of each leaf (1)

  • Static RP in the public network instance (5.5.5.5) and that in the VPN instance (1.1.1.10)

Procedure

  1. Configure V-STP-based M-LAG on Borderleaf1 and Borderleaf2, and configure a direct Layer 3 link between Layer 3 sub-interfaces of the M-LAG master and backup devices.

    # Configure Borderleaf1. The configuration on Borderleaf2 is similar to the configuration on Borderleaf1. For details, see the configuration file.

    <HUAWEI> system-view
    [~HUAWEI] sysname Borderleaf1
    [*HUAWEI] commit
    [~Borderleaf1] interface meth 0/0/0
    [~Borderleaf1-MEth0/0/0] ip address 10.10.11.1 24
    [*Borderleaf1-MEth0/0/0] quit
    [*Borderleaf1] stp mode rstp
    [*Borderleaf1] stp v-stp enable
    [*Borderleaf1] dfs-group 1
    [*Borderleaf1-dfs-group-1] source ip 10.10.11.1
    [*Borderleaf1-dfs-group-1] quit
    [*Borderleaf1] interface eth-trunk 2
    [*Borderleaf1-Eth-Trunk2] trunkport 10ge 1/0/4 to 1/0/5
    [*Borderleaf1-Eth-Trunk2] mode lacp-static
    [*Borderleaf1-Eth-Trunk2] peer-link 1
    [*Borderleaf1-Eth-Trunk2] quit
    [*Borderleaf1] interface 10ge 1/0/6
    [*Borderleaf1-10GE1/0/6] undo portswitch
    [*Borderleaf1-10GE1/0/6] quit
    [*Borderleaf1] commit
    [~Borderleaf1] interface 10ge 1/0/6.1
    [*Borderleaf1-10GE1/0/6.1] ip address 10.6.1.1 24
    [*Borderleaf1-10GE1/0/6.1] quit
    [*Borderleaf1] commit

  2. Configure V-STP-based M-LAG on Leaf1 and Leaf2.

    # Configure Leaf1. The configuration on Leaf2 is similar to the configuration on Leaf1. For details, see the configuration file.

    NOTE:

    If the link between Leaf1 and the VXLAN network fails, Leaf1 will discard all user traffic that reaches Leaf1, because no uplink interface is available. In this case, you can configure a Monitor Link group to associate the uplink and downlink interfaces of Leaf1. If the uplink interface of Leaf1 is Down, the downlink interface also goes Down. As a result, user-side traffic is not forwarded through Leaf1. This prevents traffic from being discarded.

    [~Leaf1] interface meth 0/0/0
    [~Leaf1-MEth0/0/0] ip address 10.10.10.1 32
    [*Leaf1-MEth0/0/0] quit
    [*Leaf1] stp mode rstp
    [*Leaf1] stp v-stp enable
    [*Leaf1] dfs-group 1
    [*Leaf1-dfs-group-1] source ip 10.10.10.1
    [*Leaf1-dfs-group-1] quit
    [*Leaf1] interface eth-trunk 1
    [*Leaf1-Eth-Trunk1] trunkport 10ge 1/0/4 to 1/0/5
    [*Leaf1-Eth-Trunk1] mode lacp-static
    [*Leaf1-Eth-Trunk1] peer-link 1
    [*Leaf1-Eth-Trunk1] quit
    [*Leaf1] interface eth-trunk 10
    [*Leaf1-Eth-Trunk10] trunkport 10ge 1/0/2 to 1/0/3
    [*Leaf1-Eth-Trunk10] mode lacp-static
    [*Leaf1-Eth-Trunk10] dfs-group 1 m-lag 1
    [*Leaf1-Eth-Trunk10] stp edged-port enable
    [*Leaf1-Eth-Trunk10] quit
    [*Leaf1] commit

  3. Assign IP addresses to the interfaces of the switches and configure a unicast routing protocol.

    # Configure IP addresses and masks for the interfaces according to Data plan, and configure OSPF on each switch to ensure that the switches can communicate at the network layer. The configurations on the CE, Borderleaf2, Leaf1, Leaf2, Spine1, and Spine2 are similar to the configuration on Borderleaf1. For details, see the configuration file.

    [~Borderleaf1] interface loopback 1
    [*Borderleaf1-LoopBack1] ip address 1.1.1.1 32
    [*Borderleaf1-LoopBack1] quit
    [~Borderleaf1] interface loopback 2
    [*Borderleaf1-LoopBack2] ip address 1.1.1.110 32
    [*Borderleaf1-LoopBack2] quit
    [*Borderleaf1] interface 10ge 1/0/1
    [*Borderleaf1-10GE1/0/1] undo portswitch
    [*Borderleaf1-10GE1/0/1] ip address 10.1.1.1 24
    [*Borderleaf1-10GE1/0/1] quit
    [*Borderleaf1] interface 10ge 1/0/3
    [*Borderleaf1-10GE1/0/3] undo portswitch
    [*Borderleaf1-10GE1/0/3] ip address 10.1.11.1 24
    [*Borderleaf1-10GE1/0/3] quit
    [*Borderleaf1] ospf
    [*Borderleaf1-ospf-1] area 0
    [*Borderleaf1-ospf-1-area-0.0.0.0] network 1.1.1.1 0.0.0.0
    [*Borderleaf1-ospf-1-area-0.0.0.0] network 1.1.1.110 0.0.0.0
    [*Borderleaf1-ospf-1-area-0.0.0.0] network 10.1.1.0 0.0.0.255
    [*Borderleaf1-ospf-1-area-0.0.0.0] network 10.1.11.0 0.0.0.255
    [*Borderleaf1-ospf-1-area-0.0.0.0] network 10.6.1.0 0.0.0.255
    [*Borderleaf1-ospf-1-area-0.0.0.0] quit
    [*Borderleaf1-ospf-1] quit
    [*Borderleaf1] commit

    After OSPF is configured successfully, the switches can learn the interface address of each other using OSPF and successfully ping each other. For example, if you ping the Loopback1 interface address of Borderleaf2 on Borderleaf1, the output is as follows:

    [~Borderleaf1] ping 2.2.2.2
      PING 2.2.2.2: 56  data bytes, press CTRL_C to break                           
        Reply from 2.2.2.2: bytes=56 Sequence=1 ttl=254 time=2 ms                   
        Reply from 2.2.2.2: bytes=56 Sequence=2 ttl=254 time=1 ms                   
        Reply from 2.2.2.2: bytes=56 Sequence=3 ttl=254 time=1 ms                   
        Reply from 2.2.2.2: bytes=56 Sequence=4 ttl=254 time=1 ms                   
        Reply from 2.2.2.2: bytes=56 Sequence=5 ttl=254 time=1 ms                   
                                                                                    
      --- 2.2.2.2 ping statistics ---                                               
        5 packet(s) transmitted                                                     
        5 packet(s) received                                                        
        0.00% packet loss                                                           
        round-trip min/avg/max = 1/1/1 ms 

  4. For CE12800 series switches, set the card interoperability mode to enhanced mode.

    NOTE:

    When the card interoperability mode is enhanced mode, only FD/FDA/FD1/FG/FG1/SD series interface cards and SFUF/SFUG can be installed on the switch. After completing the configuration, save the configuration and restart the switch for the configuration to take effect. You are advised to restart the switch after all the configurations are completed and saved. After the switch restarts, run the save command again to save the configuration.

    # Configure Borderleaf1. The configurations on the other switches are similar to the configuration on Borderleaf1. For details, see the configuration file.

    [~Borderleaf1] set forward capability enhanced
    Warning: Current configuration should be committed and saved, and it will take effect after reboot. [Y/N]: y
    [*Borderleaf1] commit

  5. Configure the VXLAN.

    # If the CE12800, CE6870EI, and CE6875EI are used as VXLAN gateways, configure the VXLAN tunnel mode and enable the VXLAN ACL extension function before configuring VXLAN. If other models are deployed as VXLAN gateways, skip this step. The configurations on Borderleaf2, Leaf1, and Leaf2 are similar to the configuration on Borderleaf1. For details, see the configuration file.

    [~Borderleaf1] ip tunnel mode vxlan
    [*Borderleaf1] assign forward nvo3 acl extend enable
    Info: The configuration will take effect after system reboot.
    [*Borderleaf1] commit
    NOTE:

    After configuring the VXLAN tunnel mode and enabling the VXLAN ACL extension function, you need to save the configuration and restart the device for the configuration to take effect. You are advised to restart the device after all the configurations are complete and saved.

    # Configure service access points on Leaf1 and Leaf2.

    Configure Leaf1. The configuration on Leaf2 is similar to the configuration on Leaf1. For details, see the configuration file.
    [~Leaf1] bridge-domain 10
    [*Leaf1-bd10] quit
    [*Leaf1] interface eth-trunk 10.1 mode l2
    [*Leaf1-Eth-Trunk10.1] encapsulation dot1q vid 10
    [*Leaf1-Eth-Trunk10.1] bridge-domain 10
    [*Leaf1-Eth-Trunk10.1] quit
    [*Leaf1] commit

    # Configure BGP EVPN on each leaf node as the VXLAN control plane protocol and configure BGP EVPN peers. The configurations on the other leaf nodes are similar to the configuration on Borderleaf1. For details, see the configuration file.

    [~Borderleaf1] evpn-overlay enable
    [*Borderleaf1] bgp 100
    [*Borderleaf1] router-id 1.1.1.1
    [*Borderleaf1-bgp] peer 2.2.2.2 as-number 100
    [*Borderleaf1-bgp] peer 2.2.2.2 connect-interface LoopBack1
    [*Borderleaf1-bgp] peer 3.3.3.3 as-number 100
    [*Borderleaf1-bgp] peer 3.3.3.3 connect-interface LoopBack1
    [*Borderleaf1-bgp] peer 4.4.4.4 as-number 100
    [*Borderleaf1-bgp] peer 4.4.4.4 connect-interface LoopBack1
    [*Borderleaf1-bgp] l2vpn-family evpn
    [*Borderleaf1-bgp-af-evpn] peer 2.2.2.2 enable
    Warning: This operation will reset the peer session. Continue? [Y/N]: y
    [*Borderleaf1-bgp-af-evpn] peer 3.3.3.3 enable
    Warning: This operation will reset the peer session. Continue? [Y/N]: y
    [*Borderleaf1-bgp-af-evpn] peer 4.4.4.4 enable
    Warning: This operation will reset the peer session. Continue? [Y/N]: y
    [*Borderleaf1-bgp-af-evpn] quit
    [*Borderleaf1-bgp] quit
    [*Borderleaf1] commit

    # Configure an L3VPN instance on Borderleaf1 and Borderleaf2. The configuration on Borderleaf2 is similar to the configuration on Borderleaf1. For details, see the configuration file.

    [~Borderleaf1] ip vpn-instance mcast1
    [*Borderleaf1-vpn-instance-mcast1] vxlan vni 5010
    [*Borderleaf1-vpn-instance-mcast1] ipv4-family
    [*Borderleaf1-vpn-instance-mcast1-af-ipv4] route-distinguisher 1:1
    [*Borderleaf1-vpn-instance-mcast1-af-ipv4] vpn-target 1:1
    [*Borderleaf1-vpn-instance-mcast1-af-ipv4] vpn-target 13:1 evpn
    [*Borderleaf1-vpn-instance-mcast1-af-ipv4] quit
    [*Borderleaf1-vpn-instance-mcast1] quit
    [*Borderleaf1] commit

    # Configure an L3VPN instance and an EVPN instance on Leaf1 and Leaf2. The configuration on Leaf2 is similar to the configuration on Leaf1. For details, see the configuration file.

    [~Leaf1] ip vpn-instance mcast1
    [*Leaf1-vpn-instance-mcast1] vxlan vni 5010
    [*Leaf1-vpn-instance-mcast1] ipv4-family
    [*Leaf1-vpn-instance-mcast1-af-ipv4] route-distinguisher 1:1
    [*Leaf1-vpn-instance-mcast1-af-ipv4] vpn-target 1:1
    [*Leaf1-vpn-instance-mcast1-af-ipv4] vpn-target 13:1 evpn
    [*Leaf1-vpn-instance-mcast1-af-ipv4] quit
    [*Leaf1-vpn-instance-mcast1] quit
    [*Leaf1] bridge-domain 10
    [*Leaf1-bd10] vxlan vni 10
    [*Leaf1-bd10] evpn
    [*Leaf1-bd10-evpn] route-distinguisher 11:1
    [*Leaf1-bd10-evpn] vpn-target 12:1
    [*Leaf1-bd10-evpn] vpn-target 13:1
    [*Leaf1-bd10-evpn] quit
    [*Leaf1-bd10] quit
    [*Leaf1] commit
    # Configure ingress replication on each leaf node.
    • # Configure Borderleaf1.
      [~Borderleaf1] interface nve 1
      [*Borderleaf1-Nve1] source 1.1.1.110
      [*Borderleaf1-Nve1] vni 5010 head-end peer-list protocol bgp
      [*Borderleaf1-Nve1] mac-address 0000-5e00-0101
      [*Borderleaf1-Nve1] quit
      [*Borderleaf1] commit
    • Configure Borderleaf2. Borderleaf1 and Borderleaf2 function as active-active gateways, so you must ensure that the IP addresses and MAC addresses of the NVE interfaces on the two devices are the same.
      [~Borderleaf2] interface nve 1
      [*Borderleaf2-Nve1] source 1.1.1.110
      [*Borderleaf2-Nve1] vni 5010 head-end peer-list protocol bgp
      [*Borderleaf2-Nve1] mac-address 0000-5e00-0101
      [*Borderleaf2-Nve1] quit
      [*Borderleaf2] commit
    • Configure Leaf1.
      [~Leaf1] interface nve 1
      [*Leaf1-Nve1] source 2.2.2.210
      [*Leaf1-Nve1] mac-address 0000-5e00-0102
      [*Leaf1-Nve1] vni 5010 head-end peer-list protocol bgp
      [*Leaf1-Nve1] quit
      [*Leaf1] commit
    • # Configure Leaf2. Leaf1 and Leaf2 function as active-active gateways, so you must ensure that the IP addresses and MAC addresses of the NVE interfaces on the two devices are the same.
      [~Leaf2] interface nve 1
      [*Leaf2-Nve1] source 2.2.2.210
      [*Leaf2-Nve1] mac-address 0000-5e00-0102
      [*Leaf2-Nve1] vni 5010 head-end peer-list protocol bgp
      [*Leaf2-Nve1] quit
      [*Leaf2] commit
    # Configure Leaf1 and Leaf2 to function as Layer 3 VXLAN gateways.
    • If a CE8860EI, CE8850EI, CE7855EI, CE7850EI, CE6860EI, CE6856HI, CE6855HI, CE6851HI, CE6850HI, or CE6850U-HI functions as a Layer 3 VXLAN gateway, configure a service loopback interface on the switch before configuring the switch as the Layer 3 VXLAN gateway. Skip this step if other CE switch models are configured as Layer 3 VXLAN gateways. The configuration on Leaf2 is similar to the configuration on Leaf1. For details, see the configuration file.

      [~Leaf1] interface eth-trunk 11
      [*Leaf1-Eth-Trunk11] service type tunnel
      [*Leaf1-Eth-Trunk11] quit
      [*Leaf1] interface 10ge 1/0/7
      [*Leaf1-10GE1/0/7] eth-trunk 11
      [*Leaf1-10GE1/0/7] quit
      [*Leaf1] commit
      NOTE:
      • A member interface must be an idle physical interface that does not carry any service. There is no requirement for the status of a physical interface.
      • Ensure that the bandwidth of the Eth-Trunk interface (multicast loopback interface) is at least twice the bandwidth required for transmitting traffic on the Layer 3 VXLAN gateway. For example, if traffic is sent from users to the gateway at a rate of 10 Gbit/s across the VXLAN network, add two 10GE interfaces to the Eth-Trunk as the service loopback interfaces.
      • In an M-LAG system comprised of the preceding devices, if these devices connect to the external network, the IPv4 Layer 3 multicast over VXLAN function cannot be configured together with the PIM protocol. That is, M-LAG member devices cannot function as the boarder leaf nodes when running IPv4 Layer 3 multicast over VXLAN.

    • Configure the Layer 3 VXLAN gateway on Leaf1.
      [~Leaf1] interface vbdif 10
      [*Leaf1-Vbdif10] ip binding vpn-instance mcast1
      [*Leaf1-Vbdif10] ip address 192.168.10.1 24
      [*Leaf1-Vbdif10] mac-address 0000-5e00-0104
      [*Leaf1-Vbdif10] vxlan anycast-gateway enable
      [*Leaf1-Vbdif10] arp collect host enable
      [*Leaf1-Vbdif10] quit
      [*Leaf1] commit
    • Configure the Layer 3 VXLAN gateway on Leaf2. Leaf1 and Leaf2 function as active-active gateways, so you must ensure that the IP addresses and MAC addresses of the VBDIF interfaces on the two devices are the same.
      [~Leaf2] interface vbdif 10
      [*Leaf2-Vbdif10] ip binding vpn-instance mcast1
      [*Leaf2-Vbdif10] ip address 192.168.10.1 24
      [*Leaf2-Vbdif10] mac-address 0000-5e00-0104
      [*Leaf2-Vbdif10] vxlan anycast-gateway enable
      [*Leaf2-Vbdif10] arp collect host enable
      [*Leaf2-Vbdif10] quit
      [*Leaf2] commit

    # Configure BGP on each leaf to advertise IRB routes to its peers. The configurations on the other leaf nodes are similar to the configuration on Borderleaf1. For details, see the configuration file.

    [~Borderleaf1] bgp 100
    [~Borderleaf1-bgp] l2vpn-family evpn
    [~Borderleaf1-bgp-af-evpn] peer 2.2.2.2 advertise irb
    [*Borderleaf1-bgp-af-evpn] peer 3.3.3.3 advertise irb
    [*Borderleaf1-bgp-af-evpn] peer 4.4.4.4 advertise irb
    [*Borderleaf1-bgp-af-evpn] quit
    [*Borderleaf-bgp] quit
    [*Borderleaf] commit

    # Configure BGP on Borderleaf1 to advertise IP prefix routes to its peers.

    [~Borderleaf1] bgp 100
    [~Borderleaf1-bgp] ipv4-family vpn-instance mcast1
    [*Borderleaf1-bgp-mcast1] advertise l2vpn evpn
    [*Borderleaf1-bgp-mcast1] network 1.1.1.10 32
    [*Borderleaf1-bgp-mcast1] quit
    [*Borderleaf1-bgp] quit
    [*Borderleaf1] commit

    # Configure public network Layer 3 multicast on each leaf and spine switch. The configurations on Borderleaf1, Borderleaf2, Leaf1, Leaf2, and Spine2 are similar to the configuration on Spine1. For details, see the configuration file.

    [~Spine1] multicast routing-enable
    [*Spine1] interface loopback 1
    [*Spine1-LoopBack1] pim sm
    [*Spine1-LoopBack1] quit
    [*Spine1] interface 10ge 1/0/1
    [*Spine1-10GE1/0/1] pim sm
    [*Spine1-10GE1/0/1] quit
    [*Spine1] interface 10ge 1/0/2
    [*Spine1-10GE1/0/2] pim sm
    [*Spine1-10GE1/0/2] quit
    [*Spine1] interface 10ge 1/0/3
    [*Spine1-10GE1/0/3] pim sm
    [*Spine1-10GE1/0/3] quit
    [*Spine1] interface 10ge 1/0/4
    [*Spine1-10GE1/0/4] pim sm
    [*Spine1-10GE1/0/4] quit
    [*Spine1] pim
    [*Spine1-pim] static-rp 5.5.5.5
    [*Spine1-pim] quit
    [*Spine1] commit

    # Configure the Loopback1 interface addresses on Spine1 and Spine2 as the Anycast RP addresses, and configure Loopback2 interface addresses on Spine1 and Spine2 as the Anycast RP local addresses. The configuration on Spine2 is similar to the configuration on Spine1. For details, see the configuration file.

    [~Spine1] pim
    [~Spine1-pim] anycast-rp 5.5.5.5
    [*Spine1-pim-anycast-rp-5.5.5.5] local-address 5.5.5.1 
    [*Spine1-pim-anycast-rp-5.5.5.5] commit
    [~Spine1-pim-anycast-rp-5.5.5.5] peer 5.5.5.2
    [*Spine1-pim-anycast-rp-5.5.5.5] quit
    [*Spine1-pim] quit
    [*Spine1] commit

    # Enable PIM for Layer 3 links on Borderleaf1 and Borderleaf2. The configuration on Borderleaf2 is similar to the configuration on Borderleaf1. For details, see the configuration file.

    [~Borderleaf1] interface 10ge 1/0/6
    [~Borderleaf1-10GE1/0/6] pim sm
    [~Borderleaf1-10GE1/0/6] quit
    [*Borderleaf1] commit
    [~Borderleaf1] interface 10ge 1/0/6.1
    [~Borderleaf1-10GE1/0/6.1] pim sm
    [~Borderleaf1-10GE1/0/6.1] quit
    [*Borderleaf1] commit

    # Configure BUM multicast replication for the Layer 3 VNI of the L3VPN instance on each leaf. The configurations on the other leaf nodes are similar to the configuration on Borderleaf1. For details, see the configuration file.

    [~Borderleaf1] interface nve 1
    [~Borderleaf1-Nve1] vni 5010 mcast-group 225.0.0.1
    [*Borderleaf1-Nve1] quit
    [*Borderleaf1] commit
    # Add VLANIF interfaces on Borderleaf1 and Borderleaf2 to multicast groups so that the M-LAG master and backup devices can synchronize VXLAN-encapsulated multicast packets through the peer-link. The configuration on Borderleaf2 is similar to the configuration on Borderleaf1. For details, see the configuration file.
    [~Borderleaf1] vlan 3000
    [*Borderleaf1-vlan3000] quit
    [*Borderleaf1] interface vlanif 3000
    [*Borderleaf1-Vlanif3000] ip address 10.10.21.1 24
    [*Borderleaf1-Vlanif3000] vxlan multicast-group member enable
    [*Borderleaf1-Vlanif3000] pim sm
    [*Borderleaf1-Vlanif3000] quit
    [*Borderleaf1] commit
    # Add VLANIF interfaces on Leaf1 and Leaf2 to multicast groups so that the M-LAG master and backup devices can synchronize VXLAN-encapsulated multicast packets through the peer-link. The configuration on Leaf2 is similar to the configuration on Leaf1. For details, see the configuration file.
    [~Leaf1] vlan 4000
    [*Leaf1-vlan4000] quit
    [*Leaf1] interface vlanif 4000
    [*Leaf1-Vlanif4000] ip address 10.10.20.1 24
    [*Leaf1-Vlanif4000] vxlan multicast-group member enable
    [*Leaf1-Vlanif4000] pim sm
    [*Leaf1-Vlanif4000] quit
    [*Leaf1] commit

    After the preceding configurations are complete, VXLAN tunnels can be established between leaf nodes. You can run the display vxlan tunnel command to view VXLAN tunnel information. For example, in the command output on Borderleaf1, the State field is up, indicating that the VXLAN tunnel is reachable. If the value of the Type field is static, the destination IP address is statically configured. If the value is dynamic, the destination IP address is dynamically learned through the protocol.

    [~Borderleaf1] display vxlan tunnel
    Number of vxlan tunnel : 2
    Tunnel ID   Source                Destination           State  Type     Uptime
    -----------------------------------------------------------------------------------
    4026531841  1.1.1.110               225.0.0.1             up     static   04:44:52  
    4026531845  1.1.1.110               2.2.2.210             up     dynamic  04:40:52 

  6. Configure BGP MVPN peers on each leaf.

    # Configure Borderleaf1. The configurations on the other leaf nodes are similar to the configuration on Borderleaf1. For details, see the configuration file.

    [~Borderleaf1] bgp 100
    [~Borderleaf1-bgp] ipv4-family mvpn
    [*Borderleaf1-bgp-af-mvpn] peer 2.2.2.2 enable
    Warning: This operation will reset the peer session. Continue? [Y/N]: y
    [*Borderleaf1-bgp-af-mvpn] peer 3.3.3.3 enable
    Warning: This operation will reset the peer session. Continue? [Y/N]: y
    [*Borderleaf1-bgp-af-mvpn] peer 4.4.4.4 enable
    Warning: This operation will reset the peer session. Continue? [Y/N]: y
    [*Borderleaf1-bgp-af-mvpn] quit
    [*Borderleaf1-bgp] quit
    [*Borderleaf1] commit

  7. Configure the VXLAN I-PMSI tunnel on each leaf.

    # Configure Borderleaf1. The MVPN ID configured on the distributed VXLAN gateway must be the VTEP IP address of the current gateway.

    [~Borderleaf1] multicast mvpn 1.1.1.110
    [*Borderleaf1] ip vpn-instance mcast1
    [*Borderleaf1-vpn-instance-mcast1] ipv4-family
    [*Borderleaf1-vpn-instance-mcast1-af-ipv4] multicast routing-enable
    [*Borderleaf1-vpn-instance-mcast1-af-ipv4] multicast mvpn route-import local-admin-id 1
    [*Borderleaf1-vpn-instance-mcast1-af-ipv4] mvpn
    [*Borderleaf1-vpn-instance-mcast1-af-ipv4-mvpn] c-multicast signaling bgp
    [*Borderleaf1-vpn-instance-mcast1-af-ipv4-mvpn] ipmsi-tunnel
    [*Borderleaf1-vpn-instance-mcast1-af-ipv4-mvpn-ipmsi] vxlan static
    [*Borderleaf1-vpn-instance-mcast1-af-ipv4-mvpn-ipmsi] quit
    [*Borderleaf1-vpn-instance-mcast1-af-ipv4-mvpn] quit
    [*Borderleaf1-vpn-instance-mcast1-af-ipv4] quit
    [*Borderleaf1-vpn-instance-mcast1] quit
    [*Borderleaf1] commit

    # Configure Borderleaf2. Borderleaf1 and Borderleaf2 are active-active gateways. Ensure that the two devices have the same MVPN ID, which is set to the VTEP IP address of the devices.

    [~Borderleaf2] multicast mvpn 1.1.1.110
    [*Borderleaf2] ip vpn-instance mcast1
    [*Borderleaf2-vpn-instance-mcast1] ipv4-family
    [*Borderleaf2-vpn-instance-mcast1-af-ipv4] multicast routing-enable
    [*Borderleaf2-vpn-instance-mcast1-af-ipv4] multicast mvpn route-import local-admin-id 1
    [*Borderleaf2-vpn-instance-mcast1-af-ipv4] mvpn
    [*Borderleaf2-vpn-instance-mcast1-af-ipv4-mvpn] c-multicast signaling bgp
    [*Borderleaf2-vpn-instance-mcast1-af-ipv4-mvpn] ipmsi-tunnel
    [*Borderleaf2-vpn-instance-mcast1-af-ipv4-mvpn-ipmsi] vxlan static
    [*Borderleaf2-vpn-instance-mcast1-af-ipv4-mvpn-ipmsi] quit
    [*Borderleaf2-vpn-instance-mcast1-af-ipv4-mvpn] quit
    [*Borderleaf2-vpn-instance-mcast1-af-ipv4] quit
    [*Borderleaf2-vpn-instance-mcast1] quit
    [*Borderleaf2] commit

    # Configure Leaf1.

    [~Leaf1] multicast mvpn 2.2.2.210
    [*Leaf1] ip vpn-instance mcast1
    [*Leaf1-vpn-instance-mcast1] ipv4-family
    [*Leaf1-vpn-instance-mcast1-af-ipv4] multicast routing-enable
    [*Leaf1-vpn-instance-mcast1-af-ipv4] multicast mvpn route-import local-admin-id 1
    [*Leaf1-vpn-instance-mcast1-af-ipv4] mvpn
    [*Leaf1-vpn-instance-mcast1-af-ipv4-mvpn] c-multicast signaling bgp
    [*Leaf1-vpn-instance-mcast1-af-ipv4-mvpn] ipmsi-tunnel
    [*Leaf1-vpn-instance-mcast1-af-ipv4-mvpn-ipmsi] vxlan static
    [*Leaf1-vpn-instance-mcast1-af-ipv4-mvpn-ipmsi] quit
    [*Leaf1-vpn-instance-mcast1-af-ipv4-mvpn] quit
    [*Leaf1-vpn-instance-mcast1-af-ipv4] quit
    [*Leaf1-vpn-instance-mcast1] quit
    [*Leaf1] commit

    # Configure Leaf2. Leaf1 and Leaf2 are active-active gateways. Ensure that the two devices have the same MVPN ID, which is set to the VTEP IP address of the devices.

    [~Leaf2] multicast mvpn 2.2.2.210
    [*Leaf2] ip vpn-instance mcast1
    [*Leaf2-vpn-instance-mcast1] ipv4-family
    [*Leaf2-vpn-instance-mcast1-af-ipv4] multicast routing-enable
    [*Leaf2-vpn-instance-mcast1-af-ipv4] multicast mvpn route-import local-admin-id 1
    [*Leaf2-vpn-instance-mcast1-af-ipv4] mvpn
    [*Leaf2-vpn-instance-mcast1-af-ipv4-mvpn] c-multicast signaling bgp
    [*Leaf2-vpn-instance-mcast1-af-ipv4-mvpn] ipmsi-tunnel
    [*Leaf2-vpn-instance-mcast1-af-ipv4-mvpn-ipmsi] vxlan static
    [*Leaf2-vpn-instance-mcast1-af-ipv4-mvpn-ipmsi] quit
    [*Leaf2-vpn-instance-mcast1-af-ipv4-mvpn] quit
    [*Leaf2-vpn-instance-mcast1-af-ipv4] quit
    [*Leaf2-vpn-instance-mcast1] quit
    [*Leaf2] commit

  8. Configure PIM-SM and IGMP on the VBDIF interface.

    # Configure Leaf1.

    [~Leaf1] interface vbdif 10
    [~Leaf1-Vbdif10] pim sm
    [*Leaf1-Vbdif10] igmp enable
    [*Leaf1-Vbdif10] quit
    [*Leaf1] commit

    # Configure Leaf2.

    [~Leaf2] interface vbdif 10
    [~Leaf2-Vbdif10] pim sm
    [*Leaf2-Vbdif10] igmp enable
    [*Leaf2-Vbdif10] quit
    [*Leaf2] commit

  9. Configure a VPN static RP on each leaf node.

    # Configure Borderleaf1.

    [~Borderleaf1] interface loopback 3
    [~Borderleaf1-LoopBack2] ip binding vpn-instance mcast1
    [*Borderleaf1-LoopBack2] ip address 1.1.1.10 32
    [*Borderleaf1-LoopBack2] pim sm
    [*Borderleaf1-LoopBack2] quit
    [*Borderleaf1] pim vpn-instance mcast1
    [*Borderleaf1-pim-mcast1] static-rp 1.1.1.10
    [*Borderleaf1-pim-mcast1] quit
    [*Borderleaf1] commit

    # Configure Borderleaf2.

    [*Borderleaf2] pim vpn-instance mcast1
    [*Borderleaf2-pim-mcast1] static-rp 1.1.1.10
    [*Borderleaf2-pim-mcast1] quit
    [*Borderleaf2] commit

    # Configure Leaf1.

    [*Leaf1] pim vpn-instance mcast1
    [*Leaf1-pim-mcast1] static-rp 1.1.1.10
    [*Leaf1-pim-mcast1] quit
    [*Leaf1] commit

    # Configure Leaf2.

    [*Leaf2] pim vpn-instance mcast1
    [*Leaf2-pim-mcast1] static-rp 1.1.1.10
    [*Leaf2-pim-mcast1] quit
    [*Leaf2] commit

  10. Configure VPN Layer 3 multicast on Borderleaf1, Borderleaf2, and the CE.

    # Configure Borderleaf1. The configuration on Borderleaf2 is similar to the configuration on Borderleaf1. For details, see the configuration file.

    [~Borderleaf1] interface 10ge 1/0/2
    [*Borderleaf1-10GE1/0/2] undo portswitch
    [*Borderleaf1-10GE1/0/2] ip binding vpn-instance mcast1
    [*Borderleaf1-10GE1/0/2] ip address 192.168.20.1 24
    [*Borderleaf1-10GE1/0/2] pim sm
    [*Borderleaf1-10GE1/0/2] igmp enable
    [*Borderleaf1-10GE1/0/2] quit
    [*Borderleaf1] ip route-static vpn-instance mcast1 192.168.10.2 24 10ge 1/0/2
    [*Borderleaf1] bgp 100
    [*Borderleaf1-bgp] ipv4-family vpn-instance mcast1
    [*Borderleaf1-bgp-mcast1] import-route static
    [*Borderleaf1-bgp-mcast1] quit
    [*Borderleaf1-bgp] quit
    [*Borderleaf1] commit

    # Configure the CE.

    [~CE] multicast routing-enable
    [*CE] interface 10ge 1/0/1
    [*CE-10GE1/0/1] pim sm
    [*CE-10GE1/0/1] igmp enable
    [*CE-10GE1/0/1] quit
    [*CE] interface 10ge 1/0/2
    [*CE-10GE1/0/2] pim sm
    [*CE-10GE1/0/2] igmp enable
    [*CE-10GE1/0/2] quit
    [*CE] interface 10ge 1/0/3
    [*CE-10GE1/0/2] pim sm
    [*CE-10GE1/0/2] igmp enable
    [*CE-10GE1/0/2] quit
    [*CE] ip route-static 192.168.60.1 24 10ge 1/0/2
    [*CE] commit

Verifying the Configuration

# Run the display bgp mvpn all peer command on each leaf node to query BGP MVPN peer information. For example, the information displayed on Borderleaf1 is as follows:

[~Borderleaf1] display bgp mvpn all peer
 BGP local router ID        : 1.1.1.1
 Local AS number            : 100
 Total number of peers      : 3
 Peers in established state : 3

  Peer            V          AS  MsgRcvd  MsgSent  OutQ  Up/Down       State  PrefRcv
  2.2.2.2         4         100     1860     1859     0 04:43:30 Established        1
  3.3.3.3         4         100     3219     3221     0 04:43:39 Established        1
  4.4.4.4         4         100     4559     4561     0 04:44:39 Established        1
# After a receiver initiates a request to join a multicast group, run the display pim vpn-instance mcast1 routing-table command on each leaf to query the information about the PIM routing table of the VPN.
  • The command output on Borderleaf1 shows that the multicast receiver joins the multicast group through BGP.
    [~Borderleaf1] display pim vpn-instance mcast1 routing-table
     VPN-Instance: mcast1
     Total 1 (*, G) entry; 1 (S, G) entry
    
     (*, 225.1.1.1)
         RP: 1.1.1.10 (local)
         Protocol: pim-sm, Flag: WC
         UpTime: 04:43:57
         Upstream interface: 10GE1/0/2 
             Upstream neighbor: 192.168.20.2
             RPF prime neighbor: 192.168.20.2
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: pseudo
                 Protocol: BGP, UpTime: 04:43:57, Expires: -
     
     (192.168.20.9, 225.1.1.1)
         RP: 1.1.1.10 (local)
         Protocol: pim-sm, Flag: SPT LOC ACT
         UpTime: 04:43:57
         Upstream interface: 10GE1/0/2
             Upstream neighbor: 192.168.20.2
             RPF prime neighbor: 192.168.20.2
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: pseudo
                 Protocol: pim-sm, UpTime: 04:43:57, Expires: -
  • The command output on Leaf1 shows that the upstream interface in the VPN PIM routing entry for the receiver is Through-BGP and the downstream interface is VBDIF 10.
    [~Leaf1] display pim vpn-instance mcast1 routing-table
     VPN-Instance: mcast1
     Total 1 (S, G) entry; 1 (S, G) entry
     
     (*, 225.1.1.1)
         RP: 1.1.1.10 
         Protocol: pim-sm, Flag: WC
         UpTime: 04:44:18
         Upstream interface: through-BGP
             Upstream neighbor: 1.1.1.1
             RPF prime neighbor: 1.1.1.1
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: Vbdif10
                 Protocol: igmp, UpTime: 04:44:18, Expires: -
     
     (192.168.20.9, 225.1.1.1)
         RP: 1.1.1.10 
         Protocol: pim-sm, Flag: SPT ACT
         UpTime: 04:44:18
         Upstream interface: through-BGP
             Upstream neighbor: 1.1.1.1
             RPF prime neighbor: 1.1.1.1
         Downstream interface(s) information:
         Total number of downstreams: 1
            1: Vbdif10
                 Protocol: pim-sm, UpTime: 04:44:18, Expires: -
     

Configuration Files

  • CE configuration file

    #
    sysname CE
    #
    multicast routing-enable
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 192.168.10.2 255.255.255.0
     pim sm 
     igmp enable        
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 192.168.20.2 255.255.255.0
     pim sm  
     igmp enable         
    #
    interface 10GE1/0/3
     undo portswitch
     ip address 192.168.30.2 255.255.255.0
     pim sm    
     igmp enable       
    #
    ip route-static 192.168.60.1 24 10ge 1/0/2
    #
    return
  • Borderleaf1 configuration file

    #
    sysname Borderleaf1
    #
    set forward capability enhanced //This step is required only on the CE12800.
    #
    assign forward nvo3 acl extend enable //This step is required only on the CE12800, CE6870EI, and CE6875EI.
    #
    dfs-group 1
     source ip 10.10.11.1
    #
    vlan batch 3000
    #
    stp mode rstp
    stp v-stp enable
    #
    evpn-overlay enable
    #
    multicast routing-enable
    #
    multicast mvpn 1.1.1.110
    #
    ip vpn-instance mcast1
     ipv4-family
      route-distinguisher 1:1
      vpn-target 1:1 export-extcommunity
      vpn-target 13:1 export-extcommunity evpn
      vpn-target 1:1 import-extcommunity
      vpn-target 13:1 import-extcommunity evpn
      multicast routing-enable
      multicast mvpn route-import local-admin-id 1
      mvpn          
       c-multicast signaling bgp
       ipmsi-tunnel 
        vxlan static
     vxlan vni 5010 
    #
    interface Vlanif3000
     ip address 10.10.21.1 255.255.255.0
     pim sm
     vxlan multicast-group member enable
    #
    interface MEth0/0/0
     ip address 10.10.11.1 255.255.255.0
    #
    interface Eth-Trunk2
     mode lacp-static
     peer-link 1
    #
    ip route-static vpn-instance mcast1 192.168.10.2 24 10GE1/0/2
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 10.1.1.1 255.255.255.0
     pim sm         
    #
    interface 10GE1/0/2
     undo portswitch
     ip binding vpn-instance mcast1
     ip address 192.168.20.1 24
     pim sm
     igmp enable
    #
    interface 10GE1/0/3
     undo portswitch
     ip address 10.1.11.1 255.255.255.0
     pim sm         
    #
    interface 10GE1/0/4
     eth-trunk 2
    #
    interface 10GE1/0/5
     eth-trunk 2
    #
    interface 10GE1/0/6
     undo portswitch
     pim sm         
    #
    interface 10GE1/0/6.1
     ip address 10.6.1.1 255.255.255.0
     pim sm         
    #
    interface LoopBack1
     ip address 1.1.1.1 255.255.255.255
     pim sm 
    #  
    interface LoopBack2
     ip address 1.1.1.110 255.255.255.255
     pim sm 
    #  
    interface LoopBack3
     ip binding vpn-instance mcast1
     ip address 1.1.1.10 255.255.255.255
     pim sm
    #
    interface Nve1  
     source 1.1.1.110
     vni 5010 head-end peer-list protocol bgp
     vni 5010 mcast-group 225.0.0.1
     mac-address 0000-5e00-0101
    #
    bgp 100  
     router-id 1.1.1.1        
     peer 2.2.2.2 as-number 100
     peer 2.2.2.2 connect-interface LoopBack1
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack1
     peer 4.4.4.4 as-number 100
     peer 4.4.4.4 connect-interface LoopBack1
     #              
     ipv4-family unicast
      peer 2.2.2.2 enable
      peer 3.3.3.3 enable
      peer 4.4.4.4 enable
     #              
     ipv4-family mvpn
      policy vpn-target
      peer 2.2.2.2 enable
      peer 3.3.3.3 enable
      peer 4.4.4.4 enable
     #              
     ipv4-family vpn-instance mcast1
      network 1.1.1.10 255.255.255.255
      advertise l2vpn evpn
      import-route static
     #
     l2vpn-family evpn
      policy vpn-target
      peer 2.2.2.2 enable
      peer 2.2.2.2 advertise irb
      peer 3.3.3.3 enable
      peer 3.3.3.3 advertise irb
      peer 4.4.4.4 enable
      peer 4.4.4.4 advertise irb
    #               
    ospf 1          
     area 0.0.0.0   
      network 1.1.1.1 0.0.0.0
      network 1.1.1.110 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.11.0 0.0.0.255
      network 10.6.1.0 0.0.0.255
    #               
    pim
     static-rp 5.5.5.5
    #
    pim vpn-instance mcast1
     static-rp 1.1.1.10
    #
    return
  • Borderleaf2 configuration file

    #
    sysname Borderleaf2
    #
    set forward capability enhanced //This step is required only on the CE12800.
    #
    assign forward nvo3 acl extend enable //This step is required only on the CE12800, CE6870EI, and CE6875EI.
    #
    dfs-group 1
     source ip 10.10.11.2
    #
    vlan batch 3000
    #
    stp mode rstp
    stp v-stp enable
    #
    evpn-overlay enable
    #
    multicast routing-enable
    #
    multicast mvpn 1.1.1.110
    #
    ip vpn-instance mcast1
     ipv4-family
      route-distinguisher 1:1
      vpn-target 1:1 export-extcommunity
      vpn-target 13:1 export-extcommunity evpn
      vpn-target 1:1 import-extcommunity
      vpn-target 13:1 import-extcommunity evpn
      multicast routing-enable
      multicast mvpn route-import local-admin-id 1
      mvpn          
       c-multicast signaling bgp
       ipmsi-tunnel 
        vxlan static
     vxlan vni 5010 
    #
    interface Vlanif3000
     ip address 10.10.21.2 255.255.255.0
     pim sm
     vxlan multicast-group member enable
    #
    interface MEth0/0/0
     ip address 10.10.11.2 255.255.255.0
    #
    interface Eth-Trunk2
     mode lacp-static
     peer-link 1
    #
    ip route-static vpn-instance mcast1 192.168.10.2 24 10GE1/0/2
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 10.1.44.1 255.255.255.0
     pim sm         
    #
    interface 10GE1/0/2
     undo portswitch
     ip binding vpn-instance mcast1
     ip address 192.168.30.1 24
     pim sm
     igmp enable
    #
    interface 10GE1/0/3
     undo portswitch
     ip address 10.1.4.1 255.255.255.0
     pim sm         
    #
    interface 10GE1/0/4
     eth-trunk 2
    #
    interface 10GE1/0/5
     eth-trunk 2
    #
    interface 10GE1/0/6
     undo portswitch
     pim sm         
    #
    interface 10GE1/0/6.1
     ip address 10.6.1.2 255.255.255.0
     pim sm         
    #
    interface LoopBack1
     ip address 2.2.2.2 255.255.255.255
     pim sm 
    #  
    interface LoopBack2
     ip address 1.1.1.110 255.255.255.255
     pim sm 
    #
    interface Nve1  
     source 1.1.1.110
     vni 5010 head-end peer-list protocol bgp
     vni 5010 mcast-group 225.0.0.1
     mac-address 0000-5e00-0101
    #
    bgp 100  
     router-id 2.2.2.2       
     peer 1.1.1.1 as-number 100
     peer 1.1.1.1 connect-interface LoopBack1
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack1
     peer 4.4.4.4 as-number 100
     peer 4.4.4.4 connect-interface LoopBack1
     #              
     ipv4-family unicast
      peer 1.1.1.1 enable
      peer 3.3.3.3 enable
      peer 4.4.4.4 enable
     #              
     ipv4-family mvpn
      policy vpn-target
      peer 1.1.1.1 enable
      peer 3.3.3.3 enable
      peer 4.4.4.4 enable
     #             
     ipv4-family vpn-instance mcast1
      import-route static
     #
     l2vpn-family evpn
      policy vpn-target
      peer 1.1.1.1 enable
      peer 1.1.1.1 advertise irb
      peer 3.3.3.3 enable
      peer 3.3.3.3 advertise irb
      peer 4.4.4.4 enable
      peer 4.4.4.4 advertise irb
    #               
    ospf 1          
     area 0.0.0.0   
      network 2.2.2.2 0.0.0.0
      network 1.1.1.110 0.0.0.0
      network 10.1.4.0 0.0.0.255
      network 10.1.44.0 0.0.0.255
      network 10.6.1.0 0.0.0.255
    #               
    pim
     static-rp 5.5.5.5
    #
    pim vpn-instance mcast1
     static-rp 1.1.1.10
    #
    return
    
  • Leaf1 configuration file

    #
    sysname Leaf1
    #
    set forward capability enhanced //This step is required only on the CE12800.
    #
    assign forward nvo3 acl extend enable //This step is required only on the CE12800, CE6870EI, and CE6875EI.
    #
    dfs-group 1
     source ip 10.10.10.1
    #
    vlan batch 4000
    #
    stp mode rstp
    stp v-stp enable
    #
    evpn-overlay enable
    #
    multicast routing-enable
    #
    multicast mvpn 2.2.2.210
    #
    ip vpn-instance mcast1
     ipv4-family
      route-distinguisher 1:1
      vpn-target 1:1 export-extcommunity
      vpn-target 13:1 export-extcommunity evpn
      vpn-target 1:1 import-extcommunity
      vpn-target 13:1 import-extcommunity evpn
      multicast routing-enable
      multicast mvpn route-import local-admin-id 1
      mvpn          
       c-multicast signaling bgp
       ipmsi-tunnel 
        vxlan static
     vxlan vni 5010 
    #               
    bridge-domain 10
     vxlan vni 10   
     evpn           
      route-distinguisher 11:1
      vpn-target 12:1 export-extcommunity
      vpn-target 13:1 export-extcommunity
      vpn-target 12:1 import-extcommunity
      vpn-target 13:1 import-extcommunity
    #               
    interface Vbdif10
     ip binding vpn-instance mcast1
     ip address 192.168.10.1 255.255.255.0
     mac-address 0000-5e00-0104
     pim sm
     igmp enable   
     vxlan anycast-gateway enable
     arp collect host enable
    #
    interface Vlanif4000
     ip address 10.10.20.1 255.255.255.0
     pim sm
     vxlan multicast-group member enable
    #
    interface MEth0/0/0
     ip address 10.10.10.1 255.255.255.0
    #
    interface Eth-Trunk1
     mode lacp-static
     peer-link 1
    #
    interface Eth-Trunk11 //This step is required only on the CE8860EI, CE8850EI, CE7855EI, CE7850EI, CE6860EI, CE6856HI, CE6855HI, CE6851HI, CE6850HI, and CE6850U-HI.
     service type tunnel
    #
    interface Eth-Trunk10
     stp edged-port enable
     mode lacp-static
     dfs-group 1 m-lag 1
    #
    interface Eth-Trunk10.1 mode l2
     encapsulation dot1q vid 10
     bridge-domain 10
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 10.1.2.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/2
     eth-trunk 10
    #
    interface 10GE1/0/3
     eth-trunk 10
    #
    interface 10GE1/0/4
     eth-trunk 1
    #
    interface 10GE1/0/5
     eth-trunk 1
    #
    interface 10GE1/0/6
     undo portswitch
     ip address 10.1.22.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/7 //This step is required only on the CE8860EI, CE8850EI, CE7855EI, CE7850EI, CE6860EI, CE6856HI, CE6855HI, CE6851HI, CE6850HI, and CE6850U-HI.
     eth-trunk 11
    #
    interface LoopBack1
     ip address 3.3.3.3 255.255.255.255
     pim sm
    #               
    interface LoopBack2
     ip address 2.2.2.210 255.255.255.255
     pim sm
    #               
    interface Nve1  
     source 2.2.2.210 
     vni 5010 head-end peer-list protocol bgp
     vni 5010 mcast-group 225.0.0.1
     mac-address 0000-5e00-0102
    #
    bgp 100  
     router-id 3.3.3.3       
     peer 1.1.1.1 as-number 100
     peer 1.1.1.1 connect-interface LoopBack1
     peer 2.2.2.2 as-number 100
     peer 2.2.2.2 connect-interface LoopBack1
     peer 4.4.4.4 as-number 100
     peer 4.4.4.4 connect-interface LoopBack1
     #              
     ipv4-family unicast
      peer 1.1.1.1 enable
      peer 2.2.2.2 enable
      peer 4.4.4.4 enable
     #              
     ipv4-family mvpn
      policy vpn-target
      peer 1.1.1.1 enable
      peer 2.2.2.2 enable
      peer 4.4.4.4 enable
     #
     l2vpn-family evpn
      policy vpn-target
      peer 1.1.1.1 enable
      peer 1.1.1.1 advertise irb
      peer 2.2.2.2 enable
      peer 2.2.2.2 advertise irb
      peer 4.4.4.4 enable
      peer 4.4.4.4 advertise irb
    #               
    ospf 1          
     area 0.0.0.0   
      network 3.3.3.3 0.0.0.0
      network 2.2.2.210 0.0.0.0
      network 10.1.2.0 0.0.0.255
      network 10.1.22.0 0.0.0.255
    #
    pim
     static-rp 5.5.5.5
    #
    pim vpn-instance mcast1
     static-rp 1.1.1.10
    #
    return
  • Leaf2 configuration file

    #
    sysname Leaf2
    #
    set forward capability enhanced //This step is required only on the CE12800.
    #
    assign forward nvo3 acl extend enable //This step is required only on the CE12800, CE6870EI, and CE6875EI.
    #
    dfs-group 1
     source ip 10.10.10.2
    #
    vlan batch 4000
    #
    stp mode rstp
    stp v-stp enable
    #
    evpn-overlay enable
    #
    multicast routing-enable
    #
    multicast mvpn 2.2.2.210
    #
    ip vpn-instance mcast1
     ipv4-family
      route-distinguisher 1:1
      vpn-target 1:1 export-extcommunity
      vpn-target 13:1 export-extcommunity evpn
      vpn-target 1:1 import-extcommunity
      vpn-target 13:1 import-extcommunity evpn
      multicast routing-enable
      multicast mvpn route-import local-admin-id 1
      mvpn          
       c-multicast signaling bgp
       ipmsi-tunnel 
        vxlan static
     vxlan vni 5010 
    #               
    bridge-domain 10
     vxlan vni 10   
     evpn           
      route-distinguisher 11:1
      vpn-target 12:1 export-extcommunity
      vpn-target 13:1 export-extcommunity
      vpn-target 12:1 import-extcommunity
      vpn-target 13:1 import-extcommunity
    #               
    interface Vbdif10
     ip binding vpn-instance mcast1
     ip address 192.168.10.1 255.255.255.0
     mac-address 0000-5e00-0104
     pim sm
     igmp enable   
     vxlan anycast-gateway enable
     arp collect host enable
    #
    interface Vlanif4000
     ip address 10.10.20.2 255.255.255.0
     pim sm
     vxlan multicast-group member enable
    #
    interface MEth0/0/0
     ip address 10.10.10.2 255.255.255.0
    #
    interface Eth-Trunk1
     mode lacp-static
     peer-link 1
    #
    interface Eth-Trunk11 //This step is required only on the CE8860EI, CE8850EI, CE7855EI, CE7850EI, CE6860EI, CE6856HI, CE6855HI, CE6851HI, CE6850HI, and CE6850U-HI.
     service type tunnel
    #
    interface Eth-Trunk10
     stp edged-port enable
     mode lacp-static
     dfs-group 1 m-lag 1
    #
    interface Eth-Trunk10.1 mode l2
     encapsulation dot1q vid 10
     bridge-domain 10
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 10.1.33.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/2
     eth-trunk 10
    #
    interface 10GE1/0/3
     eth-trunk 10
    #
    interface 10GE1/0/4
     eth-trunk 1
    #
    interface 10GE1/0/5
     eth-trunk 1
    #
    interface 10GE1/0/6
     undo portswitch
     ip address 10.1.3.1 255.255.255.0
     pim sm
    #
    interface 10GE1/0/7 //This step is required only on the CE8860EI, CE8850EI, CE7855EI, CE7850EI, CE6860EI, CE6856HI, CE6855HI, CE6851HI, CE6850HI, and CE6850U-HI.
     eth-trunk 11
    #
    interface LoopBack1
     ip address 4.4.4.4 255.255.255.255
     pim sm
    #               
    interface LoopBack2
     ip address 2.2.2.210 255.255.255.255
     pim sm
    #               
    interface Nve1  
     source 2.2.2.210 
     vni 5010 head-end peer-list protocol bgp
     vni 5010 mcast-group 225.0.0.1
     mac-address 0000-5e00-0102
    #
    bgp 100         
     router-id 4.4.4.4
     peer 1.1.1.1 as-number 100
     peer 1.1.1.1 connect-interface LoopBack1
     peer 2.2.2.2 as-number 100
     peer 2.2.2.2 connect-interface LoopBack1
     peer 3.3.3.3 as-number 100
     peer 3.3.3.3 connect-interface LoopBack1
     #              
     ipv4-family unicast
      peer 1.1.1.1 enable
      peer 2.2.2.2 enable
      peer 3.3.3.3 enable
     #              
     ipv4-family mvpn
      policy vpn-target
      peer 1.1.1.1 enable
      peer 2.2.2.2 enable
      peer 3.3.3.3 enable
     #
     l2vpn-family evpn
      policy vpn-target
      peer 1.1.1.1 enable
      peer 1.1.1.1 advertise irb
      peer 2.2.2.2 enable
      peer 2.2.2.2 advertise irb
      peer 3.3.3.3 enable
      peer 3.3.3.3 advertise irb
    #               
    ospf 1          
     area 0.0.0.0   
      network 4.4.4.4 0.0.0.0
      network 2.2.2.210 0.0.0.0
      network 10.1.3.0 0.0.0.255
      network 10.1.33.0 0.0.0.255
    #
    pim
     static-rp 5.5.5.5
    #
    pim vpn-instance mcast1
     static-rp 1.1.1.10
    #
    return
    
  • Spine1 configuration file

    #
    sysname Spine1
    #
    multicast routing-enable
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 10.1.1.2 255.255.255.0
     pim sm
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 10.1.2.2 255.255.255.0
     pim sm         
    #
    interface 10GE1/0/3
     undo portswitch
     ip address 10.1.3.2 255.255.255.0
     pim sm
    #
    interface 10GE1/0/4
     undo portswitch
     ip address 10.1.4.2 255.255.255.0
     pim sm
    #
    interface LoopBack1
     ip address 5.5.5.5 255.255.255.255
     pim sm
    #
    interface LoopBack2
     ip address 5.5.5.1 255.255.255.255
     pim sm
    #
    ospf 1          
     area 0.0.0.0   
      network 5.5.5.5 0.0.0.0
      network 5.5.5.1 0.0.0.0
      network 10.1.1.0 0.0.0.255
      network 10.1.2.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
      network 10.1.4.0 0.0.0.255
    #
    pim
     static-rp 5.5.5.5
     anycast-rp 5.5.5.5
      local-address 5.5.5.1
      peer 5.5.5.2
    #
    return
  • Spine2 configuration file

    #
    sysname Spine2
    #
    multicast routing-enable
    #
    interface 10GE1/0/1
     undo portswitch
     ip address 10.1.11.2 255.255.255.0
     pim sm
    #
    interface 10GE1/0/2
     undo portswitch
     ip address 10.1.22.2 255.255.255.0
     pim sm         
    #
    interface 10GE1/0/3
     undo portswitch
     ip address 10.1.33.2 255.255.255.0
     pim sm
    #
    interface 10GE1/0/4
     undo portswitch
     ip address 10.1.44.2 255.255.255.0
     pim sm
    #
    interface LoopBack1
     ip address 5.5.5.5 255.255.255.255
     pim sm
    #
    interface LoopBack2
     ip address 5.5.5.2 255.255.255.255
     pim sm
    #
    ospf 1          
     area 0.0.0.0   
      network 5.5.5.5 0.0.0.0
      network 5.5.5.2 0.0.0.0
      network 10.1.11.0 0.0.0.255
      network 10.1.22.0 0.0.0.255
      network 10.1.33.0 0.0.0.255
      network 10.1.44.0 0.0.0.255
    #
    pim
     static-rp 5.5.5.5
     anycast-rp 5.5.5.5
      local-address 5.5.5.1
      peer 5.5.5.2
    #
    return
Download
Updated: 2019-04-03

Document ID: EDOC1000039339

Views: 105997

Downloads: 7475

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next