No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Typical Configuration Examples

CloudEngine 12800, 12800E, 8800, 7800, 6800, and 5800 Series Switches

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Configuring CSS and VS to Build a Data Center Network

Configuring CSS and VS to Build a Data Center Network

Applicable Products and Versions

CE12800 and CE12800E series switches running V100R002C00 or later versions. The CE12800E does not support the CSS and VS function after FD-X series cards are installed.

Networking Requirements

On the data center network shown in Figure 1-8, two CE12800s on the core layer set up a CSS to simplify the network structure and improve reliability. VS technology is used to virtualize the CSS into two independent devices. The two devices serve as the core of the office zone and production zone to provide independent service forwarding and isolate services and traffic of different zones. In this manner, security and reliability are improved. Gateways of servers are deployed on VSs. Multiple CE6800s on the access layer set up two stack systems and connect to the CE12800s through inter-device Eth-Trunks to prevent Layer 2 loops.

Figure 1-8 Networking diagram of configuring CSS and VS
Table 1-5 Data preparation

Device Name

Interface Number

IP Address

Interconnected Device and Interface Number

Router Eth-Trunk1
  • 10GE1/0/1
  • 10GE1/0/2

10.10.10.2/24

vs1: Eth-Trunk1
Eth-Trunk2
  • 10GE1/0/3
  • 10GE1/0/4

10.10.9.2/24

vs2: Eth-Trunk2
CSS Stack-Port1/1
  • 10GE1/1/0/1 to 10GE1/1/0/4
  • 10GE1/2/0/1 to 10GE1/2/0/4

-

CSS: Stack-Port2/1

Stack-Port2/1
  • 10GE2/1/0/1 to 10GE2/1/0/4
  • 10GE2/2/0/1 to 10GE2/2/0/4

-

CSS: Stack-Port1/1

10GE1/1/0/10

-

CSS: 10GE2/1/0/10

10GE1/2/0/10

-

CSS: 10GE2/2/0/10

vs1

Eth-Trunk1
  • 10GE1/1/0/46
  • 10GE2/1/0/46

10.10.10.1/24

Router: Eth-Trunk1

Eth-Trunk3
  • 10GE1/1/0/47
  • 10GE2/1/0/47

VLANIF 100: 10.10.1.1/24

iStack-1: Eth-Trunk3

vs2

Eth-Trunk2
  • 10GE1/2/0/46
  • 10GE2/2/0/46

10.10.9.1/24

Router: Eth-Trunk2

Eth-Trunk4
  • 10GE1/2/0/47
  • 10GE2/2/0/47

VLANIF 100: 10.10.2.1/24

iStack-2: Eth-Trunk4

iStack-1

Stack-Port1/1
  • 10GE1/0/1 to 10GE1/0/4

-

iStack-1: Stack-Port2/1

Stack-Port2/1
  • 10GE2/0/1 to 10GE2/0/4

-

iStack-1: Stack-Port1/1

Eth-Trunk3
  • 10GE1/0/5
  • 10GE2/0/5

-

vs1: Eth-Trunk3

10GE1/0/9

-

iStack-1: 10GE2/0/9

10GE1/0/10

-

iStack-1: 10GE2/0/10

iStack-2

Stack-Port1/1
  • 10GE1/0/1 to 10GE1/0/4

-

iStack-2: Stack-Port2/1

Stack-Port2/1
  • 10GE2/0/1 to 10GE2/0/4

-

iStack-2: Stack-Port1/1

Eth-Trunk4
  • 10GE1/0/5
  • 10GE2/0/5

-

vs2: Eth-Trunk4

10GE1/0/9

-

iStack-2: 10GE2/0/9

10GE1/0/10

-

iStack-2: 10GE2/0/10

Configuration Roadmap

The configuration roadmap is as follows:
  1. Configure CSS on the core layer and iStack on the access layer to implement device-level redundancy backup.
  2. Divide the CSS into VS1 and VS2, which serve as the core of the office zone and production zone respectively for service isolation.
  3. Configure VSs to connect to upstream and downstream devices through Eth-Trunks to ensure high reliability and a loop-free network.
  4. Configure a routing protocol between VSs and upstream devices, and between VSs and downstream devices for Layer 3 interconnection. Run OSPF between VSs and the router. Deploy gateways of servers on VSs.

Procedure

  1. Configure the CSS function on core switches CE12800-1 and CE12800-2.

    1. Connect stack cables between CE12800-1 and CE12800-2 according to Figure 1-9.
      Figure 1-9 Physical connections of CSS
    2. Configure stack attributes for CE12800-1 and CE12800-2. (Set a higher priority for CE12800-1, so CE12800-1 will become the master switch.)

      # Set the stack ID of CE12800-1 to 1, priority to 150, domain ID to 10, and connection mode to MPU connection.

      <HUAWEI> system-view
      [~HUAWEI] sysname CE12800-1
      [*HUAWEI] commit
      [~CE12800-1] stack
      [~CE12800-1-stack] stack member 1         //Configure the stack member ID. The default value is 1.
      [*CE12800-1-stack] stack priority 150     //Configure the stack priority. The default value is 100.
      [*CE12800-1-stack] stack domain 10        //Configure the domain ID.
      [*CE12800-1-stack] stack link-type mainboard-direct     //Configure the connection mode. The default mode is mainboard-direct.
      [*CE12800-1-stack] quit
      [*CE12800-1] commit
      

      # Set the stack ID of CE12800-2 to 2, priority to 100, domain ID to 10, and connection mode to MPU connection.

      <HUAWEI> system-view
      [~HUAWEI] sysname CE12800-2
      [*HUAWEI] commit
      [~CE12800-2] stack
      [~CE12800-2-stack] stack member 2
      Warning: The device will use the configuration of member ID 2 after the device resets. Continue? [Y/N]: y
      [*CE12800-2-stack] stack priority 100
      [*CE12800-2-stack] stack domain 10
      [*CE12800-2-stack] stack link-type mainboard-direct
      [*CE12800-2-stack] quit
      [*CE12800-2] commit
      
    3. Configure stack ports. The two switches are connected by eight 10GE optical ports on different LPUs.

      # On CE12800-1, add 10GE1/0/1-10GE1/0/4 and 10GE2/0/1-10GE2/0/4 to the stack port.

      [~CE12800-1] port-group group1       //Create a port group.
      [*CE12800-1-port-group-group1] group-member 10ge 1/0/1 to 10ge 1/0/4       //Add ports to a port group.
      [*CE12800-1-port-group-group1] group-member 10ge 2/0/1 to 10ge 2/0/4
      [*CE12800-1-port-group-group1] shutdown       //Shut down the port.
      [*CE12800-1-port-group-group1] quit
      [*CE12800-1] commit
      [~CE12800-1] interface stack-port 1
      [*CE12800-1-Stack-Port1] port member-group interface 10ge 1/0/1 to 1/0/4       //Add physical ports to the stack port.
      [*CE12800-1-Stack-Port1] port member-group interface 10ge 2/0/1 to 2/0/4
      [*CE12800-1-Stack-Port1] quit
      [*CE12800-1] commit
      [~CE12800-1] port-group group1
      [~CE12800-1-port-group-group1] undo shutdown       //Enable the port.
      [*CE12800-1-port-group-group1] quit
      [*CE12800-1] commit
      [~CE12800-1] return
      

      # The configuration procedure on CE12800-2 is the same as the configuration procedure on CE12800-1, and is not mentioned here.

    4. Enable the stack function.

      # Enable the stack function on CE12800-1 and restart the device.

      <CE12800-1> save
      Warning: The current configuration will be written to the device. Continue? [Y/N]: y
      <CE12800-1> system-view
      [~CE12800-1] stack
      [~CE12800-1-stack] stack enable
      Warning: Make sure that one or more dual-active detection methods are configured once the conversion is complete and the device enters the stack mode.
      Current configuration will be converted to the next startup saved-configuration file of stack mode.
      System will reboot. Continue? [Y/N]: y
      

      # Enable the stack function on CE12800-2 and restart the device.

      <CE12800-2> save
      Warning: The current configuration will be written to the device. Continue? [Y/N]: y
      <CE12800-2> system-view
      [~CE12800-2] stack
      [~CE12800-2-stack] stack enable
      Warning: Make sure that one or more dual-active detection methods are configured once the conversion is complete and the device enters the stack mode.
      Current configuration will be converted to the next startup saved-configuration file of stack mode.
      System will reboot. Continue? [Y/N]: y
      
    5. Rename the stack system CSS.

      <CE12800-1> system-view
      [~CE12800-1] sysname CSS
      [*CE12800-1] commit
      

  2. Configure iStack on access switches. The following uses CE6800-1 and CE6800-2 as an example.

    1. Configure the stack attributes for CE6800-1 and CE6800-2. (Set a higher priority for CE6800-1, so CE6800-1 will become the master switch.)

      # On CE6800-1, set the stack ID to 1, priority to 150, and domain ID to 20. (By default, the stack member ID of a switch is 1. In this example, CE6800-1 retains the default stack member ID 1, and you do not configure this parameter.)

      <HUAWEI> system-view
      [~HUAWEI] sysname CE6800-1
      [*HUAWEI] commit
      [~CE6800-1] stack
      [~CE6800-1-stack] stack member 1 priority 150
      [*CE6800-1-stack] stack member 1 domain 20
      [*CE6800-1-stack] quit
      [*CE6800-1] commit
      

      # On CE6800-2, set the stack ID to 2 and domain ID to 20.

      <HUAWEI> system-view
      [~HUAWEI] sysname CE6800-2
      [*HUAWEI] commit
      [~CE6800-2] stack
      [~CE6800-2-stack] stack member 1 renumber 2 inherit-config
      Warning: The stack configuration of member ID 1 will be inherited to member ID 2 after the device resets. Continue? [Y/N]: y
      [*CE6800-2-stack] stack member 1 priority 100
      [*CE6800-2-stack] stack member 1 domain 20
      [*CE6800-2-stack] quit
      [*CE6800-2] commit
      
    2. Configure stack ports. Two switches are connected by four 10GE optical ports.

      # On CE6800-1, add 10GE1/0/1-10GE1/0/4 to stack port 1/1.

      [~CE6800-1] interface stack-port 1/1
      [*CE6800-1-Stack-Port1/1] port member-group interface 10ge 1/0/1 to 1/0/4
      Warning: The interface(s) (10GE1/0/1-1/0/4) will be converted to stack mode. [Y/N]: y
      [*CE6800-1-Stack-Port1/1] quit
      [*CE6800-1] commit
      

      # The configuration procedure on CE6800-2 is the same as that on CE6800-1, and is not mentioned here.

    3. Save the configurations of CE6800-1 and CE6800-2, power off the two switches, connect stack cables, and power on the switches.

    4. Rename the stack system iStack-1. CE6800-1 functions as the master switch in this example.

      <CE6800-1> system-view
      [~CE6800-1] sysname iStack-1
      [*CE6800-1] commit
      
    5. Configure the stack consisting of CE6800-3 and CE6800-4 according to the preceding configurations. Rename the stack system iStack-2. CE6800-3 functions as the master switch in this example.

  3. Configure DAD in direct mode in the CSS and iStacks to ensure high reliability. The following uses the configuration of DAD in direct mode in the CSS as an example.

    # Configure DAD in direct mode on the directly connected interfaces between the two chassis in the CSS.

    [~CSS] interface 10ge 1/1/0/10
    [~CSS-10GE1/1/0/10] dual-active detect mode direct          //10GE1/1/0/10 is directly connected to 10GE2/1/0/10.
    Warning: The interface will block common data packets, except BPDU packets. Continue? [Y/N]: y
    [*CSS-10GE1/1/0/10] quit
    [*CSS] interface 10ge 2/1/0/10
    [*CSS-10GE2/1/0/10] dual-active detect mode direct
    Warning: The interface will block common data packets, except BPDU packets. Continue? [Y/N]: y
    [*CSS-10GE2/1/0/10] quit
    [*CSS] interface 10ge 1/2/0/10
    [*CSS-10GE1/2/0/10] dual-active detect mode direct          //10GE1/2/0/10 is directly connected to 10GE2/2/0/10.
    Warning: The interface will block common data packets, except BPDU packets. Continue? [Y/N]: y
    [*CSS-10GE1/2/0/10] quit
    [*CSS] interface 10ge 2/2/0/10
    [*CSS-10GE2/2/0/10] dual-active detect mode direct
    Warning: The interface will block common data packets, except BPDU packets. Continue? [Y/N]: y
    [*CSS-10GE2/2/0/10] quit
    [*CSS] commit
    

    # Configure DAD in direct mode in iStacks according to the preceding method. The configuration is not mentioned here.

  4. Divide the CSS on the core layer into VS1 and VS2.

    NOTE:

    The VS function is controlled by a license. By default, the VS function is disabled on a new device. To use the VS function, apply for and purchase the license from the Huawei local office.

    # Create VS1 and VS2 in port group mode, allocate the last 24 10GE ports on LPUs in slots 1/1 and 2/1 to VS1 and the last 24 10GE ports on LPUs in slots 1/2 and 2/2 to VS2.

    [~CSS] admin
    [~CSS-admin] virtual-system vs1          //Create VS1.
    [*CSS-admin-vs:vs1] port-mode group          //Configure VS1 as a port group VS.
    [*CSS-admin-vs:vs1] assign interface 10ge 1/1/0/47          //Allocate physical ports to VS1.
    Warning: All configurations of the interfaces will be deleted. All interfaces of the same group will be assigned. Continue? [Y/N]: y
    [*CSS-admin-vs:vs1] assign interface 10ge 2/1/0/47
    Warning: All configurations of the interfaces will be deleted. All interfaces of the same group will be assigned. Continue? [Y/N]: y
    [*CSS-admin-vs:vs1] quit
    [*CSS-admin] virtual-system vs2          //Create VS2.
    [*CSS-admin-vs:vs2] port-mode group
    [*CSS-admin-vs:vs2] assign interface 10ge 1/2/0/47
    Warning: All configurations of the interfaces will be deleted. All interfaces of the same group will be assigned. Continue? [Y/N]: y
    [*CSS-admin-vs:vs2] assign interface 10ge 2/2/0/47
    Warning: All configurations of the interfaces will be deleted. All interfaces of the same group will be assigned. Continue? [Y/N]: y
    [*CSS-admin-vs:vs2] commit
    [~CSS-admin-vs:vs2] return
    
    NOTE:

    Before allocating physical ports to a VS in port group mode, run the display device port-map [ slot slot-id ] command in the user or system view to check the mapping between forwarding chips and ports and determine which ports will be allocated to the VS.

    # Configure management IP addresses and management accounts for VSs.

    <CSS> switch virtual-system vs1          //Switch from the Admin-VS to VS1.
    <CSS-vs1> system-view
    [~CSS-vs1] interface MEth 0/0/0/0
    [~CSS-vs1-MEth0/0/0/0] ip address 10.1.1.10 24          //Configure a management interface IP address.
    [*CSS-vs1-MEth0/0/0/0] quit
    [*CSS-vs1] user-interface vty 0 4
    [*CSS-vs1-vty0-4] authentication-mode aaa          //Configure the user authentication mode.
    [*CSS-vs1-vty0-4] user privilege level 3          //Configure the user level.
    [*CSS-vs1-vty0-4] quit
    [*CSS-vs1] aaa
    [*CSS-vs1-aaa] local-user vs1_user password cipher VS1_password          //Configure a user name and password.
    [*CSS-vs1-aaa] local-user vs1_user service-type telnet
    [*CSS-vs1-aaa] local-user vs1_user level 3
    [*CSS-vs1-aaa] quit
    [*CSS-vs1] undo telnet server disable          //Start the Telnet service.
    [*CSS-vs1] commit
    

    # The configuration of VS2 is similar to that of VS1 and is not mentioned here.

  5. Configure VSs to connect to upstream and downstream devices through inter-chassis Eth-Trunks. The following uses the configuration between VS1 and iStack-1 as an example.

    # Create Eth-Trunk3 on VS1, and add 10GE1/1/0/47 and 10GE2/1/0/47 to Eth-Trunk3.

    [~CSS-vs1] interface eth-trunk 3
    [*CSS-vs1-Eth-Trunk3] description To_iStack-1
    [*CSS-vs1-Eth-Trunk3] trunkport 10ge 1/1/0/47 2/1/0/47           //Add member ports to Eth-Trunk3.
    [*CSS-vs1-Eth-Trunk3] quit
    [*CSS-vs1] commit
    

    # Create Eth-Trunk3 on iStack-1, and add 10GE1/0/5 and 10GE2/0/5 to Eth-Trunk3.

    [~iStack-1] interface eth-trunk 3
    [*iStack-1-Eth-Trunk3] description To_vs1
    [*iStack-1-Eth-Trunk3] trunkport 10ge 1/0/5 2/0/5
    [*iStack-1-Eth-Trunk3] quit
    [*iStack-1] commit
    

    # The configurations of other Eth-Trunks listed in Table 1-5 are similar to the configuration of Eth-Trunk3 and are not mentioned here.

  6. Configure VLANs on VSs and iStacks for Layer 2 interconnection.

    # Configure the interface connecting VS1 to iStack-1 to allow packets from VLAN 100 to pass through.

    [~CSS-vs1] vlan batch 100
    [*CSS-vs1] interface eth-trunk 3
    [*CSS-vs1-Eth-Trunk3] port link-type trunk
    [*CSS-vs1-Eth-Trunk3] undo port trunk allow-pass vlan 1
    [*CSS-vs1-Eth-Trunk3] port trunk allow-pass vlan 100
    [*CSS-vs1-Eth-Trunk3] quit
    [*CSS-vs1] commit
    

    # Configure the interface connecting iStack-1 to VS1 to allow packets from VLAN 100 to pass through.

    [~iStack-1] vlan batch 100
    [*iStack-1] interface eth-trunk 3
    [*iStack-1-Eth-Trunk3] port link-type trunk
    [*iStack-1-Eth-Trunk3] undo port trunk allow-pass vlan 1
    [*iStack-1-Eth-Trunk3] port trunk allow-pass vlan 100         //Configure Eth-Trunk3 to allow packets from VLAN100 to pass through.
    [*iStack-1-Eth-Trunk3] quit
    [*iStack-1] commit
    

    # Configure the interfaces connecting VS2 and iStack-2 to allow packets from VLAN 100 to pass through according to the preceding configurations. The configurations are not mentioned here.

  7. Configure IP addresses for interfaces.

    # Configure IP addresses for the VLANIF interfaces connecting VSs to iStacks. The following uses the configuration of VS1 as an example.

    [~CSS-vs1] interface vlanif 100
    [*CSS-vs1-Vlanif100] ip address 10.10.1.1 24          //Configure IP addresses for VLANIF interfaces.
    [*CSS-vs1-Vlanif100] quit
    [*CSS-vs1] commit
    

    # The configuration of VS2 is similar to that of VS1 and is not mentioned here.

    # Configure IP addresses for Eth-Trunks connecting VSs to the Router. The following uses the configuration of VS1 as an example.

    [~CSS-vs1] interface eth-trunk 1
    [~CSS-vs1-Eth-Trunk1] undo portswitch          //Configure the Eth-Trunk as a Layer 3 interface.
    [*CSS-vs1-Eth-Trunk1] ip address 10.10.10.1 24           //Configure an IP address for the Eth-Trunk.
    [*CSS-vs1-Eth-Trunk1] quit
    [*CSS-vs1] commit
    

    # The configurations of the Router and VS2 are similar to that of VS1 and are not mentioned here.

  8. Configure a routing protocol between VSs and upstream devices, and between VSs and downstream devices for Layer 3 interconnection.

    # Run OSPF between VSs and the Router and import direct routes to OSPF. The following uses the configuration of VS1 as an example. The configuration of VS2 is similar to that of VS1 and is not mentioned here.

    [~CSS-vs1] ospf 1           //Run OSPF between VS1 and the Router.
    [*CSS-vs1-ospf-1] area 0
    [*CSS-vs1-ospf-1-area-0.0.0.0] network 10.10.10.0 0.0.0.255
    [*CSS-vs1-ospf-1-area-0.0.0.0] quit
    [*CSS-vs1-ospf-1] import-route direct          //Import direct routes into OSPF.
    [*CSS-vs1-ospf-1] commit
    [~CSS-vs1-ospf-1] return
    

    # Configure OSPF on the Router. The configuration of the Router is similar to that of VS1 and is not mentioned here.

Checking the Configuration

After the preceding configurations are complete, check whether servers and the Router can successfully ping each other (the default gateway must be configured for servers). The following uses the ping operation from a server to the Router as an example.

PC> ping 10.10.10.2

Ping 10.10.10.2: 32 data bytes, Press Ctrl_C to break
From 10.10.10.2: bytes=32 seq=1 ttl=254 time=63 ms
From 10.10.10.2: bytes=32 seq=2 ttl=254 time=94 ms
From 10.10.10.2: bytes=32 seq=3 ttl=254 time=63 ms
From 10.10.10.2: bytes=32 seq=4 ttl=254 time=62 ms
From 10.10.10.2: bytes=32 seq=5 ttl=254 time=47 ms

--- 10.10.10.2 ping statistics ---
  5 packet(s) transmitted
  5 packet(s) received
  0.00% packet loss
  round-trip min/avg/max = 47/65/94 ms

Configuration Files

  • Configuration file of the Router

    #
    sysname Router
    #
    interface Eth-Trunk1
     ip address 10.10.10.2 255.255.255.0
    #
    interface Eth-Trunk2
     ip address 10.10.9.2 255.255.255.0
    #
    interface XGigabitEthernet1/0/1 
     eth-trunk 1
    #
    interface XGigabitEthernet1/0/2 
     eth-trunk 1
    #
    interface XGigabitEthernet1/0/3 
     eth-trunk 2
    #
    interface XGigabitEthernet1/0/4 
     eth-trunk 2
    #
    ospf 100
     area 0.0.0.0
      network 10.10.9.0 0.0.0.255
      network 10.10.10.0 0.0.0.255
    #
    return
    
  • Configuration file of the CSS on the core layer

    #
    sysname CSS
    #
    stack
     #
     stack mode
     #
     stack member 1 domain 10
     stack member 1 priority 150
     #
     stack member 2 domain 10
    #
    interface 10GE1/1/0/1
     port mode stack
     stack-port 1/1
    #
    interface 10GE1/1/0/2
     port mode stack
     stack-port 1/1
    #
    interface 10GE1/1/0/3
     port mode stack
     stack-port 1/1
    #
    interface 10GE1/1/0/4
     port mode stack
     stack-port 1/1
    #
    interface 10GE1/1/0/10
     dual-active detect mode direct
    #
    interface 10GE1/2/0/1
     port mode stack
     stack-port 1/1
    #
    interface 10GE1/2/0/2
     port mode stack
     stack-port 1/1
    #
    interface 10GE1/2/0/3
     port mode stack
     stack-port 1/1
    #
    interface 10GE1/2/0/4
     port mode stack
     stack-port 1/1
    #
    interface 10GE1/2/0/10
     dual-active detect mode direct
    #
    interface 10GE2/1/0/1
     port mode stack
     stack-port 2/1
    #
    interface 10GE2/1/0/2
     port mode stack
     stack-port 2/1
    #
    interface 10GE2/1/0/3
     port mode stack
     stack-port 2/1
    #
    interface 10GE2/1/0/4
     port mode stack
     stack-port 2/1
    #
    interface 10GE1/2/0/10
     dual-active detect mode direct
    #
    interface 10GE2/2/0/1
     port mode stack
     stack-port 2/1
    #
    interface 10GE2/2/0/2
     port mode stack
     stack-port 2/1
    #
    interface 10GE2/2/0/3
     port mode stack
     stack-port 2/1
    #
    interface 10GE2/2/0/4
     port mode stack
     stack-port 2/1
    #
    interface 10GE2/2/0/10
     dual-active detect mode direct
    #
    admin
     virtual-system vs1 
      port-mode group
      resource u4route upper-limit 60000
      resource m4route upper-limit 1000
      resource u6route upper-limit 16000
      resource m6route upper-limit 100
      resource vlan upper-limit 4063
      resource mpls enable
      resource trill enable
      resource mcast enable
      resource vpn-instance upper-limit 4096
      resource cpu weight 5
      resource memory ratio-threshold 100
      assign interface 10GE1/1/0/24
      assign interface 10GE1/1/0/25
      assign interface 10GE1/1/0/26
      assign interface 10GE1/1/0/27
      assign interface 10GE1/1/0/28
      assign interface 10GE1/1/0/29
      assign interface 10GE1/1/0/30
      assign interface 10GE1/1/0/31
      assign interface 10GE1/1/0/32
      assign interface 10GE1/1/0/33
      assign interface 10GE1/1/0/34
      assign interface 10GE1/1/0/35
      assign interface 10GE1/1/0/36
      assign interface 10GE1/1/0/37
      assign interface 10GE1/1/0/38
      assign interface 10GE1/1/0/39
      assign interface 10GE1/1/0/40
      assign interface 10GE1/1/0/41
      assign interface 10GE1/1/0/42
      assign interface 10GE1/1/0/43
      assign interface 10GE1/1/0/44
      assign interface 10GE1/1/0/45
      assign interface 10GE1/1/0/46
      assign interface 10GE1/1/0/47
      assign interface 10GE2/1/0/24
      assign interface 10GE2/1/0/25
      assign interface 10GE2/1/0/26
      assign interface 10GE2/1/0/27
      assign interface 10GE2/1/0/28
      assign interface 10GE2/1/0/29
      assign interface 10GE2/1/0/30
      assign interface 10GE2/1/0/31
      assign interface 10GE2/1/0/32
      assign interface 10GE2/1/0/33
      assign interface 10GE2/1/0/34
      assign interface 10GE2/1/0/35
      assign interface 10GE2/1/0/36
      assign interface 10GE2/1/0/37
      assign interface 10GE2/1/0/38
      assign interface 10GE2/1/0/39
      assign interface 10GE2/1/0/40
      assign interface 10GE2/1/0/41
      assign interface 10GE2/1/0/42
      assign interface 10GE2/1/0/43
      assign interface 10GE2/1/0/44
      assign interface 10GE2/1/0/45
      assign interface 10GE2/1/0/46
      assign interface 10GE2/1/0/47
     virtual-system vs2 
      port-mode group
      resource u4route upper-limit 60000
      resource m4route upper-limit 1000
      resource u6route upper-limit 16000
      resource m6route upper-limit 100
      resource vlan upper-limit 4063
      resource mpls enable
      resource trill enable
      resource mcast enable
      resource vpn-instance upper-limit 4096
      resource cpu weight 5
      resource memory ratio-threshold 100
      assign interface 10GE1/2/0/24
      assign interface 10GE1/2/0/25
      assign interface 10GE1/2/0/26
      assign interface 10GE1/2/0/27
      assign interface 10GE1/2/0/28
      assign interface 10GE1/2/0/29
      assign interface 10GE1/2/0/30
      assign interface 10GE1/2/0/31
      assign interface 10GE1/2/0/32
      assign interface 10GE1/2/0/33
      assign interface 10GE1/2/0/34
      assign interface 10GE1/2/0/35
      assign interface 10GE1/2/0/36
      assign interface 10GE1/2/0/37
      assign interface 10GE1/2/0/38
      assign interface 10GE1/2/0/39
      assign interface 10GE1/2/0/40
      assign interface 10GE1/2/0/41
      assign interface 10GE1/2/0/42
      assign interface 10GE1/2/0/43
      assign interface 10GE1/2/0/44
      assign interface 10GE1/2/0/45
      assign interface 10GE1/2/0/46
      assign interface 10GE1/2/0/47
      assign interface 10GE2/2/0/24
      assign interface 10GE2/2/0/25
      assign interface 10GE2/2/0/26
      assign interface 10GE2/2/0/27
      assign interface 10GE2/2/0/28
      assign interface 10GE2/2/0/29
      assign interface 10GE2/2/0/30
      assign interface 10GE2/2/0/31
      assign interface 10GE2/2/0/32
      assign interface 10GE2/2/0/33
      assign interface 10GE2/2/0/34
      assign interface 10GE2/2/0/35
      assign interface 10GE2/2/0/36
      assign interface 10GE2/2/0/37
      assign interface 10GE2/2/0/38
      assign interface 10GE2/2/0/39
      assign interface 10GE2/2/0/40
      assign interface 10GE2/2/0/41
      assign interface 10GE2/2/0/42
      assign interface 10GE2/2/0/43
      assign interface 10GE2/2/0/44
      assign interface 10GE2/2/0/45
      assign interface 10GE2/2/0/46
      assign interface 10GE2/2/0/47
    #
    return
    
  • Configuration file of VS1

    #
    sysname vs1
    #
    vlan batch 100
    #
    aaa
     local-user vs1_user password cipher %^%#TT4N+w]%[C+rM>)S8Ti!'p1iV@RZh(3MO7QGd96Z%^%#
     local-user vs1_user service-type telnet
     local-user vs1_user level 3
    #
    interface MEth0/0/0/0
     ip address 10.1.1.10 255.255.255.0
    #
    interface Vlanif100
     ip address 10.10.1.1 24
    #
    interface Eth-Trunk1
     undo portswitch
     description To_Router
     ip address 10.10.10.1 255.255.255.0
    #
    interface Eth-Trunk3
     description To_iStack-1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100
    
    #
    interface 10GE1/1/0/46
     eth-trunk 1
    #
    interface 10GE1/1/0/47
     eth-trunk 3
    #
    interface 10GE2/1/0/46
     eth-trunk 1
    #
    interface 10GE2/1/0/47
     eth-trunk 3
    #
    ospf 1
     import-route direct
     area 0.0.0.0
      network 10.10.10.0 0.0.0.255
    #
    user-interface vty 0 4
     authentication-mode aaa
     user privilege level 3
    #
    return
    
  • Configuration file of VS2

    #
    sysname vs2
    #
    vlan batch 100
    #
    aaa
     local-user vs2_user password cipher %^%#%j]%Lv%StAqIveR"YfuS<{^%;~p*$D<&&@X/Xs(/%^%#
     local-user vs2_user service-type telnet
     local-user vs2_user level 3
    #
    interface MEth0/0/0/0
     ip address 10.1.1.20 255.255.255.0
    #
    interface Vlanif100
     ip address 10.10.2.1 24
    #
    interface Eth-Trunk2
     undo portswitch
     description To_Router
     ip address 10.10.9.1 255.255.255.0
    #
    interface Eth-Trunk4
     description To_iStack-2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100
    #
    interface 10GE1/2/0/46
     eth-trunk 2
    #
    interface 10GE1/2/0/47
     eth-trunk 4
    #
    interface 10GE2/2/0/46
     eth-trunk 2
    #
    interface 10GE2/2/0/47
     eth-trunk 4
    #
    ospf 1
     import-route direct
     area 0.0.0.0
      network 10.10.9.0 0.0.0.255
    #
    user-interface vty 0 4
     authentication-mode aaa
     user privilege level 3
    #
    return
    
  • Configuration file of iStack-1 on the access layer

    #
    sysname iStack-1
    #
    vlan batch 100
    #
    interface Eth-Trunk3
     description To_vs1
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100
    #
    stack
     #
     stack member 1 domain 20
     stack member 1 priority 150
     #
     stack member 2 domain 20
    #
    interface 10GE1/0/1
     port mode stack
     stack-port 1/1
    #
    interface 10GE1/0/2
     port mode stack
     stack-port 1/1
    #
    interface 10GE1/0/3
     port mode stack
     stack-port 1/1
    #
    interface 10GE1/0/4
     port mode stack
     stack-port 1/1
    #
    interface 10GE1/0/5
     eth-trunk 3
    #
    interface 10GE1/0/9
     dual-active detect mode direct
    #
    interface 10GE1/0/10
     dual-active detect mode direct
    #
    interface 10GE2/0/1
     port mode stack
     stack-port 2/1
    #
    interface 10GE2/0/2
     port mode stack
     stack-port 2/1
    #
    interface 10GE2/0/3
     port mode stack
     stack-port 2/1
    #
    interface 10GE2/0/4
     port mode stack
     stack-port 2/1
    #
    interface 10GE2/0/5
     eth-trunk 3
    #
    interface 10GE2/0/9
     dual-active detect mode direct
    #
    interface 10GE2/0/10
     dual-active detect mode direct
    #
    return
    
  • Configuration file of iStack-2 on the access layer

    #
    sysname iStack-2
    #
    vlan batch 100
    #
    interface Eth-Trunk4
     description To_vs2
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 100
    #
    stack
     #
     stack member 1 domain 30
     stack member 1 priority 150
     #
     stack member 2 domain 30
    #
    interface 10GE1/0/1
     port mode stack
     stack-port 1/1
    #
    interface 10GE1/0/2
     port mode stack
     stack-port 1/1
    #
    interface 10GE1/0/3
     port mode stack
     stack-port 1/1
    #
    interface 10GE1/0/4
     port mode stack
     stack-port 1/1
    #
    interface 10GE1/0/5
     eth-trunk 4
    #
    interface 10GE1/0/9
     dual-active detect mode direct
    #
    interface 10GE1/0/10
     dual-active detect mode direct
    #
    interface 10GE2/0/1
     port mode stack
     stack-port 2/1
    #
    interface 10GE2/0/2
     port mode stack
     stack-port 2/1
    #
    interface 10GE2/0/3
     port mode stack
     stack-port 2/1
    #
    interface 10GE2/0/4
     port mode stack
     stack-port 2/1
    #
    interface 10GE2/0/5
     eth-trunk 4
    #
    interface 10GE2/0/9
     dual-active detect mode direct
    #
    interface 10GE2/0/10
     dual-active detect mode direct
    #
    return
    
Download
Updated: 2019-04-03

Document ID: EDOC1000039339

Views: 117677

Downloads: 7529

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next