No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Typical Configuration Examples

CloudEngine 12800, 12800E, 8800, 7800, 6800, and 5800 Series Switches

Rate and give feedback :
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Deploying VRRP on a Data Center Network with 2-Layer Architecture

Deploying VRRP on a Data Center Network with 2-Layer Architecture

Applicable Products and Versions

This example applies to the CE12800/CE6800 (excluding CE6810LI)/CE5800 V100R001C00 or later, the CE7800 V100R003C00 or later, the CE8800 V100R006C00 or later, and CE12800E V200R002C50 or later.

Networking Requirements

Access switches are dual-homed to core devices on a data center network. The requirements are as follows:

  • To ensure service reliability, deploy link redundancy. When one uplink is disconnected, traffic can be switched to another uplink.

  • Loops caused by link redundancy on the ring network are eliminated.

Figure 1-6 Networking for deploying VRRP on a data center network with 2-layer architecture
Table 1-4 Data preparation

Device

VLAN and IP Address

Interface

Description

SwitchA

VLAN: 2

IP Address: 10.1.2.102/24

Virtual IP Address: 10.1.2.100

10GE1/0/1

TO-CE6800-SWITCHC

10GE1/0/5

TO-CE12800-SWITCHB

VLAN: 3

IP Address: 10.1.3.102/24

Virtual IP Address: 10.1.3.100

10GE1/0/2

TO-CE6800-SWITCHD

10GE1/0/5

TO-CE12800-SWITCHB

VLAN: 4

IP Address: 10.1.4.102/24

Virtual IP Address: 10.1.4.100

10GE1/0/3

TO-CE6800-SWITCHE

10GE1/0/5

TO-CE12800-SWITCHB

VLAN: 5

IP Address: 10.1.5.102/24

Virtual IP Address: 10.1.5.100

10GE1/0/4

TO-CE6800-SWITCHF

10GE1/0/5

TO-CE12800-SWITCHB

VLAN: 6

IP Address: 10.1.6.103/24

10GE1/0/6

TO-ROUTERA

SwitchB

VLAN: 2

IP Address: 10.1.2.103/24

Virtual IP Address: 10.1.2.100

10GE1/0/4

TO-CE6800-SWITCHC

10GE1/0/5

TO-CE12800-SWITCHA

VLAN: 3

IP Address: 10.1.3.103/24

Virtual IP Address: 10.1.3.100

10GE1/0/3

TO-CE6800-SWITCHD

10GE1/0/5

TO-CE12800-SWITCHA

VLAN: 4

IP Address: 10.1.4.103/24

Virtual IP Address: 10.1.4.100

10GE1/0/2

TO-CE6800-SWITCHE

10GE1/0/5

TO-CE12800-SWITCHA

VLAN: 5

IP Address: 10.1.5.103/24

Virtual IP Address: 10.1.5.100

10GE1/0/1

TO-CE6800-SWITCHF

10GE1/0/5

TO-CE12800-SWITCHA

VLAN: 7

IP Address: 10.1.7.103/24

10GE1/0/6

TO-ROUTERB

SwitchC

VLAN: 2

10GE1/0/1

TO-CE12800-SWITCHA

10GE1/0/2

TO-CE12800-SWITCHB

10GE1/0/3

TO-HOSTA

SwitchD

VLAN: 3

10GE1/0/1

TO-CE12800-SWITCHB

10GE1/0/2

TO-CE12800-SWITCHA

10GE1/0/3

TO-HOSTB

SwitchE

VLAN: 4

10GE1/0/1

TO-CE12800-SWITCHA

10GE1/0/2

TO-CE12800-SWITCHB

10GE1/0/3

TO-HOSTC

SwitchF

VLAN: 5

10GE1/0/1

TO-CE12800-SWITCHB

10GE1/0/2

TO-CE12800-SWITCHA

10GE1/0/3

TO-HOSTD

Requirement Analysis

  • Deploy VRRP between SwitchA and SwitchB to implement link redundancy at the aggregation layer.

  • Deploy MSTP between access and core layers to eliminate loops.

Procedure

  1. Configure basic MSTP functions (SwitchA, SwitchB, SwitchC, and SwitchD are used as examples).

    NOTE:

    Two devices belong to the same MST region when the following parameters on the two devices are the same:

    • Name of the MST region

    • Mapping between VLANs and MSTIs

    • Revision level of the MST region

    1. Configure SwitchA, SwitchB, SwitchC, and SwitchD in the MST region RG1 and create MSTI 1 and MSTI 2.

      # Configure an MST region on SwitchA.

      <HUAWEI> system-view
      [~HUAWEI] sysname SwitchA
      [*HUAWEI] commit
      [~SwitchA] stp region-configuration
      [~SwitchA-mst-region] region-name RG1
      [*SwitchA-mst-region] instance 1 vlan 2
      [*SwitchA-mst-region] instance 2 vlan 3
      [*SwitchA-mst-region] commit
      [~SwitchA-mst-region] quit

      # Configure an MST region on SwitchB.

      <HUAWEI> system-view
      [~HUAWEI] sysname SwitchB
      [*HUAWEI] commit
      [~SwitchB] stp region-configuration
      [~SwitchB-mst-region] region-name RG1
      [*SwitchB-mst-region] instance 1 vlan 2
      [*SwitchB-mst-region] instance 2 vlan 3
      [*SwitchB-mst-region] commit
      [~SwitchB-mst-region] quit

      # Configure an MST region on SwitchC.

      <HUAWEI> system-view
      [~HUAWEI] sysname SwitchC
      [*HUAWEI] commit
      [~SwitchC] stp region-configuration
      [~SwitchC-mst-region] region-name RG1
      [*SwitchC-mst-region] instance 1 vlan 2
      [*SwitchC-mst-region] instance 2 vlan 3
      [*SwitchC-mst-region] commit
      [~SwitchC-mst-region] quit

      # Configure an MST region on SwitchD.

      <HUAWEI> system-view
      [~HUAWEI] sysname SwitchD
      [*HUAWEI] commit
      [~SwitchD] stp region-configuration
      [~SwitchD-mst-region] region-name RG1
      [*SwitchD-mst-region] instance 1 vlan 2
      [*SwitchD-mst-region] instance 2 vlan 3
      [*SwitchD-mst-region] commit
      [~SwitchD-mst-region] quit
    2. Configure root bridges and secondary root bridges of MSTI 1 and MSTI 2 in the MST region RG1.

      • Configure the root bridge and secondary root bridge of MSTI 1.

        # Configure SwitchA as the root bridge in MSTI 1.

        [~SwitchA] stp instance 1 root primary
        [*SwitchA] commit

        # Configure SwitchB as the secondary root bridge in MSTI 1.

        [~SwitchB] stp instance 1 root secondary
        [*SwitchB] commit
      • Configure the root bridge and secondary root bridge of MSTI 2.

        # Configure SwitchB as the root bridge in MSTI 2.

        [~SwitchB] stp instance 2 root primary
        [*SwitchB] commit

        # Configure SwitchA as the secondary root bridge in MSTI 2.

        [~SwitchA] stp instance 2 root secondary
        [*SwitchA] commit
    3. Set the path costs of the interfaces to be blocked in MSTI 1 and MSTI 2 to be greater than the default value.

      NOTE:
      • The path cost range depends on the algorithm. Huawei proprietary algorithm is used as an example. Set the path costs of the interfaces to be blocked in MSTI 1 and MSTI 2 to 20000.

      • Switching devices on the same network must use the same algorithm to calculate the path cost of interfaces.

      # Configure SwitchA to use Huawei proprietary algorithm to calculate the path cost.

      [~SwitchA] stp pathcost-standard legacy
      [*SwitchA] commit

      # Configure SwitchB to use Huawei proprietary algorithm to calculate the path cost.

      [~SwitchB] stp pathcost-standard legacy
      [*SwitchB] commit

      # Configure SwitchA to use Huawei proprietary algorithm to calculate the path cost and set the path cost of 10GE1/0/2 to 20000 in MSTI 1.

      [~SwitchC] stp pathcost-standard legacy
      [*SwitchC] interface 10ge 1/0/2
      [*SwitchC-10GE1/0/2] description TO-CE12800-SWITCHB
      [*SwitchC-10GE1/0/2] stp instance 1 cost 20000
      [*SwitchC-10GE1/0/2] commit
      [~SwitchC-10GE1/0/2] quit

      # Configure SwitchD to use Huawei proprietary algorithm to calculate the path cost and set the path cost of 10GE1/0/2 to 20000 in MSTI 2.

      [~SwitchD] stp pathcost-standard legacy
      [*SwitchD] interface 10ge 1/0/2
      [*SwitchD-10GE1/0/2] description TO-CE12800-SWITCHA
      [*SwitchD-10GE1/0/2] stp instance 2 cost 20000
      [*SwitchD-10GE1/0/2] commit
      [~SwitchD-10GE1/0/2] quit
    4. Enable MSTP to eliminate loops.

      NOTE:

      MSTP is enabled by default.

      • Enable MSTP globally.

        # Enable MSTP on SwitchA.

        [~SwitchA] stp enable
        [*SwitchA] commit

        # Enable MSTP on SwitchB.

        [~SwitchB] stp enable
        [*SwitchB] commit

        # Enable MSTP on SwitchC.

        [~SwitchC] stp enable
        [*SwitchC] commit

        # Enable MSTP on SwitchD.

        [~SwitchD] stp enable
        [*SwitchD] commit
      • Configure ports connected to hosts as edge ports.

        Configure 10GE1/0/3 of SwitchC as an edge port.

        [~SwitchC] interface 10ge 1/0/3
        [~SwitchC-10GE1/0/3] description TO-HOSTA
        [*SwitchC-10GE1/0/3] stp edged-port enable 
        [*SwitchC-10GE1/0/3] commit
        [~SwitchC-10GE1/0/3] quit

        # Configure 10GE1/0/3 of SwitchD as an edge port.

        [~SwitchD] interface 10ge 1/0/3
        [~SwitchD-10GE1/0/3] description TO-HOSTB
        [*SwitchD-10GE1/0/3] stp edged-port enable 
        [*SwitchD-10GE1/0/3] commit
        [~SwitchD-10GE1/0/3] quit

  2. Enable protection functions on the designated port of each root bridge in each MSTI. Here, root protection is used (SwitchA, SwitchB, SwitchC, and SwitchD are used as examples).

    # Enable root protection on 10GE1/0/1 of SwitchA.

    [~SwitchA] interface 10ge 1/0/1
    [~SwitchA-10GE1/0/1] TO-CE6800-SWITCHC
    [*SwitchA-10GE1/0/1] stp root-protection
    [*SwitchA-10GE1/0/1] commit
    [~SwitchA-10GE1/0/1] quit

    # Enable root protection on 10GE1/0/3 of SwitchB.

    [~SwitchB] interface 10ge 1/0/3
    [~SwitchB-10GE1/0/3] TO-CE6800-SWITCHD
    [*SwitchB-10GE1/0/3] stp root-protection
    [*SwitchB-10GE1/0/3] commit
    [~SwitchB-10GE1/0/3] quit

  3. Configure Layer 2 forwarding on switches on the ring network (SwitchA, SwitchB, SwitchC, and SwitchD are used as examples).

    • Create VLAN 2 and VLAN 3 on SwitchA, SwitchB, and SwitchC.

      # Create VLAN 2 and VLAN 3 on SwitchA.

      [~SwitchA] vlan batch 2 to 3

      # Create VLAN 2 and VLAN 3 on SwitchB.

      [~SwitchB] vlan batch 2 to 3

      # Create VLAN 2 on SwitchC.

      [~SwitchC] vlan batch 2

      # Create VLAN 3 on SwitchD.

      [~SwitchD] vlan batch 3
    • Add interfaces connecting to the ring to VLANs.

      # Add 10GE1/0/1 on SwitchA to VLAN 2.

      [~SwitchA] interface 10ge 1/0/1
      [~SwitchA-10GE1/0/1] port link-type trunk
      [*SwitchA-10GE1/0/1] port trunk allow-pass vlan 2
      [*SwitchA-10GE1/0/1] undo port trunk allow-pass vlan 1
      [*SwitchA-10GE1/0/1] commit
      [~SwitchA-10GE1/0/1] quit

      # Add 10GE1/0/2 on SwitchA to VLAN 3.

      [~SwitchA] interface 10ge 1/0/2
      [~SwitchA-10GE1/0/2] description TO-CE6800-SWITCHD
      [*SwitchA-10GE1/0/2] port link-type trunk
      [*SwitchA-10GE1/0/2] port trunk allow-pass vlan 3
      [*SwitchA-10GE1/0/2] undo port trunk allow-pass vlan 1
      [*SwitchA-10GE1/0/2] commit
      [~SwitchA-10GE1/0/2] quit

      # Add 10GE1/0/5 on SwitchA to VLAN 2 and VLAN 3.

      [~SwitchA] interface 10ge 1/0/5
      [~SwitchA-10GE1/0/5] description TO-CE12800-SWITCHB
      [*SwitchA-10GE1/0/5] port link-type trunk
      [*SwitchA-10GE1/0/5] port trunk allow-pass vlan 2 to 3
      [*SwitchA-10GE1/0/5] undo port trunk allow-pass vlan 1
      [*SwitchA-10GE1/0/5] commit
      [~SwitchA-10GE1/0/5] quit

      # Add 10GE1/0/3 on SwitchB to VLAN 3.

      [~SwitchB] interface 10ge 1/0/3
      [~SwitchB-10GE1/0/3] port link-type trunk
      [*SwitchB-10GE1/0/3] port trunk allow-pass vlan 3
      [*SwitchB-10GE1/0/3] undo port trunk allow-pass vlan 1
      [*SwitchB-10GE1/0/3] commit
      [~SwitchB-10GE1/0/3] quit

      # Add 10GE1/0/4 on SwitchB to VLAN 2.

      [~SwitchB] interface 10ge 1/0/4
      [~SwitchB-10GE1/0/4] description TO-CE6800-SWITCHC
      [*SwitchB-10GE1/0/4] port link-type trunk
      [*SwitchB-10GE1/0/4] port trunk allow-pass vlan 2
      [*SwitchB-10GE1/0/4] undo port trunk allow-pass vlan 1
      [*SwitchB-10GE1/0/4] commit
      [~SwitchB-10GE1/0/4] quit

      # Add 10GE1/0/5 on SwitchB to VLAN 2 and VLAN 3.

      [~SwitchB] interface 10ge 1/0/5
      [~SwitchB-10GE1/0/5] description TO-CE12800-SWITCHB
      [*SwitchB-10GE1/0/5] port link-type trunk
      [*SwitchB-10GE1/0/5] port trunk allow-pass vlan 2 to 3
      [*SwitchB-10GE1/0/5] undo port trunk allow-pass vlan 1
      [*SwitchB-10GE1/0/5] commit
      [~SwitchB-10GE1/0/5] quit

      # Add 10GE1/0/1 on SwitchC to VLAN 2.

      [~SwitchC] interface 10ge 1/0/1
      [~SwitchC-10GE1/0/1] description TO-CE12800-SWITCHA
      [*SwitchC-10GE1/0/1] port trunk allow-pass vlan 2
      [*SwitchC-10GE1/0/1] undo port trunk allow-pass vlan 1
      [*SwitchC-10GE1/0/1] commit
      [~SwitchC-10GE1/0/1] quit

      # Add 10GE1/0/2 on SwitchC to VLAN 2.

      [~SwitchC] interface 10ge 1/0/2
      [~SwitchC-10GE1/0/2] port link-type trunk
      [*SwitchC-10GE1/0/2] port trunk allow-pass vlan 2
      [*SwitchC-10GE1/0/2] undo port trunk allow-pass vlan 1
      [*SwitchC-10GE1/0/2] commit
      [~SwitchC-10GE1/0/2] quit

      # Add 10GE1/0/3 on SwitchC to VLAN 2.

      [~SwitchC] interface 10ge 1/0/3
      [~SwitchC-10GE1/0/3] port link-type access
      [*SwitchC-10GE1/0/3] port default vlan 2
      [*SwitchC-10GE1/0/3] commit
      [~SwitchC-10GE1/0/3] quit

      # Add 10GE1/0/1 on SwitchD to VLAN 3.

      [~SwitchD] interface 10ge 1/0/1
      [~SwitchD-10GE1/0/1] description TO-CE12800-SWITCHB
      [*SwitchD-10GE1/0/1] port link-type trunk
      [*SwitchD-10GE1/0/1] port trunk allow-pass vlan 3
      [*SwitchD-10GE1/0/1] undo port trunk allow-pass vlan 1
      [*SwitchD-10GE1/0/1] commit
      [~SwitchD-10GE1/0/1] quit

      # Add 10GE1/0/2 on SwitchD to VLAN 3.

      [~SwitchD] interface 10ge 1/0/2
      [~SwitchD-10GE1/0/2] port link-type trunk
      [*SwitchD-10GE1/0/2] port trunk allow-pass vlan 3
      [*SwitchD-10GE1/0/2] commit
      [~SwitchD-10GE1/0/2] quit

      # Add 10GE1/0/3 on SwitchD to VLAN 3.

      [~SwitchD] interface 10ge 1/0/3
      [~SwitchD-10GE1/0/3] port link-type access
      [*SwitchD-10GE1/0/3] port default vlan 3
      [*SwitchD-10GE1/0/3] commit
      [~SwitchD-10GE1/0/3] quit

  4. Configure devices to ensure network connectivity.

    # Assign an IP address to each interface. SwitchA is used as an example. The configurations of other devices are similar to the configuration of SwitchA.

    [~SwitchA] vlan batch 6
    [*SwitchA] interface 10ge 1/0/6
    [*SwitchA-10GE1/0/6] description TO-ROUTERA
    [*SwitchA-10GE1/0/6] port link-type trunk
    [*SwitchA-10GE1/0/6] port trunk allow-pass vlan 6
    [*SwitchA-10GE1/0/6] undo port trunk allow-pass vlan 1
    [*SwitchA-10GE1/0/6] quit
    [*SwitchA] interface vlanif 2
    [*SwitchA-Vlanif2] ip address 10.1.2.102 24
    [*SwitchA-Vlanif2] quit
    [*SwitchA] interface vlanif 3
    [*SwitchA-Vlanif3] ip address 10.1.3.102 24
    [*SwitchA-Vlanif3] quit
    [*SwitchA] interface vlanif 4
    [*SwitchA-Vlanif4] ip address 10.1.4.102 24
    [*SwitchA-Vlanif4] quit
    [*SwitchA] interface vlanif 5
    [*SwitchA-Vlanif5] ip address 10.1.5.102 24
    [*SwitchA-Vlanif5] quit
    [*SwitchA] interface vlanif 6
    [*SwitchA-Vlanif6] ip address 10.1.6.102 24
    [*SwitchA-Vlanif6] quit
    [*SwitchA] commit

    # Configure OSPF between core devices and egress router. SwitchA is used as an example. The configurations of other devices are similar to the configuration of SwitchA.

    [~SwitchA] ospf 1
    [*SwitchA-ospf-1] area 0
    [*SwitchA-ospf-1-area-0.0.0.0] network 10.1.2.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] network 10.1.3.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] network 10.1.4.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] network 10.1.5.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] network 10.1.6.0 0.0.0.255
    [*SwitchA-ospf-1-area-0.0.0.0] quit
    [*SwitchA-ospf-1] quit
    [*SwitchA] commit

  5. Configure VRRP groups.

    # Configure VRRP group 1 on SwitchA and SwitchB, set the priority of SwitchA to 120 and the preemption delay to 20s, and set the default priority for SwitchB.

    [~SwitchA] interface vlanif 2
    [~SwitchA-Vlanif2] vrrp vrid 1 virtual-ip 10.1.2.100
    [*SwitchA-Vlanif2] vrrp vrid 1 priority 120
    [*SwitchA-Vlanif2] vrrp vrid 1 preempt-mode timer delay 20
    [*SwitchA-Vlanif2] commit
    [~SwitchA-Vlanif2] quit
    [~SwitchB] interface vlanif 2
    [~SwitchB-Vlanif2] vrrp vrid 1 virtual-ip 10.1.2.100
    [*SwitchB-Vlanif2] commit
    [~SwitchB-Vlanif2] quit

    # Configure VRRP group 2 on SwitchA and SwitchB, set the priority of SwitchB to 120 and the preemption delay to 20s, and set the default priority for SwitchA.

    [~SwitchB] interface vlanif 3
    [~SwitchB-Vlanif3] vrrp vrid 2 virtual-ip 10.1.3.100
    [*SwitchB-Vlanif3] vrrp vrid 2 priority 120
    [*SwitchB-Vlanif3] vrrp vrid 2 preempt-mode timer delay 20
    [*SwitchB-Vlanif3] commit
    [~SwitchB-Vlanif3] quit
    [~SwitchA] interface vlanif 3
    [~SwitchA-Vlanif3] vrrp vrid 2 virtual-ip 10.1.3.100
    [*SwitchA-Vlanif3] commit
    [~SwitchA-Vlanif3] quit

    # Configure VRRP group 3 on SwitchA and SwitchB, set the priority of SwitchA to 120 and the preemption delay to 20s, and set the default priority for SwitchB.

    [~SwitchA] interface vlanif 4
    [~SwitchA-Vlanif4] vrrp vrid 3 virtual-ip 10.1.4.100
    [*SwitchA-Vlanif4] vrrp vrid 3 priority 120
    [*SwitchA-Vlanif4] vrrp vrid 3 preempt-mode timer delay 20
    [*SwitchA-Vlanif4] commit
    [~SwitchA-Vlanif4] quit
    [~SwitchB] interface vlanif 4
    [~SwitchB-Vlanif4] vrrp vrid 3 virtual-ip 10.1.4.100
    [*SwitchB-Vlanif4] commit
    [~SwitchB-Vlanif4] quit

    # Configure VRRP group 4 on SwitchA and SwitchB, set the priority of SwitchB to 120 and the preemption delay to 20s, and set the default priority for SwitchA.

    [~SwitchB] interface vlanif 5
    [~SwitchB-Vlanif5] vrrp vrid 4 virtual-ip 10.1.5.100
    [*SwitchB-Vlanif5] vrrp vrid 4 priority 120
    [*SwitchB-Vlanif5] vrrp vrid 4 preempt-mode timer delay 20
    [*SwitchB-Vlanif5] commit
    [~SwitchB-Vlanif5] quit
    [~SwitchA] interface vlanif 5
    [~SwitchA-Vlanif5] vrrp vrid 4 virtual-ip 10.1.3.100
    [*SwitchA-Vlanif5] commit
    [~SwitchA-Vlanif5] quit

    # Set virtual IP address 10.1.2.100 of VRRP group 1 as the default gateway of HostA, virtual IP address 10.1.3.100 of VRRP group 2 as the default gateway of HostB, virtual IP address 10.1.4.100 of VRRP group 3 as the default gateway of HostC, and virtual IP address 10.1.5.100 of VRRP group 4 as the default gateway of HostD.

Verifying the Configuration

  1. # After the configuration is complete, run the display vrrp command on SwitchA. You can see that SwitchA is the master in VRRP group 1 and the backup in VRRP group 2.

    <SwitchA> display vrrp verbose
      Vlanif2 | Virtual Router 1
        State : Master
        Virtual IP : 10.1.2.100
        Master IP : 10.1.2.102
        PriorityRun : 120
        PriorityConfig : 120                                                        
        MasterPriority : 120                                                        
        Preempt : YES   Delay Time : 20 s   Remain : --
        TimerRun : 1 s                                                              
        TimerConfig : 1 s                                                           
        Auth Type : NONE                                                            
        Virtual MAC : 0000-5e00-0101                                                
        Check TTL : YES                                                             
        Config Type : normal-vrrp                                                   
        Create Time : 2013-05-11 11:39:18                                          
        Last Change Time : 2013-05-26 11:38:58
    
      Vlanif3 | Virtual Router 2
        State : Backup
        Virtual IP : 10.1.3.100
        Master IP : 10.1.3.103
        PriorityRun : 100
        PriorityConfig : 100                                                        
        MasterPriority : 120                                                        
        Preempt : YES   Delay Time : 0 s   Remain : --
        TimerRun : 1 s                                                              
        TimerConfig : 1 s                                                           
        Auth type : NONE                                                            
        Virtual MAC : 0000-5e00-0102                                                
        Check TTL : YES                                                             
        Config Type : normal-vrrp                                                   
        Create Time : 2013-05-11 11:40:18                                           
        Last Change Time : 2013-05-26 11:48:58
    
  2. Run the display vrrp command on SwitchB. You can see that SwitchB is the backup in VRRP group 1 and the master in VRRP group 2.

    <SwitchB> display vrrp verbose
      Vlanif2 | Virtual Router 1
        State : Backup
        Virtual IP : 10.1.2.100
        Master IP : 10.1.2.102
        PriorityRun : 100
        PriorityConfig : 100                                                        
        MasterPriority : 120                                                        
        Preempt : YES   Delay Time : 0 s   Remain : --
        TimerRun : 1 s                                                              
        TimerConfig : 1 s                                                           
        Auth Type : NONE                                                            
        Virtual MAC : 0000-5e00-0101                                                
        Check TTL : YES                                                             
        Config Type : normal-vrrp                                                   
        Create Time : 2012-05-11 11:39:18                                           
        Last Change Time : 2012-05-26 11:38:58
    
      Vlanif3 | Virtual Router 2
        State : Master
        Virtual IP : 10.1.3.100
        Master IP : 10.1.3.103
        PriorityRun : 120
        PriorityConfig : 120                                                        
        MasterPriority : 120                                                        
        Preempt : YES   Delay Time : 20 s   Remain : --
        TimerRun : 1 s                                                              
        TimerConfig : 1 s                                                           
        Auth type : NONE                                                            
        Virtual MAC : 0000-5e00-0102                                                
        Check TTL : YES                                                             
        Config Type : normal-vrrp                                                   
        Create Time : 2012-05-11 11:40:18                                           
        Last Change Time : 2012-05-26 11:48:58
    

Configuration Files

  • Configuration file of SwitchA

    #
    sysname SwitchA
    #
    vlan batch 2 to 6
    #
    stp instance 1 root primary
    stp instance 2 root secondary
    stp instance 3 root primary
    stp instance 4 root secondary
    stp pathcost-standard legacy
    #
    stp region-configuration
     region-name RG1
     instance 1 vlan 2
     instance 2 vlan 3
     instance 3 vlan 4
     instance 4 vlan 5
    #
    interface Vlanif2
     ip address 10.1.2.102 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.2.100
     vrrp vrid 1 priority 120
     vrrp vrid 1 preempt-mode timer delay 20
    #
    interface Vlanif3
     ip address 10.1.3.102 255.255.255.0
     vrrp vrid 2 virtual-ip 10.1.3.100
    #
    interface Vlanif4
     ip address 10.1.4.102 255.255.255.0
     vrrp vrid 3 virtual-ip 10.1.4.100
     vrrp vrid 3 priority 120
     vrrp vrid 3 preempt-mode timer delay 20
    #
    interface Vlanif5
     ip address 10.1.5.102 255.255.255.0
     vrrp vrid 4 virtual-ip 10.1.5.100
    #
    interface Vlanif6
     ip address 10.1.6.102 255.255.255.0
    #
    interface 10GE1/0/1
     description TO-CE6800-SWITCHC
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 2
     stp root-protection
    #
    interface 10GE1/0/2
     description TO-CE6800-SWITCHD
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 3
    #
    interface 10GE1/0/3
     description TO-CE6800-SWITCHE
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 4
     stp root-protection
    #
    interface 10GE1/0/4
     description TO-CE6800-SWITCHF
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5
    #
    interface 10GE1/0/5
     description TO-CE12800-SWITCHB
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 2 to 5
    #
    interface 10GE1/0/6
     description TO-ROUTERA
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 6
    #
    ospf 1
     area 0.0.0.0
      network 10.1.2.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
      network 10.1.4.0 0.0.0.255
      network 10.1.5.0 0.0.0.255
      network 10.1.6.0 0.0.0.255
    #
    return
  • Configuration file of SwitchB

    #
    sysname SwitchB
    #
    vlan batch 2 to 5 7
    #
    stp instance 1 root secondary
    stp instance 2 root primary
    stp instance 3 root secondary
    stp instance 4 root primary
    stp pathcost-standard legacy
    #
    stp region-configuration
     region-name RG1
     instance 1 vlan 2
     instance 2 vlan 3
     instance 3 vlan 4
     instance 4 vlan 5
    #
    interface Vlanif2
     ip address 10.1.2.103 255.255.255.0
     vrrp vrid 1 virtual-ip 10.1.2.100
    #
    interface Vlanif3
     ip address 10.1.3.103 255.255.255.0
     vrrp vrid 2 virtual-ip 10.1.3.100
     vrrp vrid 2 priority 120
     vrrp vrid 2 preempt-mode timer delay 20
    #
    interface Vlanif4
     ip address 10.1.4.103 255.255.255.0
     vrrp vrid 3 virtual-ip 10.1.4.100
    #
    interface Vlanif5
     ip address 10.1.5.103 255.255.255.0
     vrrp vrid 4 virtual-ip 10.1.5.100
     vrrp vrid 4 priority 120
     vrrp vrid 4 preempt-mode timer delay 20
    #
    interface Vlanif7
     ip address 10.1.7.103 255.255.255.0
    #
    interface 10GE1/0/1
     description TO-CE6800-SWITCHF
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5
     stp root-protection
    #
    interface 10GE1/0/2
     description TO-CE6800-SWITCHE
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 4
    #
    interface 10GE1/0/3
     description TO-CE6800-SWITCHD
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 3
     stp root-protection
    #
    interface 10GE1/0/4
     description TO-CE6800-SWITCHC
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 2
    #
    interface 10GE1/0/5
     description TO-CE12800-SWITCHA
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 2 to 5
    #
    interface 10GE1/0/6
     description TO-CE12800-SWITCHA
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 7
    #
    ospf 1
     area 0.0.0.0
      network 10.1.2.0 0.0.0.255
      network 10.1.3.0 0.0.0.255
      network 10.1.4.0 0.0.0.255
      network 10.1.5.0 0.0.0.255
      network 10.1.7.0 0.0.0.255
    #
    return
  • Configuration file of SwitchC

    #
    sysname SwitchC
    #
    vlan batch 2
    #
    stp pathcost-standard legacy
    #
    stp region-configuration
     region-name RG1
     instance 1 vlan 2
     instance 2 vlan 3
     instance 3 vlan 4
     instance 4 vlan 5
    #
    interface 10GE1/0/1
     description TO-CE12800-SWITCHA
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 2
    #
    interface 10GE1/0/2
     description TO-CE12800-SWITCHB
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 2
     stp instance 1 cost 20000
    #
    interface 10GE1/0/3
     description TO-HOSTA
     port link-type access
     port default vlan 2
     stp edged-port enable 
    #
    return
  • Configuration file of SwitchD

    #
    sysname SwitchD
    #
    vlan batch 3
    #
    stp pathcost-standard legacy
    #
    stp region-configuration
     region-name RG1
     instance 1 vlan 2
     instance 2 vlan 3
     instance 3 vlan 4
     instance 4 vlan 5
    #
    interface 10GE1/0/1
     description TO-CE12800-SWITCHB
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 3
    #
    interface 10GE1/0/2
     description TO-CE12800-SWITCHA
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 3
     stp instance 2 cost 20000
    #
    interface 10GE1/0/3
     description TO-HOSTB
     port link-type access
     port default vlan 3
     stp edged-port enable
    #
    return
  • Configuration file of SwitchE

    #
    sysname SwitchE
    #
    vlan batch 4
    #
    stp pathcost-standard legacy
    #
    stp region-configuration
     region-name RG1
     instance 1 vlan 2
     instance 2 vlan 3
     instance 3 vlan 4
     instance 4 vlan 5
    #
    interface 10GE1/0/1
     description TO-CE12800-SWITCHA
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 4
    #
    interface 10GE1/0/2
     description TO-CE12800-SWITCHB
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 4
     stp instance 1 cost 20000
    #
    interface 10GE1/0/3
     description TO-HOSTC
     port link-type access
     port default vlan 4
     stp edged-port enable
    #
    return
  • Configuration file of SwitchF

    #
    sysname SwitchF
    #
    vlan batch 5
    #
    stp pathcost-standard legacy
    #
    stp region-configuration
     region-name RG1
     instance 1 vlan 2
     instance 2 vlan 3
     instance 3 vlan 4
     instance 4 vlan 5
    #
    interface 10GE1/0/1
     description TO-CE12800-SWITCHB
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5
    #
    interface 10GE1/0/2
     description TO-CE12800-SWITCHA
     port link-type trunk
     undo port trunk allow-pass vlan 1
     port trunk allow-pass vlan 5
     stp instance 2 cost 20000
    #
    interface 10GE1/0/3
     description TO-HOSTD
     port link-type access
     port default vlan 5
     stp edged-port enable
    #
    return
Download
Updated: 2019-04-03

Document ID: EDOC1000039339

Views: 116543

Downloads: 7528

Average rating:
This Document Applies to these Products
Related Documents
Related Version
Share
Previous Next