No relevant resource is found in the selected language.

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Read our privacy policy>Search

Reminder

To have a better experience, please upgrade your IE browser.

upgrade

Typical Configuration Examples

CloudEngine 16800, 12800, 12800E, 8800, 7800, 6800, and 5800 Series Switches

Rate and give feedback:
Huawei uses machine translation combined with human proofreading to translate this document to different languages in order to help you better understand the content of this document. Note: Even the most advanced machine translation cannot match the quality of professional translators. Huawei shall not bear any responsibility for translation accuracy and it is recommended that you refer to the English document (a link for which has been provided).
Example for Configuring IPv6 M-LAG Lite

Example for Configuring IPv6 M-LAG Lite

Applicable Products and Versions

The following product running V200R019C00 or later versions:

  • CE12800E (configured with FD-X series cards)
  • CE6850HI, CE6850U-HI, CE6851HI, CE6855HI, CE6856HI, CE6857EI, CE6860EI, CE6865EI, CE7850EI, CE7855EI, CE8850EI, CE8860EI, CE8861EI, CE8868EI
The following product running V200R005C20 or later versions:
  • CE16800, CE6881, CE6863

Networking Requirements

As shown in Figure 1-16, on an IPv6 network, data center customers require device isolation at the access layer, control plane isolation, and device fault isolation, packet forwarding in active-active mode without being affected by upgrade. Multichassis Link Aggregation Group (M-LAG) Lite decouples the control planes of multiple devices, and achieves packet active-active forwarding in active-active mode among the devices, without the need to configure heartbeat links to synchronize data through negotiation packets.

Figure 1-16 IPv6 M-LAG Lite networking

Configuration Roadmap

This example only explains the configuration of IPv6 M-LAG Lite. If you need to configure M-LAG Lite over the IPv4/IPv6 dual stack, see Example for Configuring M-LAG Lite and this example.

The configuration roadmap is as follows:

  1. Configure servers to connect to leaf switches in M-LAG Lite mode.

    To ensure successful Eth-Trunk negotiation, ensure that Leaf1 and Leaf2 have the same LACP system priority and Eth-Trunks have the same interface ID and LACP system ID. In addition, the Eth-Trunk member interfaces on the two leaf switches must have different numbers in the LACP protocol to prevent LACP negotiation failures.

  2. Configure an IPv6 address for each interface.
  3. Configure the same IPv6 address and MAC address for VLANIF interfaces on leaf switches. The leaf switches function as the active-active gateways of servers.
    • A leaf switch must be a Layer 3 gateway but not a Layer 2 transparent transmission device. If a spine switch serves as a Layer 3 gateway and servers connect to leaf switches in M-LAG Lite mode, server ND entries learned by the spine device will have two egresses and MAC address flapping occurs. Therefore, the leaf switch to which servers connect in M-LAG Lite mode must be a Layer 3 gateway.
    • To make leaf switches function as Layer 3 gateways, that is, all traffic from servers to leaf switches be forwarded at Layer 3 (including the traffic forwarded in the same Layer 2 domain), enable proxy ND on leaf switches.
    • Configure the same IPv6 addresses for gateways on Leaf 1 and Leaf2 so that ECMP load balancing is performed on the traffic from spine switches to leaf switches. If a link between a server and leaf switch fails, for example, a link between Server1 and Leaf1 becomes faulty, only one link is available for traffic transmission and the traffic from Server1 to Leaf1 may be interrupted due to hash-based ECMP. Therefore, you need to ensure that the gateway interface of a leaf switch can advertise the NDP Vlink direct route to its neighbors and advertise the host route translated by the ND to spine switches. Then you need to configure a corresponding dynamic routing protocol on leaf switches to import the direct route. If the preceding fault occurs, the ND entry mapping Server1 on Leaf1 is deleted, the NDP Vlink direct route is unavailable, and the traffic from spine switches to Server1 is forwarded to Leaf2 to ensure normal traffic forwarding.
    • To ensure normal communication between Server1 and Server2, after learning the NDP Vlink direct route advertised by leaf switches, spine switches advertise the route to other leaf switches. In normal cases, both the host routes translated by the ND (not delivered to the forwarding entry) and the host routes advertised by spine switches are available on leaf switches. You need to set a higher priority for the host routes translated by the ND, to ensure that the local ND entries are forwarded. If a link between a server and leaf switch fails, for example, a link between Server1 and Leaf1 fails, the ND entry mapping Server1 on Leaf1 is deleted, and the NDP Vlink direct route becomes unavailable. The traffic from Server2 to Server1 starts from Server2, Leaf1, Spine1 or Spine2, Leaf2, and finally arrives at Server1.
  4. Configure a routing protocol between leaf and spine switches to establish neighbor relationships.
  5. Associate uplink and downlink interfaces in the Monitor Link group on the leaf switch to prevent user-side traffic from being discarded due to uplink faults.

Procedure

  1. Configure inter-device link aggregation in LACP mode.

    # Configure Leaf1.

    <HUAWEI> system-view
    [~HUAWEI] sysname Leaf1  //Change the device name to Leaf1.
    [*HUAWEI] commit
    [~Leaf1] vlan batch 100
    [*Leaf1] interface eth-trunk 10
    [*Leaf1-Eth-Trunk10] trunkport 10ge 1/0/3
    [*Leaf1-Eth-Trunk10] mode lacp-static
    [*Leaf1-Eth-Trunk10] lacp system-id 00e0-cf00-0000  //Configure the same LACP system ID on Leaf1 and Leaf2.
    [*Leaf1-Eth-Trunk10] port link-type trunk
    [*Leaf1-Eth-Trunk10] port trunk pvid vlan 100
    [*Leaf1-Eth-Trunk10] port trunk allow-pass vlan 100
    [*Leaf1-Eth-Trunk10] quit
    [*Leaf1] interface eth-trunk 20
    [*Leaf1-Eth-Trunk20] trunkport 10ge 1/0/4
    [*Leaf1-Eth-Trunk20] mode lacp-static
    [*Leaf1-Eth-Trunk20] lacp system-id 00e0-cf00-0001  //Configure the same LACP system ID on Leaf1 and Leaf2.
    [*Leaf1-Eth-Trunk20] port link-type trunk
    [*Leaf1-Eth-Trunk20] port trunk pvid vlan 100
    [*Leaf1-Eth-Trunk20] port trunk allow-pass vlan 100
    [*Leaf1-Eth-Trunk20] quit
    [*Leaf1] lacp priority 100  //Configure the same LACP system priority on Leaf1 and Leaf2.
    [*Leaf1] commit

    # Configure Leaf2.

    <HUAWEI> system-view
    [~HUAWEI] sysname Leaf2  //Change the device name to Leaf2.
    [*HUAWEI] commit
    [~Leaf2] vlan batch 100
    [*Leaf2] interface eth-trunk 10
    [*Leaf2-Eth-Trunk10] trunkport 10ge 1/0/3
    [*Leaf2-Eth-Trunk10] mode lacp-static
    [*Leaf2-Eth-Trunk10] lacp system-id 00e0-cf00-0000  //Configure the same LACP system ID on Leaf1 and Leaf2.
    [*Leaf2-Eth-Trunk10] lacp port-id-extension enable  //Enable the extension of Eth-Trunk member interface IDs on leaf2. Increase IDs of each Eth-Trunk member interface in LACP mode by 32768 to prevent the same interface ID of Eth-Trunk member interfaces on the two leaf switches.
    [*Leaf2-Eth-Trunk10] port link-type trunk
    [*Leaf2-Eth-Trunk10] port trunk pvid vlan 100
    [*Leaf2-Eth-Trunk10] port trunk allow-pass vlan 100
    [*Leaf2-Eth-Trunk10] quit
    [*Leaf2] interface eth-trunk 20
    [*Leaf2-Eth-Trunk20] trunkport 10ge 1/0/4
    [*Leaf2-Eth-Trunk20] mode lacp-static
    [*Leaf2-Eth-Trunk20] lacp system-id 00e0-cf00-0001  //Configure the same LACP system ID on Leaf1 and Leaf2.
    [*Leaf2-Eth-Trunk20] lacp port-id-extension enable  //Enable the extension of Eth-Trunk member interface IDs on leaf2. Increase IDs of each Eth-Trunk member interface in LACP mode by 32768 to prevent the same interface ID of Eth-Trunk member interfaces on the two leaf switches.
    [*Leaf2-Eth-Trunk20] port link-type trunk
    [*Leaf2-Eth-Trunk20] port trunk pvid vlan 100
    [*Leaf2-Eth-Trunk20] port trunk allow-pass vlan 100
    [*Leaf2-Eth-Trunk20] quit
    [*Leaf2] lacp priority 100  //Configure the same LACP system priority on Leaf1 and Leaf2.
    [*Leaf2] commit

  2. Configure interfaces and IPv6 addresses for the interfaces.

    # Configure Spine1.

    <HUAWEI> system-view
    [~HUAWEI] sysname Spine1  //Change the device name to Spine1.
    [*HUAWEI] commit
    [~Spine1] interface 10ge 1/0/1
    [~Spine1-10GE1/0/1] undo portswitch
    [*Spine1-10GE1/0/1] port-isolate l3 enable
    [*Spine1-10GE1/0/1] ipv6 enable  
    [*Spine1-10GE1/0/1] ipv6 address 2001:db8:1::1 64
    [*Spine1-10GE1/0/1] quit
    [*Spine1] interface 10ge 1/0/2
    [*Spine1-10GE1/0/2] undo portswitch
    [*Spine1-10GE1/0/2] port-isolate l3 enable
    [*Spine1-10GE1/0/2] ipv6 enable
    [*Spine1-10GE1/0/2] ipv6 address 2001:db8:3::1 64
    [*Spine1-10GE1/0/2] quit
    [*Spine1] commit

    # Configure Spine2.

    <HUAWEI> system-view
    [~HUAWEI] sysname Spine2  //Change the device name to Spine2.
    [*HUAWEI] commit
    [~Spine2] interface 10ge 1/0/1
    [~Spine2-10GE1/0/1] undo portswitch
    [*Spine2-10GE1/0/1] port-isolate l3 enable
    [*Spine2-10GE1/0/1] ipv6 enable
    [*Spine2-10GE1/0/1] ipv6 address 2001:db8:4::1 64
    [*Spine2-10GE1/0/1] quit
    [*Spine2] interface 10ge 1/0/2
    [*Spine2-10GE1/0/2] undo portswitch
    [*Spine2-10GE1/0/2] port-isolate l3 enable
    [*Spine2-10GE1/0/2] ipv6 enable
    [*Spine2-10GE1/0/2] ipv6 address 2001:db8:2::1 64
    [*Spine2-10GE1/0/2] quit
    [*Spine2] commit

    # Configure Leaf1.

    [~Leaf1] interface 10ge 1/0/1
    [~Leaf1-10GE1/0/1] undo portswitch
    [*Leaf1-10GE1/0/1] port-isolate l3 enable
    [*Leaf1-10GE1/0/1] ipv6 enable 
    [*Leaf1-10GE1/0/1] ipv6 address 2001:db8:1::2 64
    [*Leaf1-10GE1/0/1] quit
    [*Leaf1] interface 10ge 1/0/2
    [*Leaf1-10GE1/0/2] undo portswitch
    [*Leaf1-10GE1/0/2] port-isolate l3 enable
    [*Leaf1-10GE1/0/2] ipv6 enable 
    [*Leaf1-10GE1/0/2] ipv6 address 2001:db8:2::2 64
    [*Leaf1-10GE1/0/2] quit
    [*Leaf1] commit

    # Configure Leaf2.

    [~Leaf2] interface 10ge 1/0/1
    [~Leaf2-10GE1/0/1] undo portswitch
    [*Leaf2-10GE1/0/1] port-isolate l3 enable  
    [*Leaf2-10GE1/0/1] ipv6 enable 
    [*Leaf2-10GE1/0/1] ipv6 address 2001:db8:4::2 64
    [*Leaf2-10GE1/0/1] quit
    [*Leaf2] interface 10ge 1/0/2
    [*Leaf2-10GE1/0/2] undo portswitch
    [*Leaf2-10GE1/0/2] port-isolate l3 enable 
    [*Leaf2-10GE1/0/2] ipv6 enable 
    [*Leaf2-10GE1/0/2] ipv6 address 2001:db8:3::2 64
    [*Leaf2-10GE1/0/2] quit
    [*Leaf2] commit

  3. Configure the same IPv6 address and MAC address for VLANIF interfaces on leaf switches. The leaf switches function as the active-active gateways of access servers.

    # Configure Leaf1.

    [~Leaf1] interface vlanif 100
    [*Leaf1-Vlanif100] ipv6 enable
    [*Leaf1-Vlanif100] ipv6 address 2001:db8:100::1 64
    [*Leaf1-Vlanif100] ipv6 address FE80::300:3EFF:FE11:985 link-local
    [*Leaf1-Vlanif100] mac-address 0000-5e00-0101
    [*Leaf1-Vlanif100] ipv6 nd proxy anyway enable  //Enable any proxy ND response. After obtaining NS request packets sent by servers, leaf1 responds with the MAC address of its Layer 3 gateway interface. In this way, uplink traffic of servers is forwarded at Layer 3 after reaching leaf1.
    [*Leaf1-Vlanif100] ipv6 nd delete trigger link-down enable  //Enable fast deletion of ND entries if a link is Down. If a member interface goes Down, ND entries on the interface are deleted immediately.
    [*Leaf1-Vlanif100] ipv6 nd direct-route enable   //Enable interfaces to advertise NDP Vlink direct routes and import direct routes through the routing protocol. This enables the device to advertise ND-translated host routes to neighbors and prevents route black holes caused by link faults.
    [*Leaf1-Vlanif100] ipv6 nd direct-route preference 1  //Set the priority of an NDP Vlink direct route to 1.
    [*Leaf1-Vlanif100] ipv6 nd direct-route delay 120 
    [*Leaf1-Vlanif100] quit 
    [*Leaf1] commit

    # Configure Leaf2.

    [~Leaf2] interface vlanif 100
    [*Leaf2-Vlanif100] ipv6 enable
    [*Leaf2-Vlanif100] ipv6 address 2001:db8:100::1 64
    [*Leaf2-Vlanif100] ipv6 address FE80::300:3EFF:FE11:985 link-local
    [*Leaf2-Vlanif100] mac-address 0000-5e00-0101
    [*Leaf2-Vlanif100] ipv6 nd proxy anyway enable  //Enable any proxy ND response. After obtaining NS request packets sent by servers, leaf2 responds with the MAC address of its Layer 3 gateway interface. In this way, uplink traffic of servers is forwarded at Layer 3 after reaching leaf2.
    [*Leaf2-Vlanif100] ipv6 nd delete trigger link-down enable  //Enable fast deletion of ND entries if a link is Down. If a member interface goes Down, ND entries on the interface are deleted immediately.
    [*Leaf2-Vlanif100] ipv6 nd direct-route enable   // Enable interfaces to advertise NDP Vlink direct routes and import direct routes through the routing protocol. This enables the device to advertise ND-translated host routes to neighbors and prevents route black holes caused by link faults.
    [*Leaf2-Vlanif100] ipv6 nd direct-route preference 1  //Set the priority of an NDP Vlink direct route to 1.
    [*Leaf2-Vlanif100] ipv6 nd direct-route delay 120 
    [*Leaf2-Vlanif100] quit 
    [*Leaf2] commit

  4. Configure BGP on the aggregation and access switches to implement Layer 3 interworking.

    # Configure Spine1.

    [~Spine1] bgp 65009
    [*Spine1-bgp] router-id 172.16.1.1
    [*Spine1-bgp] group leaf external
    [*Spine1-bgp] peer leaf as-number 65021  
    [*Spine1-bgp] peer 2001:db8:1::2 as-number 65021
    [*Spine1-bgp] peer 2001:db8:1::2 group leaf
    [*Spine1-bgp] peer 2001:db8:3::2 as-number 65021
    [*Spine1-bgp] peer 2001:db8:3::2 group leaf
    [*Spine1-bgp] timer keepalive 10 hold 30
    [*Spine1-bgp] ipv6-family unicast
    [*Spine1-bgp-af-ipv6] preference 20 200 10
    [*Spine1-bgp-af-ipv6] peer 2001:db8:1::2 enable
    [*Spine1-bgp-af-ipv6] peer 2001:db8:3::2 enable
    [*Spine1-bgp-af-ipv6] network 2001:db8:1:: 64
    [*Spine1-bgp-af-ipv6] network 2001:db8:3:: 64
    [*Spine1-bgp-af-ipv6] maximum load-balancing 32
    [*Spine1-bgp-af-ipv6] quit
    [*Spine1-bgp] quit
    [*Spine1] commit

    # Configure Spine2.

    [~Spine2] bgp 65009
    [*Spine2-bgp] router-id 172.16.2.1
    [*Spine2-bgp] group leaf external
    [*Spine2-bgp] peer leaf as-number 65021  
    [*Spine2-bgp] peer 2001:db8:2::2 as-number 65021
    [*Spine2-bgp] peer 2001:db8:2::2 group leaf
    [*Spine2-bgp] peer 2001:db8:4::2 as-number 65021
    [*Spine2-bgp] peer 2001:db8:4::2 group leaf
    [*Spine2-bgp] timer keepalive 10 hold 30
    [*Spine2-bgp] ipv6-family unicast
    [*Spine2-bgp-af-ipv6] preference 20 200 10
    [*Spine2-bgp-af-ipv6] peer 2001:db8:2::2 enable
    [*Spine2-bgp-af-ipv6] peer 2001:db8:4::2 enable
    [*Spine2-bgp-af-ipv6] network 2001:db8:2:: 64
    [*Spine2-bgp-af-ipv6] network 2001:db8:4:: 64
    [*Spine2-bgp-af-ipv6] maximum load-balancing 32
    [*Spine2-bgp-af-ipv6] quit
    [*Spine2-bgp] quit
    [*Spine2] commit

    # Configure Leaf1.

    [~Leaf1] bgp 65021
    [*Leaf1-bgp] router-id 172.16.3.1
    [*Leaf1-bgp] group spine external
    [*Leaf1-bgp] peer spine as-number 65009  
    [*Leaf1-bgp] peer 2001:db8:1::1 as-number 65009
    [*Leaf1-bgp] peer 2001:db8:1::1 group spine
    [*Leaf1-bgp] peer 2001:db8:2::1 as-number 65009
    [*Leaf1-bgp] peer 2001:db8:2::1 group spine
    [*Leaf1-bgp] timer keepalive 10 hold 30
    [*Leaf1-bgp] ipv6-family unicast
    [*Leaf1-bgp-af-ipv6] preference 20 200 10
    [*Leaf1-bgp-af-ipv6] peer 2001:db8:1::1 enable
    [*Leaf1-bgp-af-ipv6] peer 2001:db8:2::1 enable
    [*Leaf1-bgp-af-ipv6] network 2001:db8:1:: 64
    [*Leaf1-bgp-af-ipv6] network 2001:db8:2:: 64
    [*Leaf1-bgp-af-ipv6] network 2001:db8:100:: 64
    [*Leaf1-bgp-af-ipv6] import-route direct // Import the routes learned through direct routes. You can configure a routing policy based on the actual networking to filter out unnecessary routes.
    [*Leaf1-bgp-af-ipv6] maximum load-balancing 32
    [*Leaf1-bgp-af-ipv6] quit
    [*Leaf1-bgp] quit
    [*Leaf1] commit

    # Configure Leaf2.

    [~Leaf2] bgp 65021
    [*Leaf2-bgp] router-id 172.16.4.1
    [*Leaf2-bgp] group spine external
    [*Leaf2-bgp] peer spine as-number 65009  
    [*Leaf2-bgp] peer 2001:db8:3::1 as-number 65009
    [*Leaf2-bgp] peer 2001:db8:3::1 group spine
    [*Leaf2-bgp] peer 2001:db8:4::1 as-number 65009
    [*Leaf2-bgp] peer 2001:db8:4::1 group spine
    [*Leaf2-bgp] timer keepalive 10 hold 30
    [*Leaf2-bgp] ipv6-family unicast
    [*Leaf2-bgp-af-ipv6] preference 20 200 10
    [*Leaf2-bgp-af-ipv6] peer 2001:db8:3::1 enable
    [*Leaf2-bgp-af-ipv6] peer 2001:db8:4::1 enable
    [*Leaf2-bgp-af-ipv6] network 2001:db8:3:: 64
    [*Leaf2-bgp-af-ipv6] network 2001:db8:4:: 64
    [*Leaf2-bgp-af-ipv6] network 2001:db8:100:: 64
    [*Leaf2-bgp-af-ipv6] import-route direct //Import the routes learned through direct routes. You can configure a routing policy based on the actual networking to filter out unnecessary routes.
    [*Leaf2-bgp-af-ipv6] maximum load-balancing 32
    [*Leaf2-bgp-af-ipv6] quit
    [*Leaf2-bgp] quit
    [*Leaf2] commit

  5. Configure the uplink and downlink interfaces associated with Monitor Link on leaf switches.

    # Configure Leaf1.

    [~Leaf1] monitor-link group 1
    [*Leaf1-mtlk-group1] port 10ge 1/0/1 uplink
    [*Leaf1-mtlk-group1] port 10ge 1/0/2 uplink
    [*Leaf1-mtlk-group1] port eth-trunk 10 downlink 1
    [*Leaf1-mtlk-group1] port eth-trunk 20 downlink 2
    [*Leaf1-mtlk-group1] timer recover-time 60
    [*Leaf1-mtlk-group1] quit
    [*Leaf1] commit

    # Configure Leaf2.

    [~Leaf2] monitor-link group 1
    [*Leaf2-mtlk-group1] port 10ge 1/0/1 uplink
    [*Leaf2-mtlk-group1] port 10ge 1/0/2 uplink
    [*Leaf2-mtlk-group1] port eth-trunk 10 downlink 1
    [*Leaf2-mtlk-group1] port eth-trunk 20 downlink 2
    [*Leaf2-mtlk-group1] timer recover-time 60
    [*Leaf2-mtlk-group1] quit
    [*Leaf2] commit

Verifying the Configuration

  • Check the Eth-Trunk information on Leaf1. The information shows that M-LAG Lite has successfully negotiated with the server and interfaces are Up.

    [~Leaf1] display eth-trunk 10
    Eth-Trunk10's state information is:
    Local:
    LAG ID: 10                      Working Mode: Static
    Preempt Delay: Disabled         Hash Arithmetic: profile default
    System Priority: 100            System ID: 00e0-cf00-0000
    Least Active-linknumber: 1      Max Active-linknumber: 32 
    Operating Status: up            Number Of Up Ports In Trunk: 1
    Timeout Period: Slow          
    --------------------------------------------------------------------------------
    ActorPortName          Status   PortType PortPri PortNo PortKey PortState Weight
    10GE1/0/3              Selected 10GE     32768   1      2625    10111100  1     
    
    Partner:
    --------------------------------------------------------------------------------
    ActorPortName          SysPri   SystemID        PortPri PortNo PortKey PortState
    10GE1/0/3              32768    0052-7512-2401  32768   1      2625    10111100 
    [~Leaf1] display eth-trunk 20
    Eth-Trunk20's state information is:
    Local:
    LAG ID: 20                      Working Mode: Static
    Preempt Delay: Disabled         Hash Arithmetic: profile default
    System Priority: 100            System ID: 00e0-cf00-0001
    Least Active-linknumber: 1      Max Active-linknumber: 32 
    Operating Status: up            Number Of Up Ports In Trunk: 1
    Timeout Period: Slow          
    --------------------------------------------------------------------------------
    ActorPortName          Status   PortType PortPri PortNo PortKey PortState Weight
    10GE1/0/4              Selected 10GE     32768   2      5185    10111100  1     
    
    Partner:
    --------------------------------------------------------------------------------
    ActorPortName          SysPri   SystemID        PortPri PortNo PortKey PortState
    10GE1/0/4              32768    406b-8839-8b01  32768   1      5185    10111100
  • Check whether Server1 and Server2 can communicate with each other.

    # Set the IPv6 addresses of Server1 and Server2 to 2001:db8:100::2/64 and 2001:db8:100::3/64 respectively.

    # After the configuration is complete, Server1 and Server2 can ping each other.

Configuration Files

  • Spine1 configuration file
    #
    sysname Spine1
    #
    interface 10GE1/0/1
     undo portswitch
     ipv6 enable
     ipv6 address 2001:DB8:1::1/64
     port-isolate l3 enable 
    #
    interface 10GE1/0/2
     undo portswitch
     ipv6 enable
     ipv6 address 2001:DB8:3::1/64
     port-isolate l3 enable 
    #
    bgp 65009
     router-id 172.16.1.1 
     timer keepalive 10 hold 30
     group leaf external
     peer leaf as-number 65021
     peer 2001:DB8:1::2 as-number 65021
     peer 2001:DB8:1::2 group leaf
     peer 2001:DB8:3::2 as-number 65021
     peer 2001:DB8:3::2 group leaf
     #
     ipv6-family unicast
      preference 20 200 10 
      network 2001:DB8:1:: 64                                                       
      network 2001:DB8:3:: 64 
      maximum load-balancing 32
      peer 2001:DB8:1::2 enable                                                     
      peer 2001:DB8:3::2 enable
    #
    return
  • Spine2 configuration file
    #
    sysname Spine2
    #
    interface 10GE1/0/1
     undo portswitch
     ipv6 enable
     ipv6 address 2001:DB8:4::1/64
     port-isolate l3 enable
    #
    interface 10GE1/0/2
     undo portswitch
     ipv6 enable
     ipv6 address 2001:DB8:2::1/64
     port-isolate l3 enable
    #
    bgp 65009
     router-id 172.16.2.1 
     timer keepalive 10 hold 30
     group leaf external
     peer leaf as-number 65021
     peer 2001:DB8:2::2 as-number 65021
     peer 2001:DB8:2::2 group leaf
     peer 2001:DB8:4::2 as-number 65021
     peer 2001:DB8:4::2 group leaf
     #
     ipv6-family unicast
      preference 20 200 10 
      network 2001:DB8:2:: 64                                                       
      network 2001:DB8:4:: 64   
      maximum load-balancing 32
      peer 2001:DB8:2::2 enable                                                     
      peer 2001:DB8:4::2 enable
    #
    return
  • Leaf1 configuration file
    #
    sysname Leaf1
    #
    vlan batch 100
    #
    lacp priority 100
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address 2001:DB8:100::1/64
     ipv6 address FE80::300:3EFF:FE11:985 link-local
     mac-address 0000-5e00-0101
     ipv6 nd proxy anyway enable
     ipv6 nd delete trigger link-down enable
     ipv6 nd direct-route enable
     ipv6 nd direct-route delay 120
     ipv6 nd direct-route preference 1
    #
    interface Eth-Trunk10
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
     mode lacp-static
     lacp system-id 00e0-cf00-0000
    #
    interface Eth-Trunk20
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
     mode lacp-static
     lacp system-id 00e0-cf00-0001
    #
    interface 10GE1/0/1
     undo portswitch
     ipv6 enable
     ipv6 address 2001:DB8:1::2/64
     port-isolate l3 enable 
    #
    interface 10GE1/0/2
     undo portswitch
     ipv6 enable
     ipv6 address 2001:DB8:2::2/64
     port-isolate l3 enable
    #
    interface 10GE1/0/3
     eth-trunk 10
    #
    interface 10GE1/0/4
     eth-trunk 20
    #
    monitor-link group 1
     port 10GE1/0/1 uplink
     port 10GE1/0/2 uplink
     port Eth-Trunk10 downlink 1
     port Eth-Trunk20 downlink 2
     timer recover-time 60
    #
    bgp 65021
     router-id 172.16.3.1 
     timer keepalive 10 hold 30
     group spine external
     peer spine as-number 65009
     peer 2001:DB8:1::1 as-number 65009
     peer 2001:DB8:1::1 group spine
     peer 2001:DB8:2::1 as-number 65009
     peer 2001:DB8:2::1 group spine
     #
     ipv6-family unicast
      preference 20 200 10 
      network 2001:DB8:1:: 64
      network 2001:DB8:2:: 64
      network 2001:DB8:100:: 64
      import-route direct 
      maximum load-balancing 32
      peer 2001:DB8:1::1 enable
      peer 2001:DB8:2::1 enable
    #
    return
  • Leaf2 configuration file
    #
    sysname Leaf2
    #
    vlan batch 100
    #
    lacp priority 100
    #
    interface Vlanif100
     ipv6 enable
     ipv6 address 2001:DB8:100::1/64
     ipv6 address FE80::300:3EFF:FE11:985 link-local
     mac-address 0000-5e00-0101
     ipv6 nd proxy anyway enable
     ipv6 nd delete trigger link-down enable
     ipv6 nd direct-route enable
     ipv6 nd direct-route delay 120
     ipv6 nd direct-route preference 1
    #
    interface Eth-Trunk10
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
     mode lacp-static
     lacp system-id 00e0-cf00-0000
     lacp port-id-extension enable 
    #
    interface Eth-Trunk20
     port link-type trunk
     port trunk pvid vlan 100
     port trunk allow-pass vlan 100
     mode lacp-static
     lacp system-id 00e0-cf00-0001
     lacp port-id-extension enable 
    #
    interface 10GE1/0/1
     undo portswitch
     ipv6 enable
     ipv6 address 2001:DB8:4::2/64
     port-isolate l3 enable 
    #
    interface 10GE1/0/2
     undo portswitch
     ipv6 enable
     ipv6 address 2001:DB8:3::2/64
     port-isolate l3 enable
    #
    interface 10GE1/0/3
     eth-trunk 10
    #
    interface 10GE1/0/4
     eth-trunk 20
    #
    monitor-link group 1
     port 10GE1/0/1 uplink
     port 10GE1/0/2 uplink
     port Eth-Trunk10 downlink 1
     port Eth-Trunk20 downlink 2
     timer recover-time 60
    #
    bgp 65021
     router-id 172.16.4.1 
     timer keepalive 10 hold 30
     group spine external
     peer spine as-number 65009
     peer 2001:DB8:3::1 as-number 65009
     peer 2001:DB8:3::1 group spine
     peer 2001:DB8:4::1 as-number 65009
     peer 2001:DB8:4::1 group spine
     #
     ipv6-family unicast
      preference 20 200 10 
      network 2001:DB8:3:: 64
      network 2001:DB8:4:: 64
      network 2001:DB8:100:: 64                                                     
      import-route direct
      maximum load-balancing 32
      peer 2001:DB8:3::1 enable
      peer 2001:DB8:4::1 enable
    #
    return
Download
Updated: 2019-11-08

Document ID: EDOC1000039339

Views: 157447

Downloads: 7958

Average rating:
This Document Applies to these Products
Related Version
Related Documents
Share
Previous Next